aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-26 17:31:28 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-26 17:47:06 +0000
commitbd9c318712cc0c8f075318591710f718f554b62a (patch)
tree8f0ce0378f7d4014de773bd4e5ec0a99236facd4
parent4cf3d6b936491fcfce238595c05f0581416284b8 (diff)
downloadports-bd9c318712cc0c8f075318591710f718f554b62a.tar.gz
ports-bd9c318712cc0c8f075318591710f718f554b62a.zip
astro/gpstk: Fix build with llvm16
Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--astro/gpstk/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/astro/gpstk/Makefile b/astro/gpstk/Makefile
index 8c1506c0d2c3..cdbf52adc14d 100644
--- a/astro/gpstk/Makefile
+++ b/astro/gpstk/Makefile
@@ -12,21 +12,22 @@ LICENSE_COMB= multi
USES= cmake compiler:c++11-lang
USE_CXXSTD= c++14
-USE_LDCONFIG= yes
-
USE_GITHUB= yes
GH_ACCOUNT= SGL-UT
GH_PROJECT= GPSTk
+USE_LDCONFIG= yes
+
+MAKE_ENV= CXXFLAGS="${CXXFLAGS}"
DOCS= *.md
EXAMPLES= *
-OPTIONS_DEFINE= DOCS EXAMPLES
-OPTIONS_SUB= yes
-
PLIST_SUB= PORTVERSION=${PORTVERSION} \
SHLIB_VER=${PORTVERSION:R}
+OPTIONS_DEFINE= DOCS EXAMPLES
+OPTIONS_SUB= yes
+
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}