aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2023-05-07 18:22:14 +0000
committerThierry Thomas <thierry@FreeBSD.org>2023-05-07 18:22:14 +0000
commitbda00852389edd6ae3bb940fa5dff08f3042e255 (patch)
tree813c7a02ff2c24df37c91424e4c67756c76f850d
parent793bb3b8a4843b53b584728a8739beb2ba430400 (diff)
downloadports-bda00852389edd6ae3bb940fa5dff08f3042e255.tar.gz
ports-bda00852389edd6ae3bb940fa5dff08f3042e255.zip
textproc/py-jupyter_sphinx: add release 3.2
Remark: this is not the latest (4.0) but the one required by Sage.
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-jupyter_sphinx/Makefile27
-rw-r--r--textproc/py-jupyter_sphinx/distinfo3
-rw-r--r--textproc/py-jupyter_sphinx/pkg-descr5
-rw-r--r--textproc/py-jupyter_sphinx/pkg-plist21
5 files changed, 57 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 4c302336717a..7f5852bfed10 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1378,6 +1378,7 @@
SUBDIR += py-jsx-lexer
SUBDIR += py-jtextfsm
SUBDIR += py-junit-xml
+ SUBDIR += py-jupyter_sphinx
SUBDIR += py-jupyterlab-pygments
SUBDIR += py-langdetect
SUBDIR += py-langid
diff --git a/textproc/py-jupyter_sphinx/Makefile b/textproc/py-jupyter_sphinx/Makefile
new file mode 100644
index 000000000000..f9ec26661569
--- /dev/null
+++ b/textproc/py-jupyter_sphinx/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= jupyter-sphinx
+PORTVERSION= 0.3.2
+CATEGORIES= textproc python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME:C/-/_/}-${DISTVERSIONFULL}
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Sphinx extension for rendering of Jupyter interactive widgets
+WWW= https://jupyter-sphinx.readthedocs.io/
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=0:textproc/py-sphinx@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=0:textproc/py-sphinx@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}nbformat>0:devel/py-nbformat@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}nbconvert>0:devel/py-nbconvert@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ipywidgets>0:devel/py-ipywidgets@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ipython>=7.0.0:devel/ipython@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/py-jupyter_sphinx/distinfo b/textproc/py-jupyter_sphinx/distinfo
new file mode 100644
index 000000000000..2da61d3cebc3
--- /dev/null
+++ b/textproc/py-jupyter_sphinx/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1683479753
+SHA256 (jupyter_sphinx-0.3.2.tar.gz) = 37fc9408385c45326ac79ca0452fbd7ae2bf0e97842d626d2844d4830e30aaf2
+SIZE (jupyter_sphinx-0.3.2.tar.gz) = 16880
diff --git a/textproc/py-jupyter_sphinx/pkg-descr b/textproc/py-jupyter_sphinx/pkg-descr
new file mode 100644
index 000000000000..aa1adb062aa3
--- /dev/null
+++ b/textproc/py-jupyter_sphinx/pkg-descr
@@ -0,0 +1,5 @@
+jupyter-sphinx enables running code embedded in Sphinx documentation and
+embedding output of that code into the resulting document. It has support for
+rich output such as images and even Jupyter interactive widgets.
+
+See also: https://github.com/jupyter/jupyter-sphinx/
diff --git a/textproc/py-jupyter_sphinx/pkg-plist b/textproc/py-jupyter_sphinx/pkg-plist
new file mode 100644
index 000000000000..1812ca5a78f8
--- /dev/null
+++ b/textproc/py-jupyter_sphinx/pkg-plist
@@ -0,0 +1,21 @@
+%%PYTHON_SITELIBDIR%%/jupyter_sphinx/__init__.py
+%%PYTHON_SITELIBDIR%%/jupyter_sphinx/__pycache__/__init__.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+%%PYTHON_SITELIBDIR%%/jupyter_sphinx/__pycache__/__init__.cpython-%%PYTHON_SUFFIX%%.pyc
+%%PYTHON_SITELIBDIR%%/jupyter_sphinx/__pycache__/_version.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+%%PYTHON_SITELIBDIR%%/jupyter_sphinx/__pycache__/_version.cpython-%%PYTHON_SUFFIX%%.pyc
+%%PYTHON_SITELIBDIR%%/jupyter_sphinx/__pycache__/ast.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+%%PYTHON_SITELIBDIR%%/jupyter_sphinx/__pycache__/ast.cpython-%%PYTHON_SUFFIX%%.pyc
+%%PYTHON_SITELIBDIR%%/jupyter_sphinx/__pycache__/execute.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+%%PYTHON_SITELIBDIR%%/jupyter_sphinx/__pycache__/execute.cpython-%%PYTHON_SUFFIX%%.pyc
+%%PYTHON_SITELIBDIR%%/jupyter_sphinx/__pycache__/thebelab.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+%%PYTHON_SITELIBDIR%%/jupyter_sphinx/__pycache__/thebelab.cpython-%%PYTHON_SUFFIX%%.pyc
+%%PYTHON_SITELIBDIR%%/jupyter_sphinx/__pycache__/utils.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+%%PYTHON_SITELIBDIR%%/jupyter_sphinx/__pycache__/utils.cpython-%%PYTHON_SUFFIX%%.pyc
+%%PYTHON_SITELIBDIR%%/jupyter_sphinx/_version.py
+%%PYTHON_SITELIBDIR%%/jupyter_sphinx/ast.py
+%%PYTHON_SITELIBDIR%%/jupyter_sphinx/css/jupyter-sphinx.css
+%%PYTHON_SITELIBDIR%%/jupyter_sphinx/execute.py
+%%PYTHON_SITELIBDIR%%/jupyter_sphinx/thebelab.py
+%%PYTHON_SITELIBDIR%%/jupyter_sphinx/thebelab/thebelab-helper.js
+%%PYTHON_SITELIBDIR%%/jupyter_sphinx/thebelab/thebelab.css
+%%PYTHON_SITELIBDIR%%/jupyter_sphinx/utils.py