aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2023-04-14 15:46:36 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2023-04-14 15:46:36 +0000
commitbdca11102a7ff71a23a24ea5d160127d7053746f (patch)
treeb8e9e917f6361d9b40069153aee8cffaf554eabd
parentf2d3fce9c34a30f5b7e12618bf44495e3e85671d (diff)
downloadports-bdca11102a7ff71a23a24ea5d160127d7053746f.tar.gz
ports-bdca11102a7ff71a23a24ea5d160127d7053746f.zip
graphics/fotoxx: the port had been updated to version 23.32
- Mute the `-Wwritable-strings' warnings (ISO C++11 does not allow conversion from string literal to `char *') for the time being: there are tons of them and they clobber the build log, making it hard to look for more important warnings and errors - While here, make `pkg-plist' better sorted against LC_COLLATE=C
-rw-r--r--graphics/fotoxx/Makefile3
-rw-r--r--graphics/fotoxx/distinfo6
-rw-r--r--graphics/fotoxx/files/patch-zfuncs.cc10
-rw-r--r--graphics/fotoxx/pkg-plist11
4 files changed, 16 insertions, 14 deletions
diff --git a/graphics/fotoxx/Makefile b/graphics/fotoxx/Makefile
index a451331ad8bd..8edbb32e1c9a 100644
--- a/graphics/fotoxx/Makefile
+++ b/graphics/fotoxx/Makefile
@@ -1,5 +1,5 @@
PORTNAME= fotoxx
-PORTVERSION= 23.2
+PORTVERSION= 23.32
CATEGORIES= graphics
MASTER_SITES= https://kornelix.net/downloads/downloads/
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
@@ -22,6 +22,7 @@ RUN_DEPENDS= xdg-open:devel/xdg-utils \
USES= desktop-file-utils gmake gnome jpeg pkgconfig
USE_GNOME= cairo glib20 gdkpixbuf2 gtk30
ALL_TARGET= fotoxx
+CXXFLAGS+= -Wno-writable-strings
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/graphics/fotoxx/distinfo b/graphics/fotoxx/distinfo
index 24b804d75adb..85f1176fc7a8 100644
--- a/graphics/fotoxx/distinfo
+++ b/graphics/fotoxx/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1677658228
-SHA256 (fotoxx-23.2-source.tar.gz) = 9e8098582c4b3dec51c6bf232670204e939372d0e9b66f281a0661ac36c2cce9
-SIZE (fotoxx-23.2-source.tar.gz) = 9233622
+TIMESTAMP = 1680699420
+SHA256 (fotoxx-23.32-source.tar.gz) = 3d88f483b671f4ba7005a9f9195994408ceb97289a77acd3981462ac92397537
+SIZE (fotoxx-23.32-source.tar.gz) = 9273650
diff --git a/graphics/fotoxx/files/patch-zfuncs.cc b/graphics/fotoxx/files/patch-zfuncs.cc
index 116014da25a0..b83322379cad 100644
--- a/graphics/fotoxx/files/patch-zfuncs.cc
+++ b/graphics/fotoxx/files/patch-zfuncs.cc
@@ -45,7 +45,7 @@
+}
+#endif
+
- // get available memory in MB units
+ // get available memory in MB units (includes swap space)
// typical < 0.1 milliseconds
double availmemory()
@@ -68,13 +68,13 @@
@@ -996,7 +1032,7 @@ double get_seconds()
timespec time1;
- double time2;
+ double secs;
- clock_gettime(CLOCK_MONOTONIC_RAW,&time1);
+ clock_gettime(CLOCK_MONOTONIC,&time1);
- time2 = time1.tv_sec;
- time2 += time1.tv_nsec * 0.000000001;
- return time2;
+ secs = time1.tv_sec;
+ secs += time1.tv_nsec * 0.000000001;
+ return secs;
@@ -1020,7 +1056,7 @@ void logtime_init(cchar *text)
using namespace logtime_names;
diff --git a/graphics/fotoxx/pkg-plist b/graphics/fotoxx/pkg-plist
index 6bf31c2d3394..bb993b920cbb 100644
--- a/graphics/fotoxx/pkg-plist
+++ b/graphics/fotoxx/pkg-plist
@@ -2,7 +2,6 @@ bin/fotoxx
share/applications/fotoxx.desktop
%%DATADIR%%/data/KB_shortcuts_E
%%DATADIR%%/data/README
-%%DATADIR%%/data/capskeys
%%DATADIR%%/data/colorwheel.jpg
%%DATADIR%%/data/custom_kernel/blur5
%%DATADIR%%/data/custom_kernel/brighten3
@@ -103,6 +102,7 @@ share/applications/fotoxx.desktop
%%DATADIR%%/images/albums-popmenu.jpg
%%DATADIR%%/images/alien-colors1.jpg
%%DATADIR%%/images/alien-colors2.jpg
+%%DATADIR%%/images/anti-alias.jpg
%%DATADIR%%/images/area-rescale.jpg
%%DATADIR%%/images/area-rescale2.jpg
%%DATADIR%%/images/batch-change-meta.jpg
@@ -132,6 +132,7 @@ share/applications/fotoxx.desktop
%%DATADIR%%/images/burn-DVD.jpg
%%DATADIR%%/images/calibrate-printer.jpg
%%DATADIR%%/images/cartoon.jpg
+%%DATADIR%%/images/change-alpha.jpg
%%DATADIR%%/images/choose-captions.jpg
%%DATADIR%%/images/chromatic1.jpg
%%DATADIR%%/images/chromatic1A.jpg
@@ -174,7 +175,6 @@ share/applications/fotoxx.desktop
%%DATADIR%%/images/edit-bookmarks.jpg
%%DATADIR%%/images/edit-dist.jpg
%%DATADIR%%/images/edit-metadata.jpg
-%%DATADIR%%/images/edit-plugins.jpg
%%DATADIR%%/images/edit.png
%%DATADIR%%/images/effects.png
%%DATADIR%%/images/emboss.jpg
@@ -193,8 +193,8 @@ share/applications/fotoxx.desktop
%%DATADIR%%/images/flatten-photo2.jpg
%%DATADIR%%/images/flatten1.jpg
%%DATADIR%%/images/flatten2.jpg
-%%DATADIR%%/images/folder.png
%%DATADIR%%/images/folder-tree.jpg
+%%DATADIR%%/images/folder.png
%%DATADIR%%/images/fotoxx-views.jpg
%%DATADIR%%/images/fotoxx.png
%%DATADIR%%/images/gallery-screen.jpg
@@ -231,6 +231,7 @@ share/applications/fotoxx.desktop
%%DATADIR%%/images/manage-tags.jpg
%%DATADIR%%/images/map-click.jpg
%%DATADIR%%/images/maps.png
+%%DATADIR%%/images/margins.jpg
%%DATADIR%%/images/markup.jpg
%%DATADIR%%/images/mashup.jpg
%%DATADIR%%/images/mashup1.jpg
@@ -268,6 +269,7 @@ share/applications/fotoxx.desktop
%%DATADIR%%/images/permissions.jpg
%%DATADIR%%/images/perspective1.jpg
%%DATADIR%%/images/perspective2.jpg
+%%DATADIR%%/images/plugins-edit.jpg
%%DATADIR%%/images/plugins.jpg
%%DATADIR%%/images/prev-next.png
%%DATADIR%%/images/print-margins.jpg
@@ -280,7 +282,6 @@ share/applications/fotoxx.desktop
%%DATADIR%%/images/red-eyes2.jpg
%%DATADIR%%/images/redball.png
%%DATADIR%%/images/refine.png
-%%DATADIR%%/images/remove-alpha.jpg
%%DATADIR%%/images/remove-dust.jpg
%%DATADIR%%/images/remove-dust2.jpg
%%DATADIR%%/images/remove-halo.jpg
@@ -295,8 +296,8 @@ share/applications/fotoxx.desktop
%%DATADIR%%/images/rotate.jpg
%%DATADIR%%/images/saturation.jpg
%%DATADIR%%/images/save.png
-%%DATADIR%%/images/search-images.jpg
%%DATADIR%%/images/search-images-metadata.jpg
+%%DATADIR%%/images/search-images.jpg
%%DATADIR%%/images/select-area-finish.jpg
%%DATADIR%%/images/select-area.jpg
%%DATADIR%%/images/select.png