aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@FreeBSD.org>2023-09-24 06:09:54 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-11-12 01:37:55 +0000
commitbe0ed95ca04ad8947e15309adc823a514e9e8744 (patch)
tree418150769c753fc752d9aa58a866e49755fd5c88
parent7838bd81960f26d7c331864f732fe8950993515b (diff)
downloadports-be0ed95ca04ad8947e15309adc823a514e9e8744.tar.gz
ports-be0ed95ca04ad8947e15309adc823a514e9e8744.zip
graphics/hugin: update to 2023.0.0
Changes since 2022.0: * PTBatcherGUI can now also queue user defined assistant and user defined output sequences. * PTBatcherGUI: Added option to generate panorama sequences from an existing pto template. * Assistant: Added option to select different output options like projection, FOV or canvas size depending on different variables (e.g. image count, field of view, lens type). * Allow building with epoxy instead of GLEW for OpenGL pointer management. * Several improvements to crop tool (outside crop, aspect ratio, ...). * Several bug fixes (e.g. for verdandi/internal blender) Changelog: https://hugin.sourceforge.io/releases/2023.0.0/en.shtml
-rw-r--r--graphics/hugin/Makefile3
-rw-r--r--graphics/hugin/distinfo6
-rw-r--r--graphics/hugin/files/patch-src_hugin__base_panodata_Exiv2Helper.cpp27
-rw-r--r--graphics/hugin/files/patch-src_hugin__base_panodata_SrcPanoImage.cpp47
-rw-r--r--graphics/hugin/pkg-plist28
5 files changed, 16 insertions, 95 deletions
diff --git a/graphics/hugin/Makefile b/graphics/hugin/Makefile
index 35ec08cf2c79..8fd5b2dcca7c 100644
--- a/graphics/hugin/Makefile
+++ b/graphics/hugin/Makefile
@@ -1,6 +1,5 @@
PORTNAME= hugin
-DISTVERSION= 2022.0.0
-PORTREVISION= 10
+DISTVERSION= 2023.0.0
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}
diff --git a/graphics/hugin/distinfo b/graphics/hugin/distinfo
index 5564c669f460..c892687f335a 100644
--- a/graphics/hugin/distinfo
+++ b/graphics/hugin/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1671372561
-SHA256 (hugin-2022.0.0.tar.bz2) = 97c8562a0ba9a743e0b955a43dfde048b1c60cd9e5f2ee2b69de1a81646e05a7
-SIZE (hugin-2022.0.0.tar.bz2) = 10374360
+TIMESTAMP = 1699739909
+SHA256 (hugin-2023.0.0.tar.bz2) = 04a39fccc6017e0544c639bd22309472c574d35b3455cbade1fc3870e631632b
+SIZE (hugin-2023.0.0.tar.bz2) = 10336322
diff --git a/graphics/hugin/files/patch-src_hugin__base_panodata_Exiv2Helper.cpp b/graphics/hugin/files/patch-src_hugin__base_panodata_Exiv2Helper.cpp
deleted file mode 100644
index c383922e90da..000000000000
--- a/graphics/hugin/files/patch-src_hugin__base_panodata_Exiv2Helper.cpp
+++ /dev/null
@@ -1,27 +0,0 @@
---- src/hugin_base/panodata/Exiv2Helper.cpp.orig 2019-05-15 15:30:47 UTC
-+++ src/hugin_base/panodata/Exiv2Helper.cpp
-@@ -40,7 +40,7 @@ namespace HuginBase
- Exiv2::ExifData::iterator itr = exifData.findKey(Exiv2::ExifKey(keyName));
- if (itr != exifData.end() && itr->count())
- {
-- value = itr->toLong();
-+ value = itr->toInt64();
- return true;
- }
- else
-@@ -165,7 +165,7 @@ namespace HuginBase
- {
- if(it!=exifData.end() && it->count())
- {
-- return it->toLong();
-+ return it->toInt64();
- }
- return 0;
- };
-@@ -600,4 +600,4 @@ namespace HuginBase
- };
-
- }; //namespace Exiv2Helper
--}; //namespace HuginBase
-\ No newline at end of file
-+}; //namespace HuginBase
diff --git a/graphics/hugin/files/patch-src_hugin__base_panodata_SrcPanoImage.cpp b/graphics/hugin/files/patch-src_hugin__base_panodata_SrcPanoImage.cpp
deleted file mode 100644
index b097a4a9939b..000000000000
--- a/graphics/hugin/files/patch-src_hugin__base_panodata_SrcPanoImage.cpp
+++ /dev/null
@@ -1,47 +0,0 @@
---- src/hugin_base/panodata/SrcPanoImage.cpp.orig 2022-05-26 16:18:56 UTC
-+++ src/hugin_base/panodata/SrcPanoImage.cpp
-@@ -384,7 +384,7 @@ bool SrcPanoImage::readEXIF()
- pos = xmpData.findKey(Exiv2::XmpKey("Xmp.GPano.CroppedAreaImageWidthPixels"));
- if (pos != xmpData.end())
- {
-- croppedWidth = pos->toLong();
-+ croppedWidth = pos->toInt64();
- }
- else
- {
-@@ -394,7 +394,7 @@ bool SrcPanoImage::readEXIF()
- pos = xmpData.findKey(Exiv2::XmpKey("Xmp.GPano.CroppedAreaImageHeightPixels"));
- if (pos != xmpData.end())
- {
-- croppedHeight = pos->toLong();
-+ croppedHeight = pos->toInt64();
- }
- else
- {
-@@ -408,7 +408,7 @@ bool SrcPanoImage::readEXIF()
- double hfov = 0;
- if (pos != xmpData.end())
- {
-- hfov = 360 * croppedWidth / (double)pos->toLong();
-+ hfov = 360 * croppedWidth / (double)pos->toInt64();
- }
- else
- {
-@@ -419,7 +419,7 @@ bool SrcPanoImage::readEXIF()
- pos = xmpData.findKey(Exiv2::XmpKey("Xmp.GPano.FullPanoHeightPixels"));
- if (pos != xmpData.end())
- {
-- fullHeight = pos->toLong();
-+ fullHeight = pos->toInt64();
- }
- else
- {
-@@ -430,7 +430,7 @@ bool SrcPanoImage::readEXIF()
- pos = xmpData.findKey(Exiv2::XmpKey("Xmp.GPano.CroppedAreaTopPixels"));
- if (pos != xmpData.end())
- {
-- cropTop = pos->toLong();
-+ cropTop = pos->toInt64();
- }
- else
- {
diff --git a/graphics/hugin/pkg-plist b/graphics/hugin/pkg-plist
index d9845e401222..48ef02c6076a 100644
--- a/graphics/hugin/pkg-plist
+++ b/graphics/hugin/pkg-plist
@@ -161,14 +161,12 @@ share/applications/pto_gen.desktop
%%DATADIR%%/xrc/data/help_en_EN/16bit_workflow_with_hugin.html
%%DATADIR%%/xrc/data/help_en_EN/180px-LagardePont-fish.jpg
%%DATADIR%%/xrc/data/help_en_EN/1876c10b5fac40156f4cd7ab00928c9fc2bed36b.png
-%%DATADIR%%/xrc/data/help_en_EN/197px-Field-of-view.svg.png
%%DATADIR%%/xrc/data/help_en_EN/1d8b2987693a73b6ef2eb74783d2e51786789f89.png
%%DATADIR%%/xrc/data/help_en_EN/1d90bc6b2f34e2398a9accb8c63bb46bdcf8a629.png
%%DATADIR%%/xrc/data/help_en_EN/200px-Ben_Architectural.jpg
%%DATADIR%%/xrc/data/help_en_EN/200px-Ben_Lambert_cylindrical_equal_area.jpg
%%DATADIR%%/xrc/data/help_en_EN/200px-Ben_Miller_cylindrical.jpg
%%DATADIR%%/xrc/data/help_en_EN/200px-Big_ben_cubic.jpg
-%%DATADIR%%/xrc/data/help_en_EN/200px-Big_ben_cylindrical.jpg
%%DATADIR%%/xrc/data/help_en_EN/200px-Big_ben_equirectangular.jpg
%%DATADIR%%/xrc/data/help_en_EN/200px-Big_ben_mercator.jpg
%%DATADIR%%/xrc/data/help_en_EN/200px-Bin_ben_sinusoidal.jpg
@@ -177,13 +175,6 @@ share/applications/pto_gen.desktop
%%DATADIR%%/xrc/data/help_en_EN/200px-Panoglview.png
%%DATADIR%%/xrc/data/help_en_EN/220px-Ben_Equirectangular_panini.jpg
%%DATADIR%%/xrc/data/help_en_EN/228647b7d4a18b6c8c0c390b439a61da8fafec76.png
-%%DATADIR%%/xrc/data/help_en_EN/22px-Fast_preview_icon_autocrop.svg.png
-%%DATADIR%%/xrc/data/help_en_EN/22px-Fast_preview_icon_crop.svg.png
-%%DATADIR%%/xrc/data/help_en_EN/22px-Fast_preview_icon_drag.svg.png
-%%DATADIR%%/xrc/data/help_en_EN/22px-Fast_preview_icon_identify.svg.png
-%%DATADIR%%/xrc/data/help_en_EN/22px-Fast_preview_icon_photometric.svg.png
-%%DATADIR%%/xrc/data/help_en_EN/22px-Preview_layout.svg.png
-%%DATADIR%%/xrc/data/help_en_EN/22px-Show_Control_Points_Button.svg.png
%%DATADIR%%/xrc/data/help_en_EN/250px-Cubic.jpg
%%DATADIR%%/xrc/data/help_en_EN/250px-Cylindrical.JPG
%%DATADIR%%/xrc/data/help_en_EN/250px-Equirectangular.JPG
@@ -237,10 +228,10 @@ share/applications/pto_gen.desktop
%%DATADIR%%/xrc/data/help_en_EN/8d3ef9dbe5e117eb5bb0de31eb3d72ae5ee9878c.png
%%DATADIR%%/xrc/data/help_en_EN/927996686539d9eacf2e62a8cf730cc117529091.png
%%DATADIR%%/xrc/data/help_en_EN/Aliasing.html
-%%DATADIR%%/xrc/data/help_en_EN/AliasingPScubic.jpg
-%%DATADIR%%/xrc/data/help_en_EN/AliasingPScubic_2x.jpg
-%%DATADIR%%/xrc/data/help_en_EN/AliasingPTpoly3.jpg
-%%DATADIR%%/xrc/data/help_en_EN/AliasingPTpoly3_2x.jpg
+%%DATADIR%%/xrc/data/help_en_EN/AliasingPsCubic.jpg
+%%DATADIR%%/xrc/data/help_en_EN/AliasingPsCubic_2x.jpg
+%%DATADIR%%/xrc/data/help_en_EN/AliasingPtPoly3.jpg
+%%DATADIR%%/xrc/data/help_en_EN/AliasingPtPoly3_2x.jpg
%%DATADIR%%/xrc/data/help_en_EN/Align_a_stack_of_photos.html
%%DATADIR%%/xrc/data/help_en_EN/Align_image_stack.html
%%DATADIR%%/xrc/data/help_en_EN/Alpha_channel.html
@@ -315,7 +306,9 @@ share/applications/pto_gen.desktop
%%DATADIR%%/xrc/data/help_en_EN/Equirectangular.html
%%DATADIR%%/xrc/data/help_en_EN/Equirectangular_Panini.html
%%DATADIR%%/xrc/data/help_en_EN/Equirectangular_Projection.html
+%%DATADIR%%/xrc/data/help_en_EN/Exposure_correction.html
%%DATADIR%%/xrc/data/help_en_EN/Field_of_View.html
+%%DATADIR%%/xrc/data/help_en_EN/Fisheye.html
%%DATADIR%%/xrc/data/help_en_EN/Fisheye_Projection.html
%%DATADIR%%/xrc/data/help_en_EN/Flags.png
%%DATADIR%%/xrc/data/help_en_EN/Focal_Length.html
@@ -365,6 +358,7 @@ share/applications/pto_gen.desktop
%%DATADIR%%/xrc/data/help_en_EN/Hugin_filesave.png
%%DATADIR%%/xrc/data/help_en_EN/Hugin_filesaveas.png
%%DATADIR%%/xrc/data/help_en_EN/Hugin_fit_pano.png
+%%DATADIR%%/xrc/data/help_en_EN/Hugin_hdrmerge.html
%%DATADIR%%/xrc/data/help_en_EN/Hugin_info.png
%%DATADIR%%/xrc/data/help_en_EN/Hugin_lensdb.html
%%DATADIR%%/xrc/data/help_en_EN/Hugin_list.png
@@ -385,9 +379,9 @@ share/applications/pto_gen.desktop
%%DATADIR%%/xrc/data/help_en_EN/Icpfind.html
%%DATADIR%%/xrc/data/help_en_EN/Illustration4.png
%%DATADIR%%/xrc/data/help_en_EN/Image_positioning_model.html
-%%DATADIR%%/xrc/data/help_en_EN/Interpolate_none.jpg
-%%DATADIR%%/xrc/data/help_en_EN/Interpolate_poly3.jpg
-%%DATADIR%%/xrc/data/help_en_EN/Interpolate_sinc256.jpg
+%%DATADIR%%/xrc/data/help_en_EN/InterpolateNone.jpg
+%%DATADIR%%/xrc/data/help_en_EN/InterpolatePoly3.jpg
+%%DATADIR%%/xrc/data/help_en_EN/InterpolateSinc256.jpg
%%DATADIR%%/xrc/data/help_en_EN/Interpolation.html
%%DATADIR%%/xrc/data/help_en_EN/JPEG.html
%%DATADIR%%/xrc/data/help_en_EN/LICENCE.manual
@@ -410,6 +404,7 @@ share/applications/pto_gen.desktop
%%DATADIR%%/xrc/data/help_en_EN/PNG.html
%%DATADIR%%/xrc/data/help_en_EN/PPI.html
%%DATADIR%%/xrc/data/help_en_EN/PSD.html
+%%DATADIR%%/xrc/data/help_en_EN/PTBatcherGUI.html
%%DATADIR%%/xrc/data/help_en_EN/PTOptimizer.html
%%DATADIR%%/xrc/data/help_en_EN/PTStitcher.html
%%DATADIR%%/xrc/data/help_en_EN/PTblender.html
@@ -473,6 +468,7 @@ share/applications/pto_gen.desktop
%%DATADIR%%/xrc/data/help_en_EN/Vig_optimize.html
%%DATADIR%%/xrc/data/help_en_EN/Vignetting.html
%%DATADIR%%/xrc/data/help_en_EN/Wavy_distortion.html
+%%DATADIR%%/xrc/data/help_en_EN/White_balance.html
%%DATADIR%%/xrc/data/help_en_EN/Yaw.html
%%DATADIR%%/xrc/data/help_en_EN/Zenith.html
%%DATADIR%%/xrc/data/help_en_EN/b46e7c5d2bb0d7e3dc91da9577785c32b9fe1c97.png