aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-09 13:57:31 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-09 14:07:22 +0000
commitbe25bb2a2d2bf5f4854595713605b513800756b5 (patch)
tree0a175b4b76968c160256a131b41ff9a835bbea9c
parente4fdf41c677cac828575b90e5ab6dfe5abca7175 (diff)
downloadports-be25bb2a2d2bf5f4854595713605b513800756b5.tar.gz
ports-be25bb2a2d2bf5f4854595713605b513800756b5.zip
net-im/py-matrix-synapse: Allow build with py-poetry-core 1.9.0 and py-setuptools-rust 1.9.0
-rw-r--r--net-im/py-matrix-synapse/Makefile4
-rw-r--r--net-im/py-matrix-synapse/files/patch-pyproject.toml13
-rw-r--r--net-im/py-matrix-synapse/files/patch-setup.py2
3 files changed, 14 insertions, 5 deletions
diff --git a/net-im/py-matrix-synapse/Makefile b/net-im/py-matrix-synapse/Makefile
index c7e897c557bf..9be42abad62c 100644
--- a/net-im/py-matrix-synapse/Makefile
+++ b/net-im/py-matrix-synapse/Makefile
@@ -13,8 +13,8 @@ WWW= https://www.matrix.org
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>=1.1.0<=1.8.1:devel/py-poetry-core@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}setuptools-rust>=1.3<=1.8.1_99:devel/py-setuptools-rust@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>=1.1.0<1.9.0_99:devel/py-poetry-core@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools-rust>=1.3<1.9.0_99:devel/py-setuptools-rust@${PY_FLAVOR}
# Keep the RUN_DEPENDS layout similar to the pyproject.toml file
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jsonschema>=3.0.0:devel/py-jsonschema@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}immutabledict>=2.0:devel/py-immutabledict@${PY_FLAVOR} \
diff --git a/net-im/py-matrix-synapse/files/patch-pyproject.toml b/net-im/py-matrix-synapse/files/patch-pyproject.toml
index a264188218ba..0289fd6dd633 100644
--- a/net-im/py-matrix-synapse/files/patch-pyproject.toml
+++ b/net-im/py-matrix-synapse/files/patch-pyproject.toml
@@ -1,6 +1,6 @@
---- pyproject.toml.orig 2023-10-31 14:05:31 UTC
+--- pyproject.toml.orig 2023-12-12 15:52:05 UTC
+++ pyproject.toml
-@@ -216,17 +216,6 @@ packaging = ">=20.0"
+@@ -216,17 +216,6 @@ pydantic = ">=1.7.4, <3"
# See https://github.com/matrix-org/synapse/issues/15858
pydantic = ">=1.7.4, <3"
@@ -18,3 +18,12 @@
# Optional Dependencies
# ---------------------
matrix-synapse-ldap3 = { version = ">=0.1", optional = true }
+@@ -382,7 +371,7 @@ furo = ">=2022.12.7,<2024.0.0"
+ # runtime errors caused by build system changes.
+ # We are happy to raise these upper bounds upon request,
+ # provided we check that it's safe to do so (i.e. that CI passes).
+-requires = ["poetry-core>=1.1.0,<=1.8.1", "setuptools_rust>=1.3,<=1.8.1"]
++requires = ["poetry-core>=1.1.0,<=1.9.0", "setuptools_rust>=1.3,<=1.9.0"]
+ build-backend = "poetry.core.masonry.api"
+
+
diff --git a/net-im/py-matrix-synapse/files/patch-setup.py b/net-im/py-matrix-synapse/files/patch-setup.py
index 5b7664929f74..7b58e4d5030c 100644
--- a/net-im/py-matrix-synapse/files/patch-setup.py
+++ b/net-im/py-matrix-synapse/files/patch-setup.py
@@ -1,6 +1,6 @@
--- setup.py.orig 1970-01-01 00:00:00 UTC
+++ setup.py
-@@ -175,7 +175,6 @@ install_requires = \
+@@ -172,7 +172,6 @@ install_requires = \
'pydantic>=1.7.4,<3',
'pymacaroons>=0.13.0',
'service-identity>=18.1.0',