aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-03-18 07:56:38 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-03-18 07:56:38 +0000
commitbe2a15a9580d1fc6b2ddae23515c140d4ec4be61 (patch)
tree9765b60c2fc5579cabc00625ae6d274d7c771b76
parent1a418c214f9d5d8b30dedf92a27b1d1e3ac6a312 (diff)
downloadports-be2a15a9580d1fc6b2ddae23515c140d4ec4be61.tar.gz
ports-be2a15a9580d1fc6b2ddae23515c140d4ec4be61.zip
- Support staging
- Convert USE_BZIP2=yes to USES=tar:bzip2 - New LIB_DEPENDS definition - Take maintainership
Notes
Notes: svn path=/head/; revision=348521
-rw-r--r--graphics/jp2a/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/graphics/jp2a/Makefile b/graphics/jp2a/Makefile
index be474321cb9a..04e4f38fff9f 100644
--- a/graphics/jp2a/Makefile
+++ b/graphics/jp2a/Makefile
@@ -7,21 +7,22 @@ PORTREVISION= 6
CATEGORIES= graphics
MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Converts JPG images to ASCII
-LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libcurl.so:${PORTSDIR}/ftp/curl
-USE_BZIP2= yes
+USES= tar:bzip2
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-jpeg-prefix=${LOCALBASE} --with-curl-config=${LOCALBASE}/bin/curl-config
-MAN1= ${PORTNAME}.1
-PLIST_FILES= bin/${PORTNAME}
-NO_STAGE= yes
+CONFIGURE_ARGS= --with-jpeg-prefix=${LOCALBASE} \
+ --with-curl-config=${LOCALBASE}/bin/curl-config
+
+PLIST_FILES= bin/jp2a man/man1/jp2a.1.gz
+
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin/
- @${INSTALL_MAN} ${WRKSRC}/man/${MAN1} ${MAN1PREFIX}/man/man1/
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/jp2a ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/man/jp2a.1 ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>