aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-08-23 13:19:58 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-08-23 13:19:58 +0000
commitbe881a5035c0000fbcc1c488c83f9a50241c4a02 (patch)
tree277ec8875ba5af1ac6a26793e32dd4d709d2e397
parent116bdfe7a031ae0a9f53d1d460749bef30e9fc60 (diff)
downloadports-be881a5035c0000fbcc1c488c83f9a50241c4a02.tar.gz
ports-be881a5035c0000fbcc1c488c83f9a50241c4a02.zip
Update to 3.0.0.2.
- Added new ioctl VIDIOC_QUERYUSBINFO for use with LIBV4L. - Fix for EVIOCGKEYCODE ioctl. - Fix for segfault, due to wrong header file used when compiling linux_i2c.c. - Include linux_make tool in distribution. Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=280272
-rw-r--r--multimedia/webcamd/Makefile3
-rw-r--r--multimedia/webcamd/distinfo4
-rw-r--r--multimedia/webcamd/files/patch-input.h17
3 files changed, 3 insertions, 21 deletions
diff --git a/multimedia/webcamd/Makefile b/multimedia/webcamd/Makefile
index 8354457052e9..17d41fae33d2 100644
--- a/multimedia/webcamd/Makefile
+++ b/multimedia/webcamd/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= webcamd
-PORTVERSION= 3.0.0.1
-PORTREVISION= 1
+PORTVERSION= 3.0.0.2
CATEGORIES= multimedia
MASTER_SITES= http://www.selasky.org/hans_petter/distfiles/ \
http://hselasky.homeunix.org:8192/distfiles/
diff --git a/multimedia/webcamd/distinfo b/multimedia/webcamd/distinfo
index ec85471ddcf0..ac55679c52a8 100644
--- a/multimedia/webcamd/distinfo
+++ b/multimedia/webcamd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (webcamd-3.0.0.1.tar.bz2) = f6ef39dbc1c4e00421e9c00aa9a88a2da2310d979e648fb34cf631118f00d55e
-SIZE (webcamd-3.0.0.1.tar.bz2) = 8027049
+SHA256 (webcamd-3.0.0.2.tar.bz2) = c0a1a84ceed778b3f9b6e6ff6778fce2d85b8de25e7428b412bfc8c3177089f2
+SIZE (webcamd-3.0.0.2.tar.bz2) = 8034500
diff --git a/multimedia/webcamd/files/patch-input.h b/multimedia/webcamd/files/patch-input.h
deleted file mode 100644
index 0d7e0389c74a..000000000000
--- a/multimedia/webcamd/files/patch-input.h
+++ /dev/null
@@ -1,17 +0,0 @@
---- media_tree/include/linux/input.h.orig
-+++ media_tree/include/linux/input.h
-@@ -104,8 +104,12 @@ struct input_keymap_entry {
- #define EVIOCGREP _IOR('E', 0x03, unsigned int[2]) /* get repeat settings */
- #define EVIOCSREP _IOW('E', 0x03, unsigned int[2]) /* set repeat settings */
-
--#define EVIOCGKEYCODE _IOR('E', 0x04, unsigned int[2]) /* get keycode */
--#define EVIOCGKEYCODE_V2 _IOR('E', 0x04, struct input_keymap_entry)
-+/*
-+ * These two need to be _IOWR not _IOR (they're wrong on Linux too but
-+ * there the driver doesn't care.)
-+ */
-+#define EVIOCGKEYCODE _IOWR('E', 0x04, unsigned int[2]) /* get keycode */
-+#define EVIOCGKEYCODE_V2 _IOWR('E', 0x04, struct input_keymap_entry)
- #define EVIOCSKEYCODE _IOW('E', 0x04, unsigned int[2]) /* set keycode */
- #define EVIOCSKEYCODE_V2 _IOW('E', 0x04, struct input_keymap_entry)
-