aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2001-10-10 01:02:07 +0000
committerAnton Berezin <tobez@FreeBSD.org>2001-10-10 01:02:07 +0000
commitbf2ee8507bded64491bf642ad09b47b0ca60ad09 (patch)
tree66fdcba94f802a05e09a04796030594a3356249c
parenta373cc2a6ef56beb1cd747e22e6a2b2d1303cb17 (diff)
downloadports-bf2ee8507bded64491bf642ad09b47b0ca60ad09.tar.gz
ports-bf2ee8507bded64491bf642ad09b47b0ca60ad09.zip
Add p5-Crypt-HCE_SHA 0.60, perl5 interface to one way hash chaining
block cipher. PR: 31152 Submitted by: Gregory Neil Shapiro <gshapiro@FreeBSD.org>
Notes
Notes: svn path=/head/; revision=48635
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-HCE_SHA/Makefile28
-rw-r--r--security/p5-Crypt-HCE_SHA/distinfo1
-rw-r--r--security/p5-Crypt-HCE_SHA/pkg-comment1
-rw-r--r--security/p5-Crypt-HCE_SHA/pkg-descr16
-rw-r--r--security/p5-Crypt-HCE_SHA/pkg-plist9
6 files changed, 56 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index f8664549e907..9924bac36b58 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -115,6 +115,7 @@
SUBDIR += p5-Crypt-DES
SUBDIR += p5-Crypt-DSA
SUBDIR += p5-Crypt-ECB
+ SUBDIR += p5-Crypt-HCE_SHA
SUBDIR += p5-Crypt-IDEA
SUBDIR += p5-Crypt-OpenPGP
SUBDIR += p5-Crypt-OpenSSL-RSA
diff --git a/security/p5-Crypt-HCE_SHA/Makefile b/security/p5-Crypt-HCE_SHA/Makefile
new file mode 100644
index 000000000000..87a70d41cb45
--- /dev/null
+++ b/security/p5-Crypt-HCE_SHA/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Crypt-HCE_SHA
+# Date created: October 8th 2001
+# Whom: Gregory Neil Shapiro <gshapiro@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-HCE_SHA
+PORTVERSION= 0.60
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+RESTRICTED= "Crypto; export-controlled"
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Crypt::HCE_SHA.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-HCE_SHA/distinfo b/security/p5-Crypt-HCE_SHA/distinfo
new file mode 100644
index 000000000000..ca339217d280
--- /dev/null
+++ b/security/p5-Crypt-HCE_SHA/distinfo
@@ -0,0 +1 @@
+MD5 (Crypt-HCE_SHA-0.60.tar.gz) = 4e92d64bfa6d2a75ae1b641bd92331ca
diff --git a/security/p5-Crypt-HCE_SHA/pkg-comment b/security/p5-Crypt-HCE_SHA/pkg-comment
new file mode 100644
index 000000000000..4b4f04929bc7
--- /dev/null
+++ b/security/p5-Crypt-HCE_SHA/pkg-comment
@@ -0,0 +1 @@
+Perl5 interface to one way hash chaining block cipher
diff --git a/security/p5-Crypt-HCE_SHA/pkg-descr b/security/p5-Crypt-HCE_SHA/pkg-descr
new file mode 100644
index 000000000000..0685e8fb8dd2
--- /dev/null
+++ b/security/p5-Crypt-HCE_SHA/pkg-descr
@@ -0,0 +1,16 @@
+ This module implements a chaining block cipher using a one
+ way hash. This method of encryption is the same that is
+ used by radius (RFC2138) and is also described in Applied
+ Cryptography.
+
+ Two interfaces are provided in the module. The first is
+ straight block encryption/decryption the second does base64
+ mime encoding/decoding of the encrypted/decrypted blocks.
+
+ The idea is the the two sides have a shared secret that
+ supplies one of the keys and a randomly generated block of
+ bytes provides the second key. The random key is passed in
+ cleartext between the two sides.
+
+ An example client and server are packaged as modules with
+ this module. They are used in the tests.
diff --git a/security/p5-Crypt-HCE_SHA/pkg-plist b/security/p5-Crypt-HCE_SHA/pkg-plist
new file mode 100644
index 000000000000..7f3cfd6004ef
--- /dev/null
+++ b/security/p5-Crypt-HCE_SHA/pkg-plist
@@ -0,0 +1,9 @@
+lib/perl5/site_perl/%%PERL_VER%%/Crypt/HCE_SHA.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/HCE_SHA/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/auto/Crypt/HCE_SHA/autosplit.ix
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/HCE_SHA
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Crypt/HCE_SHA
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt 2> /dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Crypt 2> /dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/auto/Crypt 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Crypt 2>/dev/null || true