aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2005-08-28 17:22:13 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2005-08-28 17:22:13 +0000
commitbff2537a3ce42301179e9c7c7749a1b53a43869a (patch)
tree89a1fb1e0141679930b636005684d2563c5d2696
parent5786e86ede4b884130448c9457f2c525a89c4c77 (diff)
downloadports-bff2537a3ce42301179e9c7c7749a1b53a43869a.tar.gz
ports-bff2537a3ce42301179e9c7c7749a1b53a43869a.zip
Update to 3.2.17.
Notes
Notes: svn path=/head/; revision=141147
-rw-r--r--accessibility/dasher/Makefile15
-rw-r--r--accessibility/dasher/distinfo4
-rw-r--r--accessibility/dasher/files/patch-Src_Gtk2_speech.cc10
-rw-r--r--accessibility/dasher/pkg-plist117
4 files changed, 100 insertions, 46 deletions
diff --git a/accessibility/dasher/Makefile b/accessibility/dasher/Makefile
index 494965962028..570f39ceb9fb 100644
--- a/accessibility/dasher/Makefile
+++ b/accessibility/dasher/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dasher
-PORTVERSION= 3.2.15
+PORTVERSION= 3.2.17
CATEGORIES= accessibility editors x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/3.2
@@ -24,9 +24,10 @@ USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack intlhack gnomehier libgnomeui atspi \
libwnck
WANT_GNOME= yes
-USE_LIBTOOL_VER=15
+USE_INC_LIBTOOL_VER=15
INSTALLS_OMF= yes
USE_REINPLACE= yes
+USE_GCC= 3.4+
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -45,4 +46,14 @@ post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|-O2||g'
+patch-autotools:
+ @(cd ${PATCH_WRKSRC}; \
+ for file in ${LIBTOOLFILES}; do \
+ ${CP} $$file $$file.tmp; \
+ ${SED} -e "/^ltmain=/s^\$$ac_aux_dir/ltmain.sh^${LTMAIN}^g" \
+ $$file.tmp > $$file; \
+ ${RM} $$file.tmp; \
+ done);
+
+
.include <bsd.port.post.mk>
diff --git a/accessibility/dasher/distinfo b/accessibility/dasher/distinfo
index 02812ef26e43..68955a8fac76 100644
--- a/accessibility/dasher/distinfo
+++ b/accessibility/dasher/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/dasher-3.2.15.tar.bz2) = a3fa85e32c94c69476e12ecba7d257e7
-SIZE (gnome2/dasher-3.2.15.tar.bz2) = 8981223
+MD5 (gnome2/dasher-3.2.17.tar.bz2) = 583dbd217ca9352e1a1a2f11fdfd55b2
+SIZE (gnome2/dasher-3.2.17.tar.bz2) = 4596772
diff --git a/accessibility/dasher/files/patch-Src_Gtk2_speech.cc b/accessibility/dasher/files/patch-Src_Gtk2_speech.cc
index 05d3c3b835fd..7622867dbd57 100644
--- a/accessibility/dasher/files/patch-Src_Gtk2_speech.cc
+++ b/accessibility/dasher/files/patch-Src_Gtk2_speech.cc
@@ -1,12 +1,12 @@
---- Src/Gtk2/speech.cc.orig Fri Sep 17 06:53:53 2004
-+++ Src/Gtk2/speech.cc Sat Feb 26 01:00:12 2005
-@@ -78,7 +78,8 @@
+--- Src/Gtk2/speech.cc.orig Fri Aug 19 09:57:44 2005
++++ Src/Gtk2/speech.cc Mon Aug 22 20:23:21 2005
+@@ -78,7 +78,8 @@ void setup_speech() {
void teardown_speech() {
bonobo_object_release_unref (speaker, NULL);
- CORBA_free (voices);
+ if (voices != NULL && !BONOBO_EX (&ev) && voices->_length != 0)
-+ CORBA_free (voices);
++ CORBA_free (voices);
+ GNOME_Speech_SynthesisDriver_unref(rv, &ev);
CORBA_exception_free (&ev);
- }
diff --git a/accessibility/dasher/pkg-plist b/accessibility/dasher/pkg-plist
index 1be84180bf55..c902e50152b1 100644
--- a/accessibility/dasher/pkg-plist
+++ b/accessibility/dasher/pkg-plist
@@ -1,26 +1,25 @@
bin/dasher
share/gnome/applications/dasher.desktop
+share/gnome/dasher/alphabet.AfaanOromo.xml
share/gnome/dasher/alphabet.Armenian.xml
share/gnome/dasher/alphabet.Assamese.xml
share/gnome/dasher/alphabet.Austen.xml
share/gnome/dasher/alphabet.Azerbaijani.xml
share/gnome/dasher/alphabet.Belarusian.xml
-share/gnome/dasher/alphabet.Bengali.xml
share/gnome/dasher/alphabet.Bulgarian.xml
+share/gnome/dasher/alphabet.C.xml
share/gnome/dasher/alphabet.Esperanto.xml
share/gnome/dasher/alphabet.Estonian.xml
share/gnome/dasher/alphabet.Filipino.xml
share/gnome/dasher/alphabet.Greek.xml
share/gnome/dasher/alphabet.Gujarati.xml
+share/gnome/dasher/alphabet.Hawaiian.xml
share/gnome/dasher/alphabet.Hebrew.xml
share/gnome/dasher/alphabet.Hindi.xml
share/gnome/dasher/alphabet.Icelandic.xml
share/gnome/dasher/alphabet.Igbo.xml
share/gnome/dasher/alphabet.Indonesian.xml
share/gnome/dasher/alphabet.IrishGaelic.xml
-share/gnome/dasher/alphabet.Japanese.xml
-share/gnome/dasher/alphabet.Joyo.xml
-share/gnome/dasher/alphabet.Joyo2.xml
share/gnome/dasher/alphabet.Kannada.xml
share/gnome/dasher/alphabet.Katakana.xml
share/gnome/dasher/alphabet.Malay.xml
@@ -46,83 +45,108 @@ share/gnome/dasher/alphabet.Thai.xml
share/gnome/dasher/alphabet.Tsonga.xml
share/gnome/dasher/alphabet.Tswana.xml
share/gnome/dasher/alphabet.Turkish.xml
+share/gnome/dasher/alphabet.Urdu.xml
share/gnome/dasher/alphabet.Vietnamese.xml
share/gnome/dasher/alphabet.Xhosa.xml
share/gnome/dasher/alphabet.Yoruba.xml
share/gnome/dasher/alphabet.Zulu.xml
+share/gnome/dasher/alphabet.abc.xml
+share/gnome/dasher/alphabet.adangbe.xml
share/gnome/dasher/alphabet.afrikaans.xml
+share/gnome/dasher/alphabet.akan.xml
share/gnome/dasher/alphabet.albanian.xml
+share/gnome/dasher/alphabet.amharic.xml
share/gnome/dasher/alphabet.arabic.xml
+share/gnome/dasher/alphabet.basque.xml
share/gnome/dasher/alphabet.bengali.xml
share/gnome/dasher/alphabet.bopomofo.xml
+share/gnome/dasher/alphabet.bosnian.xml
+share/gnome/dasher/alphabet.breton.xml
share/gnome/dasher/alphabet.catalan.xml
+share/gnome/dasher/alphabet.cherokee.xml
share/gnome/dasher/alphabet.chinese.xml
share/gnome/dasher/alphabet.chineseRuby.xml
+share/gnome/dasher/alphabet.corsican.xml
+share/gnome/dasher/alphabet.croatian.xml
share/gnome/dasher/alphabet.czech.xml
share/gnome/dasher/alphabet.danish.xml
+share/gnome/dasher/alphabet.danish2.xml
share/gnome/dasher/alphabet.dtd
share/gnome/dasher/alphabet.dutch.xml
share/gnome/dasher/alphabet.english.xml
-share/gnome/dasher/alphabet.english2.xml
+share/gnome/dasher/alphabet.englishC.xml
+share/gnome/dasher/alphabet.ethiopic.xml
+share/gnome/dasher/alphabet.ewe.xml
+share/gnome/dasher/alphabet.faroese.xml
share/gnome/dasher/alphabet.finnish.xml
+share/gnome/dasher/alphabet.finnish2.xml
share/gnome/dasher/alphabet.french.xml
+share/gnome/dasher/alphabet.ga.xml
+share/gnome/dasher/alphabet.galician.xml
+share/gnome/dasher/alphabet.georgian.xml
share/gnome/dasher/alphabet.german.xml
-share/gnome/dasher/alphabet.greek.xml
-share/gnome/dasher/alphabet.hebrew.xml
+share/gnome/dasher/alphabet.hausa.xml
share/gnome/dasher/alphabet.hiragana.xml
+share/gnome/dasher/alphabet.hiragana2.xml
share/gnome/dasher/alphabet.hungarian.xml
-share/gnome/dasher/alphabet.hungarianLowerCase.xml
share/gnome/dasher/alphabet.ipa.xml
share/gnome/dasher/alphabet.italian.xml
+share/gnome/dasher/alphabet.kazakh.xml
+share/gnome/dasher/alphabet.kirghiz.xml
+share/gnome/dasher/alphabet.kirundi.xml
share/gnome/dasher/alphabet.klingon.xml
share/gnome/dasher/alphabet.korean.xml
+share/gnome/dasher/alphabet.koreanNested.xml
+share/gnome/dasher/alphabet.kurdish.xml
+share/gnome/dasher/alphabet.lao.xml
+share/gnome/dasher/alphabet.latex.xml
+share/gnome/dasher/alphabet.latin.xml
+share/gnome/dasher/alphabet.latvian.xml
+share/gnome/dasher/alphabet.lithuanian.xml
+share/gnome/dasher/alphabet.luxembourgish.xml
+share/gnome/dasher/alphabet.macedonian.xml
+share/gnome/dasher/alphabet.maltese.xml
share/gnome/dasher/alphabet.mongolian.xml
-share/gnome/dasher/alphabet.mongolian2.xml
+share/gnome/dasher/alphabet.myanmar.xml
+share/gnome/dasher/alphabet.nepali.xml
share/gnome/dasher/alphabet.norwegian.xml
+share/gnome/dasher/alphabet.occitan.xml
+share/gnome/dasher/alphabet.ogham.xml
+share/gnome/dasher/alphabet.pashto.xml
+share/gnome/dasher/alphabet.perl.xml
share/gnome/dasher/alphabet.persian.xml
share/gnome/dasher/alphabet.pinyin.xml
share/gnome/dasher/alphabet.polish.xml
share/gnome/dasher/alphabet.portuguese.xml
+share/gnome/dasher/alphabet.romansch.xml
+share/gnome/dasher/alphabet.runic.xml
share/gnome/dasher/alphabet.russian.xml
+share/gnome/dasher/alphabet.sanskrit.xml
+share/gnome/dasher/alphabet.serbian.xml
+share/gnome/dasher/alphabet.somali.xml
share/gnome/dasher/alphabet.spanish.xml
share/gnome/dasher/alphabet.swahili.xml
share/gnome/dasher/alphabet.swedish.xml
share/gnome/dasher/alphabet.thaana.xml
+share/gnome/dasher/alphabet.tigrinya.xml
+share/gnome/dasher/alphabet.turkmen.xml
+share/gnome/dasher/alphabet.ukrainian.xml
+share/gnome/dasher/alphabet.uzbek.xml
share/gnome/dasher/alphabet.venda.xml
share/gnome/dasher/alphabet.welsh.xml
share/gnome/dasher/alphabet.xsl
+share/gnome/dasher/colour.blue.xml
share/gnome/dasher/colour.dtd
-share/gnome/dasher/colour.hiragana.xml
+share/gnome/dasher/colour.euroasian.xml
+share/gnome/dasher/colour.euroasian2.xml
+share/gnome/dasher/colour.jamie.xml
+share/gnome/dasher/colour.rainbow.xml
+share/gnome/dasher/colour.vowels.xml
+share/gnome/dasher/colour.vowels2.xml
share/gnome/dasher/colour.xml
share/gnome/dasher/dasher.glade
-share/gnome/dasher/training_Afrikaans_ZA.txt
-share/gnome/dasher/training_Assamese_IN.txt
-share/gnome/dasher/training_English_ZA.txt
-share/gnome/dasher/training_Esperanto_XX.txt
-share/gnome/dasher/training_Gujarati_IN.txt
-share/gnome/dasher/training_Hindi_IN.txt
-share/gnome/dasher/training_Japanese_JP.txt
-share/gnome/dasher/training_Kannada_IN.txt
-share/gnome/dasher/training_Kashmiri_IN.txt
-share/gnome/dasher/training_Malayalam_IN.txt
-share/gnome/dasher/training_Marathi_IN.txt
-share/gnome/dasher/training_Ndebele_ZA.txt
-share/gnome/dasher/training_Oriya_IN.txt
-share/gnome/dasher/training_Punjabi_IN.txt
-share/gnome/dasher/training_Punjabi_IPA_IN.txt
-share/gnome/dasher/training_Sepedi_ZA.txt
-share/gnome/dasher/training_Sesotho_ZA.txt
-share/gnome/dasher/training_Sinhala_IN.txt
-share/gnome/dasher/training_Swati_ZA.txt
-share/gnome/dasher/training_Tamil_IN.txt
-share/gnome/dasher/training_Telugu_IN.txt
-share/gnome/dasher/training_Tsonga_ZA.txt
-share/gnome/dasher/training_Tswana_ZA.txt
-share/gnome/dasher/training_Urdu_PK.txt
-share/gnome/dasher/training_Venda_ZA.txt
-share/gnome/dasher/training_Xhosa_ZA.txt
-share/gnome/dasher/training_Zulu_ZA.txt
share/gnome/dasher/training_albanian_SQ.txt
+share/gnome/dasher/training_basque_EU.txt
share/gnome/dasher/training_bengali_BD.txt
share/gnome/dasher/training_bengali_bn.txt
share/gnome/dasher/training_czech_CS.txt
@@ -155,8 +179,18 @@ share/gnome/help/dasher/C/figures/prefs3.png
share/gnome/help/dasher/C/figures/prefs4.png
share/gnome/help/dasher/C/figures/prefs5.png
share/gnome/help/dasher/C/version.xml
+share/gnome/help/dasher/eu/dasher.xml
+share/gnome/help/dasher/eu/figures/figure2.png
+share/gnome/help/dasher/eu/figures/main.png
+share/gnome/help/dasher/eu/figures/prefs1.png
+share/gnome/help/dasher/eu/figures/prefs2.png
+share/gnome/help/dasher/eu/figures/prefs3.png
+share/gnome/help/dasher/eu/figures/prefs4.png
+share/gnome/help/dasher/eu/figures/prefs5.png
+share/gnome/help/dasher/eu/version.xml
share/gnome/icons/dasher.png
share/gnome/omf/dasher/dasher-C.omf
+share/gnome/omf/dasher/dasher-eu.omf
share/locale/ar/LC_MESSAGES/dasher.mo
share/locale/az/LC_MESSAGES/dasher.mo
share/locale/be/LC_MESSAGES/dasher.mo
@@ -173,9 +207,12 @@ share/locale/en_CA/LC_MESSAGES/dasher.mo
share/locale/en_GB/LC_MESSAGES/dasher.mo
share/locale/es/LC_MESSAGES/dasher.mo
share/locale/et/LC_MESSAGES/dasher.mo
+share/locale/eu/LC_MESSAGES/dasher.mo
+share/locale/fa/LC_MESSAGES/dasher.mo
share/locale/fi/LC_MESSAGES/dasher.mo
share/locale/fr/LC_MESSAGES/dasher.mo
share/locale/ga/LC_MESSAGES/dasher.mo
+share/locale/gl/LC_MESSAGES/dasher.mo
share/locale/gu/LC_MESSAGES/dasher.mo
share/locale/he/LC_MESSAGES/dasher.mo
share/locale/hi/LC_MESSAGES/dasher.mo
@@ -199,6 +236,7 @@ share/locale/pt/LC_MESSAGES/dasher.mo
share/locale/pt_BR/LC_MESSAGES/dasher.mo
share/locale/ro/LC_MESSAGES/dasher.mo
share/locale/ru/LC_MESSAGES/dasher.mo
+share/locale/rw/LC_MESSAGES/dasher.mo
share/locale/sk/LC_MESSAGES/dasher.mo
share/locale/sq/LC_MESSAGES/dasher.mo
share/locale/sr/LC_MESSAGES/dasher.mo
@@ -207,10 +245,15 @@ share/locale/sv/LC_MESSAGES/dasher.mo
share/locale/ta/LC_MESSAGES/dasher.mo
share/locale/tk/LC_MESSAGES/dasher.mo
share/locale/tr/LC_MESSAGES/dasher.mo
+share/locale/ug/LC_MESSAGES/dasher.mo
share/locale/uk/LC_MESSAGES/dasher.mo
share/locale/zh_CN/LC_MESSAGES/dasher.mo
share/locale/zh_TW/LC_MESSAGES/dasher.mo
+@unexec rmdir %D/share/locale/ug/LC_MESSAGES 2> /dev/null || true
+@unexec rmdir %D/share/locale/ug 2> /dev/null || true
@dirrm share/gnome/omf/dasher
+@dirrm share/gnome/help/dasher/eu/figures
+@dirrm share/gnome/help/dasher/eu
@dirrm share/gnome/help/dasher/C/figures
@dirrm share/gnome/help/dasher/C
@dirrm share/gnome/help/dasher