aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2022-08-08 20:13:43 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2022-08-08 20:15:04 +0000
commitc0460b35bb3b9b791ddbebf258957948258fc69f (patch)
treec6ecc93631055451adb685219196ec3349814b2e
parenta051b5de12ba2a75709d70ef32a98ca62ad8338a (diff)
downloadports-c0460b35bb3b9b791ddbebf258957948258fc69f.tar.gz
ports-c0460b35bb3b9b791ddbebf258957948258fc69f.zip
devel/py-astroid253: add port: legacy version of devel/py-astroid
This is required for devel/py-asttokens testing
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-astroid/Makefile2
-rw-r--r--devel/py-astroid253/Makefile29
-rw-r--r--devel/py-astroid253/distinfo3
-rw-r--r--devel/py-astroid253/pkg-descr13
5 files changed, 48 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f9f48009bf00..b284ee8bad70 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4130,6 +4130,7 @@
SUBDIR += py-aspy.yaml
SUBDIR += py-astor
SUBDIR += py-astroid
+ SUBDIR += py-astroid253
SUBDIR += py-asttokens
SUBDIR += py-astunparse
SUBDIR += py-async_generator
diff --git a/devel/py-astroid/Makefile b/devel/py-astroid/Makefile
index 173db0df45d7..980683b294e3 100644
--- a/devel/py-astroid/Makefile
+++ b/devel/py-astroid/Makefile
@@ -17,6 +17,8 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR}
USES= python:3.7+
USE_PYTHON= autoplist concurrent distutils
+CONFLICTS= ${PYTHON_PKGNAMEPREFIX}astroid253
+
NO_ARCH= yes
.include <bsd.port.pre.mk>
diff --git a/devel/py-astroid253/Makefile b/devel/py-astroid253/Makefile
new file mode 100644
index 000000000000..b1ec1e0d4487
--- /dev/null
+++ b/devel/py-astroid253/Makefile
@@ -0,0 +1,29 @@
+PORTNAME= astroid
+PORTVERSION= 2.5.3
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 253
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Abstract syntax tree for Python with inference support (legacy version)
+
+LICENSE= LGPL21+
+LICENSE_FILE= ${WRKSRC}/COPYING.LESSER
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lazy-object-proxy>=0:devel/py-lazy-object-proxy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wrapt>=0:devel/py-wrapt@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>=0:devel/py-dateutil@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}nose>=0:devel/py-nose@${PY_FLAVOR} \
+ ${PYNUMPY}
+
+USES= python:3.8+ pytest
+USE_PYTHON= autoplist concurrent distutils
+
+CONFLICTS= ${PYTHON_PKGNAMEPREFIX}astroid
+
+NO_ARCH= yes
+PYTEST_IGNORED_TESTS= test_find_distutils_submodules_in_virtualenv
+
+.include <bsd.port.mk>
diff --git a/devel/py-astroid253/distinfo b/devel/py-astroid253/distinfo
new file mode 100644
index 000000000000..1564dcf49114
--- /dev/null
+++ b/devel/py-astroid253/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1619198477
+SHA256 (astroid-2.5.3.tar.gz) = ad63b8552c70939568966811a088ef0bc880f99a24a00834abd0e3681b514f91
+SIZE (astroid-2.5.3.tar.gz) = 317721
diff --git a/devel/py-astroid253/pkg-descr b/devel/py-astroid253/pkg-descr
new file mode 100644
index 000000000000..874747ee0572
--- /dev/null
+++ b/devel/py-astroid253/pkg-descr
@@ -0,0 +1,13 @@
+The aim of this module is to provide a common base representation of python
+source code for projects such as pychecker, pyreverse, pylint... Well, actually
+the development of this library is essentially governed by pylint's needs. It
+used to be called logilab-astng.
+
+It provides a compatible representation which comes from the _ast module. It
+rebuilds the tree generated by the builtin _ast module by recursively walking
+down the AST and building an extended ast. The new node classes have additional
+methods and attributes for different usages. They include some support for
+static inference and local name scopes. Furthermore, astroid builds partial
+trees by inspecting living objects.
+
+WWW: https://github.com/PyCQA/astroid