aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-09-07 20:28:39 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-09-07 20:28:39 +0000
commitc04ae9a4660ab1e7fb11a0c09f81e0fa5045d83d (patch)
treee2b1c60f0f2f0a16ec8de76cf011adb38bfe9880
parentba36f60f898b61b67d5fc3fe7fac3c0e1875484a (diff)
downloadports-c04ae9a4660ab1e7fb11a0c09f81e0fa5045d83d.tar.gz
ports-c04ae9a4660ab1e7fb11a0c09f81e0fa5045d83d.zip
Add pyro.
PyroTechnics is a simple OpenGL-based firework simulator. Features -------- o a bunch of nifty kinds of fireworks o the ability to choreograph firework displays o a texture-mapped water surface o reflections in the water o fogging o a moving camera o the ability to save screenshots WWW: http://nostatic.org/pyro/pyro.html PR: ports/85842 Submitted by: Igor Pokrovsky <ip@doom.homeunix.org>
Notes
Notes: svn path=/head/; revision=142185
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/pyro/Makefile49
-rw-r--r--graphics/pyro/distinfo1
-rw-r--r--graphics/pyro/files/patch-jpeg.c10
-rw-r--r--graphics/pyro/files/patch-pyro.c32
-rw-r--r--graphics/pyro/pkg-descr16
6 files changed, 109 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 5b50b376c5b9..554c421a32b5 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -464,6 +464,7 @@
SUBDIR += py-paint
SUBDIR += py-pydot
SUBDIR += py-visual
+ SUBDIR += pyro
SUBDIR += q-graph
SUBDIR += qcamview
SUBDIR += qcomicbook
diff --git a/graphics/pyro/Makefile b/graphics/pyro/Makefile
new file mode 100644
index 000000000000..b73424e0f1a3
--- /dev/null
+++ b/graphics/pyro/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: pyro
+# Date created: 07 Sep 2005
+# Whom: Igor Pokrovsky <ip@doom.homeunix.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pyro
+PORTVERSION= 1.5
+CATEGORIES= graphics
+MASTER_SITES= http://nostatic.org/pyro/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ip@doom.homeunix.org
+COMMENT= A simple OpenGL-based firework simulator
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ glut.3:${PORTSDIR}/graphics/libglut
+
+USE_REINPLACE= yes
+USE_GL= yes
+USE_X_PREFIX= yes
+
+EXAMPLES= pyro.dsp water.jpg
+PLIST_FILES= bin/pyro ${EXAMPLES:S|^|%%EXAMPLESDIR%%/|}
+PLIST_DIRS= %%EXAMPLESDIR%%
+PORTDOCS= README
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|malloc\.h|stdlib.h|g' ${WRKSRC}/*.c
+
+do-build:
+ ${CC} ${CFLAGS} ${WRKSRC}/*.c -o ${WRKSRC}/${PORTNAME} \
+ -DAUXDIR=\"${EXAMPLESDIR}\" -I${WRKSRC} -I${X11BASE}/include \
+ -I${LOCALBASE}/include -L${X11BASE}/lib -L${LOCALBASE}/lib \
+ -ljpeg -lm -lXmu -lXi -lXext -lGL -lGLU -lglut
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${EXAMPLES:S|^|${WRKSRC}/|} ${EXAMPLESDIR}
+
+.ifndef (NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/pyro/distinfo b/graphics/pyro/distinfo
new file mode 100644
index 000000000000..fd001caa36ee
--- /dev/null
+++ b/graphics/pyro/distinfo
@@ -0,0 +1 @@
+MD5 (pyro-1.5.tgz) = b6f6514e08d753bfa0b966e0eb1d0c09
diff --git a/graphics/pyro/files/patch-jpeg.c b/graphics/pyro/files/patch-jpeg.c
new file mode 100644
index 000000000000..3e352b7e5de0
--- /dev/null
+++ b/graphics/pyro/files/patch-jpeg.c
@@ -0,0 +1,10 @@
+--- jpeg.c.orig
++++ jpeg.c
+@@ -5,6 +5,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <malloc.h>
+ #include "jpeglib.h"
+ #include <setjmp.h>
diff --git a/graphics/pyro/files/patch-pyro.c b/graphics/pyro/files/patch-pyro.c
new file mode 100644
index 000000000000..7ce4e262d850
--- /dev/null
+++ b/graphics/pyro/files/patch-pyro.c
@@ -0,0 +1,32 @@
+--- pyro.c.orig
++++ pyro.c
+@@ -7,15 +7,18 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <math.h>
+ #ifdef __EMX__ /*os2*/
+ #include "float.h"
+ #endif
+ #include <time.h>
+
++/*
+ #ifdef XMESA
+ #include <GL/xmesa.h>
+ #endif
++*/
+
+ #include <GL/glut.h>
+ #include "pyro.h"
+@@ -704,8 +707,9 @@
+ if(fxwin)
+ glutReshapeWindow(ScreenWidth,ScreenHeight);
+ else glutFullScreen();
+-
++/*
+ XMesaSetFXmode(fxwin ? XMESA_FX_WINDOW:XMESA_FX_FULLSCREEN);
++*/
+ }
+ break;
+ #endif
diff --git a/graphics/pyro/pkg-descr b/graphics/pyro/pkg-descr
new file mode 100644
index 000000000000..3563c03e382b
--- /dev/null
+++ b/graphics/pyro/pkg-descr
@@ -0,0 +1,16 @@
+PyroTechnics is a simple OpenGL-based firework simulator.
+
+Features
+--------
+ o a bunch of nifty kinds of fireworks
+ o the ability to choreograph firework displays
+ o a texture-mapped water surface
+ o reflections in the water
+ o fogging
+ o a moving camera
+ o the ability to save screenshots
+
+WWW: http://nostatic.org/pyro/pyro.html
+
+- Igor Pokrovsky
+ip@doom.homeunix.org