aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-09-07 22:32:34 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-09-08 08:28:44 +0000
commitc04e85e180e566fa830b63a3506d919e04ac4bc5 (patch)
tree997d3d0c01ffb1b7c053ac68c5f972ca8b5f303d
parentc316200293b66ec6169ec6efb251ae8e138fca9d (diff)
graphics/luminance-qt5: adjust Eigen dependency
- get Eigen via USES - adjust CMake helpers while here
-rw-r--r--graphics/luminance-qt5/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/graphics/luminance-qt5/Makefile b/graphics/luminance-qt5/Makefile
index 1aa40edae50f..a46df0825042 100644
--- a/graphics/luminance-qt5/Makefile
+++ b/graphics/luminance-qt5/Makefile
@@ -2,7 +2,7 @@
PORTNAME= luminance-hdr
DISTVERSION= 2.6.1.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics
MASTER_SITES= SF/qtpfsgui/luminance/${DISTVERSION}
@@ -11,8 +11,7 @@ COMMENT= Complete open source solution for HDR photography
LICENSE= GPLv2
-BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:math/fftw3 \
- ${LOCALBASE}/include/eigen3/Eigen/Sparse:math/eigen3
+BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:math/fftw3
LIB_DEPENDS= libImath.so:math/Imath \
libtiff.so:graphics/tiff \
libraw_r.so:graphics/libraw \
@@ -26,19 +25,19 @@ LIB_DEPENDS= libImath.so:math/Imath \
CFLAGS+= -I${LOCALBASE}/include/Imath
-USES= cmake desktop-file-utils jpeg pkgconfig qt:5 tar:bzip2
+USES= cmake desktop-file-utils eigen:3 jpeg pkgconfig qt:5 tar:bzip2
USE_QT= concurrent core declarative gui location network \
printsupport sql svg widgets xml \
buildtools_build linguisttools_build qmake_build
-OPTIONS_DEFINE= CFITSIO DOCS HELPBROWSER
+OPTIONS_DEFINE= CFITSIO DOCS HELPBROWSER
OPTIONS_DEFAULT= CFITSIO HELPBROWSER
CFITSIO_LIB_DEPENDS= libcfitsio.so:astro/cfitsio
HELPBROWSER_DESC= Build help browser (requires QtWebEngine)
HELPBROWSER_USE= QT=webchannel,webengine
-HELPBROWSER_CMAKE_ON= -DWITH_HELPBROWSER:BOOL=ON
+HELPBROWSER_CMAKE_ON= WITH_HELPBROWSER
.include <bsd.port.options.mk>