aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2023-01-10 08:05:57 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2023-01-10 08:08:06 +0000
commitc06af015634a05f1f49c9dbe462c164c3e239294 (patch)
tree764035e06711128e702a7ff353c90057f73d8bf9
parentacd43bfbeed6c1ee73f36b08a9c650112218f9ac (diff)
downloadports-c06af015634a05f1f49c9dbe462c164c3e239294.tar.gz
ports-c06af015634a05f1f49c9dbe462c164c3e239294.zip
archivers/libarchive: Update to 3.6.2
* Backport upstream commit 1f35c466aaa9444335a1b854b0b7223b0d2346c2 to fix iconv issue with .pc file * Patch .pc file when compiled on versions of FreeBSD where we don't provide a .pc file for OpenSSL Changelog: https://github.com/libarchive/libarchive/releases/tag/v3.6.2 PR: 268693 Reviewed by: glewis (maintainer)
-rw-r--r--archivers/libarchive/Makefile16
-rw-r--r--archivers/libarchive/distinfo10
-rw-r--r--archivers/libarchive/files/extra-patch-pkgconfig-compat7
3 files changed, 24 insertions, 9 deletions
diff --git a/archivers/libarchive/Makefile b/archivers/libarchive/Makefile
index 49ba0f4b914f..9ff04ead7cd4 100644
--- a/archivers/libarchive/Makefile
+++ b/archivers/libarchive/Makefile
@@ -1,13 +1,12 @@
PORTNAME= libarchive
-DISTVERSION= 3.6.1
-PORTREVISION= 1
+DISTVERSION= 3.6.2
PORTEPOCH= 1
CATEGORIES= archivers
MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/v${DISTVERSION}/ \
https://libarchive.org/downloads/
PATCH_SITES= https://github.com/${PORTNAME}/${PORTNAME}/commit/
-PATCHFILES= bff38efe8c110469c5080d387bec62a6ca15b1a5.patch:-p1
+PATCHFILES= 1f35c466aaa9444335a1b854b0b7223b0d2346c2.patch:-p1
MAINTAINER= glewis@FreeBSD.org
COMMENT= Library to create and read several streaming archive formats
@@ -27,7 +26,8 @@ OPTIONS_RADIO_CRYPTO= OPENSSL MBEDTLS NETTLE
CRYPTO_DESC= Crypto and hashing support
NETTLE_DESC= Crypto support via Nettle
-USES= cpe iconv libtool localbase:ldflags pathfix tar:xz
+USES= autoreconf cpe iconv libtool localbase:ldflags pathfix \
+ pkgconfig tar:xz
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
@@ -117,4 +117,12 @@ CONFIGURE_ENV+= ac_cv_header_localcharset_h=no \
ac_cv_lib_charset_locale_charset=no
.endif
+# Prior to 1301508 we didn't ship openssl.pc which libarchive now excepts
+# so we need to use the old approach on older versions of FreeBSD
+# which is not to define Requires.private in libarchive.pc
+
+.if ${PORT_OPTIONS:MOPENSSL} && ${OPSYS} == FreeBSD && ${OSVERSION} < 1301508
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-pkgconfig-compat
+.endif
+
.include <bsd.port.post.mk>
diff --git a/archivers/libarchive/distinfo b/archivers/libarchive/distinfo
index 2abdb88e3519..1b971ca6d177 100644
--- a/archivers/libarchive/distinfo
+++ b/archivers/libarchive/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1670315616
-SHA256 (libarchive-3.6.1.tar.xz) = 5a411aceb978f43e626f0c2d1812ddd8807b645ed892453acabd532376c148e6
-SIZE (libarchive-3.6.1.tar.xz) = 5241148
-SHA256 (bff38efe8c110469c5080d387bec62a6ca15b1a5.patch) = 4f93c5a102cce1fc672d59888471017b545704bfa9d762c630e84b28215162e7
-SIZE (bff38efe8c110469c5080d387bec62a6ca15b1a5.patch) = 1124
+TIMESTAMP = 1672469724
+SHA256 (libarchive-3.6.2.tar.xz) = 9e2c1b80d5fbe59b61308fdfab6c79b5021d7ff4ff2489fb12daf0a96a83551d
+SIZE (libarchive-3.6.2.tar.xz) = 5213196
+SHA256 (1f35c466aaa9444335a1b854b0b7223b0d2346c2.patch) = 6db4da971fb4d5b3974bfec4c75a4d920a98b1b3bc9a9ccc381055a02205a272
+SIZE (1f35c466aaa9444335a1b854b0b7223b0d2346c2.patch) = 1329
diff --git a/archivers/libarchive/files/extra-patch-pkgconfig-compat b/archivers/libarchive/files/extra-patch-pkgconfig-compat
new file mode 100644
index 000000000000..f51609d6d0e9
--- /dev/null
+++ b/archivers/libarchive/files/extra-patch-pkgconfig-compat
@@ -0,0 +1,7 @@
+--- build/pkgconfig/libarchive.pc.in.orig 2022-12-09 13:38:31 UTC
++++ build/pkgconfig/libarchive.pc.in
+@@ -10,4 +10,3 @@ Cflags: -I${includedir}
+ Cflags.private: -DLIBARCHIVE_STATIC
+ Libs: -L${libdir} -larchive
+ Libs.private: @LIBS@
+-Requires.private: @LIBSREQUIRED@