aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2021-12-04 08:47:19 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2021-12-04 12:07:23 +0000
commitc082f4abe996a6eae0ee94d29e49e73919af379a (patch)
tree2990772883039a3042b394af786a8aac70734154
parent5c8d1c24f8622f77acc3b999bf5c58ed63ea9c61 (diff)
downloadports-c082f4abe996a6eae0ee94d29e49e73919af379a.tar.gz
ports-c082f4abe996a6eae0ee94d29e49e73919af379a.zip
*/*: new ports required for gitlab-ce 14.5
-rw-r--r--devel/Makefile2
-rw-r--r--devel/rubygem-ipynbdiff/Makefile21
-rw-r--r--devel/rubygem-ipynbdiff/distinfo3
-rw-r--r--devel/rubygem-ipynbdiff/pkg-descr6
-rw-r--r--devel/rubygem-sd_notify/Makefile18
-rw-r--r--devel/rubygem-sd_notify/distinfo3
-rw-r--r--devel/rubygem-sd_notify/pkg-descr3
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/rubygem-tanuki_emoji/Makefile19
-rw-r--r--graphics/rubygem-tanuki_emoji/distinfo3
-rw-r--r--graphics/rubygem-tanuki_emoji/pkg-descr4
-rw-r--r--security/Makefile1
-rw-r--r--security/rubygem-omniauth-dingtalk-oauth2/Makefile21
-rw-r--r--security/rubygem-omniauth-dingtalk-oauth2/distinfo3
-rw-r--r--security/rubygem-omniauth-dingtalk-oauth2/pkg-descr3
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/rubygem-diffy330/Makefile20
-rw-r--r--textproc/rubygem-diffy330/distinfo3
-rw-r--r--textproc/rubygem-diffy330/pkg-descr3
19 files changed, 138 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ed07cefeea5a..105651910846 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -6446,6 +6446,7 @@
SUBDIR += rubygem-io-wait
SUBDIR += rubygem-iobuffer
SUBDIR += rubygem-iostruct
+ SUBDIR += rubygem-ipynbdiff
SUBDIR += rubygem-irb
SUBDIR += rubygem-iso8601
SUBDIR += rubygem-jaeger-client
@@ -6753,6 +6754,7 @@
SUBDIR += rubygem-scanf
SUBDIR += rubygem-schash
SUBDIR += rubygem-scientist
+ SUBDIR += rubygem-sd_notify
SUBDIR += rubygem-sdoc
SUBDIR += rubygem-semantic_puppet
SUBDIR += rubygem-semantic_range
diff --git a/devel/rubygem-ipynbdiff/Makefile b/devel/rubygem-ipynbdiff/Makefile
new file mode 100644
index 000000000000..7fdd4849a390
--- /dev/null
+++ b/devel/rubygem-ipynbdiff/Makefile
@@ -0,0 +1,21 @@
+# Created by: Matthias Fechner <mfechner@FreeBSD.org>
+
+PORTNAME= ipynbdiff
+PORTVERSION= 0.3.7
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= mfechner@FreeBSD.org
+COMMENT= Human readable Jupyter Notebook diffs
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-diffy330>=3.3.0<3.3.1:textproc/rubygem-diffy330 \
+ rubygem-json>=2.5.1<2.5.2:devel/rubygem-json
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-ipynbdiff/distinfo b/devel/rubygem-ipynbdiff/distinfo
new file mode 100644
index 000000000000..54f53980fb0b
--- /dev/null
+++ b/devel/rubygem-ipynbdiff/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1638600039
+SHA256 (rubygem/ipynbdiff-0.3.7.gem) = 7d6e4d44762eb4adae528f9f007558027ef041517f382e9eb7556bcefe3a63a0
+SIZE (rubygem/ipynbdiff-0.3.7.gem) = 8192
diff --git a/devel/rubygem-ipynbdiff/pkg-descr b/devel/rubygem-ipynbdiff/pkg-descr
new file mode 100644
index 000000000000..26a38596c3e4
--- /dev/null
+++ b/devel/rubygem-ipynbdiff/pkg-descr
@@ -0,0 +1,6 @@
+This is a simple diff tool that cleans up jupyter notebooks, transforming each
+notebook into a readable markdown file, keeping the output of cells, and
+running the diff after. Markdowns are generated using an opinionated Jupyter
+to Markdown conversion. This means that the entire file is readable on the diff.
+
+WWW: https://gitlab.com/gitlab-org/incubation-engineering/mlops/rb-ipynbdiff
diff --git a/devel/rubygem-sd_notify/Makefile b/devel/rubygem-sd_notify/Makefile
new file mode 100644
index 000000000000..197d67ff4360
--- /dev/null
+++ b/devel/rubygem-sd_notify/Makefile
@@ -0,0 +1,18 @@
+# Created by: Matthias Fechner <mfechner@FreeBSD.org>
+
+PORTNAME= sd_notify
+PORTVERSION= 0.1.1
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= mfechner@FreeBSD.org
+COMMENT= Communicate Ruby state changes to systemd
+
+LICENSE= MIT
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-sd_notify/distinfo b/devel/rubygem-sd_notify/distinfo
new file mode 100644
index 000000000000..6483e1b2c9f6
--- /dev/null
+++ b/devel/rubygem-sd_notify/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1637598556
+SHA256 (rubygem/sd_notify-0.1.1.gem) = cbc7ac6caa7cedd26b30a72b5eeb6f36050dc0752df263452ea24fb5a4ad3131
+SIZE (rubygem/sd_notify-0.1.1.gem) = 7168
diff --git a/devel/rubygem-sd_notify/pkg-descr b/devel/rubygem-sd_notify/pkg-descr
new file mode 100644
index 000000000000..86f98ffde3a6
--- /dev/null
+++ b/devel/rubygem-sd_notify/pkg-descr
@@ -0,0 +1,3 @@
+Notify systemd about various service status changes of Ruby programs
+
+WWW: https://github.com/agis/ruby-sdnotify
diff --git a/graphics/Makefile b/graphics/Makefile
index 3097c62980e6..5deda8df018b 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -1002,6 +1002,7 @@
SUBDIR += rubygem-ruby-graphviz
SUBDIR += rubygem-ruby-vips
SUBDIR += rubygem-scruffy
+ SUBDIR += rubygem-tanuki_emoji
SUBDIR += rx
SUBDIR += s10sh
SUBDIR += s2
diff --git a/graphics/rubygem-tanuki_emoji/Makefile b/graphics/rubygem-tanuki_emoji/Makefile
new file mode 100644
index 000000000000..ea007fd5d912
--- /dev/null
+++ b/graphics/rubygem-tanuki_emoji/Makefile
@@ -0,0 +1,19 @@
+# Created by: Matthias Fechner <mfechner@FreeBSD.org>
+
+PORTNAME= tanuki_emoji
+PORTVERSION= 0.5.0
+CATEGORIES= graphics rubygems
+MASTER_SITES= RG
+
+MAINTAINER= mfechner@FreeBSD.org
+COMMENT= Emoji character information and metadata
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/rubygem-tanuki_emoji/distinfo b/graphics/rubygem-tanuki_emoji/distinfo
new file mode 100644
index 000000000000..e10231f34e50
--- /dev/null
+++ b/graphics/rubygem-tanuki_emoji/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1637598925
+SHA256 (rubygem/tanuki_emoji-0.5.0.gem) = 9abf23cf7d38f0b00357bd55b22b944ebbbdcbab5be342f98f0392df87c280e3
+SIZE (rubygem/tanuki_emoji-0.5.0.gem) = 6562816
diff --git a/graphics/rubygem-tanuki_emoji/pkg-descr b/graphics/rubygem-tanuki_emoji/pkg-descr
new file mode 100644
index 000000000000..4744f2e48123
--- /dev/null
+++ b/graphics/rubygem-tanuki_emoji/pkg-descr
@@ -0,0 +1,4 @@
+This library helps you implement Emoji support in a ruby application
+by providing you access to native Emoji character information.
+
+WWW: https://gitlab.com/gitlab-org/tanuki_emoji
diff --git a/security/Makefile b/security/Makefile
index eaf9c2deb468..b38abcf22b13 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1126,6 +1126,7 @@
SUBDIR += rubygem-omniauth-bitbucket
SUBDIR += rubygem-omniauth-cas
SUBDIR += rubygem-omniauth-cas3
+ SUBDIR += rubygem-omniauth-dingtalk-oauth2
SUBDIR += rubygem-omniauth-gitlab
SUBDIR += rubygem-omniauth-jwt
SUBDIR += rubygem-omniauth-multipassword
diff --git a/security/rubygem-omniauth-dingtalk-oauth2/Makefile b/security/rubygem-omniauth-dingtalk-oauth2/Makefile
new file mode 100644
index 000000000000..671c3837a7d6
--- /dev/null
+++ b/security/rubygem-omniauth-dingtalk-oauth2/Makefile
@@ -0,0 +1,21 @@
+# Created by: Matthias Fechner <mfechner@FreeBSD.org>
+
+PORTNAME= omniauth-dingtalk-oauth2
+PORTVERSION= 1.0.0
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+
+MAINTAINER= mfechner@FreeBSD.org
+COMMENT= Wrapper the DingTalk Oauth2 API
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= rubygem-omniauth-oauth2>=1.7.1<1.8:net/rubygem-omniauth-oauth2
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-omniauth-dingtalk-oauth2/distinfo b/security/rubygem-omniauth-dingtalk-oauth2/distinfo
new file mode 100644
index 000000000000..a437ece339b8
--- /dev/null
+++ b/security/rubygem-omniauth-dingtalk-oauth2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1638530255
+SHA256 (rubygem/omniauth-dingtalk-oauth2-1.0.0.gem) = c89362f55cf66194c7a0966673a7dfba1eed5775ec1daaf2c53cd92d8377d4e9
+SIZE (rubygem/omniauth-dingtalk-oauth2-1.0.0.gem) = 9216
diff --git a/security/rubygem-omniauth-dingtalk-oauth2/pkg-descr b/security/rubygem-omniauth-dingtalk-oauth2/pkg-descr
new file mode 100644
index 000000000000..9efbebcbb6f3
--- /dev/null
+++ b/security/rubygem-omniauth-dingtalk-oauth2/pkg-descr
@@ -0,0 +1,3 @@
+Wrapper the DingTalk Oauth2 API
+
+WWW: https://gitlab.com/gitlab-jh/jh-team/omniauth-dingtalk
diff --git a/textproc/Makefile b/textproc/Makefile
index e200f0c7dbc6..1dd29cbfc3b6 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1621,6 +1621,7 @@
SUBDIR += rubygem-diff-lcs
SUBDIR += rubygem-diff_match_patch
SUBDIR += rubygem-diffy
+ SUBDIR += rubygem-diffy330
SUBDIR += rubygem-docdiff
SUBDIR += rubygem-elasticsearch
SUBDIR += rubygem-elasticsearch-api
diff --git a/textproc/rubygem-diffy330/Makefile b/textproc/rubygem-diffy330/Makefile
new file mode 100644
index 000000000000..e0d9c2cb829b
--- /dev/null
+++ b/textproc/rubygem-diffy330/Makefile
@@ -0,0 +1,20 @@
+# Created by: Ryan Steinmetz <zi@FreeBSD.org>
+
+PORTNAME= diffy
+PORTVERSION= 3.3.0
+CATEGORIES= textproc rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 330
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Convenient diffing in ruby
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/rubygem-diffy330/distinfo b/textproc/rubygem-diffy330/distinfo
new file mode 100644
index 000000000000..a786281f7b07
--- /dev/null
+++ b/textproc/rubygem-diffy330/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1637599843
+SHA256 (rubygem/diffy-3.3.0.gem) = 909af322005817dfd848afb85ba5a30c65c38299b288349ac8c1744607391d62
+SIZE (rubygem/diffy-3.3.0.gem) = 17920
diff --git a/textproc/rubygem-diffy330/pkg-descr b/textproc/rubygem-diffy330/pkg-descr
new file mode 100644
index 000000000000..ce28df66a018
--- /dev/null
+++ b/textproc/rubygem-diffy330/pkg-descr
@@ -0,0 +1,3 @@
+Convenient diffing in ruby
+
+WWW: https://github.com/samg/diffy