aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2023-09-09 21:52:45 +0000
committerDon Lewis <truckman@FreeBSD.org>2023-09-10 05:35:14 +0000
commitc08c8db7796ec3ca70573a363ff34a909cee5105 (patch)
treeeafabb53b7cbba3720719b44a11680cb07a2d739
parente81c9f11826759d60187c6cc79463f5162781170 (diff)
downloadports-c08c8db7796ec3ca70573a363ff34a909cee5105.tar.gz
ports-c08c8db7796ec3ca70573a363ff34a909cee5105.zip
net/nmsg: 1.1.0
1.1.0: * Multiple performance improvements to JSON formatting. * Multiple performance and concurrency improvements in nmsg_io loop. * Add new dnsobs message type for raw passive DNS observations. * Format DNS messages as JSON in base:dnsqr, base:dnstap, and base:dnsobs. * Format base:encode payload in human readable form in JSON output. * Replace yajl with json-c for JSON parsing. * nmsgtool: exit with nonzero status when interrupted by signal. * Correct container size calculation when sequencing. * Address doxygen deprecations. Build fails with JSON_C option turned off, mark BROKEN. Reported upstream. Bump PORTREVISION of dependent ports MFH: 2023Q3 Sponsored by: DomainTools LLC
-rw-r--r--dns/dnstable-convert/Makefile2
-rw-r--r--net/axa/Makefile2
-rw-r--r--net/nmsg/Makefile13
-rw-r--r--net/nmsg/distinfo6
-rw-r--r--net/nmsg/pkg-plist4
-rw-r--r--net/p5-Net-Nmsg/Makefile2
-rw-r--r--net/py-pynmsg/Makefile2
-rw-r--r--net/sie-nmsg/Makefile2
8 files changed, 18 insertions, 15 deletions
diff --git a/dns/dnstable-convert/Makefile b/dns/dnstable-convert/Makefile
index 80760dbd6f5f..b6ce8e38b034 100644
--- a/dns/dnstable-convert/Makefile
+++ b/dns/dnstable-convert/Makefile
@@ -1,6 +1,6 @@
PORTNAME= dnstable-convert
PORTVERSION= 0.12.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= dns
MASTER_SITES= FARSIGHT LOCAL/truckman/farsight
diff --git a/net/axa/Makefile b/net/axa/Makefile
index 754aa293dd4f..acccfdfa38bb 100644
--- a/net/axa/Makefile
+++ b/net/axa/Makefile
@@ -1,6 +1,6 @@
PORTNAME= axa
PORTVERSION= 3.0.1
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= net dns
MASTER_SITES= FARSIGHT LOCAL/truckman/farsight
diff --git a/net/nmsg/Makefile b/net/nmsg/Makefile
index 07dd14e3311f..1a6868c14c56 100644
--- a/net/nmsg/Makefile
+++ b/net/nmsg/Makefile
@@ -1,5 +1,5 @@
PORTNAME= nmsg
-PORTVERSION= 1.0.1
+PORTVERSION= 1.1.0
PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= FARSIGHT LOCAL/truckman/farsight
@@ -24,13 +24,14 @@ PORTDOCS= *
# The DOXYGEN option is best effort.
# If doxygen is installed, it will get used if the option is set to NO.
-OPTIONS_DEFINE= YAJL ZEROMQ DOXYGEN EXAMPLES MANPAGES DOCS
-OPTIONS_DEFAULT= YAJL ZEROMQ DOXYGEN MANPAGES
+OPTIONS_DEFINE= JSON_C ZEROMQ DOXYGEN EXAMPLES MANPAGES DOCS
+OPTIONS_DEFAULT= JSON_C ZEROMQ DOXYGEN MANPAGES
OPTIONS_SUB= yes
-YAJL_DESC= JSON support via libyajl
-YAJL_CONFIGURE_WITH= yajl
-YAJL_LIB_DEPENDS= libyajl.so:devel/yajl
+JSON_C_DESC= JSON support via libjson-c
+JSON_C_CONFIGURE_WITH= json-c
+JSON_C_LIB_DEPENDS= libjson-c.so:devel/json-c
+JSON_C_BROKEN_OFF= Does not build without json-c
ZEROMQ_DESC= ZeroMQ support
ZEROMQ_CONFIGURE_WITH= libzmq
ZEROMQ_LIB_DEPENDS= libzmq.so:net/libzmq4
diff --git a/net/nmsg/distinfo b/net/nmsg/distinfo
index 47112988930b..11f2f81bcc1a 100644
--- a/net/nmsg/distinfo
+++ b/net/nmsg/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1633491704
-SHA256 (nmsg-1.0.1.tar.gz) = 6d9c950b2bd8c507b40ccd925a85b095738f9d036abe6b0d595c1f3eba31ef35
-SIZE (nmsg-1.0.1.tar.gz) = 664217
+TIMESTAMP = 1694205089
+SHA256 (nmsg-1.1.0.tar.gz) = e5931b0cfa38e50f3f9cb7100ffdef454400c5901468c6014a6a602c9215a6d8
+SIZE (nmsg-1.1.0.tar.gz) = 721466
diff --git a/net/nmsg/pkg-plist b/net/nmsg/pkg-plist
index 238f89542ceb..40cbd6896fad 100644
--- a/net/nmsg/pkg-plist
+++ b/net/nmsg/pkg-plist
@@ -4,6 +4,7 @@ include/nmsg/alias.h
include/nmsg/asprintf.h
include/nmsg/base/defs.h
include/nmsg/base/dns.pb-c.h
+include/nmsg/base/dnsobs.pb-c.h
include/nmsg/base/dnsqr.pb-c.h
include/nmsg/base/dnstap.pb-c.h
include/nmsg/base/email.pb-c.h
@@ -45,12 +46,13 @@ include/nmsg/zbuf.h
lib/libnmsg.a
lib/libnmsg.so
lib/libnmsg.so.8
-lib/libnmsg.so.8.0.0
+lib/libnmsg.so.8.1.0
lib/nmsg/nmsg_flt1_sample.so
lib/nmsg/nmsg_msg9_base.so
libdata/pkgconfig/libnmsg.pc
%%MANPAGES%%man/man1/nmsgtool.1.gz
%%DATADIR%%/base/dns.proto
+%%DATADIR%%/base/dnsobs.proto
%%DATADIR%%/base/dnsqr.proto
%%DATADIR%%/base/dnstap.proto
%%DATADIR%%/base/email.proto
diff --git a/net/p5-Net-Nmsg/Makefile b/net/p5-Net-Nmsg/Makefile
index 2bdff64213b6..b78301920cc5 100644
--- a/net/p5-Net-Nmsg/Makefile
+++ b/net/p5-Net-Nmsg/Makefile
@@ -1,6 +1,6 @@
PORTNAME= Net-Nmsg
PORTVERSION= 0.17
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net perl5
MASTER_SITES= https://tools.netsa.cert.org/confluence/download/attachments/12320770/ \
CPAN
diff --git a/net/py-pynmsg/Makefile b/net/py-pynmsg/Makefile
index 5a27f3dd40c1..36a287d7ca34 100644
--- a/net/py-pynmsg/Makefile
+++ b/net/py-pynmsg/Makefile
@@ -1,6 +1,6 @@
PORTNAME= pynmsg
PORTVERSION= 0.5.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net python
MASTER_SITES= FARSIGHT LOCAL/truckman/farsight
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/net/sie-nmsg/Makefile b/net/sie-nmsg/Makefile
index 527ef7ac56e3..9aebbfe992b8 100644
--- a/net/sie-nmsg/Makefile
+++ b/net/sie-nmsg/Makefile
@@ -1,6 +1,6 @@
PORTNAME= sie-nmsg
PORTVERSION= 1.2.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net dns
MASTER_SITES= FARSIGHT LOCAL/truckman/farsight