aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-05-15 18:16:23 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-05-15 18:16:23 +0000
commitc08cfc3dc9e58585d1b6601e95e9633a7614e5cc (patch)
treecf42a01bfae5ad7a56cc61e09457eaaa7187d25a
parentae6af583691e07daa6e90557713f793051411d15 (diff)
downloadports-c08cfc3dc9e58585d1b6601e95e9633a7614e5cc.tar.gz
ports-c08cfc3dc9e58585d1b6601e95e9633a7614e5cc.zip
- Unbreak on -stable;
- extend a start-up script with a workaround for Via Apollo KX133 chipset. Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=59188
-rw-r--r--audio/aureal-kmod/Makefile18
-rw-r--r--audio/aureal-kmod/distinfo3
-rw-r--r--audio/aureal-kmod/files/aureal.sh30
-rw-r--r--audio/aureal-kmod/pkg-descr2
-rw-r--r--audio/aureal-kmod/pkg-message6
-rw-r--r--audio/aureal-kmod/pkg-plist5
6 files changed, 53 insertions, 11 deletions
diff --git a/audio/aureal-kmod/Makefile b/audio/aureal-kmod/Makefile
index 77bc002c7224..55d21ae83d3a 100644
--- a/audio/aureal-kmod/Makefile
+++ b/audio/aureal-kmod/Makefile
@@ -7,7 +7,7 @@
PORTNAME= aureal-kmod
PORTVERSION= 1.5
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio
MASTER_SITES= http://home.columbus.rr.com/amatey/au88x0/
DISTNAME= au88x0-${PORTVERSION}_${PORTREVISION}
@@ -60,18 +60,26 @@ PORTREVISION= 2
MAKE_ENV+= HAVE_KOBJ_PCM=1
.endif
-.elif ${OSVERSION} < 500000
-# FreeBSD 4.4
+.elif ${OSVERSION} < 450004
+# FreeBSD 4.4, 4.5-
PORTVERSION= 1.3
PORTREVISION= 3
MAKE_ENV+= HAVE_KOBJ_PCM=1
+.elif ${OSVERSION} < 500000
+# FreeBSD 4.5+
+.if ${VERSION_SOUND_C_STABLE} < 12
+BROKEN= "Base system is outdated. This port needs -STABLE after 2002-04-22."
+.endif
+PORTVERSION= 1.3
+PORTREVISION= 4
+MAKE_ENV+= HAVE_KOBJ_PCM=1
.endif
.if ${OSVERSION} > 500000
# FreeBSD 5-CURRENT
-.if ${VERSION_SOUND_C_CURRENT} < 52
-BROKEN= "Base system is outdated. This port needs -CURRENT after 6/17/2001."
+.if ${VERSION_SOUND_C_CURRENT} < 70
+BROKEN= "Base system is outdated. This port needs -CURRENT after 2002-04-04."
.endif
.endif
diff --git a/audio/aureal-kmod/distinfo b/audio/aureal-kmod/distinfo
index 91fc61cdf342..9eb4ad7e916d 100644
--- a/audio/aureal-kmod/distinfo
+++ b/audio/aureal-kmod/distinfo
@@ -2,4 +2,5 @@ MD5 (au88x0-1.1_3.tar.gz) = 811026b4fd105b5b9e6a0ebfdc83b75a
MD5 (au88x0-1.3_1.tar.gz) = ec49c6e62847f6a0da318fea8c954917
MD5 (au88x0-1.3_2.tar.gz) = 266a8ba37778bfd1ea4007407f733540
MD5 (au88x0-1.3_3.tar.gz) = 5fc5e2c6d93a9209e91f7fcd02d56ddc
-MD5 (au88x0-1.5_3.tar.gz) = fa401f56925ea7793fb4238c354a44b7
+MD5 (au88x0-1.3_4.tar.gz) = 59962de0e7c97d22e799a25f4a2ec303
+MD5 (au88x0-1.5_4.tar.gz) = 215bb870b6866cef008b93cb942503d9
diff --git a/audio/aureal-kmod/files/aureal.sh b/audio/aureal-kmod/files/aureal.sh
index 457d513edbbb..fd31863ed662 100644
--- a/audio/aureal-kmod/files/aureal.sh
+++ b/audio/aureal-kmod/files/aureal.sh
@@ -1,5 +1,8 @@
#!/bin/sh
-
+#---------------------------------------------------------------------
+#
+# I. Auto-detection of your Aureal Vortex sound card
+#
# If for some reason this script fails to guess the type of your
# Aureal card correctly, you can manually override it here.
# Set this to 8810 (Vortex Advantage), 8820 (Vortex 1) or 8830
@@ -7,6 +10,15 @@
#
#CARD=8830
#
+# II. VIA Apollo KX133 lock-up issue workaround
+#
+# If your AMD Athlon system is based on a VIA Apollo KX133 motherboard
+# chipset, your system will most certainly lock up shortly after
+# you start a playback. To work around this issue please uncomment
+# this line:
+#
+#VIAKX133FIX=yes
+#---------------------------------------------------------------------
PCICONF="/usr/sbin/pciconf"
@@ -39,7 +51,22 @@ case "$1" in
exit 64
fi
/sbin/kldload ${LIBDIR}/${DRIVERFILE}
+
echo -n " aureal-kmod"
+
+ # Increase PCI timeout for broken VIA Apollo KX133 chipsets
+ # NOTE: This assumes your Aureal card is the pcm0 device
+ if [ "$VIAKX133FIX" ]; then
+ pcisel=`${PCICONF} -l 2>&- | grep ^pcm0 | awk -F: '{ gsub("^[^@]*@", ""); print $1":"$2":"$3 }'`
+ if [ -z "$pcisel" ]; then
+ echo " (WARNING: Soundcard PCI selector undetermined. Unable to install VIA KX133 workaround. Starting a playback will likely to lock-up your system!)"
+ exit 64
+ fi
+ oldvalue=`${PCICONF} -r -b $pcisel 0x40 2>&- | sed 's/ *$//'`
+ echo -n " (with VIA KX133 workaround: ${pcisel},0x40: ${oldvalue} -> "
+ ${PCICONF} -w -b $pcisel 0x40 0xff
+ echo -n "`${PCICONF} -r -b $pcisel 0x40 2>&- | sed 's/ *$//'`)"
+ fi
;;
stop)
/sbin/kldunload ${DRIVERFILE}
@@ -52,3 +79,4 @@ case "$1" in
exit 64
;;
esac
+
diff --git a/audio/aureal-kmod/pkg-descr b/audio/aureal-kmod/pkg-descr
index 4fb88673d8d4..38ab6156e4f3 100644
--- a/audio/aureal-kmod/pkg-descr
+++ b/audio/aureal-kmod/pkg-descr
@@ -1,3 +1,3 @@
FreeBSD Driver for Aureal Vortex based soundcards.
-WWW: http://home.columbus.rr.com/amatey/au88x0/
+WWW: http://www.matey.org/au88x0/
diff --git a/audio/aureal-kmod/pkg-message b/audio/aureal-kmod/pkg-message
index af7df622fc51..a344aa4cad81 100644
--- a/audio/aureal-kmod/pkg-message
+++ b/audio/aureal-kmod/pkg-message
@@ -1,4 +1,6 @@
-------------------------------------------------------------------------------
+IMPORTANT! MAKE SURE TO READ THE FOLLOWING!
+
To use the driver, make a copy of %%PREFIX%%/etc/rc.d/aureal.sh.sample under
%%PREFIX%%/etc/rc.d/aureal.sh and do: chmod +x %%PREFIX%%/etc/rc.d/aureal.sh.
@@ -17,6 +19,10 @@ edit this script and set "CARD=" to 88X0 where X is 1, 2 or 3 depending
on which Aureal chipset you have - au8810 (Vortex Advantage), au8820
(Vortex 1) or au8830 (Vortex 2) correspondingly.
+If your system is based on a Via Apollo KX133 chipset, your computer will
+most likely lock up soon after playback is started. This is a known issue.
+Make sure to uncomment "VIAKX133FIX=yes" in aureal.sh start-up script.
+
Please note that you also need to have a `snd_pcm.ko' module either already
loaded or placed into appropriate location for modules on your system (default
is /modules/ on 4-STABLE and /boot/kernel/ on 5-CURRENT). You can compile and
diff --git a/audio/aureal-kmod/pkg-plist b/audio/aureal-kmod/pkg-plist
index 412c03910a54..7b3464cf7d54 100644
--- a/audio/aureal-kmod/pkg-plist
+++ b/audio/aureal-kmod/pkg-plist
@@ -1,8 +1,7 @@
etc/rc.d/aureal.sh.sample
-@unexec /usr/bin/chflags noschg %D/lib/au88x0/snd_au8810.ko
+@unexec `if [ -e /bin/chflags ]; then echo /bin/chflags; else echo /usr/bin/chflags; fi` noschg %D/lib/au88x0/snd_au88?0.ko
+@unexec rm -f %D/lib/au88x0/linker.hints
lib/au88x0/snd_au8810.ko
-@unexec /usr/bin/chflags noschg %D/lib/au88x0/snd_au8820.ko
lib/au88x0/snd_au8820.ko
-@unexec /usr/bin/chflags noschg %D/lib/au88x0/snd_au8830.ko
lib/au88x0/snd_au8830.ko
@dirrm lib/au88x0