aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-07-09 21:56:39 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-07-09 21:59:01 +0000
commitc0a5e2416d2b24af2d83fc97fa9dde37c152d6ec (patch)
treeea95f58300e77d19c29ee32e28d5a98b1cc53582
parent71d85cac1937709444cc3f64f4745015b0acec33 (diff)
downloadports-c0a5e2416d2b24af2d83fc97fa9dde37c152d6ec.tar.gz
ports-c0a5e2416d2b24af2d83fc97fa9dde37c152d6ec.zip
*: (KDE ports) tidy up dependencies
Go another round with the dependency-cleanup: - ECM and doctools are still more only a build-dep - Qt testlibs is a build-dep This touches plenty of ports outside of KDE Frameworks that did **not** list their full dependencies and could get away with it because frameworks pulled in too much.
-rw-r--r--deskutils/plasma5-milou/Makefile5
-rw-r--r--devel/kf5-kcmutils/Makefile2
-rw-r--r--devel/kf5-kio/Makefile2
-rw-r--r--devel/plasma5-khotkeys/Makefile7
-rw-r--r--editors/kate/Makefile8
-rw-r--r--graphics/skanlite/Makefile6
-rw-r--r--math/analitza/Makefile4
-rw-r--r--math/cantor/Makefile13
-rw-r--r--math/rocs/Makefile8
-rw-r--r--misc/klettres/Makefile7
-rw-r--r--net-im/kopete/Makefile8
-rw-r--r--net/kf5-kdav/Makefile2
-rw-r--r--security/plasma5-kscreenlocker/Makefile12
-rw-r--r--security/plasma5-ksshaskpass/Makefile4
-rw-r--r--sysutils/filelight/Makefile10
-rw-r--r--sysutils/khelpcenter/Makefile12
-rw-r--r--sysutils/plasma5-discover/Makefile10
-rw-r--r--sysutils/plasma5-drkonqi/Makefile8
-rw-r--r--sysutils/plasma5-kde-cli-tools/Makefile12
-rw-r--r--sysutils/plasma5-kinfocenter/Makefile6
-rw-r--r--sysutils/plasma5-kmenuedit/Makefile8
-rw-r--r--sysutils/plasma5-ksysguard/Makefile4
-rw-r--r--sysutils/plasma5-powerdevil/Makefile6
-rw-r--r--sysutils/plasma5-systemsettings/Makefile6
-rw-r--r--www/qt5-webchannel/Makefile5
-rw-r--r--x11-themes/plasma5-kde-gtk-config/Makefile10
-rw-r--r--x11-wm/plasma5-kdecoration/Makefile7
-rw-r--r--x11-wm/plasma5-kwin/Makefile7
-rw-r--r--x11/plasma5-kgamma5/Makefile10
-rw-r--r--x11/plasma5-libkscreen/Makefile8
-rw-r--r--x11/plasma5-plasma-desktop/Makefile8
-rw-r--r--x11/plasma5-plasma-workspace/Makefile12
32 files changed, 144 insertions, 93 deletions
diff --git a/deskutils/plasma5-milou/Makefile b/deskutils/plasma5-milou/Makefile
index fdc42d728c81..f9c0242377a4 100644
--- a/deskutils/plasma5-milou/Makefile
+++ b/deskutils/plasma5-milou/Makefile
@@ -1,5 +1,6 @@
PORTNAME= milou
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= deskutils kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -8,7 +9,7 @@ COMMENT= Plasma5 Plasmoid for search
USES= cmake compiler:c++11-lib cpe gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs config coreaddons i18n itemmodels kdeclarative package \
plasma-framework runner service
-USE_QT= core declarative gui network script testlib widgets \
- buildtools_build qmake_build
+USE_QT= core declarative gui network script widgets \
+ buildtools_build qmake_build testlib_build
.include <bsd.port.mk>
diff --git a/devel/kf5-kcmutils/Makefile b/devel/kf5-kcmutils/Makefile
index 3b46e0ec1ecc..083f94959e25 100644
--- a/devel/kf5-kcmutils/Makefile
+++ b/devel/kf5-kcmutils/Makefile
@@ -11,6 +11,6 @@ USE_KDE= auth codecs config configwidgets coreaddons guiaddons i18n \
widgetsaddons xmlgui \
ecm_build
USE_QT= core dbus declarative gui network widgets xml \
- buildtools_build qmake_build
+ buildtools_build qmake_build testlib_build
.include <bsd.port.mk>
diff --git a/devel/kf5-kio/Makefile b/devel/kf5-kio/Makefile
index 8288c41df7c4..e9e30041beef 100644
--- a/devel/kf5-kio/Makefile
+++ b/devel/kf5-kio/Makefile
@@ -16,6 +16,6 @@ USE_KDE= archive auth bookmarks codecs completion config \
doctools_build ecm_build
USE_QT= concurrent core dbus declarative gui network \
script widgets x11extras xml \
- buildtools_build qmake_build
+ buildtools_build qmake_build testlib_build
.include <bsd.port.mk>
diff --git a/devel/plasma5-khotkeys/Makefile b/devel/plasma5-khotkeys/Makefile
index 7e17f0ff9219..a8b7ae208a1a 100644
--- a/devel/plasma5-khotkeys/Makefile
+++ b/devel/plasma5-khotkeys/Makefile
@@ -1,17 +1,20 @@
PORTNAME= khotkeys
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= devel kde kde-plasma
MAINTAINER= kde@FreeBSD.org
COMMENT= Plasma5 library for hotkeys
USES= cmake compiler:c++11-lib cpe gettext kde:5 qt:5 tar:xz xorg
+# kdelibs4support needs doctools
USE_KDE= auth bookmarks codecs completion config configwidgets \
- coreaddons crash dbusaddons ecm emoticons globalaccel \
+ coreaddons crash dbusaddons emoticons globalaccel \
guiaddons i18n iconthemes init itemmodels itemviews jobwidgets \
kcmutils kdelibs4support kio notifications parts \
plasma-framework plasma-workspace service solid sonnet \
- textwidgets unitconversion widgetsaddons windowsystem xmlgui
+ textwidgets unitconversion widgetsaddons windowsystem xmlgui \
+ doctools_build ecm_build
USE_QT= concurrent core dbus gui network printsupport widgets x11extras xml \
buildtools_build qmake_build
USE_XORG= x11 xtst
diff --git a/editors/kate/Makefile b/editors/kate/Makefile
index e5f7ee38fb83..e7a0ce08aee4 100644
--- a/editors/kate/Makefile
+++ b/editors/kate/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kate
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= editors kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -12,13 +13,14 @@ LIB_DEPENDS= libgit2.so:devel/libgit2
USES= cmake compiler:c++11-lang desktop-file-utils gettext \
pkgconfig kde:5 qt:5 tar:xz
USE_KDE= activities attica auth bookmarks codecs completion config \
- configwidgets coreaddons crash dbusaddons doctools ecm \
+ configwidgets coreaddons crash dbusaddons \
guiaddons i18n iconthemes init itemmodels itemviews \
jobwidgets kio newstuff package parts plasma-framework \
service solid sonnet texteditor textwidgets threadweaver \
- wallet widgetsaddons windowsystem xmlgui
+ wallet widgetsaddons windowsystem xmlgui \
+ doctools_build ecm_build
USE_QT= concurrent core dbus gui network script sql widgets xml \
- buildtools_build qmake_build
+ buildtools_build qmake_build testlib_build
OPTIONS_DEFINE= DOCS
diff --git a/graphics/skanlite/Makefile b/graphics/skanlite/Makefile
index f152e2bf24dd..ee4c792c034d 100644
--- a/graphics/skanlite/Makefile
+++ b/graphics/skanlite/Makefile
@@ -1,6 +1,6 @@
PORTNAME= skanlite
DISTVERSION= 2.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION:R}/
@@ -18,8 +18,8 @@ USE_KDE= auth config configwidgets codecs completion \
coreaddons i18n jobwidgets kio \
service widgetsaddons xmlgui \
doctools_build ecm_build
-USE_QT= buildtools_build qmake_build \
- core concurrent dbus gui network widgets xml
+USE_QT= core concurrent dbus gui network widgets xml \
+ buildtools_build qmake_build testlib_build
.include <bsd.port.mk>
diff --git a/math/analitza/Makefile b/math/analitza/Makefile
index 22ae3d652384..8f98f0aebb39 100644
--- a/math/analitza/Makefile
+++ b/math/analitza/Makefile
@@ -13,9 +13,9 @@ LICENSE_FILE_GPLv2= ${WRKSRC}/COPYING
USES= cmake compiler:c++11-lang eigen:3 gl kde:5 qt:5 tar:xz
USE_GL= glu
-USE_KDE= ecm
+USE_KDE= ecm_build
USE_QT= core declarative gui network opengl printsupport svg widgets xml \
- buildtools_build linguisttools_build qmake_build
+ buildtools_build linguisttools_build qmake_build testlib_build
USE_LDCONFIG= yes
diff --git a/math/cantor/Makefile b/math/cantor/Makefile
index 54c19263c0df..dbc4cb9974a3 100644
--- a/math/cantor/Makefile
+++ b/math/cantor/Makefile
@@ -1,8 +1,6 @@
-# TODO: ensure only ${PYTON_CMD} is pixked again
-
PORTNAME= cantor
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -20,12 +18,13 @@ BUILD_DEPENDS= ${LOCALBASE}/share/xsl/docbook/html/docbook.xsl:textproc/docbook-
USES= cmake compiler:c++11-lang desktop-file-utils gettext kde:5 \
pkgconfig python:3.4+ qt:5 tar:xz
USE_KDE= attica auth archive bookmarks codecs completion config \
- configwidgets coreaddons crash ecm emoticons i18n iconthemes \
+ configwidgets coreaddons crash emoticons i18n iconthemes \
itemmodels itemviews init jobwidgets kdelibs4support kio \
newstuff parts pty service solid sonnet syntaxhighlighting \
- texteditor textwidgets widgetsaddons xmlgui
+ texteditor textwidgets widgetsaddons xmlgui \
+ ecm_build
USE_QT= concurrent core dbus gui network printsupport svg widgets xml xmlpatterns \
- buildtools_build qmake_build
+ buildtools_build qmake_build testlib_build
USE_LDCONFIG= yes
OPTIONS_DEFINE= LUAJIT MAXIMA OCTAVE R SAGE SCILAB DOCS
@@ -53,7 +52,7 @@ SAGE_RUN_DEPENDS= sage:math/sage
SCILAB_DESC= Install Scilab
SCILAB_RUN_DEPENDS= scilab:math/scilab
-# Disable python2 binding (should probably be an option PYTHON2, PYTHON3)
+# Disable python2 binding
CMAKE_ON= CMAKE_DISABLE_FIND_PACKAGE_PythonLibs
post-patch:
diff --git a/math/rocs/Makefile b/math/rocs/Makefile
index c028f27bdf3a..f77e8bcd0122 100644
--- a/math/rocs/Makefile
+++ b/math/rocs/Makefile
@@ -1,5 +1,6 @@
PORTNAME= rocs
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= math education kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -10,12 +11,13 @@ LIB_DEPENDS= libboost_thread.so:devel/boost-libs
USES= cmake compiler:c++11-lang desktop-file-utils gettext grantlee:5 kde:5 \
qt:5 tar:xz
USE_KDE= archive auth codecs completion config configwidgets coreaddons \
- crash doctools ecm i18n itemviews jobwidgets kdeclarative \
+ crash i18n itemviews jobwidgets kdeclarative \
kio package parts service sonnet texteditor textwidgets \
- widgetsaddons xmlgui
+ widgetsaddons xmlgui \
+ doctools_build ecm_build
USE_QT= concurrent core dbus declarative gui network script scripttools svg webkit \
widgets xml xmlpatterns \
- buildtools_build qmake_build
+ buildtools_build qmake_build testlib_build
USE_LDCONFIG= yes
diff --git a/misc/klettres/Makefile b/misc/klettres/Makefile
index b57d8dcf8b6f..a4e9c9020749 100644
--- a/misc/klettres/Makefile
+++ b/misc/klettres/Makefile
@@ -7,10 +7,11 @@ COMMENT= Alphabet learning tool for KDE
USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= attica auth codecs completion config configwidgets coreaddons \
- crash doctools ecm emoticons i18n init itemmodels \
- kdelibs4support newstuff service widgetsaddons xmlgui
+ crash emoticons i18n init itemmodels \
+ kdelibs4support newstuff service widgetsaddons xmlgui \
+ doctools_build ecm_build
USE_QT= core dbus gui network phonon4 svg widgets xml \
- buildtools_build qmake_build
+ buildtools_build qmake_build testlib_build
OPTIONS_DEFINE= DOCS
diff --git a/net-im/kopete/Makefile b/net-im/kopete/Makefile
index 510cc1eea68c..1bbbbfa9b964 100644
--- a/net-im/kopete/Makefile
+++ b/net-im/kopete/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kopete
PORTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net-im kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -15,15 +16,16 @@ USES= cmake compiler:c++11-lang desktop-file-utils gnome jpeg kde:5 \
qca qt:5 shebangfix tar:xz
USE_GNOME= libxml2 libxslt
USE_KDE= archive auth bookmarks codecs completion config configwidgets \
- coreaddons crash dbusaddons dnssd ecm emoticons guiaddons i18n \
+ coreaddons crash dbusaddons dnssd emoticons guiaddons i18n \
iconthemes itemviews jobwidgets js kcmutils kdelibs4support \
khtml kio notifications notifyconfig parts service solid sonnet \
texteditor textwidgets unitconversion wallet widgetsaddons \
- windowsystem xmlgui
+ windowsystem xmlgui \
+ ecm_build
# KDE PIM components
USE_KDE+= contacts identitymanagement libkleo pimtextedit
USE_QT= concurrent core dbus gui network phonon4 printsupport sql widgets xml \
- buildtools_build qmake_build
+ buildtools_build qmake_build testlib_build
SHEBANG_FILES= protocols/winpopup/winpopup-install \
protocols/winpopup/winpopup-send \
diff --git a/net/kf5-kdav/Makefile b/net/kf5-kdav/Makefile
index 3bc57912822d..28174d7daddf 100644
--- a/net/kf5-kdav/Makefile
+++ b/net/kf5-kdav/Makefile
@@ -10,7 +10,7 @@ USES= cmake compiler:c++11-lib gettext kde:5 qt:5 tar:xz
USE_KDE= config coreaddons i18n kio service \
ecm_build
USE_QT= concurrent core dbus gui network xml xmlpatterns \
- buildtools_build qmake_build
+ buildtools_build qmake_build testlib_build
USE_LDCONFIG= yes
DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
diff --git a/security/plasma5-kscreenlocker/Makefile b/security/plasma5-kscreenlocker/Makefile
index c5c738e7bc93..ee5e3649172a 100644
--- a/security/plasma5-kscreenlocker/Makefile
+++ b/security/plasma5-kscreenlocker/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kscreenlocker
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= security kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -13,13 +14,14 @@ RUN_DEPENDS= ck-list-sessions:sysutils/consolekit2\
USES= cmake compiler:c++11-lib cpe gettext kde:5 pkgconfig \
qt:5 shebangfix tar:xz xorg
-USE_KDE= auth codecs config configwidgets coreaddons crash ecm \
+USE_KDE= auth codecs config configwidgets coreaddons crash \
emoticons globalaccel i18n idletime init itemmodels kcmutils \
- kdeclarative kdelibs4support layer-shell-qt notifications package \
+ kdeclarative layer-shell-qt notifications package \
plasma-framework sonnet textwidgets wayland widgetsaddons \
- windowsystem xmlgui
-USE_QT= core dbus declarative gui network qdbus testlib widgets x11extras xml \
- buildtools_build qmake_build
+ windowsystem xmlgui \
+ ecm_build
+USE_QT= core dbus declarative gui network qdbus widgets x11extras xml \
+ buildtools_build qmake_build testlib_build
USE_XORG= ice sm x11 xcb xcursor xext xi
SHEBANG_FILES= updaters/ksreenlocker_5_3_separate_autologin.pl
diff --git a/security/plasma5-ksshaskpass/Makefile b/security/plasma5-ksshaskpass/Makefile
index cd44895c18e4..becb5d1d439a 100644
--- a/security/plasma5-ksshaskpass/Makefile
+++ b/security/plasma5-ksshaskpass/Makefile
@@ -1,12 +1,14 @@
PORTNAME= ksshaskpass
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= security kde kde-plasma
MAINTAINER= kde@FreeBSD.org
COMMENT= Plasma5 ssh-add frontend
USES= cmake compiler:c++11-lib cpe gettext kde:5 qt:5 tar:xz
-USE_KDE= coreaddons doctools ecm i18n wallet widgetsaddons
+USE_KDE= coreaddons i18n wallet widgetsaddons \
+ doctools_build ecm_build
USE_QT= core gui widgets \
buildtools_build qmake_build
diff --git a/sysutils/filelight/Makefile b/sysutils/filelight/Makefile
index 60556b2d9e20..1e7dbc4a7bf8 100644
--- a/sysutils/filelight/Makefile
+++ b/sysutils/filelight/Makefile
@@ -1,5 +1,6 @@
PORTNAME= filelight
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= sysutils kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -11,11 +12,12 @@ BUILD_DEPENDS= ${LOCALBASE}/share/xsl/docbook/html/docbook.xsl:textproc/docbook-
USES= cmake compiler:c++11-lang desktop-file-utils gettext \
kde:5 qt:5 tar:xz
-USE_KDE= auth codecs completion config configwidgets coreaddons doctools \
- ecm i18n jobwidgets kio parts service solid sonnet textwidgets \
- widgetsaddons xmlgui
+USE_KDE= auth codecs completion config configwidgets coreaddons \
+ i18n jobwidgets kio parts service solid sonnet textwidgets \
+ widgetsaddons xmlgui \
+ doctools_build ecm_build
USE_QT= concurrent core dbus gui network script widgets xml \
- buildtools_build qmake_build
+ buildtools_build qmake_build testlib_build
OPTIONS_DEFINE= DOCS
diff --git a/sysutils/khelpcenter/Makefile b/sysutils/khelpcenter/Makefile
index 6dd4ee9b2956..48a7e9b653d1 100644
--- a/sysutils/khelpcenter/Makefile
+++ b/sysutils/khelpcenter/Makefile
@@ -1,5 +1,6 @@
PORTNAME= khelpcenter
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= sysutils kde kde-applications # kde kde-applications-plasma
MAINTAINER= kde@FreeBSD.org
@@ -11,10 +12,15 @@ USES= cmake compiler:c++11-lib cpe gettext gnome grantlee:5 kde:5 \
qt:5 shebangfix tar:xz
USE_GNOME= libxml2
USE_KDE= archive auth bookmarks codecs completion config configwidgets \
- coreaddons dbusaddons doctools ecm emoticons i18n init \
- itemmodels itemviews jobwidgets js kcmutils kdelibs4support \
+ coreaddons dbusaddons emoticons i18n init \
+ itemmodels itemviews jobwidgets js kcmutils \
kio khtml parts service sonnet textwidgets widgetsaddons \
- windowsystem xmlgui
+ windowsystem xmlgui \
+ ecm_build
+# This port depends on doctools; we need the entities and such for runtime
+# documentation support, where all the other KDE Plasma parts need it
+# only for the build-time documentation-generation.
+USE_KDE+= doctools
USE_QT= concurrent core dbus gui network widgets xml \
buildtools_build qmake_build
SHEBANG_FILES= searchhandlers/khc_mansearch.pl
diff --git a/sysutils/plasma5-discover/Makefile b/sysutils/plasma5-discover/Makefile
index 271bddf596d2..a12816d959c4 100644
--- a/sysutils/plasma5-discover/Makefile
+++ b/sysutils/plasma5-discover/Makefile
@@ -1,5 +1,6 @@
PORTNAME= discover
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= sysutils kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -11,12 +12,13 @@ COMMENT= Plasma5 package management tools
USES= cmake compiler:c++11-lib cpe desktop-file-utils \
gettext kde:5 pkgconfig qt:5 tar:xz
USE_KDE= archive attica auth codecs completion config configwidgets \
- coreaddons crash dbusaddons ecm i18n iconthemes idletime itemmodels \
+ coreaddons crash dbusaddons i18n iconthemes idletime itemmodels \
itemviews jobwidgets kcmutils kdeclarative kio kirigami2 newstuff \
notifications package plasma-framework service solid \
- textwidgets wallet windowsystem widgetsaddons xmlgui
-USE_QT= concurrent core dbus declarative gui network svg testlib \
+ textwidgets wallet windowsystem widgetsaddons xmlgui \
+ ecm_build
+USE_QT= concurrent core dbus declarative gui network svg \
widgets x11extras xml \
- buildtools_build qmake_build
+ buildtools_build qmake_build testlib_build
.include <bsd.port.mk>
diff --git a/sysutils/plasma5-drkonqi/Makefile b/sysutils/plasma5-drkonqi/Makefile
index cfabdc95e6aa..525697a16fec 100644
--- a/sysutils/plasma5-drkonqi/Makefile
+++ b/sysutils/plasma5-drkonqi/Makefile
@@ -1,5 +1,6 @@
PORTNAME= drkonqi
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= sysutils kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -7,10 +8,11 @@ COMMENT= Plasma5 crash handler
USES= cmake compiler:c++11-lang kde:5 pkgconfig qt:5 tar:xz
USE_KDE= auth codecs completion config configwidgets coreaddons \
- crash i18n idletime jobwidgets kio notifications \
+ crash i18n idletime jobwidgets kio notifications \
service syntaxhighlighting wallet widgetsaddons \
- windowsystem xmlrpcclient
+ windowsystem xmlrpcclient \
+ ecm_build
USE_QT= concurrent core dbus gui network widgets x11extras xml \
- buildtools_build qmake_build
+ buildtools_build qmake_build testlib_build
.include <bsd.port.mk>
diff --git a/sysutils/plasma5-kde-cli-tools/Makefile b/sysutils/plasma5-kde-cli-tools/Makefile
index fa4e2a4a77a2..1abf6aedb3dd 100644
--- a/sysutils/plasma5-kde-cli-tools/Makefile
+++ b/sysutils/plasma5-kde-cli-tools/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kde-cli-tools
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= sysutils kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -8,13 +9,14 @@ COMMENT= Plasma5 non-interactive system tools
USES= cmake compiler:c++11-lib cpe gettext kde:5 qt:5 tar:xz xorg
USE_KDE= activities auth bookmarks codecs completion config configwidgets \
- coreaddons crash ecm emoticons guiaddons i18n iconthemes init \
- itemmodels itemviews jobwidgets kcmutils kdeclarative kdelibs4support kdesu \
+ coreaddons crash emoticons guiaddons i18n iconthemes init \
+ itemmodels itemviews jobwidgets kcmutils kdeclarative kdesu \
kio notifications parts plasma-workspace pty service solid sonnet \
- textwidgets unitconversion widgetsaddons windowsystem xmlgui
-USE_QT= concurrent core dbus declarative gui network printsupport svg testlib widgets \
+ textwidgets unitconversion widgetsaddons windowsystem xmlgui \
+ doctools_build ecm_build
+USE_QT= concurrent core dbus declarative gui network printsupport svg widgets \
x11extras xml \
- buildtools_build qmake_build
+ buildtools_build qmake_build testlib_build
USE_XORG= x11
.include <bsd.port.mk>
diff --git a/sysutils/plasma5-kinfocenter/Makefile b/sysutils/plasma5-kinfocenter/Makefile
index 7dab4857efd6..05f7549cb1e7 100644
--- a/sysutils/plasma5-kinfocenter/Makefile
+++ b/sysutils/plasma5-kinfocenter/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kinfocenter
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= sysutils kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -11,11 +12,12 @@ USES= cmake compiler:c++11-lib cpe gettext gl kde:5 pkgconfig \
qt:5 tar:xz xorg
USE_GL= egl gl glu
USE_KDE= auth bookmarks codecs completion config configwidgets \
- coreaddons crash dbusaddons doctools ecm emoticons guiaddons \
+ coreaddons crash dbusaddons emoticons guiaddons \
i18n iconthemes jobwidgets kcmutils kdeclarative \
- kdelibs4support kio notifications package parts init \
+ kio notifications package parts init \
itemmodels itemviews service solid sonnet textwidgets \
unitconversion wayland wayland widgetsaddons windowsystem xmlgui \
+ doctools_build ecm_build \
systemsettings_run
USE_QT= concurrent core dbus declarative gui network printsupport widgets xml \
buildtools_build qmake_build
diff --git a/sysutils/plasma5-kmenuedit/Makefile b/sysutils/plasma5-kmenuedit/Makefile
index eb0c26d18b95..fd235d555abf 100644
--- a/sysutils/plasma5-kmenuedit/Makefile
+++ b/sysutils/plasma5-kmenuedit/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kmenuedit
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= sysutils kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -7,10 +8,11 @@ COMMENT= Plasma5 menu editor
USES= cmake compiler:c++11-lib cpe gettext kde:5 qt:5 tar:xz
USE_KDE= auth bookmarks codecs completion config configwidgets \
- coreaddons crash dbusaddons guiaddons ecm emoticons globalaccel \
+ coreaddons crash dbusaddons emoticons globalaccel guiaddons \
hotkeys i18n iconthemes init itemmodels itemviews jobwidgets \
- kdelibs4support kio notifications parts service solid sonnet \
- textwidgets unitconversion widgetsaddons windowsystem xmlgui
+ kio notifications parts service solid sonnet \
+ textwidgets unitconversion widgetsaddons windowsystem xmlgui \
+ doctools_build ecm_build
USE_QT= concurrent core dbus gui network printsupport widgets xml\
buildtools_build qmake_build
diff --git a/sysutils/plasma5-ksysguard/Makefile b/sysutils/plasma5-ksysguard/Makefile
index 441d19b07927..475f79a70c58 100644
--- a/sysutils/plasma5-ksysguard/Makefile
+++ b/sysutils/plasma5-ksysguard/Makefile
@@ -15,9 +15,9 @@ USE_KDE= attica auth codecs completion config configwidgets coreaddons \
itemviews jobwidgets kdelibs4support kio libksysguard \
newstuff notifications service widgetsaddons windowsystem \
xmlgui \
- doctools_build
+ doctools_build ecm_build
USE_QT= concurrent core dbus gui network widgets xml \
- buildtools_build qmake_build
+ buildtools_build qmake_build testlib_build
OPTIONS_DEFINE= INOTIFY
OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
diff --git a/sysutils/plasma5-powerdevil/Makefile b/sysutils/plasma5-powerdevil/Makefile
index fd1e717904f4..0efb21a9731d 100644
--- a/sysutils/plasma5-powerdevil/Makefile
+++ b/sysutils/plasma5-powerdevil/Makefile
@@ -1,5 +1,6 @@
PORTNAME= powerdevil
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= sysutils kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -10,12 +11,13 @@ RUN_DEPENDS= ${LOCALBASE}/libexec/upowerd:sysutils/upower
USES= cmake compiler:c++11-lib cpe gettext kde:5 pkgconfig qt:5 tar:xz xorg
USE_KDE= activities auth bookmarks codecs completion configwidgets \
- coreaddons crash config dbusaddons ecm emoticons globalaccel \
+ coreaddons crash config dbusaddons emoticons globalaccel \
guiaddons i18n idletime iconthemes init itemmodels itemviews \
jobwidgets kdelibs4support kio libkscreen notifications \
notifyconfig parts plasma-workspace service solid sonnet \
textwidgets unitconversion wayland widgetsaddons windowsystem \
- xmlgui
+ xmlgui \
+ doctools_build ecm_build
USE_QT= concurrent core dbus gui network printsupport widgets x11extras xml \
buildtools_build qmake_build
USE_XORG= xcb
diff --git a/sysutils/plasma5-systemsettings/Makefile b/sysutils/plasma5-systemsettings/Makefile
index 0887a5327861..7c6427a12add 100644
--- a/sysutils/plasma5-systemsettings/Makefile
+++ b/sysutils/plasma5-systemsettings/Makefile
@@ -1,5 +1,6 @@
PORTNAME= systemsettings
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= sysutils kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -7,10 +8,11 @@ COMMENT= Plasma5 system settings
USES= cmake compiler:c++11-lib cpe gettext kde:5 qt:5 tar:xz
USE_KDE= activities activities-stats auth codecs completion config \
- configwidgets coreaddons crash dbusaddons doctools ecm guiaddons \
+ configwidgets coreaddons crash dbusaddons guiaddons \
i18n iconthemes itemmodels itemviews jobwidgets js kcmutils \
kdeclarative khtml kio kirigami2 package parts plasma-workspace \
- service sonnet textwidgets widgetsaddons windowsystem xmlgui
+ service sonnet textwidgets widgetsaddons windowsystem xmlgui \
+ doctools_build ecm_build
USE_QT= concurrent core dbus declarative gui network widgets xml \
buildtools_build qmake_build
diff --git a/www/qt5-webchannel/Makefile b/www/qt5-webchannel/Makefile
index 05741698feaf..66e13d472042 100644
--- a/www/qt5-webchannel/Makefile
+++ b/www/qt5-webchannel/Makefile
@@ -1,6 +1,6 @@
PORTNAME= webchannel
DISTVERSION= ${QT5_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
PKGNAMEPREFIX= qt5-
@@ -8,7 +8,8 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Qt 5 library for integration of C++/QML with HTML/js clients
USES= compiler:c++11-lang qmake:norecursive qt-dist:5,webchannel
-USE_QT= buildtools_build core declarative
+USE_QT= core declarative \
+ buildtools_build testlib_build
# The default EXTRACT_AFTER_ARGS value excludes examples/ from the extracted
# tarball, which we need during the build.
diff --git a/x11-themes/plasma5-kde-gtk-config/Makefile b/x11-themes/plasma5-kde-gtk-config/Makefile
index 83f6de25513c..d351dfb673f7 100644
--- a/x11-themes/plasma5-kde-gtk-config/Makefile
+++ b/x11-themes/plasma5-kde-gtk-config/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kde-gtk-config
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= x11-themes kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -16,10 +17,11 @@ USES= cmake compiler:c++11-lib cpe gettext gnome \
kde:5 pkgconfig qt:5 tar:xz xorg
USE_GNOME= cairo gdkpixbuf2 gtk20 gtk30 glib20
USE_KDE= archive attica auth codecs completion config configwidgets \
- coreaddons dbusaddons decoration ecm guiaddons i18n iconthemes \
- jobwidgets kcmutils kio newstuff service widgetsaddons xmlgui
-USE_QT= concurrent core dbus gui network svg testlib widgets xml \
- buildtools_build qmake_build
+ coreaddons dbusaddons decoration guiaddons i18n iconthemes \
+ jobwidgets kcmutils kio newstuff service widgetsaddons xmlgui \
+ ecm_build
+USE_QT= concurrent core dbus gui network svg widgets xml \
+ buildtools_build qmake_build testlib_build
USE_XORG= xcursor
.include <bsd.port.mk>
diff --git a/x11-wm/plasma5-kdecoration/Makefile b/x11-wm/plasma5-kdecoration/Makefile
index f848541804ce..a0e233928964 100644
--- a/x11-wm/plasma5-kdecoration/Makefile
+++ b/x11-wm/plasma5-kdecoration/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kdecoration
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= x11-wm kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -9,7 +10,9 @@ LICENSE= LGPL21
USES= cmake compiler:c++11-lib cpe kde:5 qt:5 tar:xz
USE_LDCONFIG= yes
-USE_KDE= ecm i18n
-USE_QT= core gui testlib buildtools_build qmake_build
+USE_KDE= i18n \
+ ecm_build
+USE_QT= core gui \
+ buildtools_build qmake_build testlib_build
.include <bsd.port.mk>
diff --git a/x11-wm/plasma5-kwin/Makefile b/x11-wm/plasma5-kwin/Makefile
index dc94b2c23f3e..a888df48c653 100644
--- a/x11-wm/plasma5-kwin/Makefile
+++ b/x11-wm/plasma5-kwin/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kwin
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= x11-wm kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -39,11 +40,11 @@ USE_KDE= activities activities attica auth breeze codecs \
newstuff notifications package plasma-framework runner service sonnet \
textwidgets widgetsaddons windowsystem xmlgui \
kwayland-integration kwayland-server wayland \
- doctools_build
+ doctools_build ecm_build
USE_LDCONFIG= yes
USE_QT= concurrent core dbus declarative gui multimedia network script \
- sensors testlib uiplugin uitools widgets x11extras xml \
- buildtools_build qmake_build \
+ sensors uiplugin uitools widgets x11extras xml \
+ buildtools_build qmake_build testlib_build \
quickcontrols2_run virtualkeyboard_run
USE_XORG= ice sm x11 xcb xext xi
SHEBANG_FILES= kconf_update/*.py \
diff --git a/x11/plasma5-kgamma5/Makefile b/x11/plasma5-kgamma5/Makefile
index 83e089e38fa4..867fef2d92fb 100644
--- a/x11/plasma5-kgamma5/Makefile
+++ b/x11/plasma5-kgamma5/Makefile
@@ -1,17 +1,19 @@
PORTNAME= kgamma5
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde kde-plasma
MAINTAINER= kde@FreeBSD.org
-COMMENT= Plasma5 monitor's gamma settings #'
+COMMENT= Plasma5 display gamma settings
USES= cmake compiler:c++11-lang cpe gettext kde:5 qt:5 \
tar:xz xorg
USE_KDE= auth bookmarks codecs completion config configwidgets \
- coreaddons crash doctools ecm emoticons guiaddons i18n \
+ coreaddons crash emoticons guiaddons i18n \
iconthemes init itemmodels itemviews jobwidgets \
- kdelibs4support kio notifications parts service solid sonnet \
- textwidgets unitconversion widgetsaddons windowsystem xmlgui
+ kio notifications parts service solid sonnet \
+ textwidgets unitconversion widgetsaddons windowsystem xmlgui \
+ doctools_build ecm_build
USE_QT= core dbus gui network printsupport widgets x11extras xml \
buildtools_build qmake_build
USE_XORG= ice sm x11 xext xxf86vm
diff --git a/x11/plasma5-libkscreen/Makefile b/x11/plasma5-libkscreen/Makefile
index bc9b75ebc9ef..7cc63f94e99c 100644
--- a/x11/plasma5-libkscreen/Makefile
+++ b/x11/plasma5-libkscreen/Makefile
@@ -1,5 +1,6 @@
PORTNAME= libkscreen
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -7,9 +8,10 @@ COMMENT= Plasma5 screen management library
USES= cmake compiler:c++11-lib cpe kde:5 pathfix \
pkgconfig qt:5 tar:xz xorg
-USE_KDE= ecm wayland
-USE_QT= core dbus gui testlib x11extras \
- buildtools_build qmake_build
+USE_KDE= wayland \
+ ecm_build
+USE_QT= core dbus gui x11extras \
+ buildtools_build qmake_build testlib_build
USE_XORG= x11 xcb xrandr
.include <bsd.port.mk>
diff --git a/x11/plasma5-plasma-desktop/Makefile b/x11/plasma5-plasma-desktop/Makefile
index 4dbffc2946d2..3c3f32762d4c 100644
--- a/x11/plasma5-plasma-desktop/Makefile
+++ b/x11/plasma5-plasma-desktop/Makefile
@@ -1,5 +1,6 @@
PORTNAME= plasma-desktop
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -28,15 +29,16 @@ USES= cmake compiler:c++11-lib cpe desktop-file-utils gettext gnome \
USE_GNOME= glib20
USE_KDE= activities activities-stats archive attica auth baloo \
bookmarks codecs completion config configwidgets coreaddons \
- crash dbusaddons doctools ecm emoticons filemetadata \
+ crash dbusaddons emoticons filemetadata \
globalaccel guiaddons i18n iconthemes init itemmodels \
itemviews jobwidgets kcmutils kdeclarative kdelibs4support \
kio libksysguard newstuff notifications \
notifyconfig package parts people plasma-framework \
plasma-workspace runner service solid \
sonnet textwidgets unitconversion wallet \
- widgetsaddons windowsystem xmlgui
-USE_KDE+= drkonqi_run infocenter_run kde-cli-tools_run kmenuedit_run \
+ widgetsaddons windowsystem xmlgui \
+ doctools_build ecm_build \
+ drkonqi_run infocenter_run kde-cli-tools_run kmenuedit_run \
ksysguard_run \
polkit-kde-agent-1_run systemsettings_run
USE_QT= concurrent core dbus declarative gui network phonon4 printsupport \
diff --git a/x11/plasma5-plasma-workspace/Makefile b/x11/plasma5-plasma-workspace/Makefile
index 70ab1e8e0687..0eebe131c179 100644
--- a/x11/plasma5-plasma-workspace/Makefile
+++ b/x11/plasma5-plasma-workspace/Makefile
@@ -1,5 +1,6 @@
PORTNAME= plasma-workspace
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -27,22 +28,23 @@ USES= cmake compiler:c++11-lib cpe desktop-file-utils gettext kde:5 pkgconfig \
qt:5 tar:xz xorg
USE_KDE= activities activities-stats activitymanagerd attica archive auth baloo bookmarks \
codecs completion config configwidgets coreaddons crash \
- dbusaddons doctools emoticons filemetadata globalaccel \
+ dbusaddons emoticons filemetadata globalaccel \
guiaddons holidays i18n iconthemes idletime init itemmodels \
itemviews jobwidgets js jsembed kcmutils kdeclarative \
- kdelibs4support kdesu kdewebkit kio kscreenlocker \
+ kdesu kdewebkit kio kscreenlocker \
notifications package pty kwin libkscreen libksysguard \
newstuff notifyconfig parts people plasma-framework \
plasma-integration prison runner service solid sonnet \
texteditor textwidgets unitconversion wallet wayland \
widgetsaddons windowsystem xmlgui xmlrpcclient \
+ doctools_build ecm_build \
breeze_run breeze-icons_run kquickcharts_run oxygen-icons5_run \
kded_run milou_run
USE_QT= concurrent core declarative dbus graphicaleffects gui network phonon4 \
printsupport qdbus quickcontrols_run script svg sql \
- testlib wayland webkit widgets x11extras xml \
- paths_run \
- buildtools_build qmake_build
+ wayland webkit widgets x11extras xml \
+ buildtools_build qmake_build testlib_build \
+ paths_run
USE_XORG= ice sm x11 xau xcb xcomposite xcursor xext xfixes xft xkbfile xrender xtst
CMAKE_OFF= BUILD_TESTING