aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2021-04-06 07:37:56 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2021-04-06 07:51:05 +0000
commitc0b6ad5b5016162c0926dde56ef4f81e3bc8eae1 (patch)
treef412884a24265a0f1244fac71083cade24c9ef32
parentc2acab3b6bbe6cfdc9bf0c65eed81978fa416b3c (diff)
downloadports-c0b6ad5b5016162c0926dde56ef4f81e3bc8eae1.tar.gz
ports-c0b6ad5b5016162c0926dde56ef4f81e3bc8eae1.zip
Update to 13.10.1 which is required for gitlab-ce 13.10.
-rw-r--r--www/gitlab-workhorse/Makefile17
-rw-r--r--www/gitlab-workhorse/distinfo12
2 files changed, 18 insertions, 11 deletions
diff --git a/www/gitlab-workhorse/Makefile b/www/gitlab-workhorse/Makefile
index 1c6750c3feb7..c32e6c826b2a 100644
--- a/www/gitlab-workhorse/Makefile
+++ b/www/gitlab-workhorse/Makefile
@@ -1,8 +1,8 @@
# Created by: Torsten Zuehlsdorff <tz@FreeBSD.org>
-# $FreeBSD$
+# $FreeBSD: head/www/gitlab-workhorse/Makefile 567475 2021-03-06 10:08:29Z mfechner $
PORTNAME?= gitlab-workhorse
-PORTVERSION?= 8.63.2
+PORTVERSION?= 13.10.1
PORTREVISION?= 0
CATEGORIES= www
@@ -17,16 +17,18 @@ RUN_DEPENDS= p5-Image-ExifTool>=0:graphics/p5-Image-ExifTool
USES= gmake go:modules,no_targets
MAKE_ENV= GOFLAGS="${GO_BUILDFLAGS}"
+WRKSRC_SUBDIR= workhorse
USE_GITLAB= yes
GL_ACCOUNT?= gitlab-org
-# Find the commit hash here: https://gitlab.com/gitlab-org/gitlab-workhorse/tags
-GL_COMMIT?= d6a98839b0a1c98eea332e203a1632f8302b21e9
+GL_PROJECT= gitlab-foss
+# Find the commit hash here: https://gitlab.com/gitlab-org/gitlab-foss/-/tags
+GL_COMMIT?= c93927607f55350f2e2af4bdaf03ff9dba80ab1d
# for go dependencies
USE_GITHUB= nodefault
# generated with: make gomod-vendor
-# 93dd
+# 94dd
GH_TUPLE= \
Azure:azure-pipeline-go:v0.2.3:azure_azure_pipeline_go/vendor/github.com/Azure/azure-pipeline-go \
Azure:azure-storage-blob-go:6df5d9af221d:azure_azure_storage_blob_go/vendor/github.com/Azure/azure-storage-blob-go \
@@ -43,6 +45,7 @@ GH_TUPLE= \
aws:aws-sdk-go:v1.36.1:aws_aws_sdk_go/vendor/github.com/aws/aws-sdk-go \
beorn7:perks:v1.0.1:beorn7_perks/vendor/github.com/beorn7/perks \
census-instrumentation:opencensus-go:v0.22.5:census_instrumentation_opencensus_go/vendor/go.opencensus.io \
+ certifi:gocertifi:2c3bb06c6054:certifi_gocertifi/vendor/github.com/certifi/gocertifi \
cespare:xxhash:v2.1.1:cespare_xxhash_v2/vendor/github.com/cespare/xxhash/v2 \
client9:reopen:v1.0.0:client9_reopen/vendor/github.com/client9/reopen \
HdrHistogram:hdrhistogram-go:3a0bb77429bd:codahale_hdrhistogram_go/vendor/github.com/codahale/hdrhistogram \
@@ -53,7 +56,7 @@ GH_TUPLE= \
dlclark:regexp2:v1.2.0:dlclark_regexp2/vendor/github.com/dlclark/regexp2 \
dominikh:go-tools:v0.0.1-2020.1.5:dominikh_go_tools/vendor/honnef.co/go/tools \
form3tech-oss:jwt-go:v3.2.2:form3tech_oss_jwt_go/vendor/github.com/form3tech-oss/jwt-go \
- getsentry:sentry-go:v0.7.0:getsentry_sentry_go/vendor/github.com/getsentry/sentry-go \
+ getsentry:raven-go:v0.2.0:getsentry_raven_go/vendor/github.com/getsentry/raven-go \
go-yaml:yaml:9f266ea9e77c:go_yaml_yaml/vendor/gopkg.in/yaml.v3 \
gogo:protobuf:v1.2.1:gogo_protobuf/vendor/github.com/gogo/protobuf \
golang:appengine:v1.6.7:golang_appengine/vendor/google.golang.org/appengine \
@@ -146,3 +149,5 @@ post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/www/${PORTNAME}
.include <bsd.port.mk>
+
+
diff --git a/www/gitlab-workhorse/distinfo b/www/gitlab-workhorse/distinfo
index de8001a61dc6..9570333f8290 100644
--- a/www/gitlab-workhorse/distinfo
+++ b/www/gitlab-workhorse/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1614980366
+TIMESTAMP = 1617349208
SHA256 (Azure-azure-pipeline-go-v0.2.3_GH0.tar.gz) = 99bd58f4a07dd02d9615e3638b3bb6dbfad80ef678ccdb8e17e3fa2b0fef343e
SIZE (Azure-azure-pipeline-go-v0.2.3_GH0.tar.gz) = 17102
SHA256 (Azure-azure-storage-blob-go-6df5d9af221d_GH0.tar.gz) = 31047920e4c507f913b9922ad920a2e9f6d48e6056bdc6869b6c257e3ab095a7
@@ -29,6 +29,8 @@ SHA256 (beorn7-perks-v1.0.1_GH0.tar.gz) = 98db84bb0224a26094e6adba91b7ee7a1a7ace
SIZE (beorn7-perks-v1.0.1_GH0.tar.gz) = 10867
SHA256 (census-instrumentation-opencensus-go-v0.22.5_GH0.tar.gz) = 881df0d24a0df8afacd2228d4987252f742061fe8eeb5f14cc9e3f32b7c357be
SIZE (census-instrumentation-opencensus-go-v0.22.5_GH0.tar.gz) = 171403
+SHA256 (certifi-gocertifi-2c3bb06c6054_GH0.tar.gz) = b086756deac553664353a353b1e8467b80be616ffa2f186d9b6932ec3e4d6971
+SIZE (certifi-gocertifi-2c3bb06c6054_GH0.tar.gz) = 158971
SHA256 (cespare-xxhash-v2.1.1_GH0.tar.gz) = 0ee31178d2c5a1249be4e26294a2f428008dc4e1ecbbfbe47f74e41026df1148
SIZE (cespare-xxhash-v2.1.1_GH0.tar.gz) = 9292
SHA256 (client9-reopen-v1.0.0_GH0.tar.gz) = 64829db9b9fd0dd94b2444c45a2cb6e926b79c3a2e589a75a5edc2ba488a7875
@@ -49,8 +51,8 @@ SHA256 (dominikh-go-tools-v0.0.1-2020.1.5_GH0.tar.gz) = 28265e6da1fdb3f6fc2fcab9
SIZE (dominikh-go-tools-v0.0.1-2020.1.5_GH0.tar.gz) = 406267
SHA256 (form3tech-oss-jwt-go-v3.2.2_GH0.tar.gz) = 179ca725463e7f13be8591bc285f4048da6887b1056d96848b16e137c995a2e2
SIZE (form3tech-oss-jwt-go-v3.2.2_GH0.tar.gz) = 38248
-SHA256 (getsentry-sentry-go-v0.7.0_GH0.tar.gz) = b5e7432442928e4b03f61d4cb97e5d0b815e6c8618fbf34aa6275aab2218b27e
-SIZE (getsentry-sentry-go-v0.7.0_GH0.tar.gz) = 89499
+SHA256 (getsentry-raven-go-v0.2.0_GH0.tar.gz) = 51c75358dca745a76922e1b41a788416a8212839adfbbfc927ea0c0c35122d32
+SIZE (getsentry-raven-go-v0.2.0_GH0.tar.gz) = 19237
SHA256 (go-yaml-yaml-9f266ea9e77c_GH0.tar.gz) = 63efc9aabcbb56b2c9469927784fd67ecb3a79720c4fa754c511335a04156d04
SIZE (go-yaml-yaml-9f266ea9e77c_GH0.tar.gz) = 86898
SHA256 (gogo-protobuf-v1.2.1_GH0.tar.gz) = 99e423905ba8921e86817607a5294ffeedb66fdd4a85efce5eb2848f715fdb3a
@@ -177,8 +179,8 @@ SHA256 (uber-jaeger-client-go-v2.15.0_GH0.tar.gz) = 6b89d1a6684475fcbaed3f9d2137
SIZE (uber-jaeger-client-go-v2.15.0_GH0.tar.gz) = 164460
SHA256 (uber-jaeger-lib-v1.5.0_GH0.tar.gz) = 98901cc41df77858a2f601ad48b45bdf72af40c56f15bc5182416b15db0daac3
SIZE (uber-jaeger-lib-v1.5.0_GH0.tar.gz) = 31655
-SHA256 (gitlab-org-gitlab-workhorse-d6a98839b0a1c98eea332e203a1632f8302b21e9_GL0.tar.gz) = 50d50a465475e2814676f71f8732e0906b47573f078ca3277b4ad4754de7f8a7
-SIZE (gitlab-org-gitlab-workhorse-d6a98839b0a1c98eea332e203a1632f8302b21e9_GL0.tar.gz) = 2487786
+SHA256 (gitlab-org-gitlab-foss-c93927607f55350f2e2af4bdaf03ff9dba80ab1d_GL0.tar.gz) = 44d82b3ba741e1fb86aa4bc62fc63ecd3a3529a156b85dd317269dd7d9a76f39
+SIZE (gitlab-org-gitlab-foss-c93927607f55350f2e2af4bdaf03ff9dba80ab1d_GL0.tar.gz) = 100193634
SHA256 (gitlab-org-gitaly-3f5e218def93024f3aafe590c22cd1b29f744105_GL0.tar.gz) = 98d3cd87fb3feb8a14b5ac9e4a968e7a841cc3b309f997a2ba78aa8fd0b58c2d
SIZE (gitlab-org-gitaly-3f5e218def93024f3aafe590c22cd1b29f744105_GL0.tar.gz) = 3143193
SHA256 (gitlab-org-labkit-f2d7fb209ecad2eaddb5fb9c4ab03eb8eaa82811_GL0.tar.gz) = 7fb33d071f1731691125807188be8faba6100a43fa66ad9064d204b56642fbfd