aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-04-06 21:16:05 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-04-06 21:16:05 +0000
commitc126810efd96bf00b64bd08ed2b30b3b1302d4c2 (patch)
tree0912f748ae45e20155bd1db9a53bfb4c0ce511a8
parente20e302afe0d8e17121947ced86142dccb133e3b (diff)
downloadports-c126810efd96bf00b64bd08ed2b30b3b1302d4c2.tar.gz
ports-c126810efd96bf00b64bd08ed2b30b3b1302d4c2.zip
* Update to new GNOME infrastructure
* Set GNOME_DESKTOP_VERSION explicitly so users can upgrade or downgrade across desktop versions
Notes
Notes: svn path=/head/; revision=78454
-rw-r--r--deskutils/gnome-utils/Makefile7
-rw-r--r--deskutils/gnomeutils2/Makefile7
-rw-r--r--misc/gnomeutils/Makefile3
-rw-r--r--misc/gnomeutils2/Makefile7
-rw-r--r--multimedia/nautilus-media/Makefile8
-rw-r--r--x11-fm/nautilus/Makefile2
-rw-r--r--x11-fm/nautilus2/Makefile7
-rw-r--r--x11-toolkits/panel--/Makefile2
-rw-r--r--x11-toolkits/py-gnome/Makefile3
-rw-r--r--x11/gnome-applets/Makefile9
-rw-r--r--x11/gnome-desktop/Makefile7
-rw-r--r--x11/gnomeapplets/Makefile2
-rw-r--r--x11/gnomeapplets2/Makefile9
-rw-r--r--x11/gnomecore/Makefile2
-rw-r--r--x11/gnomedesktop/Makefile7
-rw-r--r--x11/libpanel/Makefile2
16 files changed, 28 insertions, 56 deletions
diff --git a/deskutils/gnome-utils/Makefile b/deskutils/gnome-utils/Makefile
index 2a26f8105103..f0ec1202e2aa 100644
--- a/deskutils/gnome-utils/Makefile
+++ b/deskutils/gnome-utils/Makefile
@@ -17,18 +17,15 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME 2.0 support utilities
-LIB_DEPENDS= panel-applet-2.0:${PORTSDIR}/x11/gnomepanel
-
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_GNOMENG= yes
-USE_GNOME= gnomeprefix gnomehack gnomehier
+GNOME_DESKTOP_VERSION=2
+USE_GNOME= gnomeprefix gnomehack gnomehier gnomepanel
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= gnome-calculator.1 \
gnome-character-map.1 gnome-dictionary.1 \
diff --git a/deskutils/gnomeutils2/Makefile b/deskutils/gnomeutils2/Makefile
index 2a26f8105103..f0ec1202e2aa 100644
--- a/deskutils/gnomeutils2/Makefile
+++ b/deskutils/gnomeutils2/Makefile
@@ -17,18 +17,15 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME 2.0 support utilities
-LIB_DEPENDS= panel-applet-2.0:${PORTSDIR}/x11/gnomepanel
-
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_GNOMENG= yes
-USE_GNOME= gnomeprefix gnomehack gnomehier
+GNOME_DESKTOP_VERSION=2
+USE_GNOME= gnomeprefix gnomehack gnomehier gnomepanel
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= gnome-calculator.1 \
gnome-character-map.1 gnome-dictionary.1 \
diff --git a/misc/gnomeutils/Makefile b/misc/gnomeutils/Makefile
index e329f48efb11..96af594ddf0f 100644
--- a/misc/gnomeutils/Makefile
+++ b/misc/gnomeutils/Makefile
@@ -19,13 +19,12 @@ LIB_DEPENDS= gtop.1:${PORTSDIR}/devel/libgtop
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOMENG= yes
+GNOME_DESKTOP_VERSION=1
USE_GNOME= gnomeprefix gnomehack gtkhtml libpanel
USE_LIBTOOL= yes
CONFIGURE_ARGS= --with-messages=/var/log/messages
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= gcalc.1 gcharmap.1 gcolorsel.1 gdialog.1 gdict.1 gdiskfree.1 \
gfontsel.1 gless.1 gnome-exe-handler.1 gsearchtool.1 guname.1 gw.1 \
diff --git a/misc/gnomeutils2/Makefile b/misc/gnomeutils2/Makefile
index 2a26f8105103..f0ec1202e2aa 100644
--- a/misc/gnomeutils2/Makefile
+++ b/misc/gnomeutils2/Makefile
@@ -17,18 +17,15 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME 2.0 support utilities
-LIB_DEPENDS= panel-applet-2.0:${PORTSDIR}/x11/gnomepanel
-
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_GNOMENG= yes
-USE_GNOME= gnomeprefix gnomehack gnomehier
+GNOME_DESKTOP_VERSION=2
+USE_GNOME= gnomeprefix gnomehack gnomehier gnomepanel
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= gnome-calculator.1 \
gnome-character-map.1 gnome-dictionary.1 \
diff --git a/multimedia/nautilus-media/Makefile b/multimedia/nautilus-media/Makefile
index bee82fa24771..05a1f8146493 100644
--- a/multimedia/nautilus-media/Makefile
+++ b/multimedia/nautilus-media/Makefile
@@ -15,19 +15,17 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= GStreamer-based multimedia views for Nautilus
-LIB_DEPENDS= nautilus.2:${PORTSDIR}/x11-fm/nautilus2 \
- gstplay-0.6.0:${PORTSDIR}/multimedia/gstreamer-plugins
+LIB_DEPENDS= gstplay-0.6.0:${PORTSDIR}/multimedia/gstreamer-plugins
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_GNOMENG= yes
-USE_GNOME= gnomeprefix gnomehack
+GNOME_DESKTOP_VERSION=2
+USE_GNOME= gnomeprefix gnomehack nautilus2
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
diff --git a/x11-fm/nautilus/Makefile b/x11-fm/nautilus/Makefile
index 5f3793ba12f5..5fa75f41539c 100644
--- a/x11-fm/nautilus/Makefile
+++ b/x11-fm/nautilus/Makefile
@@ -26,7 +26,7 @@ LIB_DEPENDS+= fam.0:${PORTSDIR}/devel/fam
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOMENG= yes
+GNOME_DESKTOP_VERSION=1
USE_GNOME= gnomehack gnomeprefix gnomehier libpanel libghttp bonobo \
gnomevfs
INSTALLS_SHLIB= yes
diff --git a/x11-fm/nautilus2/Makefile b/x11-fm/nautilus2/Makefile
index 8023269ad96f..56d9c16ae453 100644
--- a/x11-fm/nautilus2/Makefile
+++ b/x11-fm/nautilus2/Makefile
@@ -17,16 +17,13 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME file manager and graphical shell developed by Eazel
BUILD_DEPENDS= freetype-config:${PORTSDIR}/print/freetype2
-LIB_DEPENDS= rsvg-2.4:${PORTSDIR}/graphics/librsvg2 \
- eel-2.4:${PORTSDIR}/x11-toolkits/eel2 \
- gnome-desktop-2.3:${PORTSDIR}/x11/gnomedesktop
RUN_DEPENDS= gnome-control-center:${PORTSDIR}/sysutils/gnomecontrolcenter2
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOMENG= yes
-USE_GNOME= gnomeprefix gnomehack gnomehier
+USE_GNOME= gnomeprefix gnomehack gnomehier gnomedesktop eel2 librsvg2
+GNOME_DESKTOP_VERSION=2
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
USE_REINPLACE= yes
diff --git a/x11-toolkits/panel--/Makefile b/x11-toolkits/panel--/Makefile
index accb8c401144..336789266fdc 100644
--- a/x11-toolkits/panel--/Makefile
+++ b/x11-toolkits/panel--/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= gnomemm-1.2.10:${PORTSDIR}/x11-toolkits/gnome--
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOMENG= yes
+GNOME_DESKTOP_VERSION=1
USE_GNOME= gnomelibs libpanel
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
diff --git a/x11-toolkits/py-gnome/Makefile b/x11-toolkits/py-gnome/Makefile
index 849dd8ce55f4..3e063ca3f8dd 100644
--- a/x11-toolkits/py-gnome/Makefile
+++ b/x11-toolkits/py-gnome/Makefile
@@ -23,14 +23,13 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pygtk.pth:${PORTSDIR}/x11-toolkits/py-gtk
USE_BZIP2= yes
USE_GMAKE= yes
USE_PYTHON= yes
-USE_GNOMENG= yes
+GNOME_DESKTOP_VERSION=1
USE_GNOME= gtkhtml libpanel
USE_LIBTOOL= yes
LIBTOOLFILES= configure pygtk/configure
CONFIGURE_ARGS= --with-python=${PYTHON_CMD} \
--with-gnome-config=${X11BASE}/bin/gnome-config \
--with-gtkhtml
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
EG_SRC_DIR= ${WRKSRC}/pygnome/examples
EG_DST_DIR= ${PREFIX}/share/examples/py-gnome
diff --git a/x11/gnome-applets/Makefile b/x11/gnome-applets/Makefile
index 3a76836fa0be..51312167ef84 100644
--- a/x11/gnome-applets/Makefile
+++ b/x11/gnome-applets/Makefile
@@ -16,20 +16,17 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Applets components for the Gnome 2.0 Desktop Environment
-LIB_DEPENDS= panel-applet-2.0:${PORTSDIR}/x11/gnomepanel \
- gailutil.17:${PORTSDIR}/x11-toolkits/gail \
- gtop-2.0:${PORTSDIR}/devel/libgtop2
+LIB_DEPENDS= gtop-2.0:${PORTSDIR}/devel/libgtop2
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_REINPLACE= yes
-USE_GNOMENG= yes
-USE_GNOME= gnomehier gnomeprefix gnomehack
+USE_GNOME_DESKTOP=2
+USE_GNOME= gnomehier gnomeprefix gnomehack gnomepanel gail
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
.include <bsd.port.pre.mk>
diff --git a/x11/gnome-desktop/Makefile b/x11/gnome-desktop/Makefile
index 0c332110db87..f30007d9959c 100644
--- a/x11/gnome-desktop/Makefile
+++ b/x11/gnome-desktop/Makefile
@@ -17,21 +17,18 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Additional UI API for GNOME 2.0
-LIB_DEPENDS= gnomeui-2.200:${PORTSDIR}/x11-toolkits/libgnomeui
-
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_XPM= yes
USE_REINPLACE= yes
-USE_GNOMENG= yes
-USE_GNOME= gnomeprefix gnomehack gnomehier
+USE_GNOME= gnomeprefix gnomehack gnomehier libgnomeui
+GNOME_DESKTOP_VERSION=2
USE_GMAKE= yes
USE_BISON= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= gnome-about.1
diff --git a/x11/gnomeapplets/Makefile b/x11/gnomeapplets/Makefile
index 26c7bbe1bd11..3432d3658fd7 100644
--- a/x11/gnomeapplets/Makefile
+++ b/x11/gnomeapplets/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= gtop.1:${PORTSDIR}/devel/libgtop
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOMENG= yes
+USE_GNOME_DESKTOP=1
USE_GNOME= gnomeprefix gnomehack libpanel gnomevfs gnomecanvas libghttp
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/x11/gnomeapplets2/Makefile b/x11/gnomeapplets2/Makefile
index 3a76836fa0be..51312167ef84 100644
--- a/x11/gnomeapplets2/Makefile
+++ b/x11/gnomeapplets2/Makefile
@@ -16,20 +16,17 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Applets components for the Gnome 2.0 Desktop Environment
-LIB_DEPENDS= panel-applet-2.0:${PORTSDIR}/x11/gnomepanel \
- gailutil.17:${PORTSDIR}/x11-toolkits/gail \
- gtop-2.0:${PORTSDIR}/devel/libgtop2
+LIB_DEPENDS= gtop-2.0:${PORTSDIR}/devel/libgtop2
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_REINPLACE= yes
-USE_GNOMENG= yes
-USE_GNOME= gnomehier gnomeprefix gnomehack
+USE_GNOME_DESKTOP=2
+USE_GNOME= gnomehier gnomeprefix gnomehack gnomepanel gail
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
.include <bsd.port.pre.mk>
diff --git a/x11/gnomecore/Makefile b/x11/gnomecore/Makefile
index 4b92740e0653..9edb8fac4ca5 100644
--- a/x11/gnomecore/Makefile
+++ b/x11/gnomecore/Makefile
@@ -19,7 +19,7 @@ COMMENT= Core component for the Gnome Desktop Environment
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOMENG= yes
+GNOME_DESKTOP_VERSION=1
USE_GNOME= gnomehack gnomeprefix gnomehier libcapplet libglade gnomeaudio \
libpanel
INSTALLS_SHLIB= yes
diff --git a/x11/gnomedesktop/Makefile b/x11/gnomedesktop/Makefile
index 0c332110db87..f30007d9959c 100644
--- a/x11/gnomedesktop/Makefile
+++ b/x11/gnomedesktop/Makefile
@@ -17,21 +17,18 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Additional UI API for GNOME 2.0
-LIB_DEPENDS= gnomeui-2.200:${PORTSDIR}/x11-toolkits/libgnomeui
-
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_XPM= yes
USE_REINPLACE= yes
-USE_GNOMENG= yes
-USE_GNOME= gnomeprefix gnomehack gnomehier
+USE_GNOME= gnomeprefix gnomehack gnomehier libgnomeui
+GNOME_DESKTOP_VERSION=2
USE_GMAKE= yes
USE_BISON= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= gnome-about.1
diff --git a/x11/libpanel/Makefile b/x11/libpanel/Makefile
index 7f83f8fa555d..1a94f0112a56 100644
--- a/x11/libpanel/Makefile
+++ b/x11/libpanel/Makefile
@@ -16,7 +16,7 @@ COMMENT= A library for writing custom applets for GNOME Panel
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_GNOMENG= yes
+GNOME_DESKTOP_VERSION=1
USE_GNOME= gnomelibs
INSTALLS_SHLIB= yes
MAKE_ENV= X11BASE="${X11BASE}" LOCALBASE="${LOCALBASE}"