aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYasuhiro Kimura <yasu@FreeBSD.org>2022-10-24 18:42:56 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-10-25 07:50:27 +0000
commitc14a8f470eca8cf57a8cda29e62bd7a28dc82bc3 (patch)
tree10b780fc2a7fcda4ce460fa6a6feac77ef6cabc6
parentdf1615b780bced91d1f1fb226a89c90791c8a8b7 (diff)
downloadports-c14a8f470eca8cf57a8cda29e62bd7a28dc82bc3.tar.gz
ports-c14a8f470eca8cf57a8cda29e62bd7a28dc82bc3.zip
sysutils/dar: Fix failure to detect libgcrypt
Currently configure script fails to detect libgcrypt as following. configure:24491: checking for libgcrypt usability configure:24561: c++ -o conftest -O2 -pipe -fstack-protector-strong -fno-strict-aliasing -I/usr/local/include -fstack-protector-strong conftest.cpp -llzma -lbz2 -lz -ldl >&5 ld: error: undefined symbol: gcry_check_version >>> referenced by conftest.cpp >>> /tmp/conftest-5a5403.o:(main) c++: error: linker command failed with exit code 1 (use -v to see invocation) It happens because '-L/usr/local/lib' is lacked from options to compile conftest. So fix it by adding 'localbase' to USES. Bump PORTREVISION as GCRYPT option is ON by default. PR: 267312 Reported by: Graham Menhennitt (in freebsd-ports ML) MFH: 2022Q4
-rw-r--r--sysutils/dar/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/sysutils/dar/Makefile b/sysutils/dar/Makefile
index 404fc88218f7..39a03efa2ca4 100644
--- a/sysutils/dar/Makefile
+++ b/sysutils/dar/Makefile
@@ -1,5 +1,6 @@
PORTNAME= dar
PORTVERSION= 2.7.7
+PORTREVISION= 1
CATEGORIES= sysutils archivers
MASTER_SITES= SF
@@ -10,7 +11,7 @@ WWW= http://dar.linux.free.fr/
LICENSE= GPLv2+
-USES= compiler:c++14-lang libtool pathfix shebangfix
+USES= compiler:c++14-lang libtool localbase pathfix shebangfix
USE_LDCONFIG= yes
SHEBANG_FILES= doc/samples/*.bash doc/samples/*.sh doc/samples/dar_backup \