aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-09-16 05:37:23 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-09-16 05:38:21 +0000
commitc168a0df807e45f9d49ccb658d36858f9bedce26 (patch)
tree64413b20839a56cbb6e4409e197a9e155126632b
parent29e30f45493398b01f03f44a4ae78d4c7cf49193 (diff)
downloadports-c168a0df807e45f9d49ccb658d36858f9bedce26.tar.gz
ports-c168a0df807e45f9d49ccb658d36858f9bedce26.zip
security/liboqs: New port: C library for quantum-resistant cryptography
-rw-r--r--security/Makefile1
-rw-r--r--security/liboqs/Makefile25
-rw-r--r--security/liboqs/distinfo3
-rw-r--r--security/liboqs/pkg-descr14
-rw-r--r--security/liboqs/pkg-plist29
5 files changed, 72 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index a906ee24dc0e..0f0a6fbc577e 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -310,6 +310,7 @@
SUBDIR += libmcrypt
SUBDIR += libnitrokey
SUBDIR += libntlm
+ SUBDIR += liboqs
SUBDIR += libotr
SUBDIR += libotr3
SUBDIR += libp11
diff --git a/security/liboqs/Makefile b/security/liboqs/Makefile
new file mode 100644
index 000000000000..5a7c4b5687b4
--- /dev/null
+++ b/security/liboqs/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= liboqs
+DISTVERSION= 0.7.0
+CATEGORIES= security
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C library for quantum-resistant cryptography
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
+
+USES= cmake python:test ssl
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= open-quantum-safe
+
+CMAKE_ON= BUILD_SHARED_LIBS OQS_DIST_BUILD
+
+TEST_TARGET= run_tests # many tests fail to build, see https://github.com/open-quantum-safe/liboqs/issues/1090
+
+BINARY_ALIAS= python3=${PYTHON_CMD}
+
+.include <bsd.port.mk>
diff --git a/security/liboqs/distinfo b/security/liboqs/distinfo
new file mode 100644
index 000000000000..bce1be0115c5
--- /dev/null
+++ b/security/liboqs/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1631761782
+SHA256 (open-quantum-safe-liboqs-0.7.0_GH0.tar.gz) = 7a2b01d33637869b02475c5a7b3b31e8f7cebce491877719f27954a89f6d764e
+SIZE (open-quantum-safe-liboqs-0.7.0_GH0.tar.gz) = 7703900
diff --git a/security/liboqs/pkg-descr b/security/liboqs/pkg-descr
new file mode 100644
index 000000000000..d72eb9baf98d
--- /dev/null
+++ b/security/liboqs/pkg-descr
@@ -0,0 +1,14 @@
+liboqs provides:
+* a collection of open source implementations of quantum-safe key encapsulation
+ mechanism (KEM) and digital signature algorithms; the full list can be found
+ below
+* a common API for these algorithms
+* a test harness and benchmarking routines
+
+liboqs is part of the Open Quantum Safe (OQS) project led by Douglas Stebila and
+Michele Mosca, which aims to develop and integrate into applications
+quantum-safe cryptography to facilitate deployment and testing in real world
+contexts. In particular, OQS provides prototype integrations of liboqs into TLS
+and SSH, through OpenSSL and OpenSSH.
+
+WWW: https://openquantumsafe.org/
diff --git a/security/liboqs/pkg-plist b/security/liboqs/pkg-plist
new file mode 100644
index 000000000000..9b4b82760257
--- /dev/null
+++ b/security/liboqs/pkg-plist
@@ -0,0 +1,29 @@
+include/oqs/aes.h
+include/oqs/common.h
+include/oqs/kem.h
+include/oqs/kem_bike.h
+include/oqs/kem_classic_mceliece.h
+include/oqs/kem_frodokem.h
+include/oqs/kem_hqc.h
+include/oqs/kem_kyber.h
+include/oqs/kem_ntru.h
+include/oqs/kem_ntruprime.h
+include/oqs/kem_saber.h
+include/oqs/kem_sike.h
+include/oqs/oqs.h
+include/oqs/oqsconfig.h
+include/oqs/rand.h
+include/oqs/sha2.h
+include/oqs/sha3.h
+include/oqs/sha3x4.h
+include/oqs/sig.h
+include/oqs/sig_dilithium.h
+include/oqs/sig_falcon.h
+include/oqs/sig_picnic.h
+include/oqs/sig_rainbow.h
+include/oqs/sig_sphincs.h
+lib/cmake/liboqs/liboqsConfig-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/liboqs/liboqsConfig.cmake
+lib/liboqs.so
+lib/liboqs.so.0
+lib/liboqs.so.0.7.0