aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2024-02-18 10:14:08 +0000
committerThomas Zander <riggs@FreeBSD.org>2024-02-24 13:21:37 +0000
commitc1e0f931e3ddecb86d83ffc14cb8b05a38922cdd (patch)
tree3397f7dd589784f2178e7f58f193625e4791f312
parent5f41aae86ef01a9fa542984d589ff07a2807ecde (diff)
downloadports-c1e0f931e3ddecb86d83ffc14cb8b05a38922cdd.tar.gz
ports-c1e0f931e3ddecb86d83ffc14cb8b05a38922cdd.zip
multimedia/mplayer: Use DEBUG OPTION, deprecate WITH_DEBUG knob
-rw-r--r--multimedia/mplayer/Makefile2
-rw-r--r--multimedia/mplayer/Makefile.options7
-rw-r--r--multimedia/mplayer/Makefile.optvars2
3 files changed, 3 insertions, 8 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index b9e86d69d983..3e512598535e 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -8,7 +8,7 @@ WWW= http://www.mplayerhq.hu/
.include "${.CURDIR}/../../multimedia/mplayer/Makefile.common"
-OPTIONS_DEFINE= AALIB AMR_NB AMR_WB ASS BLURAY CACA CDIO DV DVDNAV \
+OPTIONS_DEFINE= AALIB AMR_NB AMR_WB ASS BLURAY CACA CDIO DEBUG DV DVDNAV \
ENCA FONTCONFIG FRIBIDI GIF GNUTLS GSM GUI IPV6 JACK \
JPEG LADSPA LIBMNG LIRC LZO NAS NLS OPENAL OPENGL \
OPENJPEG OPUS PULSEAUDIO RTMP \
diff --git a/multimedia/mplayer/Makefile.options b/multimedia/mplayer/Makefile.options
index f7392d0b2314..ebb2a84d0987 100644
--- a/multimedia/mplayer/Makefile.options
+++ b/multimedia/mplayer/Makefile.options
@@ -59,13 +59,6 @@ CONFIGURE_ARGS+= --enable-altivec
LDFLAGS_i386+= -Wl,-z,notext
-# Extra build options for debugging
-# =================================
-
-.if defined(WITH_DEBUG)
-CONFIGURE_ARGS+= --enable-debug=3
-.endif
-
# Win32 DLL codecs support on i386, mostly superseded by ffmpeg
# =============================================================
diff --git a/multimedia/mplayer/Makefile.optvars b/multimedia/mplayer/Makefile.optvars
index 49b139d7a4a8..110814732ad7 100644
--- a/multimedia/mplayer/Makefile.optvars
+++ b/multimedia/mplayer/Makefile.optvars
@@ -24,6 +24,8 @@ CACA_CONFIGURE_OFF= --disable-caca
CDIO_LIB_DEPENDS= libcdio_paranoia.so:sysutils/libcdio-paranoia
CDIO_CONFIGURE_OFF= --disable-libcdio
+DEBUG_CONFIGURE_ON= --enable-debug=3
+
DV_LIB_DEPENDS= libdv.so:multimedia/libdv
DV_CONFIGURE_ENABLE= libdv