aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2022-04-26 21:20:50 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2022-04-26 21:25:05 +0000
commitc2258034f179dc9888d95a1aefad0a2710c6eb88 (patch)
tree91faba54d6190845122874507eb1833c3dc4d6bd
parent4941a32d46be02db600c4caab96df35a4060faeb (diff)
downloadports-c2258034f179dc9888d95a1aefad0a2710c6eb88.tar.gz
ports-c2258034f179dc9888d95a1aefad0a2710c6eb88.zip
Mk/bsd.gecko.gk: fix sndio logic
my previous attempt at handling both firefox >= 100 and firefox-esr/ thunderbird at 91.x suffered a thinko. (cherry picked from commit 21791843fe99d04a53c4631aa3c917b3ede3a86e)
-rw-r--r--Mk/bsd.gecko.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 8473c10a2c1f..4d7df905a8c0 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -270,15 +270,18 @@ MOZ_OPTIONS+= --disable-pulseaudio
.if ${PORT_OPTIONS:MSNDIO}
BUILD_DEPENDS+= ${LOCALBASE}/include/sndio.h:audio/sndio
-MOZ_OPTIONS+= --enable-sndio
. if ${MOZILLA_VER:R:R} < 100
post-patch-SNDIO-on:
@${REINPLACE_CMD} -e 's|OpenBSD|${OPSYS}|g' \
-e '/DISABLE_LIBSNDIO_DLOPEN/d' \
${MOZSRC}/media/libcubeb/src/moz.build
+. else
+MOZ_OPTIONS+= --enable-sndio
. endif
. else
+. if ${MOZILLA_VER:R:R} >= 100
MOZ_OPTIONS+= --disable-sndio
+. endif
. endif
.if ${PORT_OPTIONS:MDEBUG}