aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-25 12:45:42 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-25 13:36:38 +0000
commitc25e668237e26463450ae0ae651e118438a0c85b (patch)
tree17071262c50c9bc66b175fbc59346fcb4dde7184
parent4f1eac7221994a696606199d4c26f3f2342a8e43 (diff)
downloadports-c25e668237e26463450ae0ae651e118438a0c85b.tar.gz
ports-c25e668237e26463450ae0ae651e118438a0c85b.zip
print/py-pypdf3: Add py-pypdf3 1.0.6
PyPDF3 is a fork of PyPDF2 with feature improvements. PyPDF3 is a pure-python PDF library capable of splitting, merging together, cropping, and transforming the pages of PDF files. It can also add custom data, viewing options, and passwords to PDF files. It can retrieve text and metadata from PDFs as well as merge entire files together. WWW: https://github.com/sfneal/PyPDF3
-rw-r--r--print/Makefile1
-rw-r--r--print/py-pypdf3/Makefile23
-rw-r--r--print/py-pypdf3/distinfo3
-rw-r--r--print/py-pypdf3/pkg-descr8
4 files changed, 35 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 81976afd3a79..511972f430e6 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -188,6 +188,7 @@
SUBDIR += py-preppy
SUBDIR += py-psautohint
SUBDIR += py-pycups
+ SUBDIR += py-pypdf3
SUBDIR += py-python-ly
SUBDIR += py-relatorio
SUBDIR += py-reportlab
diff --git a/print/py-pypdf3/Makefile b/print/py-pypdf3/Makefile
new file mode 100644
index 000000000000..de2d8b230aaa
--- /dev/null
+++ b/print/py-pypdf3/Makefile
@@ -0,0 +1,23 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= pypdf3
+PORTVERSION= 1.0.6
+CATEGORIES= print python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= PyPDF3-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Pure Python PDF toolkit
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tqdm>=0:misc/py-tqdm@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/print/py-pypdf3/distinfo b/print/py-pypdf3/distinfo
new file mode 100644
index 000000000000..161899c17d2b
--- /dev/null
+++ b/print/py-pypdf3/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1647264410
+SHA256 (PyPDF3-1.0.6.tar.gz) = c946f3273419e37258e35e72273f49904ab15723d87a761c1115ef99799f8c5f
+SIZE (PyPDF3-1.0.6.tar.gz) = 294825
diff --git a/print/py-pypdf3/pkg-descr b/print/py-pypdf3/pkg-descr
new file mode 100644
index 000000000000..81a1b3fc5e05
--- /dev/null
+++ b/print/py-pypdf3/pkg-descr
@@ -0,0 +1,8 @@
+PyPDF3 is a fork of PyPDF2 with feature improvements.
+
+PyPDF3 is a pure-python PDF library capable of splitting, merging together,
+cropping, and transforming the pages of PDF files. It can also add custom data,
+viewing options, and passwords to PDF files. It can retrieve text and metadata
+from PDFs as well as merge entire files together.
+
+WWW: https://github.com/sfneal/PyPDF3