aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2024-02-09 01:34:11 +0000
committerJan Beich <jbeich@FreeBSD.org>2024-02-09 01:46:16 +0000
commitc2c97cf493439320e5424da29a00466e0795979e (patch)
tree02707bc961f9df59269049e02d76b9ad00581b12
parentc3547f5eeb17ccfb60eb9bc7697a040d425911f1 (diff)
downloadports-c2c97cf493439320e5424da29a00466e0795979e.tar.gz
ports-c2c97cf493439320e5424da29a00466e0795979e.zip
x11-wm/cosmic-comp: simplify patching
-rw-r--r--x11-wm/cosmic-comp/Makefile3
-rw-r--r--x11-wm/cosmic-comp/files/patch-Cargo.toml19
2 files changed, 3 insertions, 19 deletions
diff --git a/x11-wm/cosmic-comp/Makefile b/x11-wm/cosmic-comp/Makefile
index 6787f259fd6b..bd34c90252ca 100644
--- a/x11-wm/cosmic-comp/Makefile
+++ b/x11-wm/cosmic-comp/Makefile
@@ -31,6 +31,9 @@ post-patch:
# XXX Strip double / to help "make cargo-crates"
@${REINPLACE_CMD} -e 's,\(smithay\)//,\1/,' \
${WRKSRC}/Cargo.lock
+# XXX Drop [patch.<url>] section to help "make cargo-configure"
+ @${REINPLACE_CMD} -e '/\[patch/,$$d' \
+ ${WRKSRC}/Cargo.toml
# Respect PREFIX for system-wide config
@${REINPLACE_CMD} -e 's,/etc,${PREFIX}&,' \
${WRKSRC}/src/config/mod.rs
diff --git a/x11-wm/cosmic-comp/files/patch-Cargo.toml b/x11-wm/cosmic-comp/files/patch-Cargo.toml
deleted file mode 100644
index 51758a3b65a7..000000000000
--- a/x11-wm/cosmic-comp/files/patch-Cargo.toml
+++ /dev/null
@@ -1,19 +0,0 @@
-===> Updating Cargo.lock
-error: failed to resolve patches for `https://github.com/Smithay/smithay.git`
-
-Caused by:
- patch for `smithay` in `https://github.com/Smithay/smithay.git` failed to resolve
-
-Caused by:
- The patch location `https://github.com/smithay/smithay?rev=f1e7fc18a` does not appear to contain any packages matching the name `smithay`.
-*** Error code 101
-
---- Cargo.toml.orig 2024-02-07 20:40:23 UTC
-+++ Cargo.toml
-@@ -89,6 +89,3 @@ lto = "fat"
-
- [profile.release]
- lto = "fat"
--
--[patch."https://github.com/Smithay/smithay.git"]
--smithay = { git = "https://github.com/smithay//smithay", rev = "3b3e07952e" }