aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-23 18:59:10 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-23 19:30:41 +0000
commitc2e57dd637b7daec09549f98b32e6274e8ae2716 (patch)
tree300291d1082869c686498d604e6ed517dbef6803
parent2f450c70cd91fdcbf12a8f82440db235cd90a801 (diff)
downloadports-c2e57dd637b7daec09549f98b32e6274e8ae2716.tar.gz
ports-c2e57dd637b7daec09549f98b32e6274e8ae2716.zip
lang/php80: Fix build with llvm16
It will take more time to merge OpenSSL 3 in the base so allow this to build with llvm16 for now. Sponsored by: The FreeBSD Foundation
-rw-r--r--lang/php80/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/lang/php80/Makefile b/lang/php80/Makefile
index 792ac781a46e..38d757ddbc23 100644
--- a/lang/php80/Makefile
+++ b/lang/php80/Makefile
@@ -101,8 +101,9 @@ WARNING= "!!! If you have a threaded Apache, you must build ${PHP_PORT} with ZTS
.include <bsd.port.options.mk>
-.if ( ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400089 && ${SSL_DEFAULT} == base ) || ${SSL_DEFAULT:Mopenssl3*}
-IGNORE_SSL= base openssl30 openssl31
+#.if ( ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400092 && ${SSL_DEFAULT} == base ) || ${SSL_DEFAULT:Mopenssl3*}
+.if ${SSL_DEFAULT:Mopenssl3*}
+IGNORE_SSL= openssl30 openssl31
IGNORE_SSL_REASON= Missing upstream support for OpenSSL 3.0.0 and later
.endif