aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-04-18 05:06:18 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-04-18 05:44:04 +0000
commitc3183a0a8bacf27f8ae6fe0801965cdf355d3aa0 (patch)
tree7d1d9b516df6893da3b4dfa7b09bfa79f66affde
parent2ff060b9063b92ed4e2673f8f772966624bff476 (diff)
downloadports-c3183a0a8bacf27f8ae6fe0801965cdf355d3aa0.tar.gz
ports-c3183a0a8bacf27f8ae6fe0801965cdf355d3aa0.zip
science/py-h5py: Update to 3.2.1
-rw-r--r--devel/cpp2py/Makefile2
-rw-r--r--math/py-keras-applications/Makefile2
-rw-r--r--math/py-keras/Makefile2
-rw-r--r--science/py-OpenFermion/Makefile2
-rw-r--r--science/py-PyFR/Makefile2
-rw-r--r--science/py-dipy/Makefile2
-rw-r--r--science/py-h5json/Makefile2
-rw-r--r--science/py-h5py/Makefile6
-rw-r--r--science/py-h5py/distinfo6
-rw-r--r--science/py-h5py/files/patch-setup.py13
-rw-r--r--science/py-h5py/pkg-plist1
-rw-r--r--science/py-phono3py/Makefile2
-rw-r--r--science/py-phonopy/Makefile2
13 files changed, 22 insertions, 22 deletions
diff --git a/devel/cpp2py/Makefile b/devel/cpp2py/Makefile
index 69afe2a65c72..ccbc7cc66fcd 100644
--- a/devel/cpp2py/Makefile
+++ b/devel/cpp2py/Makefile
@@ -20,7 +20,7 @@ BUILD_DEPENDS= ${PY_DEPENDS} \
RUN_DEPENDS= ${PY_DEPENDS} \
llvm${LLVM_VER}>0:devel/llvm${LLVM_VER}
-USES= cmake compiler:c++14-lang gettext-runtime python:3.6+ shebangfix
+USES= cmake compiler:c++14-lang gettext-runtime python:3.7+ shebangfix
USE_LDCONFIG= yes
USE_GITHUB= yes
diff --git a/math/py-keras-applications/Makefile b/math/py-keras-applications/Makefile
index 6706686d8982..3e74d559bc64 100644
--- a/math/py-keras-applications/Makefile
+++ b/math/py-keras-applications/Makefile
@@ -12,7 +12,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}h5py>=0:science/py-h5py@${PY_FLAVOR}
-USES= python:3.6+
+USES= python:3.7+
USE_GITHUB= yes
GH_ACCOUNT= keras-team
USE_PYTHON= autoplist distutils
diff --git a/math/py-keras/Makefile b/math/py-keras/Makefile
index c248c1bef7d5..39fa5130156a 100644
--- a/math/py-keras/Makefile
+++ b/math/py-keras/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}theano>=0.8.0:math/py-theano@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR}
-USES= python:3.6+
+USES= python:3.7+
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/science/py-OpenFermion/Makefile b/science/py-OpenFermion/Makefile
index 768844df7f9d..3a63bc1294d1 100644
--- a/science/py-OpenFermion/Makefile
+++ b/science/py-OpenFermion/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cvxopt>0:math/py-cvxopt@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
${PYNUMPY}
-USES= python:3.6+
+USES= python:3.7+
USE_GITHUB= yes
GH_ACCOUNT= quantumlib
USE_PYTHON= distutils autoplist
diff --git a/science/py-PyFR/Makefile b/science/py-PyFR/Makefile
index de7928e34d91..273efe13459e 100644
--- a/science/py-PyFR/Makefile
+++ b/science/py-PyFR/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}appdirs>=1.4.0:devel/py-appdirs@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}pytools>=2016.2.1:devel/py-pytools@${PY_FLAVOR} \
${PYNUMPY}
-USES= python:3.3+ shebangfix zip
+USES= python:3.7+ shebangfix zip
SHEBANG_FILES= setup.py pyfr/__main__.py
USE_PYTHON= distutils concurrent autoplist
NO_ARCH= yes
diff --git a/science/py-dipy/Makefile b/science/py-dipy/Makefile
index cac1801107d2..2c632a4a01e4 100644
--- a/science/py-dipy/Makefile
+++ b/science/py-dipy/Makefile
@@ -18,7 +18,7 @@ PY_DEPENDS= ${PYNUMPY} \
BUILD_DEPENDS= ${PY_DEPENDS}
RUN_DEPENDS= ${PY_DEPENDS}
-USES= python:3.6+
+USES= python:3.7+
USE_PYTHON= distutils cython concurrent autoplist # pkg-plist also exists and contains files missing from the python-generated plist
post-install:
diff --git a/science/py-h5json/Makefile b/science/py-h5json/Makefile
index 69dc22a1d3f1..7dfa6995da70 100644
--- a/science/py-h5json/Makefile
+++ b/science/py-h5json/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pkgconfig>0:devel/py-pkgconfig@${PY_FLAVOR
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}h5py>0:science/py-h5py@${PY_FLAVOR}
-USES= python:3.6+
+USES= python:3.7+
USE_PYTHON= distutils concurrent autoplist
NO_ARCH= yes
diff --git a/science/py-h5py/Makefile b/science/py-h5py/Makefile
index d9d823f6ecf5..bd4084af7d1d 100644
--- a/science/py-h5py/Makefile
+++ b/science/py-h5py/Makefile
@@ -1,7 +1,7 @@
# Created by: TAOKA Fumiyoshi
PORTNAME= h5py
-PORTVERSION= 3.1.0
+PORTVERSION= 3.2.1
CATEGORIES= science python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,14 +12,14 @@ COMMENT= General-purpose Python interface to the HDF5 library
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/licenses/license.txt
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cython>=0.29.14:lang/cython@${PY_FLAVOR} \
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cython>=0.29.15:lang/cython@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pkgconfig>=0:devel/py-pkgconfig@${PY_FLAVOR} \
${RUN_DEPENDS}
LIB_DEPENDS= libhdf5.so:science/hdf5
RUN_DEPENDS= ${PYNUMPY}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR}
-USES= localbase pkgconfig python:3.6+
+USES= localbase pkgconfig python:3.7+
USE_PYTHON= autoplist concurrent cython distutils
OPTIONS_DEFINE= DOCS EXAMPLES
diff --git a/science/py-h5py/distinfo b/science/py-h5py/distinfo
index 6dfa94d5c772..7df8245c1b79 100644
--- a/science/py-h5py/distinfo
+++ b/science/py-h5py/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1611665487
-SHA256 (h5py-3.1.0.tar.gz) = 1e2516f190652beedcb8c7acfa1c6fa92d99b42331cbef5e5c7ec2d65b0fc3c2
-SIZE (h5py-3.1.0.tar.gz) = 371392
+TIMESTAMP = 1618320258
+SHA256 (h5py-3.2.1.tar.gz) = 89474be911bfcdb34cbf0d98b8ec48b578c27a89fdb1ae4ee7513f1ef8d9249e
+SIZE (h5py-3.2.1.tar.gz) = 368170
diff --git a/science/py-h5py/files/patch-setup.py b/science/py-h5py/files/patch-setup.py
index 3a3544a35b81..e6b3709d1b00 100644
--- a/science/py-h5py/files/patch-setup.py
+++ b/science/py-h5py/files/patch-setup.py
@@ -1,20 +1,19 @@
---- setup.py.orig 2020-11-06 14:25:11 UTC
+--- setup.py.orig 2021-03-05 10:02:07 UTC
+++ setup.py
-@@ -27,10 +27,7 @@ VERSION = '3.1.0'
+@@ -27,9 +27,7 @@ VERSION = '3.2.1'
# Minimum supported versions of Numpy & Cython depend on the Python version
NUMPY_MIN_VERSIONS = [
# Numpy Python
-- ('1.12', "=='3.6'"),
- ('1.14.5', "=='3.7'"),
- ('1.17.5', "=='3.8'"),
- ('1.19.3', ">='3.9'"),
-+ ('1.14.5', ">='3.6'"),
++ ('1.14.5', ">='3.7'"),
]
# these are required to use h5py
-@@ -49,7 +46,7 @@ SETUP_REQUIRES = [
- f"Cython >=0.29; python_version<'3.8'",
- f"Cython >=0.29.14; python_version>='3.8'",
+@@ -49,7 +47,7 @@ SETUP_REQUIRES = [
+ "Cython >=0.29.14; python_version=='3.8'",
+ "Cython >=0.29.15; python_version>='3.9'",
] + [
- f"numpy =={np_min}; python_version{py_condition}"
+ f"numpy >={np_min}; python_version{py_condition}"
diff --git a/science/py-h5py/pkg-plist b/science/py-h5py/pkg-plist
index ef96ae587840..598c731c6ad5 100644
--- a/science/py-h5py/pkg-plist
+++ b/science/py-h5py/pkg-plist
@@ -35,6 +35,7 @@
%%PORTDOCS%%%%DOCSDIR%%/whatsnew/2.9.rst
%%PORTDOCS%%%%DOCSDIR%%/whatsnew/3.0.rst
%%PORTDOCS%%%%DOCSDIR%%/whatsnew/3.1.rst
+%%PORTDOCS%%%%DOCSDIR%%/whatsnew/3.2.rst
%%PORTDOCS%%%%DOCSDIR%%/whatsnew/index.rst
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bytesio.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/collective_io.py
diff --git a/science/py-phono3py/Makefile b/science/py-phono3py/Makefile
index 6709a76c4582..679da463dae6 100644
--- a/science/py-phono3py/Makefile
+++ b/science/py-phono3py/Makefile
@@ -21,7 +21,7 @@ BUILD_DEPENDS= ${PY_DEPENDS} \
${LOCALBASE}/include/lapacke.h:math/lapacke
RUN_DEPENDS= ${PY_DEPENDS}
-USES= blaslapack:openblas fortran localbase python:3.6+
+USES= blaslapack:openblas fortran localbase python:3.7+
USE_PYTHON= distutils cython autoplist
.include <bsd.port.mk>
diff --git a/science/py-phonopy/Makefile b/science/py-phonopy/Makefile
index 25c47154a8e1..ead3a4c7405f 100644
--- a/science/py-phonopy/Makefile
+++ b/science/py-phonopy/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= ${PY_DEPENDS}
RUN_DEPENDS= ${PY_DEPENDS}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR}
-USES= python:3.6+
+USES= python:3.7+
USE_PYTHON= distutils cython autoplist
do-test: