aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-03 23:21:56 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-03 23:36:30 +0000
commitc328d3ca8519cde4d92177e1dfc812fa7f926564 (patch)
tree2ff11a4bdacc794c2422a7f35e69f0fda3d43c22
parentef4df61bb52bbe573b8ae2b551be535e459c1455 (diff)
downloadports-c328d3ca8519cde4d92177e1dfc812fa7f926564.tar.gz
ports-c328d3ca8519cde4d92177e1dfc812fa7f926564.zip
security/nettle: Update to 3.8
-rw-r--r--security/nettle/Makefile9
-rw-r--r--security/nettle/distinfo6
-rw-r--r--security/nettle/files/extra-patch-powerpc64_machine.m432
-rw-r--r--security/nettle/files/patch-powerpc64-p8-aes-decrypt-internal.asm6
-rw-r--r--security/nettle/files/patch-powerpc64-p8-aes-encrypt-internal.asm6
-rw-r--r--security/nettle/pkg-plist6
6 files changed, 16 insertions, 49 deletions
diff --git a/security/nettle/Makefile b/security/nettle/Makefile
index 57ca439f03aa..2242322e6c36 100644
--- a/security/nettle/Makefile
+++ b/security/nettle/Makefile
@@ -1,7 +1,7 @@
# Created by: ijliao
PORTNAME= nettle
-PORTVERSION= 3.7.3
+PORTVERSION= 3.8
CATEGORIES= security
MASTER_SITES= GNU \
https://www.lysator.liu.se/~nisse/archive/
@@ -24,10 +24,11 @@ CONFIGURE_ENV= M4="/usr/bin/m4 -g"
GNU_CONFIGURE= yes
TEST_TARGET= check
USE_LDCONFIG= yes
-CPE_VENDOR= nettle_project
INFO= nettle
+CPE_VENDOR= nettle_project
+
OPTIONS_DEFINE= DOCS EXAMPLES
EXAMPLES_CFLAGS= -I${OPENSSLINC}
@@ -39,10 +40,6 @@ EXAMPLES_USES= ssl
CONFIGURE_ENV+= CCPIC=-fPIC
.endif
-.if defined(PPC_ABI) && ${PPC_ABI} == ELFv2
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-powerpc64_machine.m4
-.endif
-
post-patch:
@${REINPLACE_CMD} -e '/libdir=/ s|lib32|lib|' ${WRKSRC}/configure
.if ${ARCH} == "mips64"
diff --git a/security/nettle/distinfo b/security/nettle/distinfo
index e0bcb43ae699..713ec2bb06d8 100644
--- a/security/nettle/distinfo
+++ b/security/nettle/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1622214002
-SHA256 (nettle-3.7.3.tar.gz) = 661f5eb03f048a3b924c3a8ad2515d4068e40f67e774e8a26827658007e3bcf0
-SIZE (nettle-3.7.3.tar.gz) = 2383985
+TIMESTAMP = 1654275835
+SHA256 (nettle-3.8.tar.gz) = 7576c68481c198f644b08c160d1a4850ba9449e308069455b5213319f234e8e6
+SIZE (nettle-3.8.tar.gz) = 2404258
diff --git a/security/nettle/files/extra-patch-powerpc64_machine.m4 b/security/nettle/files/extra-patch-powerpc64_machine.m4
deleted file mode 100644
index e0bcdbd34fd2..000000000000
--- a/security/nettle/files/extra-patch-powerpc64_machine.m4
+++ /dev/null
@@ -1,32 +0,0 @@
---- powerpc64/machine.m4.old 2021-04-18 10:51:29.072176000 -0500
-+++ powerpc64/machine.m4 2021-04-18 11:45:30.583315000 -0500
-@@ -1,26 +1,15 @@
- define(`PROLOGUE',
- `.globl C_NAME($1)
- DECLARE_FUNC(C_NAME($1))
--ifelse(WORDS_BIGENDIAN,no,
--`ifdef(`FUNC_ALIGN',`.align FUNC_ALIGN')
-+ifdef(`FUNC_ALIGN',`.align FUNC_ALIGN')
- C_NAME($1):
- addis 2,12,(.TOC.-C_NAME($1))@ha
- addi 2,2,(.TOC.-C_NAME($1))@l
--.localentry C_NAME($1), .-C_NAME($1)',
--`.section ".opd","aw"
--.align 3
--C_NAME($1):
--.quad .C_NAME($1),.TOC.@tocbase,0
--.previous
--ifdef(`FUNC_ALIGN',`.align FUNC_ALIGN')
--.C_NAME($1):')
-+.localentry C_NAME($1), .-C_NAME($1)
- undefine(`FUNC_ALIGN')')
-
- define(`EPILOGUE',
--`ifelse(WORDS_BIGENDIAN,no,
--`.size C_NAME($1), . - C_NAME($1)',
--`.size .C_NAME($1), . - .C_NAME($1)
--.size C_NAME($1), . - .C_NAME($1)')')
-+`.size C_NAME($1), . - C_NAME($1)')
-
- C Get vector-scalar register from vector register
- C VSR(VR)
diff --git a/security/nettle/files/patch-powerpc64-p8-aes-decrypt-internal.asm b/security/nettle/files/patch-powerpc64-p8-aes-decrypt-internal.asm
index 741be5db338e..6ec80f833cc9 100644
--- a/security/nettle/files/patch-powerpc64-p8-aes-decrypt-internal.asm
+++ b/security/nettle/files/patch-powerpc64-p8-aes-decrypt-internal.asm
@@ -1,11 +1,11 @@
---- powerpc64/p8/aes-decrypt-internal.asm.orig 2021-06-06 20:06:30 UTC
+--- powerpc64/p8/aes-decrypt-internal.asm.orig 2022-06-02 17:57:16 UTC
+++ powerpc64/p8/aes-decrypt-internal.asm
@@ -71,7 +71,7 @@ define(`FUNC_ALIGN', `5')
PROLOGUE(_nettle_aes_decrypt)
vxor ZERO,ZERO,ZERO
-- DATA_LOAD_VEC(swap_mask,.swap_mask,r5)
-+ DATA_LOAD_VEC(swap_mask,.swap_data,r5)
+- DATA_LOAD_VEC(SWAP_MASK,.swap_mask,r5)
++ DATA_LOAD_VEC(SWAP_MASK,.swap_data,r5)
subi ROUNDS,ROUNDS,1
srdi LENGTH,LENGTH,4
diff --git a/security/nettle/files/patch-powerpc64-p8-aes-encrypt-internal.asm b/security/nettle/files/patch-powerpc64-p8-aes-encrypt-internal.asm
index fddeedabb748..313ba61a4f6b 100644
--- a/security/nettle/files/patch-powerpc64-p8-aes-encrypt-internal.asm
+++ b/security/nettle/files/patch-powerpc64-p8-aes-encrypt-internal.asm
@@ -1,11 +1,11 @@
---- powerpc64/p8/aes-encrypt-internal.asm.orig 2021-06-06 20:06:30 UTC
+--- powerpc64/p8/aes-encrypt-internal.asm.orig 2022-06-02 17:57:16 UTC
+++ powerpc64/p8/aes-encrypt-internal.asm
@@ -63,7 +63,7 @@ define(`S7', `v9')
define(`FUNC_ALIGN', `5')
PROLOGUE(_nettle_aes_encrypt)
-- DATA_LOAD_VEC(swap_mask,.swap_mask,r5)
-+ DATA_LOAD_VEC(swap_mask,.swap_data,r5)
+- DATA_LOAD_VEC(SWAP_MASK,.swap_mask,r5)
++ DATA_LOAD_VEC(SWAP_MASK,.swap_data,r5)
subi ROUNDS,ROUNDS,1
srdi LENGTH,LENGTH,4
diff --git a/security/nettle/pkg-plist b/security/nettle/pkg-plist
index 7073dc2ac1ae..100c1300d537 100644
--- a/security/nettle/pkg-plist
+++ b/security/nettle/pkg-plist
@@ -46,6 +46,7 @@ include/nettle/memops.h
include/nettle/memxor.h
include/nettle/nettle-meta.h
include/nettle/nettle-types.h
+include/nettle/nist-keywrap.h
include/nettle/pbkdf2.h
include/nettle/pgp.h
include/nettle/pkcs1.h
@@ -63,6 +64,7 @@ include/nettle/sha1.h
include/nettle/sha2.h
include/nettle/sha3.h
include/nettle/siv-cmac.h
+include/nettle/sm3.h
include/nettle/streebog.h
include/nettle/twofish.h
include/nettle/umac.h
@@ -72,11 +74,11 @@ include/nettle/yarrow.h
lib/libhogweed.a
lib/libhogweed.so
lib/libhogweed.so.6
-lib/libhogweed.so.6.4
+lib/libhogweed.so.6.5
lib/libnettle.a
lib/libnettle.so
lib/libnettle.so.8
-lib/libnettle.so.8.4
+lib/libnettle.so.8.5
libdata/pkgconfig/hogweed.pc
libdata/pkgconfig/nettle.pc
%%PORTDOCS%%%%DOCSDIR%%/NEWS