aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2023-03-08 04:47:02 +0000
committerDon Lewis <truckman@FreeBSD.org>2023-03-08 04:53:27 +0000
commitc36f76c2297b7294e24a9adce8b1b3a4105dd2c1 (patch)
tree35bc947ba09baf1e1ef7f34083a005dc472d7e93
parentabae885891d3bc1febabcb3af77240cd1de1a860 (diff)
downloadports-c36f76c2297b7294e24a9adce8b1b3a4105dd2c1.tar.gz
ports-c36f76c2297b7294e24a9adce8b1b3a4105dd2c1.zip
editors/openoffice-4: Upgrade to 4.1.14 and unbreak
Upgrade openoffice-4 to version from 4.1.12 to 4.1.14 and unbreak. The "invalid use of @return" build failure has come and gone probably due to some other changes to ports. Release notes for 4.1.14: https://cwiki.apache.org/confluence/display/OOOUSERS/AOO+4.1.14+Release+Notes Release notes for 4.1.13: https://cwiki.apache.org/confluence/display/OOOUSERS/AOO+4.1.13+Release+Notes Add USE_GNOME=gdkpixbuf2xlib which now seems to be necessary. Simplify the port by always using the bundled vigra and boost rather than making this compiler version dependent. The bundled versions work (better) with modern clang in -std=gnu++98 mode. Also, an upcoming version of boost will require c++14 mode. The bundled boost needs a minor patch to work with modern clang in this mode. Add upgrade advice to pkg-message. Security: 6678211c-bd47-11ed-beb0-1c1b0d9ea7e6
-rw-r--r--editors/openoffice-4/Makefile35
-rw-r--r--editors/openoffice-4/distinfo6
-rw-r--r--editors/openoffice-4/files/patch-boost_boost__1__55__0.patch18
-rw-r--r--editors/openoffice-4/files/pkg-message.in22
4 files changed, 53 insertions, 28 deletions
diff --git a/editors/openoffice-4/Makefile b/editors/openoffice-4/Makefile
index 748e74345d88..6fd8b3d81a44 100644
--- a/editors/openoffice-4/Makefile
+++ b/editors/openoffice-4/Makefile
@@ -1,6 +1,6 @@
PORTNAME= apache-openoffice
PORTVERSION= ${AOOVERSION}
-PORTREVISION= 2
+PORTREVISION= 0
CATEGORIES= editors java
MASTER_SITES= https://dlcdn.apache.org/openoffice/${PORTVERSION}/source/ \
https://archive.apache.org/dist/openoffice/${PORTVERSION}/source/ \
@@ -13,7 +13,8 @@ PKGNAMEPREFIX= ${LANG_PKGNAME}-
.if defined(LANG_SUFFIX)
PKGNAMESUFFIX= -${LANG_SUFFIX}
.endif
-DISTFILES= ${AOOSRC} ${EXTSRC}:extsrc ${PYTHON_DISTFILE}:sf
+DISTFILES= ${AOOSRC} ${EXTSRC}:extsrc ${PYTHON_DISTFILE}:sf \
+ ${GCC_EXTRA_DISTFILES:C/.*/&:sf/g}
DIST_SUBDIR= openoffice
EXTRACT_ONLY= ${AOOSRC}
@@ -48,7 +49,6 @@ LICENSE_PERMS_TWAIN= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LICENSE_PERMS_W3C= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
ONLY_FOR_ARCHS= amd64 i386 powerpc64
-BROKEN= does not build: invalid use of @return
BUILD_DEPENDS= \
p5-Archive-Zip>=0:archivers/p5-Archive-Zip \
@@ -114,7 +114,7 @@ USES= autoreconf bison compiler:c++11-lib cpe desktop-file-utils \
gettext-runtime gl gmake gnome iconv jpeg perl5 pkgconfig \
shared-mime-info ssl tar:bzip2 xorg
USE_GL= gl glu
-USE_GNOME= gdkpixbuf2 gtk20 libxslt libidl glib20
+USE_GNOME= gdkpixbuf2 gdkpixbuf2xlib gtk20 libxslt libidl glib20
USE_JAVA= yes
JAVA_BUILD= jdk
JAVA_RUN= jdk
@@ -127,10 +127,10 @@ CONFLICTS_INSTALL= apache-openoffice-devel
AOOVERSION1= 4
AOOVERSION2= 1
-AOOVERSION3= 12
+AOOVERSION3= 14
# From solenv/inc/minor.mk SOURCEREVISION LAST_MINOR BUILD
-AOOTAG= AOO4112m1\(Build:9809\)
-GITREVISION= 60e0a1c111
+AOOTAG= AOO4114m1\(Build:9811\)
+GITREVISION= a0d24fb625
EXTSRC= ApacheOpenOffice.ext_sources.${AOOVERSION1}.x.x.20150707.tar.gz
AOOVERSION= ${AOOVERSION1}.${AOOVERSION2}.${AOOVERSION3}
@@ -218,25 +218,11 @@ GCC_EXTRA_DISTFILES= d6eef4b4cacb2183f2bf265a5a03a354-boost_1_55_0.tar.bz2 \
.if ${CHOSEN_COMPILER_TYPE} == clang
CPPFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ARGS+= --with-system-boost
-BUILD_DEPENDS+= ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
-. if ${COMPILER_VERSION} < 130
-CONFIGURE_ARGS+= --with-system-vigra
-BUILD_DEPENDS+= ${LOCALBASE}/bin/vigra-config:graphics/vigra
-. endif
. if ${ARCH} == amd64
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-align16
. endif
.endif
-# These extra distfiles are needed to use the bundled versions of
-# boost and vigra for compatiblity with gcc. Also include them
-# for the makesum target so they are included in distinfo
-.if ${CHOSEN_COMPILER_TYPE} == gcc || ${COMPILER_VERSION} >= 130 || \
- make(makesum) || make(distclean)
-DISTFILES+= ${GCC_EXTRA_DISTFILES:C/.*/&:sf/g}
-.endif
-
.if ${ARCH} == amd64
FREEBSD_ENV_SET= FreeBSDAMDEnv.Set.sh
PACKAGE_MIDDLE= ${PORTVERSION}_${OPSYS}_x86-64
@@ -258,6 +244,7 @@ WRKSUBDIR= ${WRKDIR}/aoo-${AOOVERSION}
WRKSRC?= ${WRKSUBDIR}/main
SUB_FILES= pkg-message
SUB_LIST= EXECBASE=${EXECBASE} AOOTAG=${AOOTAG} AOOUDIR=${AOOUDIR} \
+ AOOVERSION=${AOOVERSION} \
PRINSTALLATION_BASEDIR=${PRINSTALLATION_BASEDIR}
CONFIGURE_ARGS+= \
@@ -350,11 +337,9 @@ do-extract-SDK-on:
post-extract:
${TAR} -C ${WRKSUBDIR} -xzf ${DISTDIR}/${DIST_SUBDIR}/${EXTSRC}
${CP} ${DISTDIR}/${DIST_SUBDIR}/${PYTHON_DISTFILE} ${WRKSUBDIR}/ext_sources/${PYTHON_DISTFILE}
-.if ${CHOSEN_COMPILER_TYPE} == gcc || ${COMPILER_VERSION} >= 130
-. for f in ${GCC_EXTRA_DISTFILES}
+.for f in ${GCC_EXTRA_DISTFILES}
${CP} ${DISTDIR}/${DIST_SUBDIR}/${f} ${WRKSUBDIR}/ext_sources/${f}
-. endfor
-.endif
+.endfor
${CP} ${FILESDIR}/freebsd-aoo-intro.png \
${WRKSRC}/default_images/introabout/intro.png
${CP} ${FILESDIR}/freebsd-aoo-about.png \
diff --git a/editors/openoffice-4/distinfo b/editors/openoffice-4/distinfo
index 1b7494d4de53..076bce564fe2 100644
--- a/editors/openoffice-4/distinfo
+++ b/editors/openoffice-4/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1632829665
-SHA256 (openoffice/apache-openoffice-4.1.12-60e0a1c111-src.tar.bz2) = 6808c81cc1d3662a2f340edd609f00a553e6ffd19193f098a047cb85d7a7be32
-SIZE (openoffice/apache-openoffice-4.1.12-60e0a1c111-src.tar.bz2) = 229470305
+TIMESTAMP = 1676701851
+SHA256 (openoffice/apache-openoffice-4.1.14-a0d24fb625-src.tar.bz2) = ea150bbd2a9c2e0fedbbff9c4c2dc7f1f129caf0236c5ddf9ec79d13bc109b59
+SIZE (openoffice/apache-openoffice-4.1.14-a0d24fb625-src.tar.bz2) = 243964178
SHA256 (openoffice/ApacheOpenOffice.ext_sources.4.x.x.20150707.tar.gz) = 966a8333c83a18ddd84401389006d6e0b52b8175924b808b54b88211669985fa
SIZE (openoffice/ApacheOpenOffice.ext_sources.4.x.x.20150707.tar.gz) = 28957004
SHA256 (openoffice/38c84292658ed4456157195f1c9bcbe1-Python-2.7.18.tgz) = da3080e3b488f648a3d7a4560ddee895284c3380b11d6de75edb986526b9a814
diff --git a/editors/openoffice-4/files/patch-boost_boost__1__55__0.patch b/editors/openoffice-4/files/patch-boost_boost__1__55__0.patch
new file mode 100644
index 000000000000..a2656de477ac
--- /dev/null
+++ b/editors/openoffice-4/files/patch-boost_boost__1__55__0.patch
@@ -0,0 +1,18 @@
+--- boost/boost_1_55_0.patch.orig 2021-04-02 12:58:20 UTC
++++ boost/boost_1_55_0.patch
+@@ -359,3 +359,15 @@ +# if defined(__VARIADIC_TEMPLATES)
+ # define BOOST_HAS_VARIADIC_TMPL
+ # else
+ # define BOOST_NO_CXX11_VARIADIC_TEMPLATES
++diff -ur misc/boost_1_55_0/boost/config/stdlib/libcpp.hpp misc/build/boost_1_55_0/boost/config/stdlib/libcpp.hpp
++--- misc/boost_1_55_0/boost/config/stdlib/libcpp.hpp 2012-05-15 04:57:21.000000000 -0700
+++++ misc/build/boost_1_55_0/boost/config/stdlib/libcpp.hpp
++@@ -19,7 +19,7 @@
++
++ #define BOOST_HAS_THREADS
++
++-#ifdef _LIBCPP_HAS_NO_VARIADICS
+++#if defined(_LIBCPP_HAS_NO_VARIADICS) || (__cplusplus < 201103)
++ # define BOOST_NO_CXX11_HDR_TUPLE
++ #endif
++
diff --git a/editors/openoffice-4/files/pkg-message.in b/editors/openoffice-4/files/pkg-message.in
index 33d8a8913f58..d33acb454f73 100644
--- a/editors/openoffice-4/files/pkg-message.in
+++ b/editors/openoffice-4/files/pkg-message.in
@@ -53,4 +53,26 @@ If you somehow run into problems, please remove the already installed
user installation and the problems should go away.
EOM
}
+{ type: upgrade
+ maximum_version: "%%AOOVERSION%%"
+ message: <<EOM
+In general, it is always a good idea to do a backup of important
+and personal data, so we recommend to always back up your OpenOffice
+user profile before doing an upgrade to a newer release.
+
+Users can back up their profile by copying this directory:
+ /home/<user name>/.openoffice
+EOM
+}
+{ type: upgrade
+ maximum_version: "4.1.13"
+ message: <<EOM
+It is recommended to make a backup of the Apache OpenOffice users
+profile before upgrading. It is especially essential for users who
+use the Master Password functionality and may decide to use an older
+version later. There is a change in the encoding of stored passwords
+between the 4.1.2 and 4.1.13 releases that may make your user
+profile unusable for previous versions.
+EOM
+}
]