aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-07-01 16:38:45 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-07-01 16:39:40 +0000
commitc37befcd7c01b6f5723a23bcb24f016879bf02db (patch)
tree7d14d16066eb5f9751a5d8fa4ff2cfe38ccd6099
parent3b308b6b2c8bc641d60b1e978fad98eafd7923cb (diff)
downloadports-c37befcd7c01b6f5723a23bcb24f016879bf02db.tar.gz
ports-c37befcd7c01b6f5723a23bcb24f016879bf02db.zip
audio/dmidiplayer: New port: Featured MIDI file player
-rw-r--r--audio/Makefile1
-rw-r--r--audio/dmidiplayer/Makefile21
-rw-r--r--audio/dmidiplayer/distinfo3
-rw-r--r--audio/dmidiplayer/pkg-descr8
-rw-r--r--audio/dmidiplayer/pkg-plist22
5 files changed, 55 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index e6e8631bac7f..4a3716affc3f 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -116,6 +116,7 @@
SUBDIR += denemo
SUBDIR += din
SUBDIR += discid
+ SUBDIR += dmidiplayer
SUBDIR += dpf-plugins-lv2
SUBDIR += dragonfly-reverb-lv2
SUBDIR += drumgizmo
diff --git a/audio/dmidiplayer/Makefile b/audio/dmidiplayer/Makefile
new file mode 100644
index 000000000000..ba9e3f3d3437
--- /dev/null
+++ b/audio/dmidiplayer/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= dmidiplayer
+DISTVERSION= 1.4.0
+CATEGORIES= audio
+MASTER_SITES= SF/${PORTNAME}/v${DISTVERSION}/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Featured MIDI file player
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libdrumstick-rt.so:audio/drumstick \
+ libuchardet.so:textproc/uchardet
+
+USES= compiler:c++11-lang cmake desktop-file-utils pkgconfig qt:5 tar:bz2
+USE_QT= core gui printsupport widgets buildtools_build linguisttools qmake_build
+
+CMAKE_ON= EMBED_TRANSLATIONS
+CMAKE_OFF= BUILD_DOCS
+
+.include <bsd.port.mk>
diff --git a/audio/dmidiplayer/distinfo b/audio/dmidiplayer/distinfo
new file mode 100644
index 000000000000..7a8f2b095fa9
--- /dev/null
+++ b/audio/dmidiplayer/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1625155657
+SHA256 (dmidiplayer-1.4.0.tar.bz2) = bdfaeee156be3719e3809239b18384ffdbcc8b6b4cfbdf2bfac8c73a010a44d8
+SIZE (dmidiplayer-1.4.0.tar.bz2) = 1354068
diff --git a/audio/dmidiplayer/pkg-descr b/audio/dmidiplayer/pkg-descr
new file mode 100644
index 000000000000..e610b4ac41d1
--- /dev/null
+++ b/audio/dmidiplayer/pkg-descr
@@ -0,0 +1,8 @@
+Featured MIDI File Player for Linux, Windows, and macOS written in C++, and
+using Qt5 and Drumstick2.
+
+Features:
+* MIDI Output to hardware MIDI ports, or any other Drumstick backend
+* Transpose song tonality between -12 and +12 semitones
+
+WWW: https://sourceforge.net/projects/dmidiplayer/
diff --git a/audio/dmidiplayer/pkg-plist b/audio/dmidiplayer/pkg-plist
new file mode 100644
index 000000000000..9ee0fe951d1b
--- /dev/null
+++ b/audio/dmidiplayer/pkg-plist
@@ -0,0 +1,22 @@
+bin/dmidiplayer
+man/man1/dmidiplayer.1.gz
+share/applications/net.sourceforge.dmidiplayer.desktop
+%%DATADIR%%/dmidiplayer_cs.qm
+%%DATADIR%%/dmidiplayer_es.qm
+%%DATADIR%%/dmidiplayer_ru.qm
+%%DATADIR%%/examples.lst
+%%DATADIR%%/haendel_hallelujah.mid
+%%DATADIR%%/lindaamiga.mid
+%%DATADIR%%/mozart_aveverum.mid
+%%DATADIR%%/mozart_diesirae.mid
+%%DATADIR%%/mozart_konigdernacht.mid
+%%DATADIR%%/schubert_avemaria.mid
+%%DATADIR%%/test.mid
+%%DATADIR%%/twinkle.kar
+share/icons/hicolor/128x128/apps/dmidiplayer.png
+share/icons/hicolor/24x24/apps/dmidiplayer.png
+share/icons/hicolor/32x32/apps/dmidiplayer.png
+share/icons/hicolor/48x48/apps/dmidiplayer.png
+share/icons/hicolor/64x64/apps/dmidiplayer.png
+share/icons/hicolor/scalable/apps/dmidiplayer.svgz
+share/metainfo/net.sourceforge.dmidiplayer.appdata.xml