aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2021-05-01 12:27:00 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2021-05-01 12:42:30 +0000
commitc399c4d12f6462f1d535e9a3143fe0e679a63eb8 (patch)
treea4ae95c49da11dcaf38fcc8e97b7ce54ab93f131
parenta96e4a942d9f71d8aee9ca88ef718f7563ed5fa4 (diff)
downloadports-c399c4d12f6462f1d535e9a3143fe0e679a63eb8.tar.gz
ports-c399c4d12f6462f1d535e9a3143fe0e679a63eb8.zip
Prepare removal for libgnomeui
Remove the GNOME option for all ports depending on libgnomeui
-rw-r--r--astro/celestia/Makefile13
-rw-r--r--astro/nightfall/Makefile11
-rw-r--r--devel/distcc/Makefile27
-rw-r--r--editors/vim/Makefile11
-rw-r--r--french/verbiste/Makefile14
-rw-r--r--french/verbiste/pkg-plist2
-rw-r--r--games/exult/Makefile8
-rw-r--r--games/exult/pkg-plist3
-rw-r--r--graphics/graphviz/Makefile8
-rw-r--r--graphics/gtkam/Makefile15
-rw-r--r--multimedia/dvdstyler/Makefile9
-rw-r--r--textproc/stardict3/Makefile23
-rw-r--r--textproc/stardict3/pkg-plist108
-rw-r--r--x11-toolkits/guile-gnome-platform/Makefile17
14 files changed, 42 insertions, 227 deletions
diff --git a/astro/celestia/Makefile b/astro/celestia/Makefile
index 7f84856bf9b9..5314974973b1 100644
--- a/astro/celestia/Makefile
+++ b/astro/celestia/Makefile
@@ -2,7 +2,7 @@
PORTNAME= celestia
PORTVERSION= 1.6.1
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= astro
MASTER_SITES= SF/${PORTNAME}/Celestia-source/${PORTVERSION}
PKGNAMESUFFIX= -${CELESTIA_UI}
@@ -37,9 +37,6 @@ CONFLICTS= ${UI_LIST:S|${CELESTIA_UI}||:S|^|celestia-|:S|$|-[0-9]*|}
# the default one);
# gtk Full interface with minimal dependencies: adds menu, configuration
# dialog, some other utilities;
-# gnome Full GTK interface plus a few GNOME integration goodies, such as
-# preference saving in GConf (this looks and works very much like
-# the Windows interface).
#
.if ${CELESTIA_UI} == "glut"
CONFIGURE_ARGS+= --with-glut
@@ -50,17 +47,11 @@ CONFIGURE_ARGS+= --with-gtk
USES+= gnome
USE_GNOME+= gtk20
PLIST_FILES= share/applications/celestia.desktop
-.elif ${CELESTIA_UI} == "gnome"
-CATEGORIES+= gnome
-CONFIGURE_ARGS+= --with-gnome
-USE_GNOME+= libgnomeui
-GCONF_SCHEMAS= celestia.schemas
-PLIST_FILES= share/applications/celestia.desktop
.else
IGNORE= requires one of the <${UI_LIST}> values for CELESTIA_UI
.endif
-.if ${CELESTIA_UI} == "gtk" || ${CELESTIA_UI} == "gnome"
+.if ${CELESTIA_UI} == "gtk"
USES+= pathfix
LIB_DEPENDS+= libgtkglext-x11-1.0.so:x11-toolkits/gtkglext \
libtheora.so:multimedia/libtheora
diff --git a/astro/nightfall/Makefile b/astro/nightfall/Makefile
index 93a48062202e..d4aa549d14e9 100644
--- a/astro/nightfall/Makefile
+++ b/astro/nightfall/Makefile
@@ -2,6 +2,7 @@
PORTNAME= nightfall
PORTVERSION= 1.92
+PORTREVISION= 1
CATEGORIES= astro education
MASTER_SITES= http://www.la-samhna.de/nightfall/
@@ -16,17 +17,13 @@ USE_GNOME= cairo gdkpixbuf2 gtk20
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS= --with-locale-prefix=${PREFIX}/share/locale
+CONFIGURE_ARGS= --with-locale-prefix=${PREFIX}/share/locale \
+ --disable-gome
-OPTIONS_DEFINE= GNOME PGPLOT OPENGL
+OPTIONS_DEFINE= PGPLOT OPENGL
OPTIONS_DEFAULT= PGPLOT OPENGL
OPTIONS_SUB= yes
-GNOME_CONFIGURE_ON= --with-gnomedoc-prefix=${PREFIX}/share
-GNOME_CONFIGURE_OFF= --disable-gnome
-GNOME_USE= GNOME=gnomeprefix,libgnomeui
-GNOME_VARS= INSTALLS_OMF=yes
-
OPENGL_CONFIGURE_ON= --with-lib-GL
OPENGL_CONFIGURE_OFF= --disable-opengl
OPENGL_LIB_DEPENDS= libgtkgl-2.0.so:x11-toolkits/gtkglarea2
diff --git a/devel/distcc/Makefile b/devel/distcc/Makefile
index 65f84bd7e92e..52d986a5434d 100644
--- a/devel/distcc/Makefile
+++ b/devel/distcc/Makefile
@@ -43,14 +43,10 @@ PLIST_FILES= ${_BIN_FILES:S|^|bin/|} \
${_SBIN_FILES:S|^|sbin/|} \
etc/default/distcc
-OPTIONS_DEFINE= AVAHI CLANGLINK DOCS IPV6 LLVMLINK PUMP
-OPTIONS_RADIO= GUI
-OPTIONS_RADIO_GUI= GNOME GTK
+OPTIONS_DEFINE= AVAHI CLANGLINK DOCS IPV6 LLVMLINK PUMP GUI
CLANGLINK_DESC= Create clang compiler links if clang is installed
-GNOME_DESC= Monitor based on GNOME
-GTK_DESC= Monitor based on GTK
-GUI_DESC= Build GUI for distcc monitor
+GUI_DESC= Build GUI distcc monitor
LLVMLINK_DESC= Create llvm compiler links if llvm is installed
PUMP_DESC= Distribute compilation as well as preprocessing to distcc servers
@@ -58,12 +54,9 @@ AVAHI_LIB_DEPENDS= libavahi-client.so:net/avahi-app
AVAHI_CONFIGURE_WITH= avahi
DOCS_PLIST_FILES+= ${_DOC_FILES:S|^|${DOCSDIR_REL}/|} \
${_README_FILES:S|^|${DOCSDIR_REL}/|}
-GNOME_USES= gnome
-GNOME_USE= GNOME=gtk20,libgnome,libgnomeui,pango
-GNOME_CONFIGURE_WITH= gnome
-GTK_USES= gnome
-GTK_USE= GNOME=gtk20
-GTK_CONFIGURE_WITH= gtk
+GUI_USES= gnome
+GUI_USE= GNOME=gtk20
+GUI_CONFIGURE_WITH= gtk
IPV6_CONFIGURE_ENABLE= rfc2553
PUMP_USES= python:3.1+
PUMP_CONFIGURE_ENABLE= pump-mode
@@ -126,22 +119,16 @@ _DISTCC_COMPILERS+= llvm-c++ llvm-g++ llvm-gcc
.endif
_DISTCC_COMPILERS+= ${EXTRA_COMPILERS}
-.if ${PORT_OPTIONS:MGNOME} || ${PORT_OPTIONS:MGTK}
-.if ${PORT_OPTIONS:MGNOME}
-PKGNAMESUFFIX= -gnome
-.else
+.if ${PORT_OPTIONS:MGTUI}
PKGNAMESUFFIX= -gtk
-.endif
_BIN_FILES+= distccmon-gnome
PLIST_FILES+= ${DESKTOPDIR}/distccmon-gnome.desktop \
share/pixmaps/distccmon-gnome-icon.png
.endif
-.if ${PORT_OPTIONS:MGNOME} || ${PORT_OPTIONS:MGTK}
-post-patch:
+post-patch-GUI-on:
${REINPLACE_CMD} -e 's|PKGDATADIR "|"${PREFIX}/share/pixmaps|' \
${WRKSRC}/src/mon-gnome.c
-.endif
.if ${PORT_OPTIONS:MPUMP}
_BIN_FILES+= pump
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index fa147af3d240..9eda015e3ec2 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -2,6 +2,7 @@
PORTNAME= vim
PORTVERSION= 8.2.2725
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= editors
@@ -39,7 +40,7 @@ OPTIONS_DEFAULT= CSCOPE DEFAULT_VIMRC CTAGS_EXUBERANT GTK3 PERL PYTHON RUBY
OPTIONS_DEFINE= CSCOPE DEFAULT_VIMRC MAKE_JOBS NLS XTERM_SAVE
OPTIONS_SINGLE= CTAGS UI
OPTIONS_SINGLE_CTAGS= CTAGS_BASE CTAGS_EXUBERANT CTAGS_UNIVERSAL
-OPTIONS_SINGLE_UI= ATHENA CONSOLE GNOME GTK2 GTK3 MOTIF X11
+OPTIONS_SINGLE_UI= ATHENA CONSOLE GTK2 GTK3 MOTIF X11
OPTIONS_GROUP= LANGBIND
OPTIONS_GROUP_LANGBIND= LUA PERL PYTHON RUBY SCHEME TCL
OPTIONS_SUB= yes
@@ -95,14 +96,6 @@ CONSOLE_CONFIGURE_OFF= --enable-xim --enable-fontset
CONSOLE_PLIST_SUB= GUI="@comment " DESKTOP="@comment "
CONSOLE_VARS= GUI=no
-GNOME_CONFIGURE_ENABLE= canberra
-GNOME_LIB_DEPENDS= libcanberra.so:audio/libcanberra
-GNOME_PLIST_SUB= GUI="" DESKTOP=""
-GNOME_IMPLIES= NLS
-GNOME_USE= GNOME=gdkpixbuf2,libgnomeui XORG=ice,sm,xorgproto,x11,xpm,xt
-GNOME_USES= desktop-file-utils gnome xorg
-GNOME_VARS= GUI=gnome2 INSTALLS_ICONS=yes
-
GTK2_PLIST_SUB= GUI="" DESKTOP=""
GTK2_USE= GNOME=gdkpixbuf2,gtk20 XORG=ice,sm,x11,xpm,xt
GTK2_USES= desktop-file-utils gnome xorg
diff --git a/french/verbiste/Makefile b/french/verbiste/Makefile
index 2ff38517fd87..a300883c886b 100644
--- a/french/verbiste/Makefile
+++ b/french/verbiste/Makefile
@@ -23,7 +23,9 @@ LDFLAGS+= -L${LOCALBASE}/lib
TEST_TARGET= check
-OPTIONS_DEFINE= GTK2 GNOME DOCS EXAMPLES
+OPTIONS_DEFINE= GTK2 DOCS EXAMPLES
+
+CONFIGURE_ARGS= --without-gnome-app --without-gnome-applet
.include <bsd.port.options.mk>
@@ -37,15 +39,7 @@ CONFIGURE_ARGS+=--without-gtk-app
PLIST_SUB+= HASGTK="@comment "
.endif
-.if ${PORT_OPTIONS:MGNOME}
-USE_GNOME+= gnomeprefix libgnomeui
-PLIST_SUB+= HASGNOME=""
-.else
-CONFIGURE_ARGS+=--without-gnome-app --without-gnome-applet
-PLIST_SUB+= HASGNOME="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MGTK2} || ${PORT_OPTIONS:MGNOME}
+.if ${PORT_OPTIONS:MGTK2}
USES+= gettext
PLIST_SUB+= HASGUI=""
.else
diff --git a/french/verbiste/pkg-plist b/french/verbiste/pkg-plist
index ade0329505ab..8761b7b3e04a 100644
--- a/french/verbiste/pkg-plist
+++ b/french/verbiste/pkg-plist
@@ -1,6 +1,5 @@
bin/french-conjugator
bin/french-deconjugator
-%%HASGNOME%%bin/verbiste
%%HASGTK%%bin/verbiste-gtk
include/verbiste-0.1/verbiste/FrenchVerbDictionary.h
include/verbiste-0.1/verbiste/Trie.cpp
@@ -17,7 +16,6 @@ man/fr/man3/verbiste.3.gz
man/man1/french-conjugator.1.gz
man/man1/french-deconjugator.1.gz
man/man3/verbiste.3.gz
-%%HASGNOME%%share/applications/verbiste.desktop
%%HASGUI%%share/locale/da/LC_MESSAGES/verbiste.mo
%%HASGUI%%share/locale/de/LC_MESSAGES/verbiste.mo
%%HASGUI%%share/locale/el/LC_MESSAGES/verbiste.mo
diff --git a/games/exult/Makefile b/games/exult/Makefile
index 2a054689e717..a7ba9cd1b296 100644
--- a/games/exult/Makefile
+++ b/games/exult/Makefile
@@ -3,6 +3,7 @@
PORTNAME= exult
DISTVERSIONPREFIX= v
DISTVERSION= 1.7.0.20210429
+PORTREVISION= 1
CATEGORIES= games
MAINTAINER= ports@FreeBSD.org
@@ -33,13 +34,12 @@ CONFIGURE_ARGS= --disable-static \
SUB_FILES= pkg-message
-OPTIONS_DEFINE= ALSA DOCS DEBUG FLUIDSYNTH GIMP STUDIO THUMBNAILER
+OPTIONS_DEFINE= ALSA DOCS DEBUG FLUIDSYNTH GIMP STUDIO
OPTIONS_DEFAULT= STUDIO
OPTIONS_SUB= yes
GIMP_DESC= GIMP plugin support
STUDIO_DESC= Install Exult Studio
-THUMBNAILER_DESC= Gnome SHP thumbnailer support
ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
ALSA_CONFIGURE_ENABLE= alsa
@@ -57,10 +57,6 @@ STUDIO_CONFIGURE_ENABLE= exult-studio exult-studio-support
STUDIO_USES= gnome
STUDIO_USE= gnome=libglade2
-THUMBNAILER_USES= gnome shared-mime-info
-THUMBNAILER_USE= gnome=libgnomeui
-THUMBNAILER_CONFIGURE_ENABLE= gnome-shp-thumbnailer
-
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in FAQ NEWS README
diff --git a/games/exult/pkg-plist b/games/exult/pkg-plist
index ae81cbb15567..e22a6f924653 100644
--- a/games/exult/pkg-plist
+++ b/games/exult/pkg-plist
@@ -2,7 +2,6 @@ bin/cmanip
bin/expack
bin/exult
%%STUDIO%%bin/exult_studio
-%%THUMBNAILER%%bin/gnome_shp_thumbnailer
bin/ipack
bin/mklink
bin/rip
@@ -71,6 +70,4 @@ share/applications/exult.desktop
%%DATADIR%%/u7opcodes.data
%%DATADIR%%/u7sibetaintrinsics.data
%%DATADIR%%/u7siintrinsics.data
-%%THUMBNAILER%%share/mime/packages/x-shapefile.xml
-%%THUMBNAILER%%share/thumbnailers/gnome_u7shapes.thumbnailer
share/pixmaps/exult.png
diff --git a/graphics/graphviz/Makefile b/graphics/graphviz/Makefile
index a1abcaf3440d..819801e36135 100644
--- a/graphics/graphviz/Makefile
+++ b/graphics/graphviz/Makefile
@@ -2,7 +2,7 @@
PORTNAME= graphviz
PORTVERSION= 2.44.1
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= graphics tk
MASTER_SITES= https://www2.graphviz.org/Packages/stable/portable_source/
@@ -49,7 +49,7 @@ FIX_TK_SCRIPT= tclpkg/tcldot/demo/doted.tcl \
tclpkg/tclpathplan/demo/pathplan.tcl
OPTIONS_DEFINE= XPM DIGCOLA IPSEPCOLA ICONV NLS PANGOCAIRO POPPLER \
- ANN GTS GTK2 GDK GDK_PIXBUF GNOMEUI SMYRNA DEVIL \
+ ANN GTS GTK2 GDK GDK_PIXBUF SMYRNA DEVIL \
GHOSTSCRIPT PERL PHP PYTHON RUBY LUA TCL TK GUILE GO \
NVTHREADS DOCS EXAMPLES
OPTIONS_DEFAULT= XPM DIGCOLA IPSEPCOLA ICONV PANGOCAIRO NVTHREADS
@@ -63,7 +63,6 @@ GTS_DESC= GNU Triangulated Surface Library support
GTK2_DESC= gtk2 plugin (requires PANGOCAIRO)
GDK_DESC= gdk library support (requires GTK2)
GDK_PIXBUF_DESC=gdk pixbuf support (requires GDK)
-GNOMEUI_DESC= libgnomeui support
SMYRNA_DESC= SMYRNA graph viewer (requires GTK2)
DEVIL_DESC= devil plugin
GHOSTSCRIPT_DESC=ghostscript plugin (requires PANGOCAIRO)
@@ -86,7 +85,6 @@ PANGOCAIRO_USES=gnome xorg
PANGOCAIRO_USE= GNOME=pango,cairo XORG=xrender,x11,xau,xdmcp
GTK2_USES= gnome xorg
GTK2_USE= XORG=sm,ice,xext,xinerama,xi,xrandr,xcursor,xfixes GNOME=gtk20
-GNOMEUI_USE= GNOME=libgnomeui
SMYRNA_USES= gnome gl
SMYRNA_USE= GNOME=libglade2,pangox-compat,gdkpixbuf2 GL=glut,glu,gl
GHOSTSCRIPT_USES=ghostscript
@@ -128,8 +126,6 @@ GTK2_IMPLIES= PANGOCAIRO
GDK_CONFIGURE_WITH= gdk
GDK_PIXBUF_CONFIGURE_WITH= gdk-pixbuf
GDK_PIXBUF_IMPLIES= GTK2 GDK
-GNOMEUI_CONFIGURE_WITH= gnomeui
-GNOMEUI_IMPLIES= GTK2
SMYRNA_CONFIGURE_OFF= --with-glut=no
SMYRNA_CONFIGURE_WITH= smyrna glade gtkgl gtkglext
SMYRNA_IMPLIES= GTK2 GTS
diff --git a/graphics/gtkam/Makefile b/graphics/gtkam/Makefile
index 42bceb5b641c..fa14ddc6393f 100644
--- a/graphics/gtkam/Makefile
+++ b/graphics/gtkam/Makefile
@@ -2,7 +2,7 @@
PORTNAME= gtkam
PORTVERSION= 1.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics
MASTER_SITES= SF/gphoto/${PORTNAME}/${PORTVERSION}
@@ -17,27 +17,18 @@ LIB_DEPENDS= libexif-gtk.so:graphics/libexif-gtk \
USES= gettext gmake gnome pathfix pkgconfig
USE_GNOME= gtk20 intltool
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --without-bonobo --without-gnome
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
-OPTIONS_DEFINE= DOCS GIMP GNOME
+OPTIONS_DEFINE= DOCS GIMP
OPTIONS_SUB= yes
GIMP_DESC= GIMP plugin support
GIMP_LIB_DEPENDS= libgimp-2.0.so:graphics/gimp
GIMP_CONFIGURE_WITH= gimp
-GNOME_USE= GNOME=gnomeprefix,libgnomeui
-GNOME_CONFIGURE_OFF= --without-bonobo --without-gnome
-GNOME_MAKE_ENV= GNOME_SUBDIRS="help omf-install"
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MGNOME}
-INSTALLS_OMF= yes
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|GIMP_VERSION="2.0"|GIMP_VERSION="2.2"|g ; \
s|images/gtkam|gtkam/images|g ; \
diff --git a/multimedia/dvdstyler/Makefile b/multimedia/dvdstyler/Makefile
index 50c6389c157e..5399fa1ca1a8 100644
--- a/multimedia/dvdstyler/Makefile
+++ b/multimedia/dvdstyler/Makefile
@@ -2,7 +2,7 @@
PORTNAME= dvdstyler
PORTVERSION= 3.1
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 2
CATEGORIES= multimedia
MASTER_SITES= SF
@@ -40,15 +40,12 @@ USE_WX= 3.0
WX_CONF_ARGS= absolute
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_path_AVCONV_PATH="" OBJCXX="${CXX}"
+CONFIGURE_ARG= --without-gnome
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS_DEFINE= DOCS GNOME
-
-GNOME_USES= gnome
-GNOME_USE= GNOME=libgnomeui
-GNOME_CONFIGURE_WITH= gnome
+OPTIONS_DEFINE= DOCS
.if defined(WITH_DVD_DEVICE)
DEFAULT_DVD_DEVICE=${WITH_DVD_DEVICE}
diff --git a/textproc/stardict3/Makefile b/textproc/stardict3/Makefile
index 90f1426c40a2..3a7e5ee8d957 100644
--- a/textproc/stardict3/Makefile
+++ b/textproc/stardict3/Makefile
@@ -2,7 +2,7 @@
PORTNAME= stardict
PORTVERSION= 3.0.6
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= textproc
MASTER_SITES= SF/stardict-4/${PORTVERSION}
DIST_SUBDIR= stardict
@@ -10,6 +10,9 @@ DIST_SUBDIR= stardict
MAINTAINER= makc@FreeBSD.org
COMMENT= Dictionary lookup program written in Gtk2
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= libsigc-2.0.so:devel/libsigc++20 \
libenchant.so:textproc/enchant
RUN_DEPENDS= xdg-open:devel/xdg-utils
@@ -20,21 +23,15 @@ CONFIGURE_ARGS= --disable-festival \
--disable-espeak \
--disable-tools \
--disable-updateinfo \
- --disable-advertisement
+ --disable-advertisement \
+ --disable-gnome-support \
+ --disable-schemas-install \
+ --disable-scrollkeeper
USES= compiler:c++11-lang gettext gmake gnome libtool localbase \
pathfix pkgconfig tar:bzip2
USE_CXXSTD= c++11
-USE_GNOME= intltool
-
-OPTIONS_DEFINE= GNOME
-OPTIONS_SUB= yes
-
-GNOME_USE= GNOME=gnomeprefix,gnomedocutils,libgnomeui
-GNOME_USE_OFF= GNOME=gtk20
-GNOME_CONFIGURE_ENABLE= gnome-support schemas-install scrollkeeper
-GNOME_VARS= GCONF_SCHEMAS=stardict.schemas \
- INSTALLS_OMF=yes
+USE_GNOME= intltool gtk20
post-patch:
@${REINPLACE_CMD} -e 's,/usr/share,${PREFIX}/share,g' \
@@ -43,8 +40,6 @@ post-patch:
-e '/as_fn_error.*gnome-doc-utils/d' \
-e '/DEP_MODULES=/s/"$$/ gmodule-2.0"/' \
${WRKSRC}/dict/configure
-
-post-patch-GNOME-off:
${REINPLACE_CMD} -e '/^SUBDIRS/s,help,,' ${WRKSRC}/dict/Makefile.in
.include <bsd.port.mk>
diff --git a/textproc/stardict3/pkg-plist b/textproc/stardict3/pkg-plist
index 1edeebc378c3..829ca58a83cc 100644
--- a/textproc/stardict3/pkg-plist
+++ b/textproc/stardict3/pkg-plist
@@ -9,109 +9,8 @@ lib/stardict/plugins/stardict_wiki_parsedata.so
lib/stardict/plugins/stardict_wordnet.so
lib/stardict/plugins/stardict_wordnet_parsedata.so
lib/stardict/plugins/stardict_xdxf_parsedata.so
-%%GNOME%%libdata/bonobo/servers/GNOME_Stardict.server
man/man1/stardict.1.gz
share/applications/stardict.desktop
-%%GNOME%%share/gnome/help/stardict/C/figures/acrobat_toolbar.png
-%%GNOME%%share/gnome/help/stardict/C/figures/portable_apps_menu.png
-%%GNOME%%share/gnome/help/stardict/C/figures/stardict_float_window.png
-%%GNOME%%share/gnome/help/stardict/C/figures/stardict_full_text_translation.png
-%%GNOME%%share/gnome/help/stardict/C/figures/stardict_main_window.png
-%%GNOME%%share/gnome/help/stardict/C/figures/stardict_manage_dicts_add_dict.png
-%%GNOME%%share/gnome/help/stardict/C/figures/stardict_manage_dicts_dict_list.png
-%%GNOME%%share/gnome/help/stardict/C/figures/stardict_manage_dicts_manage_dict.png
-%%GNOME%%share/gnome/help/stardict/C/figures/stardict_manage_dicts_network_dicts.png
-%%GNOME%%share/gnome/help/stardict/C/figures/stardict_manage_dicts_network_dicts_browse.png
-%%GNOME%%share/gnome/help/stardict/C/figures/stardict_manage_dicts_tree_dict.png
-%%GNOME%%share/gnome/help/stardict/C/figures/stardict_notification_area.png
-%%GNOME%%share/gnome/help/stardict/C/figures/stardict_windows_console.png
-%%GNOME%%share/gnome/help/stardict/C/legal.xml
-%%GNOME%%share/gnome/help/stardict/C/stardict.xml
-%%GNOME%%share/gnome/help/stardict/mk/figures/acrobat_toolbar.png
-%%GNOME%%share/gnome/help/stardict/mk/figures/portable_apps_menu.png
-%%GNOME%%share/gnome/help/stardict/mk/figures/stardict_float_window.png
-%%GNOME%%share/gnome/help/stardict/mk/figures/stardict_full_text_translation.png
-%%GNOME%%share/gnome/help/stardict/mk/figures/stardict_main_window.png
-%%GNOME%%share/gnome/help/stardict/mk/figures/stardict_manage_dicts_add_dict.png
-%%GNOME%%share/gnome/help/stardict/mk/figures/stardict_manage_dicts_dict_list.png
-%%GNOME%%share/gnome/help/stardict/mk/figures/stardict_manage_dicts_manage_dict.png
-%%GNOME%%share/gnome/help/stardict/mk/figures/stardict_manage_dicts_network_dicts.png
-%%GNOME%%share/gnome/help/stardict/mk/figures/stardict_manage_dicts_network_dicts_browse.png
-%%GNOME%%share/gnome/help/stardict/mk/figures/stardict_manage_dicts_tree_dict.png
-%%GNOME%%share/gnome/help/stardict/mk/figures/stardict_notification_area.png
-%%GNOME%%share/gnome/help/stardict/mk/figures/stardict_windows_console.png
-%%GNOME%%share/gnome/help/stardict/mk/stardict.xml
-%%GNOME%%share/gnome/help/stardict/nl/figures/acrobat_toolbar.png
-%%GNOME%%share/gnome/help/stardict/nl/figures/portable_apps_menu.png
-%%GNOME%%share/gnome/help/stardict/nl/figures/stardict_float_window.png
-%%GNOME%%share/gnome/help/stardict/nl/figures/stardict_full_text_translation.png
-%%GNOME%%share/gnome/help/stardict/nl/figures/stardict_main_window.png
-%%GNOME%%share/gnome/help/stardict/nl/figures/stardict_manage_dicts_add_dict.png
-%%GNOME%%share/gnome/help/stardict/nl/figures/stardict_manage_dicts_dict_list.png
-%%GNOME%%share/gnome/help/stardict/nl/figures/stardict_manage_dicts_manage_dict.png
-%%GNOME%%share/gnome/help/stardict/nl/figures/stardict_manage_dicts_network_dicts.png
-%%GNOME%%share/gnome/help/stardict/nl/figures/stardict_manage_dicts_network_dicts_browse.png
-%%GNOME%%share/gnome/help/stardict/nl/figures/stardict_manage_dicts_tree_dict.png
-%%GNOME%%share/gnome/help/stardict/nl/figures/stardict_notification_area.png
-%%GNOME%%share/gnome/help/stardict/nl/figures/stardict_windows_console.png
-%%GNOME%%share/gnome/help/stardict/nl/stardict.xml
-%%GNOME%%share/gnome/help/stardict/ru/figures/acrobat_toolbar.png
-%%GNOME%%share/gnome/help/stardict/ru/figures/portable_apps_menu.png
-%%GNOME%%share/gnome/help/stardict/ru/figures/stardict_float_window.png
-%%GNOME%%share/gnome/help/stardict/ru/figures/stardict_full_text_translation.png
-%%GNOME%%share/gnome/help/stardict/ru/figures/stardict_main_window.png
-%%GNOME%%share/gnome/help/stardict/ru/figures/stardict_manage_dicts_add_dict.png
-%%GNOME%%share/gnome/help/stardict/ru/figures/stardict_manage_dicts_dict_list.png
-%%GNOME%%share/gnome/help/stardict/ru/figures/stardict_manage_dicts_manage_dict.png
-%%GNOME%%share/gnome/help/stardict/ru/figures/stardict_manage_dicts_network_dicts.png
-%%GNOME%%share/gnome/help/stardict/ru/figures/stardict_manage_dicts_network_dicts_browse.png
-%%GNOME%%share/gnome/help/stardict/ru/figures/stardict_manage_dicts_tree_dict.png
-%%GNOME%%share/gnome/help/stardict/ru/figures/stardict_notification_area.png
-%%GNOME%%share/gnome/help/stardict/ru/figures/stardict_windows_console.png
-%%GNOME%%share/gnome/help/stardict/ru/stardict.xml
-%%GNOME%%share/gnome/help/stardict/uk/figures/acrobat_toolbar.png
-%%GNOME%%share/gnome/help/stardict/uk/figures/portable_apps_menu.png
-%%GNOME%%share/gnome/help/stardict/uk/figures/stardict_float_window.png
-%%GNOME%%share/gnome/help/stardict/uk/figures/stardict_full_text_translation.png
-%%GNOME%%share/gnome/help/stardict/uk/figures/stardict_main_window.png
-%%GNOME%%share/gnome/help/stardict/uk/figures/stardict_manage_dicts_add_dict.png
-%%GNOME%%share/gnome/help/stardict/uk/figures/stardict_manage_dicts_dict_list.png
-%%GNOME%%share/gnome/help/stardict/uk/figures/stardict_manage_dicts_manage_dict.png
-%%GNOME%%share/gnome/help/stardict/uk/figures/stardict_manage_dicts_network_dicts.png
-%%GNOME%%share/gnome/help/stardict/uk/figures/stardict_manage_dicts_network_dicts_browse.png
-%%GNOME%%share/gnome/help/stardict/uk/figures/stardict_manage_dicts_tree_dict.png
-%%GNOME%%share/gnome/help/stardict/uk/figures/stardict_notification_area.png
-%%GNOME%%share/gnome/help/stardict/uk/figures/stardict_windows_console.png
-%%GNOME%%share/gnome/help/stardict/uk/stardict.xml
-%%GNOME%%share/gnome/help/stardict/zh_CN/figures/acrobat_toolbar.png
-%%GNOME%%share/gnome/help/stardict/zh_CN/figures/portable_apps_menu.png
-%%GNOME%%share/gnome/help/stardict/zh_CN/figures/stardict_float_window.png
-%%GNOME%%share/gnome/help/stardict/zh_CN/figures/stardict_full_text_translation.png
-%%GNOME%%share/gnome/help/stardict/zh_CN/figures/stardict_main_window.png
-%%GNOME%%share/gnome/help/stardict/zh_CN/figures/stardict_manage_dicts_add_dict.png
-%%GNOME%%share/gnome/help/stardict/zh_CN/figures/stardict_manage_dicts_dict_list.png
-%%GNOME%%share/gnome/help/stardict/zh_CN/figures/stardict_manage_dicts_manage_dict.png
-%%GNOME%%share/gnome/help/stardict/zh_CN/figures/stardict_manage_dicts_network_dicts.png
-%%GNOME%%share/gnome/help/stardict/zh_CN/figures/stardict_manage_dicts_network_dicts_browse.png
-%%GNOME%%share/gnome/help/stardict/zh_CN/figures/stardict_manage_dicts_tree_dict.png
-%%GNOME%%share/gnome/help/stardict/zh_CN/figures/stardict_notification_area.png
-%%GNOME%%share/gnome/help/stardict/zh_CN/figures/stardict_windows_console.png
-%%GNOME%%share/gnome/help/stardict/zh_CN/stardict.xml
-%%GNOME%%share/gnome/help/stardict/zh_TW/figures/acrobat_toolbar.png
-%%GNOME%%share/gnome/help/stardict/zh_TW/figures/portable_apps_menu.png
-%%GNOME%%share/gnome/help/stardict/zh_TW/figures/stardict_float_window.png
-%%GNOME%%share/gnome/help/stardict/zh_TW/figures/stardict_full_text_translation.png
-%%GNOME%%share/gnome/help/stardict/zh_TW/figures/stardict_main_window.png
-%%GNOME%%share/gnome/help/stardict/zh_TW/figures/stardict_manage_dicts_add_dict.png
-%%GNOME%%share/gnome/help/stardict/zh_TW/figures/stardict_manage_dicts_dict_list.png
-%%GNOME%%share/gnome/help/stardict/zh_TW/figures/stardict_manage_dicts_manage_dict.png
-%%GNOME%%share/gnome/help/stardict/zh_TW/figures/stardict_manage_dicts_network_dicts.png
-%%GNOME%%share/gnome/help/stardict/zh_TW/figures/stardict_manage_dicts_network_dicts_browse.png
-%%GNOME%%share/gnome/help/stardict/zh_TW/figures/stardict_manage_dicts_tree_dict.png
-%%GNOME%%share/gnome/help/stardict/zh_TW/figures/stardict_notification_area.png
-%%GNOME%%share/gnome/help/stardict/zh_TW/figures/stardict_windows_console.png
-%%GNOME%%share/gnome/help/stardict/zh_TW/stardict.xml
-%%GNOME%%share/idl/GNOME_Stardict.idl
share/locale/ar/LC_MESSAGES/stardict.mo
share/locale/be/LC_MESSAGES/stardict.mo
share/locale/cs/LC_MESSAGES/stardict.mo
@@ -138,13 +37,6 @@ share/locale/uk/LC_MESSAGES/stardict.mo
share/locale/vi/LC_MESSAGES/stardict.mo
share/locale/zh_CN/LC_MESSAGES/stardict.mo
share/locale/zh_TW/LC_MESSAGES/stardict.mo
-%%GNOME%%share/omf/stardict/stardict-C.omf
-%%GNOME%%share/omf/stardict/stardict-mk.omf
-%%GNOME%%share/omf/stardict/stardict-nl.omf
-%%GNOME%%share/omf/stardict/stardict-ru.omf
-%%GNOME%%share/omf/stardict/stardict-uk.omf
-%%GNOME%%share/omf/stardict/stardict-zh_CN.omf
-%%GNOME%%share/omf/stardict/stardict-zh_TW.omf
share/pixmaps/stardict.png
share/stardict/dic/stardict-dict/res/huzheng.png
share/stardict/dic/stardict-dict/res/huzheng_redhat.png
diff --git a/x11-toolkits/guile-gnome-platform/Makefile b/x11-toolkits/guile-gnome-platform/Makefile
index d66144b947a1..5f76536b8a5e 100644
--- a/x11-toolkits/guile-gnome-platform/Makefile
+++ b/x11-toolkits/guile-gnome-platform/Makefile
@@ -1,5 +1,6 @@
PORTNAME= guile-gnome-platform
DISTVERSION= 2.16.5
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= GNU/guile-gnome/${PORTNAME}
@@ -14,7 +15,7 @@ LIB_DEPENDS= libguile-2.2.so:lang/guile2 \
libgwrap-guile-runtime.so:devel/g-wrap \
libffi.so:devel/libffi
-# A note on flavors: LIBGNOMEUI, LIBGNOME, GCONF pull in very long
+# A note on flavors: LIBGNOME, GCONF pull in very long
# dependency lists including things like spidermonkey and samba, which
# is rather overkill if you just want to do GUI tools. So make "lite"
# the default.
@@ -41,11 +42,11 @@ DATADIR= ${PREFIX}/share/guile-gnome-2
INFO= guile-gnome-glib guile-gnome-gobject
-OPTIONS_DEFINE= ATK CAIRO CANVAS GCONF GLADE GTK2 LIBGNOME LIBGNOMEUI PANGO
+OPTIONS_DEFINE= ATK CAIRO CANVAS GCONF GLADE GTK2 LIBGNOME PANGO
OPTIONS_DEFAULT=ATK CAIRO CANVAS GLADE GTK2 PANGO
.if ${FLAVOR} == full
-OPTIONS_SLAVE= ATK CAIRO CANVAS GCONF GLADE GTK2 LIBGNOME LIBGNOMEUI PANGO
+OPTIONS_SLAVE= ATK CAIRO CANVAS GCONF GLADE GTK2 LIBGNOME PANGO
.endif
OPTIONS_SUB= yes
@@ -53,7 +54,6 @@ OPTIONS_SUB= yes
# other options have descriptions provided by ports/Mk/*
ATK_DESC= GNOME accessibility toolkit (ATK)
CANVAS_DESC= GNOMECanvas Graphics library
-LIBGNOMEUI_DESC=libgnomeui support
LIBGNOME_DESC= libgnome support
ATK_USE= gnome=atk
@@ -89,15 +89,6 @@ GTK2_USE= gnome=gtk20,gdkpixbuf2
GTK2_CONFIGURE_WITH= gtk pixbuf
GTK2_INFO= guile-gnome-gtk guile-gnome-gdk
-LIBGNOMEUI_IMPLIES= LIBGNOME GTK2 CAIRO
-# libgnomeui's pkgconf brings in libSM and libICE from xorg, but for
-# some reason Uses/gnome doesn't account for this, so we arrange for
-# USES=xorg and USE_XORG=sm,ice
-LIBGNOMEUI_USES= xorg
-LIBGNOMEUI_USE= gnome=libgnomeui xorg=sm,ice
-LIBGNOMEUI_CONFIGURE_WITH=libgnomeui
-LIBGNOMEUI_INFO= guile-gnome-libgnomeui
-
# This dependency is brought in from libgnome's pkgconf, but
# not accounted for by Uses/gnome
LIBGNOME_LIB_DEPENDS= libpopt.so:devel/popt