aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-11-27 10:23:46 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-11-27 10:30:09 +0000
commitc3bd59faafb0cfcbe50fe735b7347e2ac55c97d9 (patch)
treedaad4f66f6179e7940de429e0721bba4903fa8f0
parentdbe851cc291bde43def88e727615619c64c2117c (diff)
downloadports-c3bd59faafb0cfcbe50fe735b7347e2ac55c97d9.tar.gz
ports-c3bd59faafb0cfcbe50fe735b7347e2ac55c97d9.zip
devel/cunit: Remove AUTOMATED, BASIC, CONSOLE, CURSES, DEBUG, MEMTRACE and TEST options
PR: 275076 Reported by: amdmi3
-rw-r--r--devel/cunit/Makefile27
-rw-r--r--devel/cunit/pkg-plist8
2 files changed, 9 insertions, 26 deletions
diff --git a/devel/cunit/Makefile b/devel/cunit/Makefile
index d9ec3b4e969f..b9f58167cf9d 100644
--- a/devel/cunit/Makefile
+++ b/devel/cunit/Makefile
@@ -12,10 +12,12 @@ WWW= https://cunit.sourceforge.net/
LICENSE= LGPL20
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= autoreconf gmake libtool pathfix tar:bzip2
+USES= autoreconf gmake libtool ncurses pathfix tar:bzip2
+CONFIGURE_ARGS= --enable-automated --enable-basic --enable-console --enable-curses --enable-debug --enable-memtrace --enable-test
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
+LDFLAGS+= -lncurses
TEST_TARGET= check
USE_LDCONFIG= yes
@@ -25,28 +27,9 @@ EXAMPLESDIR= ${PREFIX}/share/examples/CUnit
CONFLICTS_INSTALL= c-unit
-OPTIONS_DEFINE= AUTOMATED BASIC CONSOLE CURSES DEBUG DOCS EXAMPLES MEMTRACE TEST
-OPTIONS_DEFAULT=AUTOMATED BASIC CONSOLE CURSES DEBUG MEMTRACE TEST
-OPTIONS_SUB= yes
-AUTOMATED_DESC= Automated (XML) interface
-BASIC_DESC= Basic interface
-CONSOLE_DESC= Console interface
-CURSES_DESC= Curses interface
-DEBUG_DESC= Debug interface
-EXAMPLES_DESC= Example programs
-MEMTRACE_DESC= Internal memory tracking
-TEST_DESC= Internal test program
-
-AUTOMATED_CONFIGURE_ENABLE= automated
-BASIC_CONFIGURE_ENABLE= basic
-CONSOLE_CONFIGURE_ENABLE= console
-CURSES_CONFIGURE_ENABLE=curses
-CURSES_LDFLAGS= -lncurses
-CURSES_USES= ncurses
-DEBUG_CONFIGURE_ENABLE= debug
+OPTIONS_DEFINE= DOCS EXAMPLES
+
EXAMPLES_CONFIGURE_ENABLE= examples
-MEMTRACE_CONFIGURE_ENABLE= memtrace
-TEST_CONFIGURE_ENABLE= test
post-patch:
@${REINPLACE_CMD} -e 's|/doc/@PACKAGE@|/share/doc/@PACKAGE@|g' ${WRKSRC}/doc/Makefile.am ${WRKSRC}/doc/headers/Makefile.am
diff --git a/devel/cunit/pkg-plist b/devel/cunit/pkg-plist
index 2d352ece866c..9455c2703d17 100644
--- a/devel/cunit/pkg-plist
+++ b/devel/cunit/pkg-plist
@@ -1,10 +1,10 @@
-%%AUTOMATED%%include/CUnit/Automated.h
-%%BASIC%%include/CUnit/Basic.h
-%%CURSES%%include/CUnit/CUCurses.h
+include/CUnit/Automated.h
+include/CUnit/Basic.h
+include/CUnit/CUCurses.h
include/CUnit/CUError.h
include/CUnit/CUnit.h
include/CUnit/CUnit_intl.h
-%%CONSOLE%%include/CUnit/Console.h
+include/CUnit/Console.h
include/CUnit/MyMem.h
include/CUnit/TestDB.h
include/CUnit/TestRun.h