aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-09-26 16:26:17 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-09-26 16:26:17 +0000
commitc4918b7203d0ab9300669891311f528eeab84491 (patch)
tree6973dc5f550dc1d8e41c9ef27d0ed409c8c1dddb
parente9e533c79f2193c24b33e50ac2517cf65ec1ed6a (diff)
downloadports-c4918b7203d0ab9300669891311f528eeab84491.tar.gz
ports-c4918b7203d0ab9300669891311f528eeab84491.zip
- Fix on CURRENT [1]
- Support STAGEDIR - Fix up CFLAGS Reported by: pkg-fallout
Notes
Notes: svn path=/head/; revision=328376
-rw-r--r--cad/meshdev/Makefile5
-rw-r--r--cad/meshdev/files/patch-build_Makefile.release.gcc15
-rw-r--r--cad/meshdev/files/patch-src_MeshDev.h10
3 files changed, 23 insertions, 7 deletions
diff --git a/cad/meshdev/Makefile b/cad/meshdev/Makefile
index 51c7537525dc..e898030efaf7 100644
--- a/cad/meshdev/Makefile
+++ b/cad/meshdev/Makefile
@@ -10,6 +10,8 @@ MASTER_SITES= ${MASTER_SITE_LOCAL}/gahr/ \
MAINTAINER= gahr@FreeBSD.org
COMMENT= A mesh comparison software
+USE_DOS2UNIX= src/MeshDev.h
+
BUILD_WRKSRC= ${WRKSRC}/build
INSTALL_WRKSRC= ${WRKSRC}/bin
@@ -17,8 +19,7 @@ MAKEFILE= Makefile.release.gcc
PLIST_FILES= bin/${PORTNAME}
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/cad/meshdev/files/patch-build_Makefile.release.gcc b/cad/meshdev/files/patch-build_Makefile.release.gcc
index 0e69947fc7c2..ae80852fee8a 100644
--- a/cad/meshdev/files/patch-build_Makefile.release.gcc
+++ b/cad/meshdev/files/patch-build_Makefile.release.gcc
@@ -1,13 +1,18 @@
---- build/Makefile.release.gcc.orig 2012-02-06 16:12:55.000000000 +0100
-+++ build/Makefile.release.gcc 2012-02-06 16:13:07.000000000 +0100
-@@ -2,7 +2,7 @@
+--- build/Makefile.release.gcc.orig 2012-02-06 14:04:02.000000000 +0100
++++ build/Makefile.release.gcc 2013-09-26 17:53:17.000000000 +0200
+@@ -1,10 +1,10 @@
+ # Project: MeshDev
# Makefile created by Michaël Roy
- CXX = g++
+-CXX = g++
-OBJ = tmp/Deviation.o tmp/FileVrml1.o tmp/FileVrml2.o tmp/Mesh.o tmp/MeshDev.o tmp/Neighborhood.o tmp/Sample.o tmp/UniformGrid.o
++CXX ?= g++
+OBJ = tmp/Deviation.o tmp/FileVrml1.o tmp/FileVrml2.o tmp/FileSTL.o tmp/Mesh.o tmp/MeshDev.o tmp/Neighborhood.o tmp/Sample.o tmp/UniformGrid.o
BIN = ../bin/meshdev
- CFLAGS += -DNDEBUG -Wall -W -ansi -pedantic -s -O2
+-CFLAGS += -DNDEBUG -Wall -W -ansi -pedantic -s -O2
++CFLAGS += -DNDEBUG -Wall -W -pedantic
+
+ .PHONY: all clean
@@ -25,6 +25,9 @@
tmp/FileVrml2.o: ../src/FileVrml2.cpp
diff --git a/cad/meshdev/files/patch-src_MeshDev.h b/cad/meshdev/files/patch-src_MeshDev.h
new file mode 100644
index 000000000000..41d1f9491fbc
--- /dev/null
+++ b/cad/meshdev/files/patch-src_MeshDev.h
@@ -0,0 +1,10 @@
+--- src/MeshDev.h.orig 2013-09-26 18:00:27.000000000 +0200
++++ src/MeshDev.h 2013-09-26 18:00:43.000000000 +0200
+@@ -30,7 +30,6 @@
+ // C Standard Library
+ #include <math.h> // sqrt, ceil
+ #include <stdlib.h> // EXIT_SUCCESS, EXIT_FAILURE
+-#include <sys/timeb.h> // timeb, ftime
+ #include <time.h> // time
+
+ // Use C++ Standard Library namespace