aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2022-12-17 21:16:33 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2022-12-17 23:10:33 +0000
commitc49f3491b8e2ca2bbe2fd32f6ccfb0818a0ab9d6 (patch)
treece8b6c6e0be3fabf0e7d0acca83719bd0033364e
parentf815d3802109d816bef09333a201e0b88dfcd0d2 (diff)
downloadports-c49f3491b8e2ca2bbe2fd32f6ccfb0818a0ab9d6.tar.gz
ports-c49f3491b8e2ca2bbe2fd32f6ccfb0818a0ab9d6.zip
databases/xtrabackup: fix llvm version at 10 explicitely
In the previous commit [1] in 2021, clang was locked at 10: Compilation of the embedded mysql server fail with clang 11, use clang 10 as workaround (same as databases/mysql57-server do). As LLVM_DEFAULT will now be higher than 10, explicitely depend on 10. Note: USES=llvm:max=10 would be the preferable solution for this usecase, however, llvm.mk cannot be used after bsd.options.mk at the moment. [1] 106d01226d33ce7f76ca480bb9d9598a3b711b60 PR: 263456
-rw-r--r--databases/xtrabackup/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/databases/xtrabackup/Makefile b/databases/xtrabackup/Makefile
index 5223551c9a3c..b984c86c2282 100644
--- a/databases/xtrabackup/Makefile
+++ b/databases/xtrabackup/Makefile
@@ -48,9 +48,10 @@ PLIST_FILES= bin/xtrabackup bin/xbstream bin/innobackupex bin/xbcrypt \
# a backport of amongst other tings:
# https://github.com/mysql/mysql-server/commit/08f46b3c00ee70e7ed7825daeb91df2289f80f50
.if ${CHOSEN_COMPILER_TYPE} == clang && ${OPSYS} == FreeBSD && ${OSVERSION} >= 1300109
-BUILD_DEPENDS+= clang${LLVM_DEFAULT}:devel/llvm${LLVM_DEFAULT}
-CC= ${LOCALBASE}/bin/clang${LLVM_DEFAULT}
-CXX= ${LOCALBASE}/bin/clang++${LLVM_DEFAULT}
+_LLVM_VERSION= 10
+BUILD_DEPENDS+= clang${_LLVM_VERSION}:devel/llvm${_LLVM_VERSION}
+CC= ${LOCALBASE}/bin/clang${_LLVM_VERSION}
+CXX= ${LOCALBASE}/bin/clang++${_LLVM_VERSION}
.endif
# Not sure why it's trying to install mysql client libraries now