aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2022-11-18 21:27:00 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2022-11-18 21:27:52 +0000
commitc4acd5432a124ed947a8a31e480aa2ce98c2e6e3 (patch)
tree82b469b6958b0472a5341c3b4cd392a482203aa6
parente179401ac53f02bd27e2307a3c786957a9dec4c4 (diff)
downloadports-c4acd5432a124ed947a8a31e480aa2ce98c2e6e3.tar.gz
ports-c4acd5432a124ed947a8a31e480aa2ce98c2e6e3.zip
net/go-tcping: Add new port
A cross-platform ping program for TCP ports. This program will send TCP probes to an IP address or a hostname specified by you and prints the result. It works with both IPv4 and IPv6.
-rw-r--r--net/Makefile1
-rw-r--r--net/go-tcping/Makefile27
-rw-r--r--net/go-tcping/distinfo7
-rw-r--r--net/go-tcping/pkg-descr5
4 files changed, 40 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index bcfc9d5d68e7..7ba7eca16610 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -199,6 +199,7 @@
SUBDIR += gnu-radius
SUBDIR += go-bapu
SUBDIR += go-cs
+ SUBDIR += go-tcping
SUBDIR += gobgp
SUBDIR += gofish
SUBDIR += google-cloud-sdk
diff --git a/net/go-tcping/Makefile b/net/go-tcping/Makefile
new file mode 100644
index 000000000000..d0aeb5f25c79
--- /dev/null
+++ b/net/go-tcping/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= tcping
+PORTVERSION= 1.12.1
+DISTVERSIONPREFIX= v
+CATEGORIES= net
+PKGNAMEPREFIX= go-
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Command-line utility to ping TCP ports written in Go
+WWW= https://github.com/pouriyajamshidi/tcping
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+
+USE_GITHUB= yes
+GH_ACCOUNT= pouriyajamshidi
+
+GO_MODULE= github.com/${GH_ACCOUNT}/${PORTNAME}
+
+PLIST_FILES= bin/gotcping
+
+post-install:
+ @${MV} ${STAGEDIR}${PREFIX}/bin/${PORTNAME} \
+ ${STAGEDIR}${PREFIX}/bin/gotcping
+
+.include <bsd.port.mk>
diff --git a/net/go-tcping/distinfo b/net/go-tcping/distinfo
new file mode 100644
index 000000000000..353767a734cb
--- /dev/null
+++ b/net/go-tcping/distinfo
@@ -0,0 +1,7 @@
+TIMESTAMP = 1668804820
+SHA256 (go/net_go-tcping/pouriyajamshidi-tcping-v1.12.1_GH0/v1.12.1.mod) = e76f9bebf53afdcc0b584046625c31bc698b823c60562132c83944594c6723ee
+SIZE (go/net_go-tcping/pouriyajamshidi-tcping-v1.12.1_GH0/v1.12.1.mod) = 576
+SHA256 (go/net_go-tcping/pouriyajamshidi-tcping-v1.12.1_GH0/v1.12.1.zip) = 470c6716bc0b4e6857d149a1af9964916c0115d31435eabc397a7c40ceceb555
+SIZE (go/net_go-tcping/pouriyajamshidi-tcping-v1.12.1_GH0/v1.12.1.zip) = 2283322
+SHA256 (go/net_go-tcping/pouriyajamshidi-tcping-v1.12.1_GH0/pouriyajamshidi-tcping-v1.12.1_GH0.tar.gz) = 66b8817dab6b3a910fe24c20e1a2d795f6a53ce1a16c265ce62ce53d8d6d0586
+SIZE (go/net_go-tcping/pouriyajamshidi-tcping-v1.12.1_GH0/pouriyajamshidi-tcping-v1.12.1_GH0.tar.gz) = 2275891
diff --git a/net/go-tcping/pkg-descr b/net/go-tcping/pkg-descr
new file mode 100644
index 000000000000..3971dee3eb40
--- /dev/null
+++ b/net/go-tcping/pkg-descr
@@ -0,0 +1,5 @@
+A cross-platform ping program for TCP ports.
+
+This program will send TCP probes to an IP address or a hostname
+specified by you and prints the result. It works with both IPv4 and
+IPv6.