aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-12-31 03:51:54 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-12-31 03:51:54 +0000
commitc4c1f581ad10f323ab1cafd7d2de4eb9a2de9190 (patch)
tree68cf1688a268846188f2937f058332306d188f2f
parentf273887cfe2341c4af9df98bd4cb24f78bcf95e1 (diff)
downloadports-c4c1f581ad10f323ab1cafd7d2de4eb9a2de9190.tar.gz
ports-c4c1f581ad10f323ab1cafd7d2de4eb9a2de9190.zip
games/species: Refactor after wxgtk28 removal
- Pet portclippy - Generate makepatch compatible patches
-rw-r--r--games/species/Makefile18
-rw-r--r--games/species/files/patch-Makefile4
-rw-r--r--games/species/files/patch-main.cpp4
3 files changed, 11 insertions, 15 deletions
diff --git a/games/species/Makefile b/games/species/Makefile
index 0a2ec36f6899..37b5d4e97461 100644
--- a/games/species/Makefile
+++ b/games/species/Makefile
@@ -12,21 +12,17 @@ WWW= http://redcoder.sourceforge.net/?p=species
LICENSE= GPLv1+ # though COPYING files mention LGPL21 and GPLv2 instead
USES= gmake dos2unix tar:bzip2
+
WRKSRC= ${WRKDIR}/${PORTNAME}
OPTIONS_DEFINE= VISITOOL
-VISITOOL_DESC= Build GUI tool for displaying evolution
-
OPTIONS_SUB= yes
-VISITOOL_USE= WX=2.4
-VISITOOL_ALL_TARGET= all visitool
-
-.include <bsd.port.options.mk>
+VISITOOL_DESC= Build GUI tool for displaying evolution
-.if empty(PORT_OPTIONS:MVISITOOL)
-MAKE_ENV+= WX_CONFIG="${TRUE}"
-.endif
+VISITOOL_USE= WX=3.0
+VISITOOL_MAKE_ENV= WX_CONFIG="${TRUE}"
+VISITOOL_ALL_TARGET= all visitool
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
@@ -35,8 +31,8 @@ do-install:
.for i in bench evolver_hill wilfiz
@(cd ${WRKSRC} && ${COPYTREE_SHARE} ${i} ${STAGEDIR}${DATADIR})
.endfor
-.if ${PORT_OPTIONS:MVISITOOL}
+
+do-install-VISITOOL-on:
${INSTALL_PROGRAM} ${WRKSRC}/visitool ${STAGEDIR}${PREFIX}/bin/${PORTNAME}-visitool
-.endif
.include <bsd.port.mk>
diff --git a/games/species/files/patch-Makefile b/games/species/files/patch-Makefile
index c98c0f58487f..ad8c0cc8fdfb 100644
--- a/games/species/files/patch-Makefile
+++ b/games/species/files/patch-Makefile
@@ -1,5 +1,5 @@
---- ./Makefile.orig Sun Feb 22 03:54:24 2004
-+++ ./Makefile Wed Jan 16 18:29:09 2008
+--- Makefile.orig 2022-12-31 03:50:49 UTC
++++ Makefile
@@ -1,22 +1,22 @@
# makefile for species
diff --git a/games/species/files/patch-main.cpp b/games/species/files/patch-main.cpp
index 8b3059f0dafc..a8294c8847da 100644
--- a/games/species/files/patch-main.cpp
+++ b/games/species/files/patch-main.cpp
@@ -1,6 +1,6 @@
---- main.cpp.orig
+--- main.cpp.orig 2022-12-31 03:50:49 UTC
+++ main.cpp
-@@ -29,7 +29,7 @@
+@@ -29,7 +29,7 @@ using namespace std;
/***** main program entry point ********************/