aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-11-23 10:02:04 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-11-23 10:02:04 +0000
commitc50013f8cb95a8565d80174103ac16b1eeeb8c1b (patch)
tree4b261aa6af46cf2011aac6d7042fe29a666ac2da
parent59400fdd78739456ad559ef7b9c7baa97edcd6ce (diff)
downloadports-c50013f8cb95a8565d80174103ac16b1eeeb8c1b.tar.gz
ports-c50013f8cb95a8565d80174103ac16b1eeeb8c1b.zip
- Bump PORTREVISION for pkg-plist change, LICENSE adding
- Add license - Simplify DOCS installation handling - Add OPTIONS_SUB - Simplify Option NLS handling - Add symlink for the icon and add Desktop entry file - Change WWW - Recreate pkg-plist with make makeplist PR: 177333 Submitted by: nemysis (self) Approved by: maintainer timeout (2 months)
Notes
Notes: svn path=/head/; revision=373138
-rw-r--r--games/ceferino/Makefile30
-rw-r--r--games/ceferino/pkg-descr2
-rw-r--r--games/ceferino/pkg-plist48
3 files changed, 38 insertions, 42 deletions
diff --git a/games/ceferino/Makefile b/games/ceferino/Makefile
index 7ed11c406e32..09d4e109d602 100644
--- a/games/ceferino/Makefile
+++ b/games/ceferino/Makefile
@@ -3,13 +3,15 @@
PORTNAME= ceferino
PORTVERSION= 0.97.8
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= games
MASTER_SITES= http://www.losersjuegos.com.ar/_media/juegos/ceferino/descargas/
MAINTAINER= acm@FreeBSD.org
COMMENT= Game similar to Super Pang
+LICENSE= GPLv2
+
USE_SDL= sdl mixer image
GNU_CONFIGURE= yes
USES= gmake
@@ -18,18 +20,17 @@ LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD}
CEFEDIRS= ima music levels sounds
+PORTDOCS= AUTHORS ChangeLog README
OPTIONS_DEFINE= NLS DOCS
+OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-FLAG_NLS= true
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
+DESKTOP_ENTRIES="Don Ceferino HazaƱa" "" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" ""
+
+.include <bsd.port.options.mk>
post-extract:
@${REINPLACE_CMD} -e 's/-lSDL /`sdl-config --libs`/g' ${WRKSRC}/configure
@@ -43,14 +44,17 @@ do-install:
@cd ${WRKSRC}/data && \
${FIND} ${CEFEDIRS} -type d -exec ${MKDIR} "${STAGEDIR}${DATADIR}/{}" \; && \
${FIND} -E ${CEFEDIRS} -type f -iregex ".*\.(png|jpg|xm|map|wav)" -exec ${INSTALL_DATA} "{}" "${STAGEDIR}${DATADIR}/{}" \;
-.if defined(FLAG_NLS)
+ ${LN} -sf ${DATADIR}/ima/icono.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
+
+.if ${PORT_OPTIONS:MNLS}
.for f in es ca fr
${MKDIR} ${STAGEDIR}${PREFIX}/share/locale/${f}/LC_MESSAGES && \
${INSTALL_DATA} ${WRKSRC}/po/${f}.gmo ${STAGEDIR}${PREFIX}/share/locale/${f}/LC_MESSAGES/${PORTNAME}.mo
.endfor
.endif
+
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- @cd ${WRKSRC} && \
- ${INSTALL_DATA} AUTHORS ChangeLog README ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/games/ceferino/pkg-descr b/games/ceferino/pkg-descr
index b01b13e8d621..ef905a9ad04c 100644
--- a/games/ceferino/pkg-descr
+++ b/games/ceferino/pkg-descr
@@ -1,3 +1,3 @@
Ceferino is a fun game similar to super pang developed using the SDL library.
-WWW: http://www.losersjuegos.com.ar/
+WWW: http://www.losersjuegos.com.ar/juegos/ceferino
diff --git a/games/ceferino/pkg-plist b/games/ceferino/pkg-plist
index fc04e55f1391..1ab3b2d1574e 100644
--- a/games/ceferino/pkg-plist
+++ b/games/ceferino/pkg-plist
@@ -1,51 +1,45 @@
bin/ceferino
bin/ceferinoeditor
bin/ceferinosetup
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%NLS%%share/locale/ca/LC_MESSAGES/ceferino.mo
-%%NLS%%share/locale/es/LC_MESSAGES/ceferino.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/ceferino.mo
%%DATADIR%%/ima/barra.png
%%DATADIR%%/ima/cargando.png
%%DATADIR%%/ima/editor.png
+%%DATADIR%%/ima/final1.jpg
+%%DATADIR%%/ima/final2.jpg
+%%DATADIR%%/ima/final3.jpg
+%%DATADIR%%/ima/final4.jpg
+%%DATADIR%%/ima/final5.jpg
+%%DATADIR%%/ima/final6.jpg
+%%DATADIR%%/ima/fondo.jpg
+%%DATADIR%%/ima/fondos.jpg
+%%DATADIR%%/ima/fuente.png
%%DATADIR%%/ima/fuente1.png
%%DATADIR%%/ima/fuente2.png
-%%DATADIR%%/ima/fuente.png
+%%DATADIR%%/ima/fuente_2.png
%%DATADIR%%/ima/gaucho.png
%%DATADIR%%/ima/how_to_play.png
%%DATADIR%%/ima/icono.png
%%DATADIR%%/ima/items.png
%%DATADIR%%/ima/mate.png
+%%DATADIR%%/ima/menu.jpg
%%DATADIR%%/ima/niveles.png
%%DATADIR%%/ima/op_items.png
%%DATADIR%%/ima/pelota_1.png
%%DATADIR%%/ima/pelota_2.png
%%DATADIR%%/ima/pelota_3.png
%%DATADIR%%/ima/pelota_4.png
-%%DATADIR%%/ima/tiros.png
-%%DATADIR%%/ima/tit_1.png
-%%DATADIR%%/ima/tit_2.png
-%%DATADIR%%/ima/tit_3.png
-%%DATADIR%%/ima/final1.jpg
-%%DATADIR%%/ima/final2.jpg
-%%DATADIR%%/ima/final3.jpg
-%%DATADIR%%/ima/final4.jpg
-%%DATADIR%%/ima/final5.jpg
-%%DATADIR%%/ima/final6.jpg
-%%DATADIR%%/ima/fondo.jpg
-%%DATADIR%%/ima/fondos.jpg
-%%DATADIR%%/ima/menu.jpg
%%DATADIR%%/ima/pres_casa.jpg
%%DATADIR%%/ima/pres_lee.jpg
%%DATADIR%%/ima/pres_losers.jpg
%%DATADIR%%/ima/pres_rapto.jpg
%%DATADIR%%/ima/pres_sentado.jpg
%%DATADIR%%/ima/pres_vs.jpg
-%%DATADIR%%/ima/fuente_2.png
-%%DATADIR%%/music/menu.xm
+%%DATADIR%%/ima/tiros.png
+%%DATADIR%%/ima/tit_1.png
+%%DATADIR%%/ima/tit_2.png
+%%DATADIR%%/ima/tit_3.png
%%DATADIR%%/levels/base.map
+%%DATADIR%%/music/menu.xm
%%DATADIR%%/sounds/alarma.wav
%%DATADIR%%/sounds/boom.wav
%%DATADIR%%/sounds/explo.wav
@@ -59,9 +53,7 @@ bin/ceferinosetup
%%DATADIR%%/sounds/tic.wav
%%DATADIR%%/sounds/tiro.wav
%%DATADIR%%/sounds/toc.wav
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%DATADIR%%/ima
-@dirrm %%DATADIR%%/music
-@dirrm %%DATADIR%%/levels
-@dirrm %%DATADIR%%/sounds
-@dirrm %%DATADIR%%
+%%NLS%%share/locale/ca/LC_MESSAGES/ceferino.mo
+%%NLS%%share/locale/es/LC_MESSAGES/ceferino.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/ceferino.mo
+share/pixmaps/ceferino.png