aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-12-04 21:20:45 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-12-04 21:20:45 +0000
commitc53f4ec8dc009f623109648548fae9becb27c046 (patch)
tree473ae99815161fee6ee7a1b42e1d81d5d2cdd374
parentc2a36e97feb2bd14735ea86871bb8b9c6cd96837 (diff)
downloadports-c53f4ec8dc009f623109648548fae9becb27c046.tar.gz
ports-c53f4ec8dc009f623109648548fae9becb27c046.zip
science/InsightToolkit521: Broken on i386
Reported by: fallout
-rw-r--r--science/InsightToolkit521/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/science/InsightToolkit521/Makefile b/science/InsightToolkit521/Makefile
index 56a498b90369..28a004098c4f 100644
--- a/science/InsightToolkit521/Makefile
+++ b/science/InsightToolkit521/Makefile
@@ -13,6 +13,8 @@ WWW= https://www.itk.org
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_i386= compilation fails: always_inline function '_mm_cvtsd_si32' requires target feature 'sse2' (i386 doesn't have SSE2 enabled by default, and adding -msse2 doesn't help)
+
BUILD_DEPENDS= googletest>=0:devel/googletest
LIB_DEPENDS= libgdcmCommon.so:devel/gdcm \
libexpat.so:textproc/expat2 \
@@ -48,8 +50,6 @@ CMAKE_ARGS= -DPython3_EXECUTABLE=${PYTHON_CMD}
CMAKE_OFF= ITK_USE_KWSTYLE BUILD_TESTING
CMAKE_TESTING_ON= BUILD_TESTING # 3 tests are known to fail, see https://github.com/InsightSoftwareConsortium/ITK/issues/3739
-CXXFLAGS_i386= -msse2 # to fix this error: always_inline function '_mm_cvtsd_si32' requires target feature 'sse2' (i386 doesn't have SSE2 enabled by default)
-
ITK_VER= ${PORTVERSION:R}
PLIST_SUB+= ITK_VER=${ITK_VER}