aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-08-15 01:04:55 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-08-15 01:04:55 +0000
commitc54010f43433d6a46ee3d2484b4d98dbcecb24c0 (patch)
treec200c20995b53ca07f9f89992ecdeaf583596751
parent147fdee482ca1a335dcd09608f3b820a1dad2b40 (diff)
downloadports-c54010f43433d6a46ee3d2484b4d98dbcecb24c0.tar.gz
ports-c54010f43433d6a46ee3d2484b4d98dbcecb24c0.zip
- s,INSTALLS_SHLIB,USE_LDCONFIG,g
- these include security/ sysutils/ textproc/ maintained by ports@ PR: ports/101916 Submitted by: Gea-Suan Lin <gslin_AT_gslin dot org>
Notes
Notes: svn path=/head/; revision=170652
-rw-r--r--ports-mgmt/portmanager/Makefile2
-rw-r--r--security/beecrypt/Makefile2
-rw-r--r--security/cracklib/Makefile2
-rw-r--r--security/cyrus-sasl/Makefile2
-rw-r--r--security/gss/Makefile2
-rw-r--r--security/heimdal/Makefile2
-rw-r--r--security/ifd-devkit/Makefile2
-rw-r--r--security/ifd-gpr400/Makefile2
-rw-r--r--security/krb4/Makefile2
-rw-r--r--security/libecc/Makefile2
-rw-r--r--security/libident/Makefile2
-rw-r--r--security/libmcrypt/Makefile2
-rw-r--r--security/libntlm/Makefile2
-rw-r--r--security/libotr/Makefile2
-rw-r--r--security/libsectok/Makefile2
-rw-r--r--security/newpki-lib/Makefile2
-rw-r--r--security/pam_smb/Makefile2
-rw-r--r--security/sectok/Makefile2
-rw-r--r--security/shishi/Makefile2
-rw-r--r--sysutils/LPRng/Makefile2
-rw-r--r--sysutils/LPRngTool/Makefile2
-rw-r--r--sysutils/am-utils/Makefile2
-rw-r--r--sysutils/ftrace/Makefile2
-rw-r--r--sysutils/heartbeat/Makefile2
-rw-r--r--sysutils/heartbeat2/Makefile2
-rw-r--r--sysutils/libutempter/Makefile2
-rw-r--r--sysutils/ntfsprogs/Makefile2
-rw-r--r--sysutils/portmanager/Makefile2
-rw-r--r--sysutils/progsreiserfs/Makefile2
-rw-r--r--sysutils/xfce4-genmon-plugin/Makefile2
-rw-r--r--textproc/cole/Makefile2
-rw-r--r--textproc/domc/Makefile2
-rw-r--r--textproc/eruby/Makefile2
-rw-r--r--textproc/gdome2/Makefile2
-rw-r--r--textproc/latte/Makefile2
-rw-r--r--textproc/liblrdf/Makefile2
-rw-r--r--textproc/libparsifal/Makefile2
-rw-r--r--textproc/libpathan/Makefile2
-rw-r--r--textproc/libxode/Makefile2
-rw-r--r--textproc/mifluz/Makefile2
-rw-r--r--textproc/minidom/Makefile2
-rw-r--r--textproc/py-ltxml/Makefile2
-rw-r--r--textproc/sary/Makefile2
-rw-r--r--textproc/sp/Makefile2
-rw-r--r--textproc/wbxml2/Makefile2
-rw-r--r--textproc/wv/Makefile2
-rw-r--r--textproc/xalan-c/Makefile2
-rw-r--r--textproc/xerces-c/Makefile2
-rw-r--r--textproc/xerces-c2-devel/Makefile2
-rw-r--r--textproc/xerces-c2/Makefile2
-rw-r--r--textproc/xerces-c27/Makefile2
-rw-r--r--textproc/xls2xml/Makefile2
-rw-r--r--textproc/xmlwrapp/Makefile2
53 files changed, 53 insertions, 53 deletions
diff --git a/ports-mgmt/portmanager/Makefile b/ports-mgmt/portmanager/Makefile
index 5229ac7aba89..6b26cd9c3ffe 100644
--- a/ports-mgmt/portmanager/Makefile
+++ b/ports-mgmt/portmanager/Makefile
@@ -20,7 +20,7 @@ MAN3= libMG.3 MGdbAdd.3 MGdbCreate.3 MGdbDelete.3 \
MGdbGetRecordQty.3 MGdbGoTop.3 MGdbSeek.3
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
INSTALL_TARGET= install info
diff --git a/security/beecrypt/Makefile b/security/beecrypt/Makefile
index cb95da12b3ca..f8428dec32e6 100644
--- a/security/beecrypt/Makefile
+++ b/security/beecrypt/Makefile
@@ -18,7 +18,7 @@ COMMENT= BeeCrypt is an open source cryptography library
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
post-patch:
@${REINPLACE_CMD} -e "s|-pthread|${PTHREAD_LIBS}|g" ${WRKSRC}/configure
diff --git a/security/cracklib/Makefile b/security/cracklib/Makefile
index 98b3a8fd707a..4f02594ede1e 100644
--- a/security/cracklib/Makefile
+++ b/security/cracklib/Makefile
@@ -17,7 +17,7 @@ COMMENT= Password-checking library
MAN3= cracklib.3
MLINKS= cracklib.3 FascistCheck.3
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
pre-su-install:
${INSTALL_DATA} ${WRKSRC}/cracklib/libcrack.a ${PREFIX}/lib
diff --git a/security/cyrus-sasl/Makefile b/security/cyrus-sasl/Makefile
index 5b5fc791756d..5c80009fd6a3 100644
--- a/security/cyrus-sasl/Makefile
+++ b/security/cyrus-sasl/Makefile
@@ -31,7 +31,7 @@ PATCH_SITES= ftp://ftp.westbend.net/pub/cyrus-mail/contrib/:apop \
USE_SUBMAKE= yes
USE_OPENSSL= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
# IPv6 Patch provided by Hajimu UMEMOTO <ume@mahoroba.org>
IPV6_VER= 20020106
diff --git a/security/gss/Makefile b/security/gss/Makefile
index d07896f901c2..b59b37bb0876 100644
--- a/security/gss/Makefile
+++ b/security/gss/Makefile
@@ -26,7 +26,7 @@ USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-kerberos5
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
INFO= gss
diff --git a/security/heimdal/Makefile b/security/heimdal/Makefile
index b25154d9a785..edfbaf509cbd 100644
--- a/security/heimdal/Makefile
+++ b/security/heimdal/Makefile
@@ -24,7 +24,7 @@ OPTIONS+= X11 "Build X11 utilies" off
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ENV+= CFLAGS="${CFLAGS}"
CONFIGURE_ARGS+= --enable-shared --without-krb4
diff --git a/security/ifd-devkit/Makefile b/security/ifd-devkit/Makefile
index 2514b637f0ed..67bb559ba308 100644
--- a/security/ifd-devkit/Makefile
+++ b/security/ifd-devkit/Makefile
@@ -16,7 +16,7 @@ COMMENT= IFD Handler Developer's Kit for MUSCLE PC/SC Lite
LIB_DEPENDS= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
NOMAN=
diff --git a/security/ifd-gpr400/Makefile b/security/ifd-gpr400/Makefile
index c9dfc93aa7ee..fb0bd11569c2 100644
--- a/security/ifd-gpr400/Makefile
+++ b/security/ifd-gpr400/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
MAKE_ENV+= DESTDIR="${PREFIX}"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
NOMAN=
diff --git a/security/krb4/Makefile b/security/krb4/Makefile
index 54fac990f31d..47635b25cd84 100644
--- a/security/krb4/Makefile
+++ b/security/krb4/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= KTH Kerberos 4
CONFLICTS= krb5-[0-9]* heimdal-[0-9]*
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
# Don't remove this. This port installs several applications
# which have the same name as some in the base system (e.g.
# ftp, telnet, su).
diff --git a/security/libecc/Makefile b/security/libecc/Makefile
index 890c7e240d42..0b6b9e3da3f3 100644
--- a/security/libecc/Makefile
+++ b/security/libecc/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
USE_GCC= 3.3+
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ENV+= LDFLAGS="-L${PREFIX}/lib -L${LOCALBASE}/lib" \
CPPFLAGS="-I${PREFIX}/include -I${LOCALBASE}/include"
diff --git a/security/libident/Makefile b/security/libident/Makefile
index 403a91a49d0e..96e239f0f28a 100644
--- a/security/libident/Makefile
+++ b/security/libident/Makefile
@@ -16,7 +16,7 @@ COMMENT= A small library to interface the ident protocol server (rfc1413)
USE_GNOME= gnometarget lthack
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MAN3= ident.3
diff --git a/security/libmcrypt/Makefile b/security/libmcrypt/Makefile
index 8e5f10381fae..ce68105fcbc5 100644
--- a/security/libmcrypt/Makefile
+++ b/security/libmcrypt/Makefile
@@ -18,7 +18,7 @@ COMMENT= Multi-cipher cryptographic library (used in PHP)
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-static
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MAN3= mcrypt.3
diff --git a/security/libntlm/Makefile b/security/libntlm/Makefile
index 0a7abf4f443e..cfce23e90266 100644
--- a/security/libntlm/Makefile
+++ b/security/libntlm/Makefile
@@ -17,6 +17,6 @@ COMMENT= A library that implement Microsoft's NTLM authentication
USE_GNOME= gnomehack gnometarget pkgconfig
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/security/libotr/Makefile b/security/libotr/Makefile
index 1678d0374b32..6ca81c2cb95f 100644
--- a/security/libotr/Makefile
+++ b/security/libotr/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= gpg-error:${PORTSDIR}/security/libgpg-error \
gcrypt:${PORTSDIR}/security/libgcrypt
USE_AUTOTOOLS= autoconf:259 libtool:15
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MAN1= otr_toolkit.1
MLINKS= otr_toolkit.1 otr_parse.1 \
diff --git a/security/libsectok/Makefile b/security/libsectok/Makefile
index 4649c7d2b142..7725259b8a7f 100644
--- a/security/libsectok/Makefile
+++ b/security/libsectok/Makefile
@@ -15,7 +15,7 @@ DISTNAME= libsectok-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= ISO 7816 Smartcard API Library
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_OPENSSL= YES
diff --git a/security/newpki-lib/Makefile b/security/newpki-lib/Makefile
index cc944b0cc4d6..5d7e2e858574 100644
--- a/security/newpki-lib/Makefile
+++ b/security/newpki-lib/Makefile
@@ -18,7 +18,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-2.0.0
USE_OPENSSL= yes
USE_GMAKE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS+= --includedir=${PREFIX}/include/newpki
diff --git a/security/pam_smb/Makefile b/security/pam_smb/Makefile
index 04cbe5040d0a..267bc119145b 100644
--- a/security/pam_smb/Makefile
+++ b/security/pam_smb/Makefile
@@ -15,7 +15,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/-rc/}
MAINTAINER= ports@FreeBSD.org
COMMENT= NetBIOS domain logon PAM module
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
HAS_CONFIGURE= yes
USE_GMAKE= yes
USE_PERL5= yes
diff --git a/security/sectok/Makefile b/security/sectok/Makefile
index 0041facf7078..6209bf56c084 100644
--- a/security/sectok/Makefile
+++ b/security/sectok/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= sectok.3:${PORTSDIR}/security/libsectok
USE_OPENSSL= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAN1= sectok.1
diff --git a/security/shishi/Makefile b/security/shishi/Makefile
index 8e105317efa0..e3ad95d61cb3 100644
--- a/security/shishi/Makefile
+++ b/security/shishi/Makefile
@@ -28,7 +28,7 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
MAKEINFO="makeinfo --no-split"
CONFIGURE_ARGS= --disable-starttls \
--with-db-dir=/var/shishi
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
INFO= shishi
diff --git a/sysutils/LPRng/Makefile b/sysutils/LPRng/Makefile
index 7d868e7e988a..46c28e3cae2d 100644
--- a/sysutils/LPRng/Makefile
+++ b/sysutils/LPRng/Makefile
@@ -25,7 +25,7 @@ CONFLICTS= cups-base-1.[2-9]*
LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
SUB_FILES= pkg-message pkg-install
SUB_LIST= SYSCONFDIR="${SYSCONFDIR}"
diff --git a/sysutils/LPRngTool/Makefile b/sysutils/LPRngTool/Makefile
index 9365ecea6f78..a2bc90c6275b 100644
--- a/sysutils/LPRngTool/Makefile
+++ b/sysutils/LPRngTool/Makefile
@@ -36,7 +36,7 @@ PLIST_SUB+= CWD="@comment " SYSCONFDIR="${SYSCONFDIR:S,^${PREFIX}/,,}"
.endif
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ARGS+= --with-spool_directory=/var/spool/lpd \
--with-sysconfdir="${SYSCONFDIR}"
diff --git a/sysutils/am-utils/Makefile b/sysutils/am-utils/Makefile
index 829be20150ca..2195d38db115 100644
--- a/sysutils/am-utils/Makefile
+++ b/sysutils/am-utils/Makefile
@@ -18,7 +18,7 @@ MASTER_SITES= ftp://ftp.am-utils.org/pub/am-utils/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= The Berkeley Automounter Suite of Utilities
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool:15
PORTDOCS= AUTHORS BUGS COPYING FAQ NEWS README.attrcache
diff --git a/sysutils/ftrace/Makefile b/sysutils/ftrace/Makefile
index be4554a918c4..6bdbb40bbf11 100644
--- a/sysutils/ftrace/Makefile
+++ b/sysutils/ftrace/Makefile
@@ -18,7 +18,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME:S/_/-/}
GNU_CONFIGURE= yes
MAKE_ARGS= CFLAGS="${CFLAGS} -DPIC -fPIC -D_REENTRANT -I." \
LDFLAGS="-shared"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
PLIST_FILES= bin/ftrace lib/libftrace.so
PORTDOCS= COPYING README TODO ChangeLog
diff --git a/sysutils/heartbeat/Makefile b/sysutils/heartbeat/Makefile
index 216ea8a5f1d2..e0b778dbdd9e 100644
--- a/sysutils/heartbeat/Makefile
+++ b/sysutils/heartbeat/Makefile
@@ -21,7 +21,7 @@ GNU_CONFIGURE= yes
USE_PERL5= yes
USE_GMAKE= yes
USE_GNOME= glib12
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ARGS+= --disable-fatal-warnings \
--with-initdir=${PREFIX}/etc/rc.d
diff --git a/sysutils/heartbeat2/Makefile b/sysutils/heartbeat2/Makefile
index 216ea8a5f1d2..e0b778dbdd9e 100644
--- a/sysutils/heartbeat2/Makefile
+++ b/sysutils/heartbeat2/Makefile
@@ -21,7 +21,7 @@ GNU_CONFIGURE= yes
USE_PERL5= yes
USE_GMAKE= yes
USE_GNOME= glib12
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ARGS+= --disable-fatal-warnings \
--with-initdir=${PREFIX}/etc/rc.d
diff --git a/sysutils/libutempter/Makefile b/sysutils/libutempter/Makefile
index b6d0328d603e..c2461bf1b8fc 100644
--- a/sysutils/libutempter/Makefile
+++ b/sysutils/libutempter/Makefile
@@ -14,7 +14,7 @@ COMMENT= Interface to record user sessions to utmp and wtmp files
USE_BZIP2= yes
USE_GMAKE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
NO_FILTER_SHLIBS=yes
.include <bsd.port.mk>
diff --git a/sysutils/ntfsprogs/Makefile b/sysutils/ntfsprogs/Makefile
index a7ece1ad7c97..f7509f7a4bc2 100644
--- a/sysutils/ntfsprogs/Makefile
+++ b/sysutils/ntfsprogs/Makefile
@@ -18,7 +18,7 @@ GNU_CONFIGURE= yes
USE_GCC= 3.4+
USE_GETOPT_LONG=yes
WANT_GNOME= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ARGS= --program-transform-name=""
CONFIGURE_ENV= PKG_CONFIG=${LOCALBASE}/bin/pkg-config
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/sysutils/portmanager/Makefile b/sysutils/portmanager/Makefile
index 5229ac7aba89..6b26cd9c3ffe 100644
--- a/sysutils/portmanager/Makefile
+++ b/sysutils/portmanager/Makefile
@@ -20,7 +20,7 @@ MAN3= libMG.3 MGdbAdd.3 MGdbCreate.3 MGdbDelete.3 \
MGdbGetRecordQty.3 MGdbGoTop.3 MGdbSeek.3
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
INSTALL_TARGET= install info
diff --git a/sysutils/progsreiserfs/Makefile b/sysutils/progsreiserfs/Makefile
index 43baafe200a0..7fe08610df7f 100644
--- a/sysutils/progsreiserfs/Makefile
+++ b/sysutils/progsreiserfs/Makefile
@@ -17,7 +17,7 @@ COMMENT= Utilities and library to manipulate ReiserFS partitions
USE_GETOPT_LONG=yes
USE_AUTOTOOLS= libtool:15
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --disable-debug
diff --git a/sysutils/xfce4-genmon-plugin/Makefile b/sysutils/xfce4-genmon-plugin/Makefile
index 9adaf8a78dc0..fc9286fccf91 100644
--- a/sysutils/xfce4-genmon-plugin/Makefile
+++ b/sysutils/xfce4-genmon-plugin/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
USE_GNOME= gtk20 libxml2
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
.include <bsd.port.mk>
diff --git a/textproc/cole/Makefile b/textproc/cole/Makefile
index 03adfa686a8c..3bb1cbeb10f3 100644
--- a/textproc/cole/Makefile
+++ b/textproc/cole/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A free C OLE library
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
post-patch:
@${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
diff --git a/textproc/domc/Makefile b/textproc/domc/Makefile
index 620e03b09348..743077bd4ddc 100644
--- a/textproc/domc/Makefile
+++ b/textproc/domc/Makefile
@@ -29,7 +29,7 @@ USE_GMAKE= yes
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ENV+= SHLIB_MAJOR="${SHLIB_MAJOR}" INSTDIR=${PREFIX} LDFLAGS="${LDFLAGS}"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
diff --git a/textproc/eruby/Makefile b/textproc/eruby/Makefile
index 251187565655..777520ee1961 100644
--- a/textproc/eruby/Makefile
+++ b/textproc/eruby/Makefile
@@ -18,7 +18,7 @@ USE_RUBY= yes
CONFIGURE_ARGS= --enable-shared --with-charset="${DEFAULT_CHARSET}"
INSTALL_TARGET= site-install
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
DEFAULT_CHARSET?= ISO-8859-1
diff --git a/textproc/gdome2/Makefile b/textproc/gdome2/Makefile
index 434613a72169..5e447d65f142 100644
--- a/textproc/gdome2/Makefile
+++ b/textproc/gdome2/Makefile
@@ -21,7 +21,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= GLIB_CONFIG="${LOCALBASE}/bin/pkg-config glib-2.0" \
CPPFLAGS="-I${LOCALBASE}/include"
PLIST_SUB= DOCSDIR="share/doc/${DISTNAME}"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MAN1= gdome-config.1
diff --git a/textproc/latte/Makefile b/textproc/latte/Makefile
index 1326b7e24592..08682e2e996e 100644
--- a/textproc/latte/Makefile
+++ b/textproc/latte/Makefile
@@ -22,7 +22,7 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-shared
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
INFO= latte liblatte
diff --git a/textproc/liblrdf/Makefile b/textproc/liblrdf/Makefile
index f2f0015d7f5e..d2c22a9e70d8 100644
--- a/textproc/liblrdf/Makefile
+++ b/textproc/liblrdf/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= raptor.2:${PORTSDIR}/textproc/raptor
USE_GNOME= gnomehack gnometarget
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
diff --git a/textproc/libparsifal/Makefile b/textproc/libparsifal/Makefile
index b62405d454e2..d4360302216c 100644
--- a/textproc/libparsifal/Makefile
+++ b/textproc/libparsifal/Makefile
@@ -20,7 +20,7 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
PLIST_SUB= VERSION=${PORTVERSION}
diff --git a/textproc/libpathan/Makefile b/textproc/libpathan/Makefile
index c7216cb25e65..10f4a74d793a 100644
--- a/textproc/libpathan/Makefile
+++ b/textproc/libpathan/Makefile
@@ -23,7 +23,7 @@ USE_GMAKE= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
XERCESCROOT= `cd ${PORTSDIR}/textproc/xerces-c2; ${MAKE} -V WRKSRC`
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV+= XERCESCROOT=${XERCESCROOT}
diff --git a/textproc/libxode/Makefile b/textproc/libxode/Makefile
index e56d5e960eb4..a6013008182f 100644
--- a/textproc/libxode/Makefile
+++ b/textproc/libxode/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
post-patch:
@${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
diff --git a/textproc/mifluz/Makefile b/textproc/mifluz/Makefile
index 02762379bd6d..96ac85e2a972 100644
--- a/textproc/mifluz/Makefile
+++ b/textproc/mifluz/Makefile
@@ -18,7 +18,7 @@ COMMENT= C++ library to build and query a full text inverted index
USE_ICONV= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE} --without-unac
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
USE_BISON= yes
USE_GCC= 2.95
diff --git a/textproc/minidom/Makefile b/textproc/minidom/Makefile
index a953ef710dfe..729cd4dc2131 100644
--- a/textproc/minidom/Makefile
+++ b/textproc/minidom/Makefile
@@ -23,7 +23,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-libxml2=yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
post-patch:
@${REINPLACE_CMD} -e 's|-lglib|-lglib-12|g ; \
diff --git a/textproc/py-ltxml/Makefile b/textproc/py-ltxml/Makefile
index 1954b49bd0b7..475ba79d9ef0 100644
--- a/textproc/py-ltxml/Makefile
+++ b/textproc/py-ltxml/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
USE_PYTHON= yes
USE_PYDISTUTILS= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
diff --git a/textproc/sary/Makefile b/textproc/sary/Makefile
index acad8abca01c..1bad8bd6e038 100644
--- a/textproc/sary/Makefile
+++ b/textproc/sary/Makefile
@@ -16,7 +16,7 @@ COMMENT= A suffix array library and tools, which provide fast full-text search
USE_GNOME= glib20 gnomehack gnometarget
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MAN1= sary.1 mksary.1
diff --git a/textproc/sp/Makefile b/textproc/sp/Makefile
index 93dd8b4593a5..15b4e1ec24da 100644
--- a/textproc/sp/Makefile
+++ b/textproc/sp/Makefile
@@ -21,7 +21,7 @@ BROKEN= "does not compile on ${MACHINE_ARCH}"
.endif
USE_SUBMAKE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
USE_GCC= 2.95
PORTDOCS= Makefile archform.htm build.htm catalog catalog.htm \
charset.htm features.htm generic.htm ideas.htm index.htm \
diff --git a/textproc/wbxml2/Makefile b/textproc/wbxml2/Makefile
index c92074c274e9..0b39c7e5337e 100644
--- a/textproc/wbxml2/Makefile
+++ b/textproc/wbxml2/Makefile
@@ -23,7 +23,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_AUTOTOOLS= automake:19 autoconf:259 libtool:15
AUTOMAKE_ARGS= -acf
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -lexpat"
diff --git a/textproc/wv/Makefile b/textproc/wv/Makefile
index 8d7a4b5ba51b..86433d756749 100644
--- a/textproc/wv/Makefile
+++ b/textproc/wv/Makefile
@@ -32,7 +32,7 @@ CONFIGURE_ARGS= --with-png=${LOCALBASE} \
--with-libwmf=${LOCALBASE}
MAKEFILE= GNUmakefile
MAKE_ARGS= pkgconfigdir="${PREFIX}/libdata/pkgconfig"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MAN1= wvAbw.1 wvCleanLatex.1 wvDVI.1 wvHtml.1 wvLatex.1 wvMime.1 wvPDF.1 \
wvPS.1 wvRTF.1 wvSummary.1 wvText.1 wvVersion.1 wvWare.1 wvWml.1
diff --git a/textproc/xalan-c/Makefile b/textproc/xalan-c/Makefile
index bf636eb68ee8..bb73893c4ffe 100644
--- a/textproc/xalan-c/Makefile
+++ b/textproc/xalan-c/Makefile
@@ -50,7 +50,7 @@ XERCESCROOT?= ${LOCALBASE}
# expect this to get broken some day
NO_FILTER_SHLIBS= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/xml-xalan/c
diff --git a/textproc/xerces-c/Makefile b/textproc/xerces-c/Makefile
index baae4e59add7..70aebb6f7de7 100644
--- a/textproc/xerces-c/Makefile
+++ b/textproc/xerces-c/Makefile
@@ -17,7 +17,7 @@ DISTNAME= xerces-c-src${PORTVERSION:S/./_/g}
MAINTAINER= ports@FreeBSD.org
COMMENT= Xerces-C++ is a validating XML parser written in a subset of C++
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
XERCESWRKSRC= ${WRKSRC}/src/xercesc
CONFIGURE_WRKSRC= ${XERCESWRKSRC}
diff --git a/textproc/xerces-c2-devel/Makefile b/textproc/xerces-c2-devel/Makefile
index f2803055ee00..08f42bc067eb 100644
--- a/textproc/xerces-c2-devel/Makefile
+++ b/textproc/xerces-c2-devel/Makefile
@@ -69,7 +69,7 @@ PLIST_SUB+= TRANSICU="@comment "
# expect this to get broken some day
NO_FILTER_SHLIBS= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
XERCESWRKSRC= ${WRKSRC}/src/xercesc
CONFIGURE_WRKSRC= ${XERCESWRKSRC}
diff --git a/textproc/xerces-c2/Makefile b/textproc/xerces-c2/Makefile
index f2803055ee00..08f42bc067eb 100644
--- a/textproc/xerces-c2/Makefile
+++ b/textproc/xerces-c2/Makefile
@@ -69,7 +69,7 @@ PLIST_SUB+= TRANSICU="@comment "
# expect this to get broken some day
NO_FILTER_SHLIBS= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
XERCESWRKSRC= ${WRKSRC}/src/xercesc
CONFIGURE_WRKSRC= ${XERCESWRKSRC}
diff --git a/textproc/xerces-c27/Makefile b/textproc/xerces-c27/Makefile
index f2803055ee00..08f42bc067eb 100644
--- a/textproc/xerces-c27/Makefile
+++ b/textproc/xerces-c27/Makefile
@@ -69,7 +69,7 @@ PLIST_SUB+= TRANSICU="@comment "
# expect this to get broken some day
NO_FILTER_SHLIBS= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
XERCESWRKSRC= ${WRKSRC}/src/xercesc
CONFIGURE_WRKSRC= ${XERCESWRKSRC}
diff --git a/textproc/xls2xml/Makefile b/textproc/xls2xml/Makefile
index bb5e37d45fa4..dd490fbb8230 100644
--- a/textproc/xls2xml/Makefile
+++ b/textproc/xls2xml/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= cole.2:${PORTSDIR}/textproc/cole \
xml.5:${PORTSDIR}/textproc/libxml
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lcole"
diff --git a/textproc/xmlwrapp/Makefile b/textproc/xmlwrapp/Makefile
index e0886ad661f0..5c5af810dea3 100644
--- a/textproc/xmlwrapp/Makefile
+++ b/textproc/xmlwrapp/Makefile
@@ -22,7 +22,7 @@ WANT_GNOME= yes
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= configure.pl
CONFIGURE_ARGS= --prefix ${PREFIX}
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CFLAGS+= -fPIC
.include <bsd.port.pre.mk>