aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2023-10-15 11:09:40 +0000
committerBernard Spil <brnrd@FreeBSD.org>2023-10-15 11:14:59 +0000
commitc55803584171e1029f57c0f4ae248c6220e7ecd5 (patch)
treedbca906ed0de59b9d290bcffc5a5ce93d6853b24
parentd59ea56e40877edaaeb8a04eba0f539f9d3621d2 (diff)
downloadports-c55803584171e1029f57c0f4ae248c6220e7ecd5.tar.gz
ports-c55803584171e1029f57c0f4ae248c6220e7ecd5.zip
security/openssl: Update BROKEN_SSL ports referring to openssl30
-rw-r--r--archivers/xar/Makefile2
-rw-r--r--audio/murmur/Makefile2
-rw-r--r--audio/spotify-tui/Makefile4
-rw-r--r--audio/umurmur/Makefile2
-rw-r--r--devel/gbump/Makefile6
-rw-r--r--devel/kore/Makefile2
-rw-r--r--devel/ptlib/Makefile2
-rw-r--r--mail/enma/Makefile2
-rw-r--r--net-im/telegram-desktop/Makefile2
-rw-r--r--net/gq/Makefile2
-rw-r--r--security/krb5-119/Makefile2
-rw-r--r--security/libfido2/Makefile2
-rw-r--r--security/p5-Filter-Crypto/Makefile2
-rw-r--r--security/pkcs11-tools/Makefile4
-rw-r--r--security/proxytunnel/Makefile2
-rw-r--r--security/py-nassl/Makefile2
-rw-r--r--security/sslsplit/Makefile4
-rw-r--r--sysutils/flowgger/Makefile2
-rw-r--r--sysutils/vector/Makefile4
-rw-r--r--www/castor/Makefile4
-rw-r--r--www/rearx/Makefile4
21 files changed, 29 insertions, 29 deletions
diff --git a/archivers/xar/Makefile b/archivers/xar/Makefile
index 048f09947e8b..275af621738b 100644
--- a/archivers/xar/Makefile
+++ b/archivers/xar/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
DEPRECATED= Upstream last release was in 2012 and seems dead
USES= cpe gmake gnome libtool ssl
-BROKEN_SSL= openssl30 openssl31
+BROKEN_SSL= openssl openssl31
BROKEN_SSL_REASON= undefined reference due to --no-allow-shlib-undefined: EVP_MD_type
CPE_VENDOR= xar_project
USE_GNOME= libxml2
diff --git a/audio/murmur/Makefile b/audio/murmur/Makefile
index 3342afa69d90..d1cec5937837 100644
--- a/audio/murmur/Makefile
+++ b/audio/murmur/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/function.hpp:devel/boost-libs
LIB_DEPENDS= libprotobuf.so:devel/protobuf
USES= compiler:c++11-lang qmake pkgconfig python:build qt:5 ssl
-BROKEN_SSL= openssl30 openssl31
+BROKEN_SSL= openssl openssl31
BROKEN_SSL_REASON= Requires OpenSSL 3.0.0 deprecated CRYPTO_MEM_CHECK_ON
USE_CXXSTD= c++11
USE_QT= buildtools:build core network sql xml
diff --git a/audio/spotify-tui/Makefile b/audio/spotify-tui/Makefile
index a09b4893eb7b..f12a21b16988 100644
--- a/audio/spotify-tui/Makefile
+++ b/audio/spotify-tui/Makefile
@@ -290,8 +290,8 @@ SPOTIFYD_RUN_DEPENDS= spotifyd:audio/spotifyd
.include <bsd.port.options.mk>
-.if ( ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400092 && ${SSL_DEFAULT} == base ) || ${SSL_DEFAULT:Mopenssl3*}
-BROKEN_SSL= base openssl30 openssl31
+.if ( ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400092 && ${SSL_DEFAULT} == base ) || ${SSL_DEFAULT:Mopenssl} || ${SSL_DEFAULT:Mopenssl3*}
+BROKEN_SSL= base openssl openssl31
BROKEN_SSL_REASON= Fails to detect OpenSSL 3.0.0 and later
.endif
diff --git a/audio/umurmur/Makefile b/audio/umurmur/Makefile
index 01a5e0eb7f0e..c7ab80fceb03 100644
--- a/audio/umurmur/Makefile
+++ b/audio/umurmur/Makefile
@@ -28,7 +28,7 @@ LIB_DEPENDS+= libmbedtls.so:security/mbedtls
CONFIGURE_ARGS= --with-ssl=mbedtls
.else
USES+= ssl
-BROKEN_SSL= openssl30 openssl31
+BROKEN_SSL= openssl openssl31
BROKEN_SSL_REASON= Requires OpenSSL 3.0.0 deprecated CRYPTO_MEM_CHECK_ON
CONFIGURE_ARGS= --with-ssl=openssl
.endif
diff --git a/devel/gbump/Makefile b/devel/gbump/Makefile
index 47feecdcd9a8..aa652298d9db 100644
--- a/devel/gbump/Makefile
+++ b/devel/gbump/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libgit2.so:devel/libgit2 \
USES= cargo localbase ssl
-BROKEN_SSL= openssl30 openssl31
+BROKEN_SSL= openssl openssl31
BROKEN_SSL_REASON= Fails to find OpenSSL development headers
CARGO_CRATES= aho-corasick-1.0.2 \
@@ -65,8 +65,8 @@ PLIST_FILES= bin/gbump
.include <bsd.port.options.mk>
-.if ( ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400092 && ${SSL_DEFAULT} == base ) || ${SSL_DEFAULT:Mopenssl3*}
-BROKEN_SSL= base openssl30 openssl31
+.if ( ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400092 && ${SSL_DEFAULT} == base ) || ${SSL_DEFAULT:Mopenssl} || ${SSL_DEFAULT:Mopenssl3*}
+BROKEN_SSL= base openssl openssl31
BROKEN_SSL_REASON= Fails to find OpenSSL 3 development headers
.endif
diff --git a/devel/kore/Makefile b/devel/kore/Makefile
index c286efeb664d..33de8c0d8d8c 100644
--- a/devel/kore/Makefile
+++ b/devel/kore/Makefile
@@ -10,7 +10,7 @@ WWW= http://www.kore.io/
LICENSE= ISCL
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_SSL= openssl30 openssl31
+BROKEN_SSL= openssl openssl31
BROKEN_SSL_REASON= Requires OpenSSL 3.0.0 deprecated RSA_* routines
USES= compiler:c11 gmake ssl
diff --git a/devel/ptlib/Makefile b/devel/ptlib/Makefile
index 9558e6816bf6..994d0db9beb8 100644
--- a/devel/ptlib/Makefile
+++ b/devel/ptlib/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= libexpat.so:textproc/expat2
USES= autoreconf:build bison:wrapper compiler:c11 gmake localbase:ldflags \
pathfix pkgconfig ssl tar:xz
-BROKEN_SSL= openssl30 openssl31
+BROKEN_SSL= openssl openssl31
BROKEN_SSL_REASON= Uses OpenSSL 3.0.0 deprecated BIO_s_file_internal
USE_LDCONFIG= yes
diff --git a/mail/enma/Makefile b/mail/enma/Makefile
index 343fc427462d..0e3e23cfed53 100644
--- a/mail/enma/Makefile
+++ b/mail/enma/Makefile
@@ -16,7 +16,7 @@ CONFIGURE_ARGS= --with-ssl-incdir=${OPENSSLINC} \
--with-ssl-libdir=${OPENSSLLIB}
USES= gmake libtool perl5 ssl
-BROKEN_SSL= openssl30 openssl31
+BROKEN_SSL= openssl openssl31
BROKEN_SSL_REASON= Fails to build with error undefined reference due to --no-allow-shlib-undefined: EVP
USE_RC_SUBR= milter-enma
USE_LDCONFIG= yes
diff --git a/net-im/telegram-desktop/Makefile b/net-im/telegram-desktop/Makefile
index 4b736654360c..739000572c73 100644
--- a/net-im/telegram-desktop/Makefile
+++ b/net-im/telegram-desktop/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_i386= does not build, webrtc related
-BROKEN_SSL= openssl30 openssl31
+BROKEN_SSL= openssl openssl31
BROKEN_SSL_REASON= undefined symbol: ERR_load_BIO_strings
NOT_FOR_ARCHS= powerpc powerpc64 powerpcspe
NOT_FOR_ARCHS_REASON= Only little endian is supported
diff --git a/net/gq/Makefile b/net/gq/Makefile
index 513cc231f6e1..b55172cc99da 100644
--- a/net/gq/Makefile
+++ b/net/gq/Makefile
@@ -45,7 +45,7 @@ DND_CONFIGURE_ENABLE= browser-dns
.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
BROKEN= Fails to build with OpenSSL 1.1.1t and later
-BROKEN_SSL= base openssl openssl30 openssl31
+BROKEN_SSL= base openssl openssl111 openssl31
BROKEN_SSL_REASON= Fails to build with OpenSSL 1.1.1t and later
.endif
diff --git a/security/krb5-119/Makefile b/security/krb5-119/Makefile
index fddc65d4e0d8..c7b33c3304cb 100644
--- a/security/krb5-119/Makefile
+++ b/security/krb5-119/Makefile
@@ -25,7 +25,7 @@ KERBEROSV_URL= http://web.mit.edu/kerberos/
USES= autoreconf compiler:c++11-lang cpe gmake gettext-runtime \
gssapi:bootstrap,mit libtool:build localbase \
perl5 pkgconfig ssl
-BROKEN_SSL= openssl30 openssl31
+BROKEN_SSL= openssl openssl31
BROKEN_SSL_REASON= Requires OpenSSL 3.0.0 deprecated RSA_ routines
BROKEN_FreeBSD_14= Incompatible with OpenSSL 3.0 in 14-STABLE
BROKEN_FreeBSD_15= Incompatible with OpenSSL 3.0 in 15-CURRENT
diff --git a/security/libfido2/Makefile b/security/libfido2/Makefile
index 2217d26fe805..4388c9c3999e 100644
--- a/security/libfido2/Makefile
+++ b/security/libfido2/Makefile
@@ -28,7 +28,7 @@ OPTIONS_DEFINE= DOCS
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-openssl
.endif
-.if ${SSL_DEFAULT} == openssl30
+.if ${SSL_DEFAULT} == openssl
CFLAGS+= -DOPENSSL_API_COMPAT=0x10100000L
.endif
diff --git a/security/p5-Filter-Crypto/Makefile b/security/p5-Filter-Crypto/Makefile
index 100e1b4b20b6..6af5d82e68e0 100644
--- a/security/p5-Filter-Crypto/Makefile
+++ b/security/p5-Filter-Crypto/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= p5-PAR-Packer>=0:devel/p5-PAR-Packer
TEST_DEPENDS= p5-CPAN-Changes>=0:devel/p5-CPAN-Changes
USES= perl5 ssl
-BROKEN_SSL= openssl30 openssl31
+BROKEN_SSL= openssl openssl31
BROKEN_SSL_REASON= Cannot detect OpenSSL 3.0.0 and later
USE_PERL5= configure
diff --git a/security/pkcs11-tools/Makefile b/security/pkcs11-tools/Makefile
index 24e110a8e67a..09f20141c785 100644
--- a/security/pkcs11-tools/Makefile
+++ b/security/pkcs11-tools/Makefile
@@ -13,9 +13,9 @@ LICENSE_NAME_THIRDPARTY= Third-party licenses
LICENSE_FILE_THIRDPARTY= ${WRKSRC}/docs/TPLICENSES.md
LICENSE_PERMS_THIRDPARTY= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-BROKEN_SSL= libressl openssl30 openssl31
+BROKEN_SSL= libressl openssl openssl31
BROKEN_SSL_REASON_libressl= error: use of undeclared identifier 'EVP_PKEY_X25519' (LibreSSL has no support for Edwards curves)
-BROKEN_SSL_REASON_openssl30= error: undefined symbol: EVP_PKEY_*
+BROKEN_SSL_REASON_openssl= error: undefined symbol: EVP_PKEY_*
BROKEN_SSL_REASON_openssl31= error: undefined symbol: EVP_PKEY_*
BUILD_DEPENDS= autoconf-archive>0:devel/autoconf-archive \
diff --git a/security/proxytunnel/Makefile b/security/proxytunnel/Makefile
index 5117b73ecd94..79ece8d9b2d1 100644
--- a/security/proxytunnel/Makefile
+++ b/security/proxytunnel/Makefile
@@ -15,7 +15,7 @@ BUILD_DEPENDS= asciidoc:textproc/asciidoc \
minixmlto:textproc/minixmlto
USES= cpe gmake pkgconfig ssl
-BROKEN_SSL= openssl30 openssl31
+BROKEN_SSL= openssl openssl31
BROKEN_SSL_REASON= Fails to build with ld: error: undefined symbol: SSL_get_peer_certificate
USE_GITHUB= yes
diff --git a/security/py-nassl/Makefile b/security/py-nassl/Makefile
index df45eb2343c6..7bdacfa4906b 100644
--- a/security/py-nassl/Makefile
+++ b/security/py-nassl/Makefile
@@ -11,7 +11,7 @@ LICENSE= AGPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
# Upstream bug https://github.com/nabla-c0d3/nassl/issues/110
-BROKEN_SSL= openssl30 openssl31
+BROKEN_SSL= openssl openssl31
BROKEN_SSL_REASON= Fails to detect OpenSSL 3.0.0 libcrypt.so
USES= python ssl
diff --git a/security/sslsplit/Makefile b/security/sslsplit/Makefile
index b6940e92d8cb..2b4ef5b65aff 100644
--- a/security/sslsplit/Makefile
+++ b/security/sslsplit/Makefile
@@ -25,8 +25,8 @@ PLIST_FILES= bin/sslsplit man/man1/sslsplit.1.gz \
.include <bsd.port.options.mk>
-.if ( ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400092 && ${SSL_DEFAULT} == base ) || ${SSL_DEFAULT:Mopenssl3*}
-IGNORE_SSL= base openssl30 openssl31
+.if ( ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400092 && ${SSL_DEFAULT} == base ) || ${SSL_DEFAULT:Mopenssl} || ${SSL_DEFAULT:Mopenssl3*}
+IGNORE_SSL= base openssl openssl31
IGNORE_SSL_REASON= error: undefined symbol: ERR_GET_FUNC which were deprecated in OpenSSL 3.0.0 and later
.endif
diff --git a/sysutils/flowgger/Makefile b/sysutils/flowgger/Makefile
index 8e103aa02b3e..bc3009ae09c9 100644
--- a/sysutils/flowgger/Makefile
+++ b/sysutils/flowgger/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= capnp:devel/capnproto
USES= cargo ssl
-#BROKEN_SSL= openssl30 openssl31
+#BROKEN_SSL= openssl openssl31
#BROKEN_SSL_REASON= Cannot detect OpenSSL 3.0.0 and later
CARGO_CRATES= addr2line-0.19.0 \
adler-1.0.2 \
diff --git a/sysutils/vector/Makefile b/sysutils/vector/Makefile
index 65632a97350f..0050af9d791c 100644
--- a/sysutils/vector/Makefile
+++ b/sysutils/vector/Makefile
@@ -564,8 +564,8 @@ LTO_UNSAFE= yes
.include <bsd.port.options.mk>
-.if ( ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400092 && ${SSL_DEFAULT} == base ) || ${SSL_DEFAULT:Mopenssl3*}
-BROKEN_SSL= base openssl30 openssl31
+.if ( ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400092 && ${SSL_DEFAULT} == base ) || ${SSL_DEFAULT:Mopenssl} || ${SSL_DEFAULT:Mopenssl3*}
+BROKEN_SSL= base openssl openssl31
BROKEN_SSL_REASON= Fails to detect OpenSSL 3.0.0 and later
.endif
diff --git a/www/castor/Makefile b/www/castor/Makefile
index c9b811caf4b7..519842433220 100644
--- a/www/castor/Makefile
+++ b/www/castor/Makefile
@@ -129,8 +129,8 @@ SUB_FILES= pkg-message
.include <bsd.port.options.mk>
-.if ( ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400092 && ${SSL_DEFAULT} == base ) || ${SSL_DEFAULT:Mopenssl3*}
-BROKEN_SSL= base openssl30 openssl31
+.if ( ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400092 && ${SSL_DEFAULT} == base ) || ${SSL_DEFAULT:Mopenssl} || ${SSL_DEFAULT:Mopenssl3*}
+BROKEN_SSL= base openssl openssl31
BROKEN_SSL_REASON= Fails to detect OpenSSL 3.0.0 library
.endif
diff --git a/www/rearx/Makefile b/www/rearx/Makefile
index ef33e201905e..f86e83797bc1 100644
--- a/www/rearx/Makefile
+++ b/www/rearx/Makefile
@@ -173,8 +173,8 @@ SUB_FILES= pkg-message
.include <bsd.port.options.mk>
-.if ( ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400092 && ${SSL_DEFAULT} == base ) || ${SSL_DEFAULT:Mopenssl3*}
-BROKEN_SSL= base openssl30 openssl31
+.if ( ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400092 && ${SSL_DEFAULT} == base ) || ${SSL_DEFAULT:Mopenssl} || ${SSL_DEFAULT:Mopenssl3*}
+BROKEN_SSL= base openssl openssl31
BROKEN_SSL_REASON= Fails to detect OpenSSL 3.0.0 and later
.endif