aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Judge <tj@FreeBSD.org>2015-01-30 16:22:39 +0000
committerTom Judge <tj@FreeBSD.org>2015-01-30 16:22:39 +0000
commitc5683e6c6f6c4f2de66c10733c532fcb4e9334e0 (patch)
tree5171026b24196a373863954724d33ddcf4a09b02
parent0f3212398bcb03397a2e62113e3f157a1a09138d (diff)
downloadports-c5683e6c6f6c4f2de66c10733c532fcb4e9334e0.tar.gz
ports-c5683e6c6f6c4f2de66c10733c532fcb4e9334e0.zip
New port: databases/p5-DBIx-Introspector
Detect what database you are connected to.
Notes
Notes: svn path=/head/; revision=378159
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-DBIx-Introspector/Makefile23
-rw-r--r--databases/p5-DBIx-Introspector/distinfo2
-rw-r--r--databases/p5-DBIx-Introspector/pkg-descr3
-rw-r--r--databases/p5-DBIx-Introspector/pkg-plist7
5 files changed, 36 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index fc96e7c8ed11..ce2dc5899fa3 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -361,6 +361,7 @@
SUBDIR += p5-DBIx-Ease
SUBDIR += p5-DBIx-HA
SUBDIR += p5-DBIx-Inspector
+ SUBDIR += p5-DBIx-Introspector
SUBDIR += p5-DBIx-Log4perl
SUBDIR += p5-DBIx-MySQLSequence
SUBDIR += p5-DBIx-NoSQL
diff --git a/databases/p5-DBIx-Introspector/Makefile b/databases/p5-DBIx-Introspector/Makefile
new file mode 100644
index 000000000000..fc66af1132f2
--- /dev/null
+++ b/databases/p5-DBIx-Introspector/Makefile
@@ -0,0 +1,23 @@
+# Created by: Tom Judge <tj@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= DBIx-Introspector
+PORTVERSION= 0.001005
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tj@FreeBSD.org
+COMMENT= Detect what database you are connected to
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+RUN_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
+ p5-Moo>=0:${PORTSDIR}/devel/p5-Moo
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-Introspector/distinfo b/databases/p5-DBIx-Introspector/distinfo
new file mode 100644
index 000000000000..0b06d37e61fe
--- /dev/null
+++ b/databases/p5-DBIx-Introspector/distinfo
@@ -0,0 +1,2 @@
+SHA256 (DBIx-Introspector-0.001005.tar.gz) = 96a94d2cc690c1fa8fd34113e3b084bf2a469a323a9780285aef92ddc381e63a
+SIZE (DBIx-Introspector-0.001005.tar.gz) = 16672
diff --git a/databases/p5-DBIx-Introspector/pkg-descr b/databases/p5-DBIx-Introspector/pkg-descr
new file mode 100644
index 000000000000..ca88e5619582
--- /dev/null
+++ b/databases/p5-DBIx-Introspector/pkg-descr
@@ -0,0 +1,3 @@
+Detect what database you are connected to.
+
+WWW: http://search.cpan.org/dist/DBIx-Introspector/
diff --git a/databases/p5-DBIx-Introspector/pkg-plist b/databases/p5-DBIx-Introspector/pkg-plist
new file mode 100644
index 000000000000..3de69a7e315e
--- /dev/null
+++ b/databases/p5-DBIx-Introspector/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/DBIx/Introspector.pm
+%%SITE_PERL%%/DBIx/Introspector/Advent.pod
+%%SITE_PERL%%/DBIx/Introspector/Driver.pm
+%%PERL5_MAN3%%/DBIx::Introspector.3.gz
+%%PERL5_MAN3%%/DBIx::Introspector::Advent.3.gz
+@dirrm %%SITE_PERL%%/DBIx/Introspector
+@dirrmtry %%SITE_PERL%%/DBIx