aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2022-02-23 10:14:43 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2022-03-09 10:07:54 +0000
commitc5be8a862afc21ac9de0fbf5bcb22016790d1004 (patch)
tree6418768333bd9107ea4e67a2b16727900852d98e
parent814e99f70e9367ae5fa21ad4a0fc55bb30edf3a0 (diff)
downloadports-c5be8a862afc21ac9de0fbf5bcb22016790d1004.tar.gz
ports-c5be8a862afc21ac9de0fbf5bcb22016790d1004.zip
devel/gitaly: update to 14.8.0
Required for gitlab-ce 14.8. Changelog: https://gitlab.com/gitlab-org/gitaly/-/blob/master/CHANGELOG.md 14.8.0 (2022-02-21) Added (9 changes) repository: Add new RPC to prune unreachable objects (merge request) limithandler: Add metrics for queue limiting (merge request) migrate: Add -verbose flag to sql-migrate (merge request) Added json output for gitaly-backup by @imskr (merge request) limithandler: enable max queue wait time (merge request) limithandler: add concurrency queue limit (merge request) proto: Add detailed errors when updating references fails (merge request) feat: Detect SSH signed objects (merge request) cmd/praefect: Check of the system clock synchronization (merge request) Fixed (10 changes) Propagate NotFound error returned by GetRepoPath (merge request) coordinator: Fix error comparison causing excessive replication jobs (merge request) Handle CreateObjectPool as a repository creation RPC (merge request) Makefile: Use pkg-config if available to set LIBPCREDIR (merge request) demo: Fix deletion of Praefect Cloud SQL instance (merge request) operations: Skip rebasing commits which become empty (merge request) housekeeping: Fix pruning of "remote.*.prune" config key (merge request) operations: Always respect committer timezone in UserApplyPatch (merge request) Shorten server keepalive period to 5 minutes (merge request) operations: Respect timezone of committer in UserApplyPatch (merge request) Changed (14 changes) Update actionpack and related Ruby gems (merge request) ci: Upgrade CI images to Debian bullseye (merge request) repository: Clean up worktrees in OptimizeRepository (merge request) repository: Use heuristic to pack refs in OptimizeRepository (merge request) repository: Use heuristic to prune objects in OptimizeRepository (merge request) repository: Use heuristic for incremental repacks in OptimizeRepository (merge request) repository: Use heuristic for full repacks in OptimizeRepository (merge request) migrate: Print execution time of migrations (merge request) replicator: Log number of stale jobs deleted (merge request) fetch: Stop writing FETCH_HEAD (merge request) config: Exclude DB metrics by default (merge request) hooks: Don't use Ruby hooks by default (merge request) cmd/gitaly-git2go: Upgrade to libgit2 v1.3.0 (merge request) operations: Return detailed error when reference update fails in merge (merge request) Deprecated (1 change) operations: Deprecate the rebase ID (merge request) Performance (7 changes) git: Backport patches to speed up git-fetch(1) in repos with many refs (merge request) datastore: Clean completed & dead replication jobs (merge request) repository: Avoid spawning Git command if there is no worktree to prune (merge request) localrepo: Use protocol v2 for internal fetches (merge request) repository: Use skipping negotiation algorithm for replication (merge request) housekeeping: Strip empty config sections (merge request) Expand flat paths only for the returned page in GetTreeEntries (merge request) Other (2 changes) chore: Add ssh signature test case (merge request) client: Expose sidechannel server methods (merge request)
-rw-r--r--devel/gitaly/Makefile13
-rw-r--r--devel/gitaly/distinfo12
-rw-r--r--devel/gitaly/files/patch-Makefile15
-rw-r--r--devel/gitaly/files/patch-ruby_Gemfile14
4 files changed, 37 insertions, 17 deletions
diff --git a/devel/gitaly/Makefile b/devel/gitaly/Makefile
index 60299e45e0b3..2115f138be50 100644
--- a/devel/gitaly/Makefile
+++ b/devel/gitaly/Makefile
@@ -1,5 +1,5 @@
PORTNAME= gitaly
-DISTVERSION= 14.7.3
+DISTVERSION= 14.8.0
PORTREVISION= 0
CATEGORIES= devel
@@ -19,7 +19,7 @@ MY_DEPENDS= git>=2.33.0:devel/git \
rubygem-rugged>=1.2<2:devel/rubygem-rugged \
rubygem-github-linguist>=7.12.1<8:textproc/rubygem-github-linguist \
rubygem-gitlab-markup>=1.8.0<1.9.0:textproc/rubygem-gitlab-markup \
- rubygem-activesupport61>=6.1.4.1<6.1.5:devel/rubygem-activesupport61 \
+ rubygem-activesupport61>=6.1.4.6<6.1.5:devel/rubygem-activesupport61 \
rubygem-rdoc>=6.3.2<7.0:devel/rubygem-rdoc \
rubygem-gitlab-gollum-lib>=4.2.7.10.gitlab.2<4.2.8:www/rubygem-gitlab-gollum-lib \
rubygem-gitlab-gollum-rugged_adapter>=0.4.4.4.gitlab.1<0.4.5.0:www/rubygem-gitlab-gollum-rugged_adapter \
@@ -27,7 +27,7 @@ MY_DEPENDS= git>=2.33.0:devel/git \
rubygem-sentry-raven>=3.0<4:devel/rubygem-sentry-raven \
rubygem-faraday>=1.0.1<2:www/rubygem-faraday \
rubygem-rbtrace>=0.4.14:devel/rubygem-rbtrace \
- rubygem-gitlab-labkit>=0.21.1<0.22:devel/rubygem-gitlab-labkit \
+ rubygem-gitlab-labkit>=0.22.0<0.23:devel/rubygem-gitlab-labkit \
rubygem-licensee>=9.14.1<9.15:devel/rubygem-licensee \
rubygem-google-protobuf>=3.19.0<3.20:devel/rubygem-google-protobuf
BUILD_DEPENDS= gem:devel/ruby-gems \
@@ -49,12 +49,12 @@ MAKE_ENV+= ${GO_ENV}
USE_GITLAB= yes
GL_ACCOUNT= gitlab-org
# Find this here: https://gitlab.com/gitlab-org/gitaly/-/tags
-GL_COMMIT= 9115228ca694cf94776a13d09afd654422a7d366
+GL_COMMIT= 67927360e245c392f73c444a997366824669efe2
# for go dependencies
USE_GITHUB= nodefault
# generated with: make gomod-vendor
-# 144dd
+# 145dd
GH_TUPLE= \
Azure:azure-pipeline-go:v0.2.3:azure_azure_pipeline_go/vendor/github.com/Azure/azure-pipeline-go \
Azure:azure-storage-blob-go:v0.13.0:azure_azure_storage_blob_go/vendor/github.com/Azure/azure-storage-blob-go \
@@ -71,6 +71,7 @@ GH_TUPLE= \
alexbrainman:sspi:4729b3d4d858:alexbrainman_sspi/vendor/github.com/alexbrainman/sspi \
avast:retry-go:v2.4.2:avast_retry_go/vendor/github.com/avast/retry-go \
aws:aws-sdk-go:v1.38.35:aws_aws_sdk_go/vendor/github.com/aws/aws-sdk-go \
+ beevik:ntp:v0.3.0:beevik_ntp/vendor/github.com/beevik/ntp \
beorn7:perks:v1.0.1:beorn7_perks/vendor/github.com/beorn7/perks \
census-ecosystem:opencensus-go-exporter-stackdriver:v0.13.8:census_ecosystem_opencensus_go_exporter_stackdriver/vendor/contrib.go.opencensus.io/exporter/stackdriver \
census-instrumentation:opencensus-go:v0.23.0:census_instrumentation_opencensus_go/vendor/go.opencensus.io \
@@ -154,7 +155,7 @@ GH_TUPLE= \
jstemmer:go-junit-report:v0.9.1:jstemmer_go_junit_report/vendor/github.com/jstemmer/go-junit-report \
kelseyhightower:envconfig:v1.3.0:kelseyhightower_envconfig/vendor/github.com/kelseyhightower/envconfig \
kevinburke:ssh_config:4977a11b4351:kevinburke_ssh_config/vendor/github.com/kevinburke/ssh_config \
- libgit2:git2go:v32.1.6:libgit2_git2go_v32/vendor/github.com/libgit2/git2go/v32 \
+ libgit2:git2go:v33.0.6:libgit2_git2go_v33/vendor/github.com/libgit2/git2go/v33 \
lightstep:lightstep-tracer-common:a8dfcb80d3a7:lightstep_lightstep_tracer_common_gogo/vendor/github.com/lightstep/lightstep-tracer-common \
lightstep:lightstep-tracer-go:v0.24.0:lightstep_lightstep_tracer_go/vendor/github.com/lightstep/lightstep-tracer-go \
mattn:go-ieproxy:v0.0.1:mattn_go_ieproxy/vendor/github.com/mattn/go-ieproxy \
diff --git a/devel/gitaly/distinfo b/devel/gitaly/distinfo
index 26f7b1228828..0524a8f87adf 100644
--- a/devel/gitaly/distinfo
+++ b/devel/gitaly/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1644937754
+TIMESTAMP = 1645608573
SHA256 (Azure-azure-pipeline-go-v0.2.3_GH0.tar.gz) = 99bd58f4a07dd02d9615e3638b3bb6dbfad80ef678ccdb8e17e3fa2b0fef343e
SIZE (Azure-azure-pipeline-go-v0.2.3_GH0.tar.gz) = 17102
SHA256 (Azure-azure-storage-blob-go-v0.13.0_GH0.tar.gz) = 6bf7145210331efa3f0417f6684cf764c22743cf23122048ec136600daebf443
@@ -29,6 +29,8 @@ SHA256 (avast-retry-go-v2.4.2_GH0.tar.gz) = 9ed430a4e0c24740db16ba2696422d2d2b07
SIZE (avast-retry-go-v2.4.2_GH0.tar.gz) = 7225
SHA256 (aws-aws-sdk-go-v1.38.35_GH0.tar.gz) = 1c1cd41669e75f4225b8fda42f7500f21408d0a8575ad3665542338ba267242b
SIZE (aws-aws-sdk-go-v1.38.35_GH0.tar.gz) = 18967606
+SHA256 (beevik-ntp-v0.3.0_GH0.tar.gz) = 6a398b24ee7c4204f73881299a1860976b2a8d6f77c11895e2d06c6c657b5584
+SIZE (beevik-ntp-v0.3.0_GH0.tar.gz) = 10977
SHA256 (beorn7-perks-v1.0.1_GH0.tar.gz) = 98db84bb0224a26094e6adba91b7ee7a1a7ace28cb648d818f8e779e6a19f825
SIZE (beorn7-perks-v1.0.1_GH0.tar.gz) = 10867
SHA256 (census-ecosystem-opencensus-go-exporter-stackdriver-v0.13.8_GH0.tar.gz) = 759ac647e059e4fddf4857bcac7b5a82a4a5c389a15dd67b74f647bb8dcf127e
@@ -195,8 +197,8 @@ SHA256 (kelseyhightower-envconfig-v1.3.0_GH0.tar.gz) = 3556a0d014ba778b78955e8ec
SIZE (kelseyhightower-envconfig-v1.3.0_GH0.tar.gz) = 12408
SHA256 (kevinburke-ssh_config-4977a11b4351_GH0.tar.gz) = 568ea6be8d237ca16dcd03e2fa5e07461ab596ccff40197ac34dac43f97389ec
SIZE (kevinburke-ssh_config-4977a11b4351_GH0.tar.gz) = 17407
-SHA256 (libgit2-git2go-v32.1.6_GH0.tar.gz) = 88e3c479b68f7920ec17fde693c7c9ece25507b9ec102a5e944fd7e1f9a926e7
-SIZE (libgit2-git2go-v32.1.6_GH0.tar.gz) = 129122
+SHA256 (libgit2-git2go-v33.0.6_GH0.tar.gz) = 14b0e4604f97b40e91d5d54ac01f4e2ea56014cf647d16063d692fbe8269a33f
+SIZE (libgit2-git2go-v33.0.6_GH0.tar.gz) = 129055
SHA256 (lightstep-lightstep-tracer-common-a8dfcb80d3a7_GH0.tar.gz) = 0403290c66b3dd109d0a726784b8b0a8583c5d19d35d12a0c2b89a434ed2d0c6
SIZE (lightstep-lightstep-tracer-common-a8dfcb80d3a7_GH0.tar.gz) = 58493
SHA256 (lightstep-lightstep-tracer-go-v0.24.0_GH0.tar.gz) = 794c5cea97c46ee5a9139c1b2770cbd81d4534ba4359a8b6b744566c4abfb15b
@@ -279,8 +281,8 @@ SHA256 (xanzy-ssh-agent-v0.3.0_GH0.tar.gz) = 7ce80a93d0fdbeb6760f97d6d166d11c215
SIZE (xanzy-ssh-agent-v0.3.0_GH0.tar.gz) = 8421
SHA256 (gonum-gonum-v0.8.2_GH0.tar.gz) = a2aad1ac038d36d568939910f39eb0c58cae3c6f0b18df3ca74a8daa954d1663
SIZE (gonum-gonum-v0.8.2_GH0.tar.gz) = 3226037
-SHA256 (gitlab-org-gitaly-9115228ca694cf94776a13d09afd654422a7d366_GL0.tar.gz) = 5ef70a044657bb755aac0c2f09e8a88e879795be1dec33c23a6f66d4d9706bbf
-SIZE (gitlab-org-gitaly-9115228ca694cf94776a13d09afd654422a7d366_GL0.tar.gz) = 3769473
+SHA256 (gitlab-org-gitaly-67927360e245c392f73c444a997366824669efe2_GL0.tar.gz) = e85fb6d14263b4de1ac7e9995a8a6af55b11e2f991c5dfe8e9b99c5ac2cfdd87
+SIZE (gitlab-org-gitaly-67927360e245c392f73c444a997366824669efe2_GL0.tar.gz) = 3804132
SHA256 (gitlab-org-gitlab-shell-50da611814d256c77e689977265ec7e07633a4dc_GL0.tar.gz) = a00e10d3dbe50e7c70b75c5fcf7d42a039a24c13b0b751a0339bb18261ac50af
SIZE (gitlab-org-gitlab-shell-50da611814d256c77e689977265ec7e07633a4dc_GL0.tar.gz) = 124516
SHA256 (gitlab-org-labkit-397363e2404ac0276b1959373a1c1c2bc1610d67_GL0.tar.gz) = e48dae8ea183f946189a9ac7e4cbe4bc0fa583e6baafb0074a3463a879565ecb
diff --git a/devel/gitaly/files/patch-Makefile b/devel/gitaly/files/patch-Makefile
index 4731a17756d7..e97345affa20 100644
--- a/devel/gitaly/files/patch-Makefile
+++ b/devel/gitaly/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2022-01-21 10:20:57 UTC
+--- Makefile.orig 2022-02-25 19:11:57 UTC
+++ Makefile
-@@ -298,7 +298,7 @@ help:
+@@ -317,7 +317,7 @@ help:
.PHONY: build
## Build Go binaries and install required Ruby Gems.
@@ -9,7 +9,16 @@
@ # We used to install Gitaly binaries into the source directory by default when executing
@ # "make" or "make all", which has been changed in v14.5 to only build binaries into
@ # `_build/bin`. In order to quickly fail in case any source install still refers to these
-@@ -522,7 +522,7 @@ libgit2: ${LIBGIT2_INSTALL_DIR}/lib/libgit2.a
+@@ -348,7 +348,7 @@ $(call find_commands):
+ @ # This fallback is unique but non-deterministic, making it sufficient to avoid generating the
+ @ # GNU build-id from the empty string and causing guaranteed collisions.
+ GO_BUILD_ID=$$( go tool buildid $(addprefix ${BUILD_DIR}/bin/, $@) || openssl rand -hex 32 ) && \
+- GNU_BUILD_ID=$$( echo $$GO_BUILD_ID | sha1sum | cut -d' ' -f1 ) && \
++ GNU_BUILD_ID=$$( echo $$GO_BUILD_ID | sha1 | cut -d' ' -f1 ) && \
+ go install -ldflags '${GO_LDFLAGS}'" -B 0x$$GNU_BUILD_ID" -tags "${GO_BUILD_TAGS}" $(addprefix ${GITALY_PACKAGE}/cmd/, $@)
+ endif
+
+@@ -558,7 +558,7 @@ libgit2: ${LIBGIT2_INSTALL_DIR}/lib/libgit2.a
# step. Both Omnibus and CNG assume it is in the Gitaly root, not in
# _build. Hence the '../' in front.
${SOURCE_DIR}/.ruby-bundle: ${GITALY_RUBY_DIR}/Gemfile.lock ${GITALY_RUBY_DIR}/Gemfile
diff --git a/devel/gitaly/files/patch-ruby_Gemfile b/devel/gitaly/files/patch-ruby_Gemfile
index 925a7bf48676..2f46adc53063 100644
--- a/devel/gitaly/files/patch-ruby_Gemfile
+++ b/devel/gitaly/files/patch-ruby_Gemfile
@@ -1,4 +1,4 @@
---- ruby/Gemfile.orig 2022-01-21 10:20:57 UTC
+--- ruby/Gemfile.orig 2022-02-21 12:41:47 UTC
+++ ruby/Gemfile
@@ -2,7 +2,7 @@ source 'https://rubygems.org'
@@ -6,10 +6,18 @@
gem 'github-linguist', '~> 7.12', require: 'linguist'
-gem 'gitlab-markup', '~> 1.7.1'
+gem 'gitlab-markup', '~> 1.8.0'
- gem 'activesupport', '~> 6.1.4.4'
+ gem 'activesupport', '~> 6.1.4.6'
gem 'rdoc', '~> 6.0'
gem 'gitlab-gollum-lib', '~> 4.2.7.10.gitlab.2', require: false
-@@ -20,22 +20,3 @@ gem 'gitlab-labkit', '~> 0.21.1'
+@@ -13,29 +13,10 @@ gem 'faraday', '~> 1.0'
+ gem 'rbtrace', require: false
+
+ # Labkit provides observability functionality
+-gem 'gitlab-labkit', '~> 0.21.1'
++gem 'gitlab-labkit', '~> 0.22.0'
+
+ # Detects the open source license the repository includes
+ # This version needs to be in sync with GitLab CE/EE
gem 'licensee', '~> 9.14.1'
gem 'google-protobuf', '~> 3.19.0'