aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2023-05-26 08:46:05 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2023-05-26 08:46:05 +0000
commitc5e7ca8dcf013e44a12fd6faa9a563d230efd4de (patch)
tree7c26540220a8affabc9d781e7e9f84ebb427ad1c
parent8e89562ef6c4a12d1cacd510a167a5c76b806160 (diff)
downloadports-c5e7ca8dcf013e44a12fd6faa9a563d230efd4de.tar.gz
ports-c5e7ca8dcf013e44a12fd6faa9a563d230efd4de.zip
graphics/3d-ascii-viewer-c: Add new port
3d-ascii-viewer-c is a program written in C that allows users to view 3D models in ASCII. It supports Wavefront .obj files and provides an example usage capture. The program can be executed by passing any of the models in the models folder as an argument. The available models include Fox and ShibaInu models, as well as Tree models. This program is inspired by the ASCII luminescence and offers an intuitive way of viewing 3D models in ASCII.
-rw-r--r--graphics/3d-ascii-viewer-c/Makefile29
-rw-r--r--graphics/3d-ascii-viewer-c/distinfo3
-rw-r--r--graphics/3d-ascii-viewer-c/files/patch-Makefile15
-rw-r--r--graphics/3d-ascii-viewer-c/pkg-descr12
-rw-r--r--graphics/Makefile1
5 files changed, 60 insertions, 0 deletions
diff --git a/graphics/3d-ascii-viewer-c/Makefile b/graphics/3d-ascii-viewer-c/Makefile
new file mode 100644
index 000000000000..a660361ba02a
--- /dev/null
+++ b/graphics/3d-ascii-viewer-c/Makefile
@@ -0,0 +1,29 @@
+PORTNAME= 3d-ascii-viewer-c
+PORTVERSION= 1.1.0
+DISTVERSIONPREFIX= v
+CATEGORIES= graphics
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Viewer of 3D models in ASCII
+WWW= https://github.com/autopawn/3d-ascii-viewer-c
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= gmake
+USE_GITHUB= yes
+GH_ACCOUNT= autopawn
+
+ALL_TARGET= 3d-ascii-viewer
+
+PLIST_FILES= bin/3d-ascii-viewer
+PORTEXAMPLES= *
+
+OPTIONS_DEFINE= EXAMPLES
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/3d-ascii-viewer ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/models
+ ${INSTALL_DATA} ${WRKSRC}/models/* ${STAGEDIR}${EXAMPLESDIR}/models/
+
+.include <bsd.port.mk>
diff --git a/graphics/3d-ascii-viewer-c/distinfo b/graphics/3d-ascii-viewer-c/distinfo
new file mode 100644
index 000000000000..62ff3c087f39
--- /dev/null
+++ b/graphics/3d-ascii-viewer-c/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1683962458
+SHA256 (autopawn-3d-ascii-viewer-c-v1.1.0_GH0.tar.gz) = 692100eaf4600033f8a8d07ca3e107a8b3a8ebdf59ac7f154149fda212cb7b12
+SIZE (autopawn-3d-ascii-viewer-c-v1.1.0_GH0.tar.gz) = 6864524
diff --git a/graphics/3d-ascii-viewer-c/files/patch-Makefile b/graphics/3d-ascii-viewer-c/files/patch-Makefile
new file mode 100644
index 000000000000..98d7f0090fdd
--- /dev/null
+++ b/graphics/3d-ascii-viewer-c/files/patch-Makefile
@@ -0,0 +1,15 @@
+--- Makefile.orig 2023-05-04 04:46:08 UTC
++++ Makefile
+@@ -1,9 +1,9 @@
+ TARGET_EXEC := 3d-ascii-viewer
+ TEMPDIR := tmp
+
+-CC := gcc
+-CFLAGS := -Wall
+-LDFLAGS := -lm -lncurses
++CC ?= gcc
++CFLAGS += -Wall
++LDFLAGS += -lm -lncurses
+ SRC_DIR := src
+
+ SRCS := $(shell find $(SRC_DIR) -name '*.c')
diff --git a/graphics/3d-ascii-viewer-c/pkg-descr b/graphics/3d-ascii-viewer-c/pkg-descr
new file mode 100644
index 000000000000..b965c8c6f242
--- /dev/null
+++ b/graphics/3d-ascii-viewer-c/pkg-descr
@@ -0,0 +1,12 @@
+3d-ascii-viewer-c is a program written in C that allows users to view 3D
+models in ASCII. It supports Wavefront .obj files and provides an
+example usage capture.
+
+The program can be executed by passing any of the models in the models
+folder as an argument.
+
+The available models include Fox and ShibaInu models, as well as Tree
+models.
+
+This program is inspired by the ASCII luminescence and offers an
+intuitive way of viewing 3D models in ASCII.
diff --git a/graphics/Makefile b/graphics/Makefile
index ff43fbdc9b85..557f61af875f 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -1,5 +1,6 @@
COMMENT = Graphics tools and libraries
+ SUBDIR += 3d-ascii-viewer-c
SUBDIR += 4va
SUBDIR += Coin
SUBDIR += GraphicsMagick