aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2009-04-11 13:23:05 +0000
committerStanislav Sedov <stas@FreeBSD.org>2009-04-11 13:23:05 +0000
commitc6762e80516b169cd71a8d7e68d0ed5b308f7e55 (patch)
treef23cbb8b9252353d844bff7e183b8b588e997854
parent3b03d918066c823f39536b8d108d1145c833a3dd (diff)
downloadports-c6762e80516b169cd71a8d7e68d0ed5b308f7e55.tar.gz
ports-c6762e80516b169cd71a8d7e68d0ed5b308f7e55.zip
- Update lang/ocaml to 3.11.0. [1]
- Fix devel/cil build with 3.11.0 by using proper object file name - Fix devel/deputy build with 3.11.0 by using proper object file name - Fix lang/mtasc. Ocamlp4 syntax has changed and usage of ';' as delimiters is not allowed now. - Fix usage message in lang/mtasc. - Implement a FreeBSD specific code for retriving the executable path in lang/mtasc. - Update devel/omake to 0.9.8.5. - Fix devel/omake compilation with 3.11 by dropping an unused reference from the code. - Fix www/geneweb build with 3.11 by not emitting errors for warnings. - Fix print/advi build. [2] - Update lang/cduce to 0.5.3 (this fixes build with ocaml 3.11.0). PR: ports/130845 [1] [2] (based on) Submitted by: Hirohisa Yamaguchi <umq@ueo.co.jp> [1], Tsurutani Naoki <turutani@scphys.kyoto-u.ac.jp> [2]
Notes
Notes: svn path=/head/; revision=232098
-rw-r--r--devel/cil/files/patch-Makefile.in25
-rw-r--r--devel/deputy/files/patch-cil-Makefile.in27
-rw-r--r--devel/omake/Makefile9
-rw-r--r--devel/omake/distinfo6
-rw-r--r--devel/omake/files/patch-src_exec_omake_exec.ml11
-rw-r--r--devel/omake/pkg-plist2
-rw-r--r--lang/cduce/Makefile5
-rw-r--r--lang/cduce/distinfo6
-rw-r--r--lang/cduce/files/patch-parser_cduce_curl.ml18
-rw-r--r--lang/mtasc/Makefile1
-rw-r--r--lang/mtasc/files/patch-basepath10
-rw-r--r--lang/mtasc/files/patch-extc_extc_stubs.c42
-rw-r--r--lang/mtasc/files/patch-mtasc_parser.ml40
-rw-r--r--lang/ocaml/Makefile15
-rw-r--r--lang/ocaml/distinfo6
-rw-r--r--lang/ocaml/files/mann1
-rw-r--r--lang/ocaml/files/patch-camlp4-man_Makefile10
-rw-r--r--lang/ocaml/files/patch-configure17
-rw-r--r--lang/ocaml/files/patch-stdlib_Makefile12
-rw-r--r--lang/ocaml/pkg-plist20
-rw-r--r--lang/ocamlduce/Makefile1
-rw-r--r--print/advi/Makefile1
-rw-r--r--www/geneweb/files/patch-tools_Makefile.inc.unix13
23 files changed, 221 insertions, 77 deletions
diff --git a/devel/cil/files/patch-Makefile.in b/devel/cil/files/patch-Makefile.in
new file mode 100644
index 000000000000..42d13b825bba
--- /dev/null
+++ b/devel/cil/files/patch-Makefile.in
@@ -0,0 +1,25 @@
+--- Makefile.in.orig 2009-04-10 02:07:19.000000000 +0400
++++ Makefile.in 2009-04-10 02:07:54.000000000 +0400
+@@ -213,7 +213,7 @@
+ # build two libraries
+ .PHONY: cillib libcil
+ ifeq ($(NATIVECAML),1)
+-cillib: $(OBJDIR)/cil.$(CMXA) $(OBJDIR)/libcil.a
++cillib: $(OBJDIR)/cil.$(CMXA) $(OBJDIR)/libcil.o
+ else
+ cillib: $(OBJDIR)/cil.$(CMXA)
+ endif
+@@ -271,11 +271,11 @@
+ # be called from C code; this is like the target above, except
+ # it is callable from C instead of from Ocaml
+ ifeq ($(NATIVECAML),1)
+-$(OBJDIR)/libcil.a: $(OCAML_CIL_LIB_CMODULES:%=$(OBJDIR)/lib%.a) \
++$(OBJDIR)/libcil.o: $(OCAML_CIL_LIB_CMODULES:%=$(OBJDIR)/lib%.a) \
+ $(OCAML_CIL_LIB_MODULES:%=$(OBJDIR)/%.$(CMO))
+ ocamlopt -output-obj -o $@ $(CILLY_LIBS:%=%.cmxa) $^
+ else
+-$(OBJDIR)/libcil.a:
++$(OBJDIR)/libcil.o:
+ @echo "Can only build $@ when NATIVECAML is 1."
+ exit 2
+ endif
diff --git a/devel/deputy/files/patch-cil-Makefile.in b/devel/deputy/files/patch-cil-Makefile.in
index 3133b4902f04..5ade88951148 100644
--- a/devel/deputy/files/patch-cil-Makefile.in
+++ b/devel/deputy/files/patch-cil-Makefile.in
@@ -1,5 +1,14 @@
---- cil/Makefile.in.orig Fri Mar 16 17:10:11 2007
-+++ cil/Makefile.in Fri Mar 16 17:10:16 2007
+--- cil/Makefile.in.orig 2007-02-02 15:22:17.000000000 +0300
++++ cil/Makefile.in 2009-04-11 00:18:21.000000000 +0400
+@@ -210,7 +210,7 @@
+ # build two libraries
+ .PHONY: cillib libcil
+ ifeq ($(NATIVECAML),1)
+-cillib: $(OBJDIR)/cil.$(CMXA) $(OBJDIR)/libcil.a
++cillib: $(OBJDIR)/cil.$(CMXA) $(OBJDIR)/libcil.o
+ else
+ cillib: $(OBJDIR)/cil.$(CMXA)
+ endif
@@ -236,7 +236,7 @@
endif
# Now the extra features, with the first letter capitalized
@@ -9,3 +18,17 @@
$(foreach f,@EXTRAFEATURES@, \
"\n "`echo $f | cut -c 1 | tr "[a-z]" "[A-Z]"``echo $f | cut -c 2-`".feature;") >> $@
echo "]" >>$@
+@@ -267,11 +267,11 @@
+ # be called from C code; this is like the target above, except
+ # it is callable from C instead of from Ocaml
+ ifeq ($(NATIVECAML),1)
+-$(OBJDIR)/libcil.a: $(OCAML_CIL_LIB_CMODULES:%=$(OBJDIR)/lib%.a) \
++$(OBJDIR)/libcil.o: $(OCAML_CIL_LIB_CMODULES:%=$(OBJDIR)/lib%.a) \
+ $(OCAML_CIL_LIB_MODULES:%=$(OBJDIR)/%.$(CMO))
+ ocamlopt -output-obj -o $@ $(CILLY_LIBS:%=%.cmxa) $^
+ else
+-$(OBJDIR)/libcil.a:
++$(OBJDIR)/libcil.o:
+ @echo "Can only build $@ when NATIVECAML is 1."
+ exit 2
+ endif
diff --git a/devel/omake/Makefile b/devel/omake/Makefile
index 0477d5df817b..da1f7329d5e3 100644
--- a/devel/omake/Makefile
+++ b/devel/omake/Makefile
@@ -7,12 +7,11 @@
#
PORTNAME= omake
-PORTVERSION= 0.9.8.1
-PORTREVISION= 1
+PORTVERSION= 0.9.8.5
+PORTREVISION= 0
CATEGORIES= devel
-MASTER_SITES= http://omake.metaprl.org/downloads/ \
- http://sunner.elcomnet.ru/~stas/
-DISTNAME= omake-0.9.8.1-1
+MASTER_SITES= http://omake.metaprl.org/downloads/
+DISTNAME= omake-0.9.8.5-3
MAINTAINER= stas@FreeBSD.org
COMMENT= A flexible build system
diff --git a/devel/omake/distinfo b/devel/omake/distinfo
index adbe66520f35..2660a07b9049 100644
--- a/devel/omake/distinfo
+++ b/devel/omake/distinfo
@@ -1,3 +1,3 @@
-MD5 (omake-0.9.8.1-1.tar.gz) = 1d0fb573fab8f4de38993f81f3d383cd
-SHA256 (omake-0.9.8.1-1.tar.gz) = 3265293803e75dcea72c62ebb18022b16e1984d59f1ab6cc4397b17b976f7500
-SIZE (omake-0.9.8.1-1.tar.gz) = 2919405
+MD5 (omake-0.9.8.5-3.tar.gz) = d114b3c4201808aacd73ec1a98965c47
+SHA256 (omake-0.9.8.5-3.tar.gz) = 5b675e09f49ff8249a775798f25ab127515cf2fed39527b202784757a35eddad
+SIZE (omake-0.9.8.5-3.tar.gz) = 3321245
diff --git a/devel/omake/files/patch-src_exec_omake_exec.ml b/devel/omake/files/patch-src_exec_omake_exec.ml
new file mode 100644
index 000000000000..249096522da8
--- /dev/null
+++ b/devel/omake/files/patch-src_exec_omake_exec.ml
@@ -0,0 +1,11 @@
+--- src/exec/omake_exec.ml.orig 2009-04-11 14:50:31.000000000 +0400
++++ src/exec/omake_exec.ml 2009-04-11 14:50:36.000000000 +0400
+@@ -46,8 +46,6 @@
+ open Omake_options
+ open Omake_command_type
+
+-external sync : unit -> unit = "caml_sync"
+-
+ module Exec =
+ struct
+ (*
diff --git a/devel/omake/pkg-plist b/devel/omake/pkg-plist
index 856161ca6037..30751b70dda3 100644
--- a/devel/omake/pkg-plist
+++ b/devel/omake/pkg-plist
@@ -14,6 +14,7 @@ lib/omake/build/svn_realclean.om
lib/omake/configure/Configure.om
lib/omake/configure/X.om
lib/omake/configure/fam.om
+lib/omake/configure/fs_case_sensitive.om
lib/omake/configure/ncurses.om
lib/omake/configure/readline.om
lib/omake/configure/snprintf.om
@@ -46,6 +47,7 @@ lib/omake/parse/C/Parse.om
%%PORTDOCS%%%%DOCSDIR%%/omake-fun-index.html
%%PORTDOCS%%%%DOCSDIR%%/omake-grammar.html
%%PORTDOCS%%%%DOCSDIR%%/omake-language-examples.html
+%%PORTDOCS%%%%DOCSDIR%%/omake-language-naming.html
%%PORTDOCS%%%%DOCSDIR%%/omake-language.html
%%PORTDOCS%%%%DOCSDIR%%/omake-obj-index.html
%%PORTDOCS%%%%DOCSDIR%%/omake-option-index.html
diff --git a/lang/cduce/Makefile b/lang/cduce/Makefile
index 9d4f50d30c3a..f76e489d0629 100644
--- a/lang/cduce/Makefile
+++ b/lang/cduce/Makefile
@@ -5,8 +5,8 @@
# $FreeBSD$
PORTNAME= cduce
-PORTVERSION= 0.5.2.1
-PORTREVISION= 1
+PORTVERSION= 0.5.3
+PORTREVISION= 0
CATEGORIES= lang
MASTER_SITES= http://www.cduce.org/download/ \
ftp://ftp.stack.nl/pub/users/johans/cduce/
@@ -33,7 +33,6 @@ INSTALL_TARGET= install_bin install_lib
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --with-ocamlopt --with-cgi --without-netclient --without-pxp_wlex --docdir=${DOCSDIR}
SITELIBDIR= ${LOCALBASE}/${OCAML_SITELIBDIR}
-WRKSRC= ${WRKDIR}/${DISTNAME:R}
MAN1= cduce.1 cduce_mktop.1 dtd2cduce.1
diff --git a/lang/cduce/distinfo b/lang/cduce/distinfo
index cc9696ba4a56..76e3c4d86e1f 100644
--- a/lang/cduce/distinfo
+++ b/lang/cduce/distinfo
@@ -1,3 +1,3 @@
-MD5 (cduce-0.5.2.1.tar.gz) = d2d52bf536c1a8f4397b4c64794d9322
-SHA256 (cduce-0.5.2.1.tar.gz) = 4edd13db651a26d0ce4751f7634eec11b06284839c31f47299a99af7b162b683
-SIZE (cduce-0.5.2.1.tar.gz) = 595196
+MD5 (cduce-0.5.3.tar.gz) = 5506326db28419b3f578ff225417448f
+SHA256 (cduce-0.5.3.tar.gz) = 38264f53790075c3046f9ea55984b50366e0888e80512b9cbc2ed42ff36f10b2
+SIZE (cduce-0.5.3.tar.gz) = 594275
diff --git a/lang/cduce/files/patch-parser_cduce_curl.ml b/lang/cduce/files/patch-parser_cduce_curl.ml
deleted file mode 100644
index f9d04b01077b..000000000000
--- a/lang/cduce/files/patch-parser_cduce_curl.ml
+++ /dev/null
@@ -1,18 +0,0 @@
---- parser/cduce_curl.ml 2008-02-25 11:10:42.000000000 +0100
-+++ parser/cduce_curl.ml 2009-02-13 16:52:26.000000000 +0100
-@@ -9,7 +9,14 @@
- let buff = Buffer.create 4096 in
- let conn = Curl.init () in
- Curl.set_url conn s;
-- Curl.set_writefunction conn (Buffer.add_string buff);
-+ Curl.set_writefunction conn (
-+ fun str ->
-+ try
-+ Buffer.add_string buff str;
-+ String.length str
-+ with
-+ Failure _ -> 0
-+ );
- Curl.perform conn;
- Buffer.contents buff
- with Curl.CurlException (code, n, msg) ->
diff --git a/lang/mtasc/Makefile b/lang/mtasc/Makefile
index 620c4aaa4e4d..60cb02ac437b 100644
--- a/lang/mtasc/Makefile
+++ b/lang/mtasc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mtasc
PORTVERSION= 1.14
+PORTREVISION= 1
CATEGORIES= lang www
MASTER_SITES= http://saper.info/distfiles/ LOCAL/chinsan
diff --git a/lang/mtasc/files/patch-basepath b/lang/mtasc/files/patch-basepath
index a28f5e7d7977..012583a41249 100644
--- a/lang/mtasc/files/patch-basepath
+++ b/lang/mtasc/files/patch-basepath
@@ -1,10 +1,12 @@
---- mtasc/main.ml.orig 2008-09-06 03:09:02.176005686 +0200
-+++ mtasc/main.ml 2008-09-06 03:11:37.642045225 +0200
-@@ -113,7 +113,7 @@
+--- mtasc/main.ml.orig 2008-08-31 15:14:17.000000000 +0400
++++ mtasc/main.ml 2009-04-11 12:38:50.000000000 +0400
+@@ -112,8 +112,8 @@
+ if do_exit then exit 1
;;
try
- let usage = "Motion-Twin ActionScript2 Compiler 1.14 - (c)2004-2008 Motion-Twin\n Usage : mtasc.exe [options] <files...>\n Options :" in
+- let usage = "Motion-Twin ActionScript2 Compiler 1.14 - (c)2004-2008 Motion-Twin\n Usage : mtasc.exe [options] <files...>\n Options :" in
- let base_path = normalize_path (try Extc.executable_path() with _ -> ".") in
++ let usage = "Motion-Twin ActionScript2 Compiler 1.14 - (c)2004-2008 Motion-Twin\n Usage : mtasc [options] <files...>\n Options :" in
+ let base_path = normalize_path (try Extc.executable_path() ^ "/.." with _ -> "..") in
let files = ref [] in
let time = Sys.time() in
diff --git a/lang/mtasc/files/patch-extc_extc_stubs.c b/lang/mtasc/files/patch-extc_extc_stubs.c
new file mode 100644
index 000000000000..f9411fe39ada
--- /dev/null
+++ b/lang/mtasc/files/patch-extc_extc_stubs.c
@@ -0,0 +1,42 @@
+--- extc/extc_stubs.c.orig 2007-03-05 14:09:37.000000000 +0300
++++ extc/extc_stubs.c 2009-04-11 12:57:23.000000000 +0400
+@@ -32,6 +32,11 @@
+ # include <sys/syslimits.h>
+ # include <mach-o/dyld.h>
+ #endif
++#ifdef __FreeBSD__
++# include <sys/param.h>
++# include <sys/sysctl.h>
++# include <sys/user.h>
++#endif
+
+ #define zval(z) ((z_streamp)(z))
+
+@@ -125,7 +130,26 @@
+ }
+
+ CAMLprim value executable_path(value u) {
+-#ifdef _WIN32
++#if defined(__FreeBSD__)
++ char pathname[PATH_MAX];
++ int error, name[4];
++ size_t len;
++ pid_t pid;
++
++ pid = getpid();
++ name[0] = CTL_KERN;
++ name[1] = KERN_PROC;
++ name[2] = KERN_PROC_PATHNAME;
++ name[3] = pid;
++
++ len = sizeof(pathname);
++ error = sysctl(name, 4, pathname, &len, NULL, 0);
++ if (error < 0 && errno != ESRCH)
++ warn("sysctl: kern.proc.pathname: %d", pid);
++ if (error < 0)
++ return caml_copy_string("-");
++ return caml_copy_string(pathname);
++#elif defined(_WIN32)
+ char path[MAX_PATH];
+ if( GetModuleFileName(NULL,path,MAX_PATH) == 0 )
+ failwith("executable_path");
diff --git a/lang/mtasc/files/patch-mtasc_parser.ml b/lang/mtasc/files/patch-mtasc_parser.ml
new file mode 100644
index 000000000000..2c504486ec20
--- /dev/null
+++ b/lang/mtasc/files/patch-mtasc_parser.ml
@@ -0,0 +1,40 @@
+--- mtasc/parser.ml.orig 2009-04-11 12:35:07.000000000 +0400
++++ mtasc/parser.ml 2009-04-11 12:37:16.000000000 +0400
+@@ -166,8 +166,8 @@
+ | [< '(Kwd For,p); '(POpen,_); c = parse_expr_opt; e = parse_for p c >] -> e
+ | [< '(Kwd If,p); cond = parse_eval; e = parse_expr_opt; e2 , p2 = parse_else (pos e) >] -> EIf (cond,wrap_var e,e2), punion p p2
+ | [< '(Kwd Return,p); v , p2 = parse_eval_option p; >] -> EReturn v , punion p p2
+- | [< '(Kwd Break,p); >] -> EBreak , p
+- | [< '(Kwd Continue,p); >] -> EContinue , p
++ | [< '(Kwd Break,p) >] -> EBreak , p
++ | [< '(Kwd Continue,p) >] -> EContinue , p
+ | [< '(Kwd While,p1); v = parse_eval; e = parse_expr_opt >] -> EWhile (v,wrap_var e,NormalWhile) , punion p1 (pos e)
+ | [< '(Kwd Do,p1); e = parse_expr; '(Kwd While,_); v = parse_eval; >] -> EWhile (v,wrap_var e,DoWhile) , punion p1 (pos v)
+ | [< '(Kwd Switch,p1); v = parse_eval; '(BrOpen,_); el, p2 = parse_switch false >] -> ESwitch (v,el) , punion p1 p2
+@@ -278,7 +278,7 @@
+
+ and parse_expr_opt = parser
+ | [< e = parse_expr >] -> e
+- | [< '(Next,p); >] -> EBlock [] , p
++ | [< '(Next,p) >] -> EBlock [] , p
+
+ and parse_for p c = parser
+ | [< '(Kwd In,_); v = parse_eval; '(PClose,p2); e = parse_expr_opt >] -> EForIn(c,v,wrap_var e) , punion p p2
+@@ -324,7 +324,7 @@
+ and parse_block callb sp = parser
+ | [< e = callb; el,p = parse_block callb sp >] -> e :: el , p
+ | [< '(Next,_); el = parse_block callb sp >] -> el
+- | [< '(BrClose,p); >] -> [] , p
++ | [< '(BrClose,p) >] -> [] , p
+ | [< '(Eof,_) >] -> error Unclosed_parenthesis sp
+
+ and parse_expr_list p = parser
+@@ -351,7 +351,7 @@
+
+ and parse_import = parser
+ | [< '(Const (Ident name),_); p = parse_import2 name >] -> p
+- | [< '(Binop OpMult,_); >] -> [] , None
++ | [< '(Binop OpMult,_) >] -> [] , None
+
+ and parse_import2 name = parser
+ | [< '(Dot,_); p , n = parse_import >] -> name :: p , n
diff --git a/lang/ocaml/Makefile b/lang/ocaml/Makefile
index 2cc85c6a0e80..58c1d8ef4d43 100644
--- a/lang/ocaml/Makefile
+++ b/lang/ocaml/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ocaml
-PORTVERSION= 3.10.2
-PORTREVISION= 1
+PORTVERSION= 3.11.0
CATEGORIES= lang
MASTER_SITES= http://caml.inria.fr/distrib/${DISTNAME:R}/ \
ftp://ftp.inria.fr/INRIA/caml-light/${DISTNAME:R}/ \
@@ -22,6 +21,7 @@ COMMENT?= The Objective Caml compiler and programming environment
USE_BZIP2= yes
REINPLACE_ARGS= -i ""
HAS_CONFIGURE= yes
+USE_LDCONFIG= yes
ALL_TARGET= world.opt
STRIP=
@@ -70,14 +70,13 @@ SFX= -notk
CONFLICTS+= ocaml-[0-9]* ocaml-nox11-[0-9]*
CONFIGURE_ARGS+=-no-tk
.else
+USE_TK= 84+
+.include "${PORTSDIR}/Mk/bsd.tcl.mk"
PLIST_SUB+= TK=""
CONFLICTS+= ocaml-nox11-[0-9]* ocaml-notk-[0-9]*
-CONFIGURE_ARGS+=-tkdefs \
- "-I${LOCALBASE}/include/tcl8.4 -I${LOCALBASE}/include/tk8.4 ${THR_CPP}"\
- -tklibs "-L${LOCALBASE}/lib ${THR_LD}"
-BUILD_DEPENDS+= ${LOCALBASE}/include/tcl8.4:${PORTSDIR}/lang/tcl84 \
- ${LOCALBASE}/include/tk8.4:${PORTSDIR}/x11-toolkits/tk84
-LIB_DEPENDS+= tk84.1:${PORTSDIR}/x11-toolkits/tk84
+CONFIGURE_ARGS+= -tkdefs \
+ "-I${TCL_INCLUDEDIR} -I${TK_INCLUDEDIR} ${THR_CPP}" \
+ -tklibs "-L${LOCALBASE}/lib ${THR_LD}"
.endif
.if ${ARCH} == sparc64 || ${ARCH} == ia64
diff --git a/lang/ocaml/distinfo b/lang/ocaml/distinfo
index adbdc5c2364c..8997fbd3636f 100644
--- a/lang/ocaml/distinfo
+++ b/lang/ocaml/distinfo
@@ -1,3 +1,3 @@
-MD5 (ocaml-3.10.2.tar.bz2) = d86f8f8aa4574fa60dd6f89044580307
-SHA256 (ocaml-3.10.2.tar.bz2) = 3755a32da1a7490d47fff7838c12c754d3fcfe69d7c9ff2358704259dc477c58
-SIZE (ocaml-3.10.2.tar.bz2) = 2284860
+MD5 (ocaml-3.11.0.tar.bz2) = 6ed1c3ed660a15408362242fa8fa4668
+SHA256 (ocaml-3.11.0.tar.bz2) = 3faa9057bdac916413a5dee17180f5a8fbc7fb7589465208f72f692bddbd6776
+SIZE (ocaml-3.11.0.tar.bz2) = 2359311
diff --git a/lang/ocaml/files/mann b/lang/ocaml/files/mann
index f2f57930f306..8540f41cb8ab 100644
--- a/lang/ocaml/files/mann
+++ b/lang/ocaml/files/mann
@@ -79,3 +79,4 @@ Weak.Make.n
Weak.S.n
Weak.n
CamlinternalMod.n
+CamlinternalLazy.n
diff --git a/lang/ocaml/files/patch-camlp4-man_Makefile b/lang/ocaml/files/patch-camlp4-man_Makefile
index 2626d2574ce6..d2d090287e96 100644
--- a/lang/ocaml/files/patch-camlp4-man_Makefile
+++ b/lang/ocaml/files/patch-camlp4-man_Makefile
@@ -1,14 +1,14 @@
---- ./camlp4/man/Makefile.orig Thu Jul 3 20:14:49 2003
-+++ ./camlp4/man/Makefile Sun May 21 14:02:41 2006
+--- ./camlp4/man/Makefile.orig 2008-10-27 23:03:31.000000000 +0900
++++ ./camlp4/man/Makefile 2009-01-21 01:35:26.000000000 +0900
@@ -3,7 +3,6 @@
- include ../config/Makefile
+ include ../config/Makefile.cnf
TARGET=camlp4.1
-ALIASES=camlp4o.1 camlp4r.1 mkcamlp4.1 ocpp.1 camlp4o.opt.1 camlp4r.opt.1
- all: $(TARGET)
+ include ../config/Makefile.base
-@@ -18,10 +17,6 @@
+@@ -11,10 +10,6 @@
if test -n '$(MANDIR)'; then \
$(MKDIR) $(MANDIR)/man1 ; \
cp $(TARGET) $(MANDIR)/man1/. ; \
diff --git a/lang/ocaml/files/patch-configure b/lang/ocaml/files/patch-configure
index 3d3fc9eb03d1..12a76b7f2081 100644
--- a/lang/ocaml/files/patch-configure
+++ b/lang/ocaml/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2008-01-04 16:26:38.000000000 +0300
-+++ configure 2009-04-06 23:35:00.000000000 +0400
-@@ -79,6 +79,8 @@
+--- ./configure.orig 2008-11-07 19:34:16.000000000 +0900
++++ ./configure 2009-01-21 01:41:11.000000000 +0900
+@@ -85,6 +85,8 @@
withcurses=no;;
-no-shared-libs)
withsharedlibs=no;;
@@ -9,15 +9,15 @@
-x11include*|--x11include*)
x11_include_dir=$2; shift;;
-x11lib*|--x11lib*)
-@@ -686,6 +688,7 @@
- i386,*,gnu) profiling='prof';;
+@@ -739,6 +741,7 @@
i386,*,bsd_elf) profiling='prof';;
+ amd64,*,macosx) profiling='prof';;
i386,*,macosx) profiling='prof';;
+ *,*,freebsd) profiling='prof';;
sparc,*,solaris)
profiling='prof'
case "$nativecc" in gcc*) ;; *) cc_profile='-xpg';; esac;;
-@@ -1132,124 +1135,24 @@
+@@ -1183,127 +1186,24 @@
x11_include="not found"
x11_link="not found"
@@ -129,8 +129,11 @@
- if test $dir = /usr/lib; then
- x11_link="-lX11"
- else
-- x11_link="-L$dir -lX11"
- x11_libs="-L$dir"
+- case "$host" in
+- *-*-*bsd*) x11_link="-R$dir -L$dir -lX11";;
+- *) x11_link="-L$dir -lX11";;
+- esac
- fi
- break
- fi
diff --git a/lang/ocaml/files/patch-stdlib_Makefile b/lang/ocaml/files/patch-stdlib_Makefile
deleted file mode 100644
index 9bd92e1c2566..000000000000
--- a/lang/ocaml/files/patch-stdlib_Makefile
+++ /dev/null
@@ -1,12 +0,0 @@
---- ./stdlib/Makefile.orig Mon Nov 29 17:53:30 2004
-+++ ./stdlib/Makefile Sun May 21 14:02:41 2006
-@@ -48,8 +48,7 @@
- rm -f std_exit.p.cmi
-
- install:
-- cp stdlib.cma std_exit.cmo *.cmi *.mli *.ml camlheader camlheader_ur \
-- $(LIBDIR)
-+ cp stdlib.cma std_exit.cmo *.cmi *.mli *.ml camlheader camlheader_ur $(LIBDIR)
-
- installopt: installopt-default installopt-$(PROFILING)
-
diff --git a/lang/ocaml/pkg-plist b/lang/ocaml/pkg-plist
index ee26a1ed5069..07c2ec076fa1 100644
--- a/lang/ocaml/pkg-plist
+++ b/lang/ocaml/pkg-plist
@@ -66,6 +66,7 @@ lib/ocaml/bigarray.cma
lib/ocaml/bigarray.cmi
lib/ocaml/bigarray.cmx
lib/ocaml/bigarray.cmxa
+lib/ocaml/bigarray.cmxs
lib/ocaml/bigarray.mli
lib/ocaml/buffer.cmi
lib/ocaml/buffer.cmx
@@ -93,6 +94,11 @@ lib/ocaml/caml/signals.h
lib/ocaml/caml/unixsupport.h
lib/ocaml/camlheader
lib/ocaml/camlheader_ur
+lib/ocaml/camlinternalLazy.cmi
+lib/ocaml/camlinternalLazy.cmx
+lib/ocaml/camlinternalLazy.ml
+lib/ocaml/camlinternalLazy.mli
+lib/ocaml/camlinternalLazy.p.cmx
lib/ocaml/camlinternalMod.cmi
lib/ocaml/camlinternalMod.cmx
lib/ocaml/camlinternalMod.ml
@@ -136,10 +142,6 @@ lib/ocaml/camlp4/Camlp4Filters/Camlp4Profiler.cmi
lib/ocaml/camlp4/Camlp4Filters/Camlp4Profiler.cmo
lib/ocaml/camlp4/Camlp4Filters/Camlp4Profiler.cmx
lib/ocaml/camlp4/Camlp4Filters/Camlp4Profiler.o
-lib/ocaml/camlp4/Camlp4Filters/Camlp4Tracer.cmi
-lib/ocaml/camlp4/Camlp4Filters/Camlp4Tracer.cmo
-lib/ocaml/camlp4/Camlp4Filters/Camlp4Tracer.cmx
-lib/ocaml/camlp4/Camlp4Filters/Camlp4Tracer.o
lib/ocaml/camlp4/Camlp4Filters/Camlp4TrashRemover.cmi
lib/ocaml/camlp4/Camlp4Filters/Camlp4TrashRemover.cmo
lib/ocaml/camlp4/Camlp4Filters/Camlp4TrashRemover.cmx
@@ -268,14 +270,18 @@ lib/ocaml/dbm.cma
lib/ocaml/dbm.cmi
lib/ocaml/dbm.cmx
lib/ocaml/dbm.cmxa
+lib/ocaml/dbm.cmxs
lib/ocaml/dbm.mli
lib/ocaml/digest.cmi
lib/ocaml/digest.cmx
lib/ocaml/digest.ml
lib/ocaml/digest.mli
lib/ocaml/digest.p.cmx
+lib/ocaml/dynlink.a
lib/ocaml/dynlink.cma
lib/ocaml/dynlink.cmi
+lib/ocaml/dynlink.cmx
+lib/ocaml/dynlink.cmxa
lib/ocaml/dynlink.mli
lib/ocaml/event.mli
lib/ocaml/expunge
@@ -305,8 +311,10 @@ lib/ocaml/genlex.p.cmx
%%X11%%lib/ocaml/graphics.cmi
%%X11%%lib/ocaml/graphics.cmx
%%X11%%lib/ocaml/graphics.cmxa
+%%X11%%lib/ocaml/graphics.cmxs
%%X11%%lib/ocaml/graphics.mli
%%X11%%lib/ocaml/graphicsX11.cmi
+%%X11%%lib/ocaml/graphicsX11.cmx
%%X11%%lib/ocaml/graphicsX11.mli
lib/ocaml/hashtbl.cmi
lib/ocaml/hashtbl.cmx
@@ -664,6 +672,7 @@ lib/ocaml/libasmrun.a
lib/ocaml/libasmrunp.a
lib/ocaml/libbigarray.a
lib/ocaml/libcamlrun.a
+lib/ocaml/libcamlrun_shared.so
%%X11%%lib/ocaml/libgraphics.a
lib/ocaml/libmldbm.a
lib/ocaml/libnums.a
@@ -711,6 +720,7 @@ lib/ocaml/num.mli
lib/ocaml/nums.a
lib/ocaml/nums.cma
lib/ocaml/nums.cmxa
+lib/ocaml/nums.cmxs
lib/ocaml/obj.cmi
lib/ocaml/obj.cmx
lib/ocaml/obj.ml
@@ -870,6 +880,7 @@ lib/ocaml/str.cma
lib/ocaml/str.cmi
lib/ocaml/str.cmx
lib/ocaml/str.cmxa
+lib/ocaml/str.cmxs
lib/ocaml/str.mli
lib/ocaml/stream.cmi
lib/ocaml/stream.cmx
@@ -926,6 +937,7 @@ lib/ocaml/unix.cma
lib/ocaml/unix.cmi
lib/ocaml/unix.cmx
lib/ocaml/unix.cmxa
+lib/ocaml/unix.cmxs
lib/ocaml/unix.mli
lib/ocaml/unixLabels.cmi
lib/ocaml/unixLabels.cmx
diff --git a/lang/ocamlduce/Makefile b/lang/ocamlduce/Makefile
index 1e3ab51fcc63..864184d08bd4 100644
--- a/lang/ocamlduce/Makefile
+++ b/lang/ocamlduce/Makefile
@@ -22,6 +22,7 @@ USE_OCAML_LDCONFIG= yes
USE_OCAML_PLIST= yes
ALL_TARGET= all opt
+BROKEN= does not build with current version of lang/ocaml
.include <bsd.port.pre.mk>
diff --git a/print/advi/Makefile b/print/advi/Makefile
index f90c3124f9fe..582bf762d83a 100644
--- a/print/advi/Makefile
+++ b/print/advi/Makefile
@@ -44,6 +44,7 @@ post-extract:
-e 's,^(X11_INCLUDES[[:space:]]*=).*,\1-I${LOCALBASE}/include,' \
-e 's,install -m 644,\$${BSD_INSTALL_DATA},' \
-e 's,install -m 755,\$${BSD_INSTALL_PROGRAM},' \
+ -e 's,^LIBRARIES = graphics,LIBRARIES =,' \
${WRKSRC}/Makefile
.include <bsd.port.mk>
diff --git a/www/geneweb/files/patch-tools_Makefile.inc.unix b/www/geneweb/files/patch-tools_Makefile.inc.unix
new file mode 100644
index 000000000000..f9916a8a0b2a
--- /dev/null
+++ b/www/geneweb/files/patch-tools_Makefile.inc.unix
@@ -0,0 +1,13 @@
+--- tools/Makefile.inc.unix.orig 2009-04-11 15:01:55.000000000 +0400
++++ tools/Makefile.inc.unix 2009-04-11 15:02:01.000000000 +0400
+@@ -5,8 +5,8 @@
+ CAMLP5F=-DUNIX
+ CAMLP5D=+camlp5
+ LIBUNIX=-cclib -lunix
+-OCAMLC=ocamlc.opt -warn-error A
+-OCAMLOPT=ocamlopt.opt -warn-error A
++OCAMLC=ocamlc.opt
++OCAMLOPT=ocamlopt.opt
+ OCAMLI=
+ OCAMLD=
+ STRIP=strip