aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-07-09 10:10:21 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-07-09 10:10:21 +0000
commitc6a13c6a8342ee029b240ece46013d5792d78d9a (patch)
tree51ae35fcc6a085146e0415d15d8294e7dc947915
parentc627bda70687ce314ec01bb39308f7533869d143 (diff)
downloadports-c6a13c6a8342ee029b240ece46013d5792d78d9a.tar.gz
ports-c6a13c6a8342ee029b240ece46013d5792d78d9a.zip
devel/py-aiorwlock: Add py-aiorwlock 1.3.0
aiorwlock provides read write lock for asyncio . A RWLock maintains a pair of associated locks, one for read-only operations and one for writing. The read lock may be held simultaneously by multiple reader tasks, so long as there are no writers. The write lock is exclusive. Whether or not a read-write lock will improve performance over the use of a mutual exclusion lock depends on the frequency that the data is read compared to being modified. For example, a collection that is initially populated with data and thereafter infrequently modified, while being frequently searched is an ideal candidate for the use of a read-write lock. However, if updates become frequent then the data spends most of its time being exclusively locked and there is little, if any increase in concurrency.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-aiorwlock/Makefile19
-rw-r--r--devel/py-aiorwlock/distinfo3
-rw-r--r--devel/py-aiorwlock/pkg-descr12
4 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 656d457e4d40..efebea912f3e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4197,6 +4197,7 @@
SUBDIR += py-aiologger
SUBDIR += py-aiorpcX
SUBDIR += py-aiortc
+ SUBDIR += py-aiorwlock
SUBDIR += py-aiosignal
SUBDIR += py-airtable-python-wrapper
SUBDIR += py-amalgamate
diff --git a/devel/py-aiorwlock/Makefile b/devel/py-aiorwlock/Makefile
new file mode 100644
index 000000000000..7f44ce2eaba7
--- /dev/null
+++ b/devel/py-aiorwlock/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= aiorwlock
+PORTVERSION= 1.3.0
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Read write lock for asyncio
+WWW= https://github.com/aio-libs/aiorwlock
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-aiorwlock/distinfo b/devel/py-aiorwlock/distinfo
new file mode 100644
index 000000000000..390a6f28add9
--- /dev/null
+++ b/devel/py-aiorwlock/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1688166002
+SHA256 (aiorwlock-1.3.0.tar.gz) = 83f12d87df4b9728a0b8fda1756585ab0d652b107bab59c6084e1b1ad692ab45
+SIZE (aiorwlock-1.3.0.tar.gz) = 12945
diff --git a/devel/py-aiorwlock/pkg-descr b/devel/py-aiorwlock/pkg-descr
new file mode 100644
index 000000000000..7a954b551982
--- /dev/null
+++ b/devel/py-aiorwlock/pkg-descr
@@ -0,0 +1,12 @@
+aiorwlock provides read write lock for asyncio . A RWLock maintains a pair of
+associated locks, one for read-only operations and one for writing. The read
+lock may be held simultaneously by multiple reader tasks, so long as there are
+no writers. The write lock is exclusive.
+
+Whether or not a read-write lock will improve performance over the use of a
+mutual exclusion lock depends on the frequency that the data is read compared to
+being modified. For example, a collection that is initially populated with data
+and thereafter infrequently modified, while being frequently searched is an
+ideal candidate for the use of a read-write lock. However, if updates become
+frequent then the data spends most of its time being exclusively locked and
+there is little, if any increase in concurrency.