aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-10-07 06:24:19 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-10-07 06:24:19 +0000
commitc6a8430aee9f6b3ae9a3604644026979025a4ce7 (patch)
tree5dedbf73b02521d5b7733f8fe281716a3f5da10f
parent24bca4aeb5e1c1876b67e9fabc420cd4dea76366 (diff)
downloadports-c6a8430aee9f6b3ae9a3604644026979025a4ce7.tar.gz
ports-c6a8430aee9f6b3ae9a3604644026979025a4ce7.zip
New port: devel/py-jsonpickle: Python library for serializing any arbitrary object graph into JSON
Notes
Notes: svn path=/head/; revision=481431
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-jsonpickle/Makefile19
-rw-r--r--devel/py-jsonpickle/distinfo3
-rw-r--r--devel/py-jsonpickle/pkg-descr10
4 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 383bfed011ee..255195fe7bd1 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4670,6 +4670,7 @@
SUBDIR += py-jsonlib2
SUBDIR += py-jsonlines
SUBDIR += py-jsonpatch
+ SUBDIR += py-jsonpickle
SUBDIR += py-jsonpointer
SUBDIR += py-jsonref
SUBDIR += py-jsonrpclib
diff --git a/devel/py-jsonpickle/Makefile b/devel/py-jsonpickle/Makefile
new file mode 100644
index 000000000000..7fe44986e1a3
--- /dev/null
+++ b/devel/py-jsonpickle/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= jsonpickle
+DISTVERSION= 1.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python library for serializing any arbitrary object graph into JSON
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-jsonpickle/distinfo b/devel/py-jsonpickle/distinfo
new file mode 100644
index 000000000000..bacc568f450c
--- /dev/null
+++ b/devel/py-jsonpickle/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1538893231
+SHA256 (jsonpickle-1.0.tar.gz) = d43ede55b3d9b5524a8e11566ea0b11c9c8109116ef6a509a1b619d2041e7397
+SIZE (jsonpickle-1.0.tar.gz) = 70899
diff --git a/devel/py-jsonpickle/pkg-descr b/devel/py-jsonpickle/pkg-descr
new file mode 100644
index 000000000000..fc62f19feb9c
--- /dev/null
+++ b/devel/py-jsonpickle/pkg-descr
@@ -0,0 +1,10 @@
+jsonpickle is a Python library for serialization and deserialization of complex
+Python objects to and from JSON. The standard Python libraries for encoding
+Python into JSON, such as the stdlib's json, simplejson, and demjson, can only
+handle Python primitives that have a direct JSON equivalent (e.g. dicts, lists,
+strings, ints, etc.). jsonpickle builds on top of these libraries and allows
+more complex data structures to be serialized to JSON. jsonpickle is highly
+configurable and extendable-allowing the user to choose the JSON backend and add
+additional backends.
+
+WWW: https://jsonpickle.github.io/