aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2022-12-07 21:40:25 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2022-12-07 21:40:25 +0000
commitc6a8e65577414d70cc6110336a7d6b8863c1cd92 (patch)
treeda82f29fe0a6b4d8a96fb9474a86004c747b1e21
parenta3d310920338a083f0412d99d4e293c84d8f06cc (diff)
downloadports-c6a8e65577414d70cc6110336a7d6b8863c1cd92.tar.gz
ports-c6a8e65577414d70cc6110336a7d6b8863c1cd92.zip
devel/clazy: USES=compiler does not make sense with explicit compiler
-rw-r--r--devel/clazy/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/devel/clazy/Makefile b/devel/clazy/Makefile
index a6b372fa12b4..c51f0ae4f33f 100644
--- a/devel/clazy/Makefile
+++ b/devel/clazy/Makefile
@@ -17,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING-LGPL2.txt
BUILD_DEPENDS= llvm${LLVM_DEFAULT}>0:devel/llvm${LLVM_DEFAULT}
RUN_DEPENDS= llvm${LLVM_DEFAULT}>0:devel/llvm${LLVM_DEFAULT}
-USES= cmake compiler:c++17-lang tar:xz
+USES= cmake tar:xz
CMAKE_ARGS= -DLLVM_ROOT=${LOCALBASE}/llvm${LLVM_DEFAULT}
@@ -26,8 +26,6 @@ OPTIONS_DEFINE= DOCS
DOCS_CMAKE_BOOL= CLAZY_MAN_PAGE
-.include <bsd.port.options.mk>
-
CPP= ${LOCALBASE}/bin/clang-cpp${LLVM_DEFAULT}
CC= ${LOCALBASE}/bin/clang${LLVM_DEFAULT}
CXX= ${LOCALBASE}/bin/clang++${LLVM_DEFAULT}