aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2023-07-20 09:23:57 +0000
committerNicola Vitale <nivit@FreeBSD.org>2023-07-20 09:23:57 +0000
commitc7b44004f9d2ac06e2f5304423166eda37cea547 (patch)
tree83a53be69f3aa6dd1fc91f377db4828d9a7471a2
parent6e5a6d0c06c3b070490f2ac45de2e4d5b18158e9 (diff)
downloadports-c7b44004f9d2ac06e2f5304423166eda37cea547.tar.gz
ports-c7b44004f9d2ac06e2f5304423166eda37cea547.zip
audio/libechonest: Fix build with llvm16
- Pet port(clippy|fmt|lint) Reported by: pkg-fallout
-rw-r--r--audio/libechonest/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/audio/libechonest/Makefile b/audio/libechonest/Makefile
index e8b0b68b648f..8f39dc9f8ba5 100644
--- a/audio/libechonest/Makefile
+++ b/audio/libechonest/Makefile
@@ -13,18 +13,19 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libqjson-qt5.so:devel/qjson
USES= cmake compiler:c++11-lang pkgconfig qt:5
-USE_LDCONFIG= yes
+USE_CXXSTD= c++14
USE_GITHUB= yes
+USE_LDCONFIG= yes
GH_ACCOUNT= lfranchi
-USE_QT= core buildtools:build qmake:build network xml
+USE_QT= core network xml buildtools:build qmake:build
CMAKE_OFF+= BUILD_WITH_QT4
PLIST_SUB= PORTVERSION=${PORTVERSION}
OPTIONS_DEFINE= TEST
-TEST_USE= QT=testlib:build
-TEST_CMAKE_BOOL=ECHONEST_BUILD_TESTS
+TEST_USE= QT=testlib:build
+TEST_CMAKE_BOOL= ECHONEST_BUILD_TESTS
.include <bsd.port.mk>