aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-08-05 04:01:26 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-08-06 22:06:25 +0000
commitc7b4ee785e1dd2003db4415d8c29df437adb5fb5 (patch)
tree31d0524035e5753c57ac2a5419239ab3b7aff792
parent48f47042b774ff666b694792c73b46a6abc514a7 (diff)
downloadports-c7b4ee785e1dd2003db4415d8c29df437adb5fb5.tar.gz
ports-c7b4ee785e1dd2003db4415d8c29df437adb5fb5.zip
x11-toolkits/gtk40: update to 4.12.0
Changes: https://gitlab.gnome.org/GNOME/gtk/-/blob/4.12.0/NEWS Reported by: GitLab (notify releases)
-rw-r--r--x11-toolkits/gtk40/Makefile8
-rw-r--r--x11-toolkits/gtk40/distinfo6
-rw-r--r--x11-toolkits/gtk40/files/patch-gtk_print_gtkprinteroptionprivate.h54
-rw-r--r--x11-toolkits/gtk40/pkg-plist34
4 files changed, 82 insertions, 20 deletions
diff --git a/x11-toolkits/gtk40/Makefile b/x11-toolkits/gtk40/Makefile
index 68151c2e3744..ad4b1922a71d 100644
--- a/x11-toolkits/gtk40/Makefile
+++ b/x11-toolkits/gtk40/Makefile
@@ -1,6 +1,5 @@
PORTNAME= gtk
-PORTVERSION= 4.10.4
-PORTREVISION= 1
+PORTVERSION= 4.12.0
CATEGORIES= x11-toolkits
MASTER_SITES= GNOME
PKGNAMESUFFIX= 4
@@ -38,7 +37,7 @@ LDFLAGS+= -lexecinfo
BINARY_ALIAS= python3=${PYTHON_CMD}
-LIBVERSION= 1.1000.4
+LIBVERSION= 1.1200.0
PLIST_SUB+= LIBVERSION=${LIBVERSION}
GLIB_SCHEMAS= org.gtk.Demo4.gschema.xml \
@@ -67,7 +66,8 @@ GSTREAMER_USES= gstreamer
GSTREAMER_USE= GSTREAMER=bad,gl
VULKAN_DESC= GDK Vulkan renderer backend
-VULKAN_BUILD_DEPENDS= vulkan-headers>0:graphics/vulkan-headers
+VULKAN_BUILD_DEPENDS= glslc:graphics/shaderc \
+ vulkan-headers>0:graphics/vulkan-headers
VULKAN_LIB_DEPENDS= libvulkan.so:graphics/vulkan-loader
VULKAN_RUN_DEPENDS= vulkan-headers>0:graphics/vulkan-headers
VULKAN_MESON_ENABLED= vulkan
diff --git a/x11-toolkits/gtk40/distinfo b/x11-toolkits/gtk40/distinfo
index 0387445a9181..23be42d7c019 100644
--- a/x11-toolkits/gtk40/distinfo
+++ b/x11-toolkits/gtk40/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1685978842
-SHA256 (gnome/gtk-4.10.4.tar.xz) = 7725400482e0685e28265e226c62847f4e73cfca9e9b416ac5838207f5377a24
-SIZE (gnome/gtk-4.10.4.tar.xz) = 20526652
+TIMESTAMP = 1691208086
+SHA256 (gnome/gtk-4.12.0.tar.xz) = a6d10829f405b1afc0b65e2a9642c04126a1d1b638d11c6d97426da4f84f1f6f
+SIZE (gnome/gtk-4.12.0.tar.xz) = 16918992
diff --git a/x11-toolkits/gtk40/files/patch-gtk_print_gtkprinteroptionprivate.h b/x11-toolkits/gtk40/files/patch-gtk_print_gtkprinteroptionprivate.h
new file mode 100644
index 000000000000..faf24a404b5d
--- /dev/null
+++ b/x11-toolkits/gtk40/files/patch-gtk_print_gtkprinteroptionprivate.h
@@ -0,0 +1,54 @@
+$ gtk4-demo
+/usr/local/lib/gtk-4.0/4.0.0/printbackends/libprintbackend-file.so: Undefined symbol "gtk_printer_option_new"
+Failed to load module: /usr/local/lib/gtk-4.0/4.0.0/printbackends/libprintbackend-file.so
+/usr/local/lib/gtk-4.0/4.0.0/printbackends/libprintbackend-cups.so: Undefined symbol "gtk_printer_option_new"
+Failed to load module: /usr/local/lib/gtk-4.0/4.0.0/printbackends/libprintbackend-cups.so
+[...]
+
+--- gtk/print/gtkprinteroptionprivate.h.orig 2023-08-05 04:01:26 UTC
++++ gtk/print/gtkprinteroptionprivate.h
+@@ -27,6 +27,7 @@
+ #endif
+
+ #include <glib-object.h>
++#include <gdk/gdk.h>
+
+ G_BEGIN_DECLS
+
+@@ -89,26 +90,36 @@ GType gtk_printer_option_get_type (void) G_GNU
+
+ GType gtk_printer_option_get_type (void) G_GNUC_CONST;
+
++GDK_AVAILABLE_IN_ALL
+ GtkPrinterOption *gtk_printer_option_new (const char *name,
+ const char *display_text,
+ GtkPrinterOptionType type);
++GDK_AVAILABLE_IN_ALL
+ void gtk_printer_option_set (GtkPrinterOption *option,
+ const char *value);
++GDK_AVAILABLE_IN_ALL
+ void gtk_printer_option_set_has_conflict (GtkPrinterOption *option,
+ gboolean has_conflict);
++GDK_AVAILABLE_IN_ALL
+ void gtk_printer_option_clear_has_conflict (GtkPrinterOption *option);
++GDK_AVAILABLE_IN_ALL
+ void gtk_printer_option_set_boolean (GtkPrinterOption *option,
+ gboolean value);
++GDK_AVAILABLE_IN_ALL
+ void gtk_printer_option_allocate_choices (GtkPrinterOption *option,
+ int num);
++GDK_AVAILABLE_IN_ALL
+ void gtk_printer_option_choices_from_array (GtkPrinterOption *option,
+ int num_choices,
+ const char **choices,
+ const char **choices_display);
++GDK_AVAILABLE_IN_ALL
+ gboolean gtk_printer_option_has_choice (GtkPrinterOption *option,
+ const char *choice);
++GDK_AVAILABLE_IN_ALL
+ void gtk_printer_option_set_activates_default (GtkPrinterOption *option,
+ gboolean activates);
++GDK_AVAILABLE_IN_ALL
+ gboolean gtk_printer_option_get_activates_default (GtkPrinterOption *option);
+
+
diff --git a/x11-toolkits/gtk40/pkg-plist b/x11-toolkits/gtk40/pkg-plist
index 05f6e06e5645..782223526660 100644
--- a/x11-toolkits/gtk40/pkg-plist
+++ b/x11-toolkits/gtk40/pkg-plist
@@ -8,6 +8,7 @@ bin/gtk4-launch
bin/gtk4-node-editor
bin/gtk4-print-editor
bin/gtk4-query-settings
+bin/gtk4-rendernode-tool
bin/gtk4-update-icon-cache
bin/gtk4-widget-factory
%%BROADWAY%%include/gtk-4.0/gdk/broadway/gdkbroadway.h
@@ -15,6 +16,7 @@ bin/gtk4-widget-factory
%%BROADWAY%%include/gtk-4.0/gdk/broadway/gdkbroadwaydisplay.h
%%BROADWAY%%include/gtk-4.0/gdk/broadway/gdkbroadwaymonitor.h
%%BROADWAY%%include/gtk-4.0/gdk/broadway/gdkbroadwaysurface.h
+include/gtk-4.0/gdk/deprecated/gdkpixbuf.h
include/gtk-4.0/gdk/gdk.h
include/gtk-4.0/gdk/gdkapplaunchcontext.h
include/gtk-4.0/gdk/gdkcairo.h
@@ -34,6 +36,7 @@ include/gtk-4.0/gdk/gdkdisplay.h
include/gtk-4.0/gdk/gdkdisplaymanager.h
include/gtk-4.0/gdk/gdkdrag.h
include/gtk-4.0/gdk/gdkdragsurface.h
+include/gtk-4.0/gdk/gdkdragsurfacesize.h
include/gtk-4.0/gdk/gdkdrawcontext.h
include/gtk-4.0/gdk/gdkdrop.h
include/gtk-4.0/gdk/gdkenums.h
@@ -43,13 +46,13 @@ include/gtk-4.0/gdk/gdkframeclock.h
include/gtk-4.0/gdk/gdkframetimings.h
include/gtk-4.0/gdk/gdkglcontext.h
include/gtk-4.0/gdk/gdkgltexture.h
+include/gtk-4.0/gdk/gdkgltexturebuilder.h
include/gtk-4.0/gdk/gdkkeys.h
include/gtk-4.0/gdk/gdkkeysyms.h
include/gtk-4.0/gdk/gdkmemorytexture.h
include/gtk-4.0/gdk/gdkmonitor.h
include/gtk-4.0/gdk/gdkpaintable.h
include/gtk-4.0/gdk/gdkpango.h
-include/gtk-4.0/gdk/gdkpixbuf.h
include/gtk-4.0/gdk/gdkpopup.h
include/gtk-4.0/gdk/gdkpopuplayout.h
include/gtk-4.0/gdk/gdkrectangle.h
@@ -63,8 +66,9 @@ include/gtk-4.0/gdk/gdktoplevel.h
include/gtk-4.0/gdk/gdktoplevellayout.h
include/gtk-4.0/gdk/gdktoplevelsize.h
include/gtk-4.0/gdk/gdktypes.h
-include/gtk-4.0/gdk/gdkversionmacros.h
include/gtk-4.0/gdk/gdkvulkancontext.h
+include/gtk-4.0/gdk/version/gdk-visibility.h
+include/gtk-4.0/gdk/version/gdkversionmacros.h
%%WAYLAND%%include/gtk-4.0/gdk/wayland/gdkwayland.h
%%WAYLAND%%include/gtk-4.0/gdk/wayland/gdkwaylanddevice.h
%%WAYLAND%%include/gtk-4.0/gdk/wayland/gdkwaylanddisplay.h
@@ -197,7 +201,9 @@ include/gtk-4.0/gtk/gtkcolordialog.h
include/gtk-4.0/gtk/gtkcolordialogbutton.h
include/gtk-4.0/gtk/gtkcolorutils.h
include/gtk-4.0/gtk/gtkcolumnview.h
+include/gtk-4.0/gtk/gtkcolumnviewcell.h
include/gtk-4.0/gtk/gtkcolumnviewcolumn.h
+include/gtk-4.0/gtk/gtkcolumnviewrow.h
include/gtk-4.0/gtk/gtkcolumnviewsorter.h
include/gtk-4.0/gtk/gtkconstraint.h
include/gtk-4.0/gtk/gtkconstraintguide.h
@@ -271,6 +277,7 @@ include/gtk-4.0/gtk/gtklevelbar.h
include/gtk-4.0/gtk/gtklinkbutton.h
include/gtk-4.0/gtk/gtklistbase.h
include/gtk-4.0/gtk/gtklistbox.h
+include/gtk-4.0/gtk/gtklistheader.h
include/gtk-4.0/gtk/gtklistitem.h
include/gtk-4.0/gtk/gtklistitemfactory.h
include/gtk-4.0/gtk/gtklistview.h
@@ -293,19 +300,13 @@ include/gtk-4.0/gtk/gtkorientable.h
include/gtk-4.0/gtk/gtkoverlay.h
include/gtk-4.0/gtk/gtkoverlaylayout.h
include/gtk-4.0/gtk/gtkpadcontroller.h
-include/gtk-4.0/gtk/gtkpagesetup.h
include/gtk-4.0/gtk/gtkpaned.h
-include/gtk-4.0/gtk/gtkpapersize.h
include/gtk-4.0/gtk/gtkpasswordentry.h
include/gtk-4.0/gtk/gtkpasswordentrybuffer.h
include/gtk-4.0/gtk/gtkpicture.h
include/gtk-4.0/gtk/gtkpopover.h
include/gtk-4.0/gtk/gtkpopovermenu.h
include/gtk-4.0/gtk/gtkpopovermenubar.h
-include/gtk-4.0/gtk/gtkprintcontext.h
-include/gtk-4.0/gtk/gtkprintoperation.h
-include/gtk-4.0/gtk/gtkprintoperationpreview.h
-include/gtk-4.0/gtk/gtkprintsettings.h
include/gtk-4.0/gtk/gtkprogressbar.h
include/gtk-4.0/gtk/gtkrange.h
include/gtk-4.0/gtk/gtkrecentmanager.h
@@ -316,8 +317,10 @@ include/gtk-4.0/gtk/gtkscalebutton.h
include/gtk-4.0/gtk/gtkscrollable.h
include/gtk-4.0/gtk/gtkscrollbar.h
include/gtk-4.0/gtk/gtkscrolledwindow.h
+include/gtk-4.0/gtk/gtkscrollinfo.h
include/gtk-4.0/gtk/gtksearchbar.h
include/gtk-4.0/gtk/gtksearchentry.h
+include/gtk-4.0/gtk/gtksectionmodel.h
include/gtk-4.0/gtk/gtkselectionfiltermodel.h
include/gtk-4.0/gtk/gtkselectionmodel.h
include/gtk-4.0/gtk/gtkseparator.h
@@ -378,12 +381,17 @@ include/gtk-4.0/gtk/gtkwindow.h
include/gtk-4.0/gtk/gtkwindowcontrols.h
include/gtk-4.0/gtk/gtkwindowgroup.h
include/gtk-4.0/gtk/gtkwindowhandle.h
-include/gtk-4.0/unix-print/gtk/gtkpagesetupunixdialog.h
-include/gtk-4.0/unix-print/gtk/gtkprinter.h
-include/gtk-4.0/unix-print/gtk/gtkprintjob.h
-include/gtk-4.0/unix-print/gtk/gtkprintunixdialog.h
-include/gtk-4.0/unix-print/gtk/gtkunixprint-autocleanups.h
+include/gtk-4.0/gtk/print/gtkpagesetup.h
+include/gtk-4.0/gtk/print/gtkpapersize.h
+include/gtk-4.0/gtk/print/gtkprintcontext.h
+include/gtk-4.0/gtk/print/gtkprintoperation.h
+include/gtk-4.0/gtk/print/gtkprintoperationpreview.h
+include/gtk-4.0/gtk/print/gtkprintsettings.h
include/gtk-4.0/unix-print/gtk/gtkunixprint.h
+include/gtk-4.0/unix-print/gtk/print/gtkpagesetupunixdialog.h
+include/gtk-4.0/unix-print/gtk/print/gtkprinter.h
+include/gtk-4.0/unix-print/gtk/print/gtkprintjob.h
+include/gtk-4.0/unix-print/gtk/print/gtkprintunixdialog.h
lib/girepository-1.0/Gdk-4.0.typelib
%%WAYLAND%%lib/girepository-1.0/GdkWayland-4.0.typelib
%%X11%%lib/girepository-1.0/GdkX11-4.0.typelib