aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2023-06-05 15:36:44 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2023-06-05 15:36:44 +0000
commitc7ebfa287cecd6a76bfc4aebd69d4fe1d1d86404 (patch)
tree3acc236e16e6f726c2fd8d9f53b05f8dfcdf7638
parentc92e6eff6f2c3dcdfb2340f66dd3eb374e28075b (diff)
downloadports-c7ebfa287cecd6a76bfc4aebd69d4fe1d1d86404.tar.gz
ports-c7ebfa287cecd6a76bfc4aebd69d4fe1d1d86404.zip
devel/libevent: register CONFLICTS_INSTALL with -devel port
While here, drop needless OPENSSL_{CPP,LD}FLAGS assignments. With DEFAULT_VERSIONS+=ssl=openssl|libressl, the following definitions end up in the ${WRKSRC}/Makefile without manual specification of the paths, as they come from pkgconf(1): OPENSSL_INCS = -I/usr/local/include OPENSSL_LIBS = -L/usr/local/lib -lssl -lcrypto With default OpenSSL implementation (base): OPENSSL_INCS = OPENSSL_LIBS = -lssl -lcrypto
-rw-r--r--devel/libevent/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/devel/libevent/Makefile b/devel/libevent/Makefile
index c921b55bd11b..77831a375b0b 100644
--- a/devel/libevent/Makefile
+++ b/devel/libevent/Makefile
@@ -19,13 +19,13 @@ INSTALL_TARGET= install-strip
TEST_TARGET= check
USE_LDCONFIG= yes
+CONFLICTS_INSTALL= ${PORTNAME}-devel
+
OPTIONS_DEFINE= OPENSSL THREADS
OPTIONS_DEFAULT= OPENSSL THREADS
OPTIONS_SUB= yes
OPENSSL_USES= ssl
-OPENSSL_CPPFLAGS= -I${OPENSSLINC}
-OPENSSL_LDFLAGS= -L${OPENSSLLIB}
OPENSSL_CONFIGURE_ENABLE= openssl
THREADS_CONFIGURE_ENABLE= thread-support